O programie avast! - witamy!

Witamy w programie antywirusowym avast! 2014

Dziękujemy za zainstalowanie programu antywirusowego avast! 2014, jednego z najlepszych programów antywirusowych w swej kategorii. Mamy nadzieję, że będą Państwo zadowoleni z programu avast!, a korzystanie z niego przyniesie zadowolenie.

avast! to pakiet aplikacji, których zadaniem jest ochrona komputera przed możliwością zarażenia wirusami oraz zagrożeniem ze strony innego złośliwego oprogramowania. Właściwie korzystanie z programu połączone z wykorzystaniem innego oprogramowania, takiego jak narzędzia do tworzenia kopii zapasowych, znacząco redukuje ryzyko wystawienia komputera na atak lub zarażenia wirusem, a zatem ryzyko utraty ważnych lub osobistych danych.

Zbudowany na bazie nagradzanego silnika antywirusowego avast!, program antywirusowy avast! 2014 posiada wszystkie cechy, jakich można oczekiwać od nowoczesnego programu antywirusowego. Wyposażony został w technologię zwalczania oprogramowania szpiegującego certyfikowaną wedle procedur West Coast Labs' Checkmark, jak też w moduł zwalczania rootkitów oraz silne funkcje samoobrony. Teraz szybkość skanowania została zwiększona i jednocześnie zwiększono zdolności wykrywania wirusów. W wersji 2014 zmieniliśmy ilość osłon ochronnych do trzech (Osłona systemu plików, Osłona WWW oraz Osłona poczty). Osłona WWW zawiera funkcjonalność wcześniejszej Osłony sieci oraz Osłony przed skryptami, natomiast Osłona systemu plików zawiera funkcjonalność Osłony komunikatorów i P2P. Zapewnia to nie tylko łatwiejsze korzystanie z ważnych funkcji osłon, ale również usprawnia ich funkcjonalność, jak i komunikację między tymi modułami.

Program antywirusowy avast! 2014 oferuje również kilka nowych technologii analizy podejrzanych programów i identyfikacji potencjalnych zagrożeń przez nie powodowanych. Utwardzenie systemu uniemożliwia uruchomienie aplikacji, które nie są na białej liście (tryb agresywny) lub mają niską reputację (tryb umiarkowany). Można go skonfigurować w Ustawieniach, następnie wybierając z lewego paska menu zakładkę Antywirus. Nowa technologia DeepScreen umożliwia avast! 2014 podjęcie inteligentnych decyzji dotyczących nowych lub nieznanych plików. DeepScreen, który jest następcą funkcji AutoSandbox, został wzbogacony o kilka nowych technologii, takich jak dynamiczne tłumaczenie binarne i DynaGen. DynaGen to technologia, która dynamicznie generuje aktualizacje sygnatur opartych na sztucznej inteligencji, znajdujących się wewnątrz algorytmu odpowiedzialnego za analizy podejrzanych plików.

Program antywirusowy avast! Pro Antivirus 2014 oferuje szereg dodatkowych funkcji, m.in. moduł avast! SafeZone, który umożliwia użytkownikowi zarządzanie wrażliwymi transakcjami wewnątrz prywatnego, bezpiecznego środowiska, niewidocznego dla reszty systemu. Pakiet ochrony internetowej avast! Internet Security 2014 wyposażono w filtr antyspamowy oraz wbudowaną zaporę ogniową.

avast! Premier zawiera naszą Niszczarkę danych, którą umożliwia trwałe usunięcie poufnych danych z dysku twardego, oraz pełną funkcję AccessAnywhere umożliwiającą przyjaciołom lub członkom rodziny podłączenie do komputera i odwrotnie. Nowy moduł Software Updater sprawdza, czy oprogramowanie zainstalowane na komputerze nie jest przestarzałe, albo czy nie wymaga łatek usuwających luki w bezpieczeństwie. Wszelkie aktualizacje są pobierane i instalowane automatycznie.

Po zainstalowaniu program avast! działa w tle i chroni komputer przed wszystkimi znanymi formami złośliwego oprogramowania. Użytkownik nie musi robić nic więcej. Wystarczy zainstalować i zapomnieć!

Pliki pomocy stworzono po to, by pomóc użytkownikowi zrozumieć, jak program działa jako całość i opisać właściwości i funkcje komponentów programu. Zakładamy, że użytkownik zna podstawowe terminy i posiada podstawowe umiejętności potrzebne do korzystania z systemu operacyjnego Windows. Jeśli użytkownik nie na takich terminów jak "folder", "plik" czy "okno", albo nie wie, co znaczy "aktywuj okno" lub "kliknij przycisk", zalecamy, by zajrzał do odpowiedniego podręcznika użytkownika zanim przejdzie do korzystania z programu.


Porównanie edycji programu avast!

Program antywirusowy avast! 2014

Program antywirusowy avast! 2014 obejmuje cztery nowe produkty: darmowy program antywirusowy avast! Free antivirus 2014, profesjonalny program antywirusowy avast! Pro antivirus 2014, pakiet ochrony internetowej avast! Internet Security 2014 oraz pakiet avast! Premier 2014. Kluczowe cechy tych czterech produktów porównano w poniższej tabeli.

 | avast! Free antivirus 2014 | avast! Pro antivirus 2014 | avast! Internet Security 2014 | avast! Premier 2014
Silnik antywirusowy o wysokiej wydajności | TAK | TAK | TAK | TAK
Ochrona przed rootkitami | TAK | TAK | TAK | TAK
Ochrona przed oprogramowaniem szpiegowskim | TAK | TAK | TAK | TAK
Wtyczka avast! Online Security | TAK | TAK | TAK | TAK
avast! DeepScreen | TAK | TAK | TAK | TAK
Tryb Wzmacniający | TAK | TAK | TAK | TAK
Dysk ratunkowy | TAK | TAK | TAK | TAK
avast! Sandbox | NIE | TAK | TAK | TAK
avast! SafeZone | NIE | TAK | TAK | TAK
Skaner uruchamiany z wiersza poleceń | NIE | TAK | TAK | TAK
Filtr antyspamowy | NIE | NIE | TAK | TAK
Wbudowana zapora ogniowa | NIE | NIE | TAK | TAK
Automatyczne aktualizacje oprogramowania | NIE | NIE | NIE | TAK
Zdalny Dostęp | NIE | NIE | NIE | TAK
Niszczarka danych | NIE | NIE | NIE | TAK

Darmowy program antywirusowy avast! Free antivirus udostępniany jest do pobrania i użytkowania całkowicie za darmo. Program antywirusowy avast! Pro antivirus, pakiet ochrony internetowej avast! Internet Security oraz pakiet avast! Premier można pobrać i używać za darmo przez okres 30 dni, ale po zakończeniu tego okresu próbnego konieczne jest dokonanie zakupu pliku licencyjnego i wprowadzenie go do programu. Szczegółowe informacje o cenach można znaleźć na naszych stronach WWW.

Copyright © 1988-2014 AVAST Software.
 Wszystkie prawa zastrzeżone.


Rejestracja

Darmową wersję avast! Free antivirus można pobrać i korzystać z niej całkowicie za darmo. Należy jednak zarejestrować swój program w ciągu 30 dni, jeśli użytkownik chce dalej jej używać po upływie tego okresu. Zapewni to możliwość otrzymywania aktualizacji definicji wirusów a zatem skutecznej ochrony przed najnowszymi zagrożeniami.

Jeśli użytkownik utworzył Konto avast! w trakcie instalacji lub jeśli już posiada Konto avast!, do którego podłączony jest darmowy program antywirusowy, rejestracja przebiega automatycznie i użytkownik nie musi robić nic więcej. Jeśli darmowy avast! antivirus nie jest jeszcze podłączony do Konta avast!, wystarczy otworzyć zakładkę Konserwacja po lewej stronie ekranu i kliknąć opcję Rejestracja.

Rejestracji można dokonać za pomocą danych logowania na portalu Facebook albo też można podać alternatywny adres e-mail. Jeśli użytkownik już ma Konto avast!, powinien wprowadzić e-mail oraz hasło Konta avast! Wtedy darmowy avast! antivirus zostanie podłączony do Konta avast! Jeśli użytkownik wybierze rejestrację za pomocą danych do portalu Facebook, uzyska dostęp do Konta avast! bezpośrednio z portalu Facebook, bez konieczności ponownego logowania.

Jeśli użytkownik jeszcze nie ma Konta avast!, automatycznie zostanie dlań utworzone nowe Konto, do którego może uzyskać dostęp podając ten sam e-mail i hasło. Na Konto avast! użytkownik może wejść w dowolnym momencie, by sprawdzić status swojego darmowego programu avast! antivirus oraz innych produktów avast!, które zainstalował.

Teraz można dalej używać programu, który będzie pobierał aktualizacje przez następne 12 miesięcy, co zapewni ochronę przed najnowszymi zagrożeniami.

Po 12 miesiącach konieczna będzie ponowna rejestracja, ale przed tym terminem na głównym ekranie informacyjnym wyświetlony zostanie komunikat o tym, że wkrótce upłynie termin rejestracji. Wystarczy, że użytkownik ponownie zarejestruje program a jego komputer będzie chroniony przez następne 12 miesięcy.


Subskrypcja

Programy avast! Pro antivirus, avast! Internet Security oraz avast! Premier można pobrać i korzystać z nich za darmo przez 30-dniowy okres próbny. Jeśli użytkownik zdecyduje, że chciałby dalej korzystać z programu po upływie okresu próbnego, powinien zakupić licencję, którą należy wprowadzić do programu. Zapewni to możliwość otrzymywania aktualizacji definicji wirusów, co zapewnia skuteczną ochronę przed najnowszymi zagrożeniami.

Licencje na użytkowanie w domu lub małej sieci domowej/biurowej można zakupić na 1 rok, 2 lub 3 lata, dla 3, 5 lub 10 komputerów.

Dla większych sieci i użytkowników korporacyjnych, zalecamy zastosowanie naszych centralnie zarządzanych produktów, które umożliwiają centralne administrowanie wszystkimi komputerami w sieci. Więcej informacji o naszych centralnie zarządzanych produktach można znaleźć na naszej stronie www.avast.com.

Aby zakupić licencję wystarczy otworzyć zakładkę "Sklep", wybrać produkt i kliknąć przycisk "Kup". Następnie postępuj według instrukcji wyświetlanych na ekranie, aby wybrać i kupić odpowiednią licencję.

Po otrzymaniu pliku licencyjnego wystarczy, że użytkownik dwukrotnie kliknie plik, by go otworzyć a licencja zostanie automatycznie wprowadzona do programu. Alternatywnie, można zapisać plik licencyjny w komputerze, otworzyć interfejs programu avast! i kliknąć zakładkę Konserwacja. Następnie kliknąć "Subskrypcja" oraz polecenie "Wprowadź plik licencyjny".

Otwarte zostanie nowe okno, w którym możesz przeglądać pliki zapisane w komputerze w celu zlokalizowania pliku licencyjnego.

Po jego zlokalizowaniu należy go dwukrotnie kliknąć a plik zostanie automatycznie wprowadzony do programu.

Jeśli użytkownik zakupił licencję wielostanowiskową w celu ochrony kilku komputerów, będzie musiał przeprowadzić ten sam proces na każdym komputerze, gdzie zainstalowany został program avast!, np. przesyłając wiadomość z dołączonym kluczem licencyjnym do każdego użytkownika lub zapisując plik licencyjny na współdzielonym napędzie, pamięci USB, itd.

Jeśli użytkownik aktywował Usługę Ochrony Nieprzerwanej (Automatyczne odnawianie), subskrypcja będzie odnawiana automatycznie zanim bieżąca licencja wygaśnie. Użytkownik z wyprzedzeniem otrzyma powiadomienie o nadchodzącym odnowieniu subskrypcji a odnowiona licencja będzie ważna od daty wygaśnięcia bieżącej licencji, tak by użytkownik nie stracił nawet jednego dnia subskrypcji. Automatyczne odnawianie subskrypcji można anulować w dowolnym momencie na stronie wsparcia technicznego programu avast!.


Pomoc techniczna

Te pliki pomocy zostały przygotowane, by pomóc użytkownikowi zrozumieć program oraz sposób wykorzystania jego ustawień w celu zmodyfikowania działania szeregu dostępnych w nim funkcjonalności. Jeśli użytkownik napotka jakiekolwiek trudności podczas korzystania z programu, zawarte tutaj informacje mogą mu pomóc szybko rozwiązać dany problem.

W zakładce "Pomoc techniczna" kliknięcie na "Sprawdź FAQ" pozwoli zapoznać się na naszej stronie z odpowiedziami na najczęściej zadawane pytania.

Można również odwiedzić forum użytkowników programu avast!. Umożliwia ono kontakt z innymi użytkownikami programu avast!, którzy mogli mieć podobne problemy i już odkryli ich rozwiązania. Aby korzystać z forum trzeba się zarejestrować. Jest to bardzo szybka i prosta procedura. Aby zarejestrować się i korzystać z forum, należy przejść na stronę forum avast! - rejestracja.

Jeśli użytkownik wciąż nie był w stanie znaleźć rozwiązania problemu, może Wysłać zgłoszenie do naszego zespołu pomocy technicznej. I w tym przypadku trzeba się zarejestrować. W zgłoszeniu prosimy podać możliwie najwięcej informacji dot. problemu.

Zdalne wsparcie

Na tym ekranie można również uzyskać pomoc zdalną od znajomego.

Jeśli użytkownik chce zwrócić się o pomoc od innej osoby, musi kliknąć przycisk "Uzyskaj Pomoc" w prawym górnym rogu ekranu.

avast! wygeneruje kod, który należy następnie przekazać osobie udzielającej pomocy. Aby przekazać kod osobie udzielającej wsparcia, należy użyć np. telefonu, programu pocztowego lub programu do "czatowania". Wysyłając kod, użytkownik udziela innej osobie zdalnego dostępu do swego komputera. To okno dialogowe znika automatycznie, gdy osoba ta przejmuje kontrolę nad komputerem.

Jeśli użytkownik zamierza udzielić zdalnego wsparcia, należy kliknąć "Steruj zdalnie innym komputerem". Następnie należy wprowadzić kod otrzymany od osoby potrzebującej pomocy i kliknąć przycisk "Połącz". Po ustanowieniu połączenia to okno dialogowe zniknie i wyświetlone zostanie okno zdalnego pulpitu.

Aby zamknąć połączenie, należy kliknąć link lub nacisnąć kombinację klawiszy Alt+Shift+End.


Interfejs użytkownika

Interfejs użytkownika pozwala sprawdzić bieżący poziom zabezpieczeń, dostosować ustawienia programu oraz wykonać ręcznie zadania skanowania na obecność wirusów. Jeśli użytkownik nie ma potrzeby wykonywania tych działań, może nigdy nie wchodzić w interfejs użytkownika, ponieważ po zainstalowaniu programu osłony rezydentalne działają w tle i stale chronią komputer przed zagrożeniami w postaci wirusów i innego złośliwego oprogramowania.

Po wejściu w interfejs użytkownika wyświetlany jest pasek stanu, informujący użytkownika o bieżącym statusie zabezpieczeń. Komunikat "Jesteś chroniony" oznacza, że wszystkie komponenty są zaktualizowane i działają jak powinny. Komunikat "Uwaga" oznacza, że komputer nie jest w pełni chroniony, np. jeśli program lub definicje wirusów nie zostały zaktualizowane lub jeśli wyłączono jedną lub kilka osłon. Komunikat "Nie jesteś chroniony" oznacza, że komputer nie jest w danym momencie wcale chroniony, najprawdopodobniej dlatego, że wszystkie osłony zostały wyłączone.

Jeśli wyświetlony zostanie komunikat "Uwaga" lub "Nie jesteś chroniony", użytkownik może spróbować ponownie zabezpieczyć komputer klikając przycisk "Rozwiąż problemy".

W tym oknie można również dodać skróty innych funkcji, takich jak skanowanie, SafeZone, Czyszczenie przeglądarki itp.., dzięki czemu można uzyskać do nich szybki dostęp. Zmiany tego okna pozwalają dopasować je do potrzeb użytkownika.


Jak uruchomić zdefiniowane fabrycznie zadanie skanowania

Uruchamianie fabrycznie zdefiniowanego zadania skanowania

Program antywirusowy avast! antivirus 2014 wyposażony jest w szereg fabrycznie zdefiniowanych zadań skanowania, instalowanych w konfiguracji domyślnej.

  • Szybkie skanowanie - Domyślnie zadanie to obejmuje szybkie skanowanie woluminu pamięci komputera (zwykle jest to dysk C:\). Domyślnie skanowane są tylko pliki z "niebezpiecznymi" rozszerzeniami, np. pliki z takimi rozszerzeniami jak "exe", "com", "bat" itd. Testowane są jedynie te części na początku albo na końcu pliku, gdzie zwykle znajdowane są elementy zarażające.
  • Pełne skanowanie systemu - Zadanie to obejmuje bardziej szczegółowe skanowanie wszystkich dysków twardych komputera oraz domyślną analizę wszystkich plików wedle ich zawartości. Innymi słowy, avast! przeszukuje wnętrze każdego pliku, by sprawdzić jakiego typu jest to plik i czy powinien być skanowany. Testowany jest cały plik, a nie tylko te części na początku albo na końcu pliku, gdzie zwykle znajdowane są elementy zarażające.
  • Skanowanie dysków wymiennych - Zadanie to obejmuje skanowanie wszelkich dysków wymiennych (pamięci USB, zewnętrzne dyski twarde, itd.) w chwili ich podłączenia do komputera. Zadanie skanuje dyski wymienne w celu wykrycia potencjalnych programów uruchamiających się automatycznie, które mogą próbować uruchomić się automatycznie w chwili podłączenia dysku.
  • Wybierz folder do przeskanowania - Opcja ta pozwala użytkownikowi przeskanować tylko wybrany folder lub foldery.
  • Skanowanie podczas uruchamiania systemu - Jeśli użytkownik kliknie "Wprowadź do harmonogramu", zadanie skanowania zostanie uruchomione automatycznie przy następnym uruchomieniu systemu.

Aby uruchomić fabrycznie zdefiniowane zadania skanowania wystarczy kliknąć "Uruchom".

Ewentualnie klikając na "Utwórz własne zadanie skanowania" można utworzyć nowe skanowanie, w którym można wybrać obszary i typy plików, które mają być skanowane.


Skanowanie z menu kontekstowego

Skanowanie z Eksploratora Windows

Funkcja ta to udogodnienie umożliwiające skanowanie pojedynczego pliku bez otwierania głównego interfejsu programu, ani bez uruchamiania zadania z wiersza poleceń.

Aby przeskanować pojedynczy plik wystarczy kliknąć plik prawym klawiszem myszy, aby otworzyć menu kontekstowe i wybrać opcję "Skanuj <nazwa pliku>".

Aby dodać to zadanie do listy fabrycznie zdefiniowanych zadań skanowania na stronie Skanuj natychmiast, należy przejść do "Ustawień" programu i zaznaczyć pole wyboru "Pokaż specjalne zadania skanowania w interfejsie avast!". Dzięki temu użytkownik będzie miał dostęp do ustawień parametrów skanowania.


Wygaszacz ekranu

Program avast! umożliwia skanowanie plików nawet wtedy, gdy komputer nie pracuje i uruchomiony jest wygaszacz ekranu. Wyświetla wtedy małe okienko w wygaszaczu ekranu, które powiadamia o postępie skanowania, tj. o liczbie przeskanowanych plików, itd.

Jeśli program avast! ma skanować komputer podczas pracy wygaszacza ekranu, należy odszukać opcje wygaszacza w panelu kontrolnym komputera a następnie wybrać "avast! antivirus".

Aby dodać to zadanie do listy fabrycznie zdefiniowanych zadań skanowania na stronie Skanuj natychmiast, należy przejść do "Ustawień" programu i zaznaczyć pole wyboru "Pokaż specjalne zadania skanowania w interfejsie avast!". Dzięki temu użytkownik będzie miał dostęp do ustawień parametrów skanowania.


Jak utworzyć własne zadanie skanowania

Tworzenie własnego zadania skanowania

Klikając przycisk "Utwórz własne zadanie skanowania" użytkownik może zdefiniować całkiem nowe zadanie skanowania z własnymi parametrami.

Domyślnie obszar podlegający skanowaniu to "Wszystkie dyski twarde". Aby wybrać nowy obszar do przeskanowania wystarczy otworzyć menu rozwijalne i wybrać dodatkowy obszar do przeskanowania. Aby usunąć dany obszar należy kliknąć go raz a następnie kliknąć "usuń". Można również określić sposób wykrywania potencjalnie podejrzanych plików na obszarze podlegającym skanowaniu, tj. przez sprawdzanie rozszerzenia plików albo przez sprawdzanie całej zawartości plików.

Jeśli wybrane zostanie skanowanie "zawartości", avast! będzie przeszukiwał wnętrze każdego pliku, by sprawdzić jakiego typu jest to plik i czy powinien być skanowany.

Jeśli wybrana zostanie opcja "rozszerzenia nazwy", wtedy domyślnie skanowane będą tylko pliki z rozszerzeniami "exe", "com", "bat", itp. Można dodać inne rozszerzenia plików klikając opcję "wybierz dodatkowe obszary" i wpisując w polu tekstowym żądane rozszerzenia plików. Następnie należy kliknąć OK. Aby usunąć rozszerzenie pliku, należy raz kliknąć dane rozszerzenie a następnie kliknąć "usuń".


Skanowanie podczas uruchamiania systemu

Możliwe jest zaplanowanie w harmonogramie automatycznego skanowania podczas ponownego uruchomienia systemu, zanim system operacyjny zostanie uaktywniony. Jest to użyteczna funkcja, gdy użytkownik podejrzewa, że wirus mógł się zainstalować w komputerze, ponieważ umożliwia wykrycie wirusa przed jego aktywacją, zanim będzie miał szansę wyrządzić jakiekolwiek szkody.

W ustawieniach modułu Skanowanie podczas uruchamiania systemu można wskazać inne obszary, które mają być skanowane automatycznie podczas rozruchu systemu, oprócz skanowania sektora rozruchowego. Aby uzyskać dostęp do ustawień Skanowania przy uruchomieniu systemu, po wybraniu go z listy dostępnych Skanowań należy kliknąć przycisk "Ustawienia"

Można dostosować czułość algorytmów heurystycznych klikając na pomarańczowe paski, aby zmienić czułość na Niską, Normalną lub Wysoką. Analizę heurystyczną można również wyłączyć. Analiza heurystyczna obejmuje dużą liczbę testów opartych o typowe elementy lub zachowania wirusów, a poziom czułości określa jaka liczba testów musi zakończyć się niepowodzeniem, by plik został uznany za zarażony. Im wyższa czułość, tym wyższy "próg przejścia", a zatem tym większe szanse, że plik nie przejdzie testu heurystycznego i zostanie uznany za potencjalnego wirusa.

W domyślnej konfiguracji program automatycznie skanuje w poszukiwaniu potencjalnie niepożądanych programów oraz skanuje zawartość spakowanych archiwów, ale każdą z tych funkcji można wyłączyć usuwając zaznaczenie odpowiedniego pola wyboru.

Można również określić działanie, które zostanie podjęte w razie wykrycia zagrożenia. avast! może automatycznie podjąć próbę naprawy pliku, przenieść go do kwarantanny lub usunąć go. Użytkownik może również zdecydować, czy program powinien zapytać, jakie działanie podjąć w stosunku do każdego wykrytego zagrożenia, albo że nie należy podejmować żadnego działania


Przetwarzanie wyników skanowania

Jeśli wykryty zostanie wirus lub inne złośliwe oprogramowanie, w dolnej połowie okna skanowania wyświetlony zostanie komunikat "Znaleziono wirusa". Tutaj wyświetlane są informacje ogólne o zadaniu skanowania, takie jak liczba zbadanych plików, liczba zarażonych plików, itd. Aby zobaczyć informacje o wirusie oraz miejscu jego wykrycia należy kliknąć "Pokaż wyniki".

Na ekranie "Wyniki skanowania" można także określić jakie dalsze działanie mają zostać podjęte, jeśli żadne działania nie zostały wykonane automatycznie w oparciu o ustawienia skanowania. Dalsze informacje zawiera sekcja "Szczegółowe ustawienia skanowania".

Kliknięcie ikony "v" w kolumnie "Podejmowane działanie" pokazuje listę dostępnych opcji: Napraw, Kwarantanna, Usuń, Nie rób nic. Zalecane działanie to "Przenieś do Kwarantanny".

Aby zastosować to samo działanie w odniesieniu do wszystkich plików, należy wybrać żądane działanie z listy u dołu ekranu. Dla dowolnego pliku można zmienić działanie wykonywane przez program przez wybranie żądanego działania z listy w odpowiednim rzędzie.

Po określeniu działań, które mają być wykonywane dla każdego pliku, należy kliknąć "Zastosuj", aby wybrane działania zostały wykonane.

Działanie podejmowane zostanie wyświetlone w kolumnie "wynik".

Jeśli w tej fazie użytkownik nie chce wykonywać żadnych działań, wystarczy wybrać "Nie rób nic" i zamknąć ten ekran. Można wrócić na ten ekran później klikając opcję "Dzienniki skanowania". Następnie należy wybrać jednym kliknięciem konkretne zadanie skanowania i kliknąć opcję "Pokaż wyniki".

Szczególne przypadki:

Czasami kolumna "Wyniki" pokazuje, że plik nie może być przeskanowany, np. plik jest chroniony hasłem lub jest to uszkodzone archiwum, albo może informować, że coś podejrzanego zostało wykryte w pliku pamięci. Nie oznacza to, że plik jest zainfekowany.

  • Plik archiwum jest chroniony hasłem - Niektóre programy wykorzystują archiwa zabezpieczone hasłem, aby przechowywać swoje dane (hasło jest ustalane w programie), więc takie pliki mogą zostać zgłoszone, nawet jeśli hasło nie było wcześnie ustawione. avast! mówi, że nie był w stanie wyodrębnić zawartość archiwum, jednak "wrapper" został zeskanowany.

  • Plik archiwum jest uszkodzony - plik jest uszkodzony, na przykład, jeśli połączenie internetowe zostało zakończone w trakcie pobierania. Może to być również specjalny rodzaj archiwum, którego avast! nie może otworzyć. Ponownie oznacza to, że zawartość nie była przeskanowana, ale "wrapper" został przeskanowany.

  • Detekcje w pamięci - Jeśli wyniki skanowania pokazują wykrywania w "Proces X, blok pamięci Y, rozmiar bloku Z" oznacza to, że sygnatura wirusa nie była znaleziona w pliku na dysku, ale najprawdopodobniej w pamięci. Może to sugerować, że jest coś podejrzanego w pamięci systemu, więc zalecanym jest uruchomienie skanowania w czasie uruchamiania systemu, aby sprawdzić system, zanim wirus może się uaktywnić. Jednak takie przypadki wykrycia w pamięci mogą być również spowodowane przez inne zainstalowane programy zabezpieczające. avast! może po prostu wykrywać sygnatury wirusów używane przez inny program. W tym przypadku nic nie zostanie wykryte na dysku lub w trakcie skanowania podczas uruchamiania systemu. Po wyświetlanym "ID Procesu" powinna następować nazwa pliku procesu, który może pomóc w identyfikacji konkretnej aplikacji.


Dzienniki skanowania

Dzienniki skanowania można znaleźć w łączu "Historia skanowania" u dołu ekranu Skanowania. W tej sekcji można znaleźć listę wszystkich wykonanych zadań skanowania wraz z wynikami. Aby uzyskać informacje o tym, co i gdzie wykryto, należy podświetlić odpowiednie zadanie skanowania na liście i kliknąć "Szczegółowy raport".

W kolumnie wyników można przejrzeć wykonane czynności, jeśli jakiekolwiek zostały wykonane.

Jeśli nie została wykonana żadna czynność, kliknięcie ikony "v" w kolumnie "Podejmowane działanie" pokazuje listę dostępnych opcji: Napraw, Przenieś do Kwarantanny, Usuń, Nie rób nic. Zalecane działanie to "Przenieś do Kwarantanny".

Aby zastosować to samo działanie w odniesieniu do wszystkich plików, należy wybrać żądane działanie z listy u dołu ekranu. Dla dowolnego pliku można zmienić działanie wykonywane przez program przez wybranie żądanego działania z listy w odpowiednim rzędzie.

Po określeniu działań, które mają być wykonywane dla każdego pliku, należy kliknąć "Zastosuj", aby wybrane działania zostały wykonane.

Działanie podejmowane zostanie wyświetlone w kolumnie "wynik".

Jeśli w tej fazie użytkownik nie chce wykonywać żadnych działań, wystarczy wybrać "Nie rób nic" i zamknąć ten ekran.


Czułość

Na tym ekranie można dostosować podstawową czułość, która określa jak dokładnie pliki będą skanowane. Można również ustawić czułość analizy heurystycznej.

Oprócz standardowego procesu skanowania plików na obecność znanego złośliwego oprogramowania, program avast! przeprowadza także analizę heurystyczną w celu zidentyfikowania potencjalnie złośliwego, ale jeszcze nie znanego oprogramowania. W ramach analizy moduł poszukuje pewnych cech charakterystycznych, które mogą być znakiem potencjalnego zarażenia. Czułość analizy heurystycznej można dostosować klikając na pomarańczowe paski, aby zmienić jej poziom na Niski, Normalny lub Wysoki. Analizę heurystyczną można również wyłączyć. Zwiększenie czułości zwiększa prawdopodobieństwo wykrycia wirusa, ale zwiększa także prawdopodobieństwo "fałszywych alarmów".

Jeśli okaże się, że avast! wyszukał dużą liczbę czystych plików i uznał je za podejrzane (tzw. "fałszywe alarmy"), możliwe że czułość analizy została ustawiona zbyt wysoko. Obniżenie czułości analizy heurystycznej powinno spowodować zmniejszenie liczby plików uznawanych za podejrzane, ale obniży także szanse wykrycia rzeczywistych wirusów.

  • Użyj emulacji kodu - Jeśli zaznaczone zostanie to pole wyboru i avast! wykryje jakiś podejrzany kod w pliku, program spróbuje uruchomić ten kod w wirtualnym środowisku, by określić jego zachowanie. Jeśli wykryte zostanie potencjalnie szkodliwe zachowanie, plik zostanie potraktowany jako wirus. Uruchomienie kodu w środowisku wirtualnym oznacza, że nawet jeśli kod jest szkodliwy, nie będzie mógł spowodować żadnych szkód.
  • Testuj całe pliki (może wolno działać w przypadku dużych plików) - Zaznaczenie tego pola wyboru spowoduje skanowanie całych plików, a nie tylko tych części plików, na które zwykle mają wpływ wirusy. Większość wirusów lokuje się albo na początku pliku, albo na jego końcu. Zaznaczenie tego pola wyboru wywoła zatem bardziej dokładne skanowanie, ale jednocześnie spowolni proces skanowania.
  • Skanuj w poszukiwaniu potencjalnie niepożądanych programów (PNP) - Zaznaczenie tego pola wyboru umożliwia skanowanie w poszukiwaniu programów, które użytkownik mógł nieświadomie pobrać z sieci.

Zwykle są to programy wykorzystywane do rozpowszechniania reklamy lub zbierania informacji o sposobie korzystania z Internetu przez użytkownika programu. Zaznaczając pole wyboru "Śledź łącza w trakcie skanowania" można zadbać o to, by elementy docelowe dowolnych łączy do systemu plików będą również skanowane na obecność szkodliwej zawartości.


Programy pakujące

Na tej stronie można wskazać typy spakowanych archiwów, które będą sprawdzane podczas skanowania. Niektóre typy plików są skanowane w konfiguracji domyślnej, ale zaznaczając odpowiednie pole wyboru użytkownik może także wybrać inne typy, które powinny być skanowane.

Jednokrotne kliknięcie na dowolnym z domyślnych typów plików na liście wyświetla opis danego typu plików u dołu strony.

Jeśli skanowane mają być wszystkie typy spakowanych archiwów, należy zaznaczyć "Wszystkie programy pakujące", ale to może znacząco wydłużyć czas skanowania.


Ustawienia skanowania - działania

Działania

Na tym ekranie można wskazać działania, które powinny zostać podjęte automatycznie po każdym wykryciu wirusa, potencjalnie niepożądanego programu (PNP) lub podejrzanego pliku.

Aby zobaczyć dostępne opcje, najpierw należy zaznaczyć pole "Zastosuj czynności automatycznie podczas skanowania..."

Działanie domyślne to "Brak działań". Jeśli użytkownik go nie zmieni, o wszelkich podejrzanych plikach program będzie informować po zakończeniu skanowania, a użytkownik będzie miał wtedy możliwość indywidualnego ich potraktowania, np. usunięcia, przeniesienia do kwarantanny lub pozostawienia bez zmian.

Użytkownik może również wybrać działanie, które avast! spróbuje wykonać automatycznie. Dostępne działania to: Napraw, Kwarantanna i Usuń.

Jeśli wybrane zostanie jakieś działanie, użytkownik może wskazać działanie alternatywne, które ma zostać wykonane, jeśli pierwsze się nie powiedzie.

Opcje:

  • W razie konieczności wykonaj działanie przy następnym uruchomieniu systemu. Jeśli to pole wyboru zostało zaznaczone, ale avast! nie był w stanie wykonać wskazanego działania, program spróbuje wykonać to działanie ponownie po następnym uruchomieniu komputera. Może się tak zdarzyć np. wtedy, gdy plik jest używany i nie może być usunięty lub przeniesiony.

Dostępne są również opcje dodatkowe, określające sposób postępowania z zainfekowanymi archiwami:

W konfiguracji domyślnej, po wykryciu zainfekowanego pliku w archiwum avast! podejmuje próbę usunięcia takiego pliku.

Jeśli pliku nie da się usunąć, można skonfigurować program avast! tak, by usuwał plik archiwum, w którym mieści się zarażony plik.

Można również wybrać opcję, która nakazuje usunięcie całego archiwum zawsze wtedy, gdy w jego wnętrzu wykryty zostanie zarażony plik.


Ustawienia skanowania - wydajność

Wydajność

Priorytet:

Tutaj można określić priorytet procesu skanowania w sytuacji, gdy zasoby systemowe potrzebne są także innym aplikacjom. Priorytet procesu można dostosować klikając na pomarańczowe paski, aby zmienić poziom na Niski, Normalny lub Wysoki. Im wyższy priorytet, tym mniej czasu zabierze skanowanie w sytuacji, gdy inne aplikacje pracują jednocześnie z programem avast!.

Stała pamięć podręczna:

Na tym ekranie można skonfigurować ustawienia stałej pamięci podręcznej. Program avast! może przechowywać informacje o plikach, które zweryfikowano jako czyste (np. zawierają ważny podpis cyfrowy) i wykorzystywać te informacje później, by przyspieszyć wykonywanie następnych zadań skanowania. Informacje te przechowywane są w "stałej pamięci podręcznej".

  • Przyspiesz skanowanie korzystając ze stałej pamięci podręcznej. Jeśli to pole zostanie zaznaczone, avast! będzie sprawdzał, czy w stałej pamięci podręcznej nie ma informacji o plikach, które zostały zweryfikowane jako czyste. Takie pliki nie będą ponownie skanowane.

  • Przechowuj dane o skanowanych plikach w stałej pamięci podręcznej. Jeśli to pole zostanie zaznaczone, informacje o nowych wykrytych plikach, które avast! zweryfikował jako czyste podczas skanowania zostaną dodane do stałej pamięci podręcznej. To spowoduje spowolnienie bieżącego zadania skanowania, ale może zwiększyć prędkość następnych zadań, jeśli zaznaczone zostanie pierwsze pole wyboru.

Dostęp do plików:

  • Przyspiesz skanowanie przez odczyt plików w porządku ich przechowywania na dysku. Zaznaczenie tego pola może przyspieszyć skanowanie poprzez zredukowanie liczby operacji wyszukiwania, które muszą zostać wykonane.


Plik raportu

Na tej stronie można utworzyć raport z wynikami skanowania. Można określić, czy raport ma być utworzony jako plik czysto tekstowy, czy też w formacie XML.

Jeśli po każdym skanowaniu ma być tworzony nowy raport, a wyniki poprzednich skanowań nie mają być przechowywane, należy wybrać opcję "Nadpisz". Nowy raport zostanie utworzony po każdym skanowaniu i zastąpi poprzedni raport.

Jeśli wyniki poprzednich skanowań mają być przechowywane, należy wybrać opcję "Dołącz", a wyniki nowego skanowania zostaną dodane na końcu poprzedniego raportu.

Można też wskazać elementy, które mają zostać uwzględnione w raporcie:

  • Elementy zarażone - Pliki, które potencjalnie zawierają wirusa lub inne złośliwe oprogramowanie.
  • Poważne błędy - pojawiają się, gdy program wykryje coś nieoczekiwanego w normalnej sytuacji, co wymaga dalszego badania.
  • Pomniejsze błędy - to zdarzenia mniej poważne niż błędy i zwykle dotyczą plików, których nie można było przeskanować, np. dlatego, że były otwarte i użytkowane przez inną aplikację.
  • Czyste pliki - To są przeskanowane pliki, w których nie znaleziono nic podejrzanego. Jeśli skanowane są wszystkie dyski lokalne, zaznaczenie tego pola wyboru spowoduje utworzenie bardzo długiego raportu. Zaleca się zaznaczenie tego pola wyboru tylko jeśli wykonane ma zostać zadanie ograniczonego skanowania i tylko jeśli rzeczywiście wszystkie czyste pliki mają zostać uwzględnione w raporcie oprócz wszelkich plików podejrzanych.
  • Pominięte pliki - Są to pliki, które nie zostały przeskanowane w wyniku ustawień skanowania, na przykład jeśli w konfiguracji wskazano, że skanowane mają być tylko pliki z określonym rozszerzeniem lub jeśli pewne pliki zostały specjalnie wykluczone z zakresu skanowania.

Raporty zwykle przechowywane są w następujących lokalizacjach:

Na komputerze z systemem Windows 2000/XP - C:\Documents and Settings\All Users\Application Data\AVAST Software\Avast\report

Na komputerze z systemem Windows Vista lub Windows 8 - C:\ProgramData\AVAST Software\Avast\report

Aby przeglądnąć raport natychmiast po wykonaniu ręcznie uruchamianego zadania skanowania należy kliknąć polecenie "Pokaż plik raportu" - po zakończeniu takiego zadania.


Ustawienia skanowania - wykluczenia

Wykluczenia

Tutaj można określić lub zmodyfikować miejsca, które nie powinny być skanowane. Należy jednak zauważyć, że wykluczenia tutaj zdefiniowane nie stosują się do innych zadań skanowania, uruchamianych ręcznie lub wpisanych do harmonogramu, ani do skanowania przez osłony działające w czasie rzeczywistym.

Aby wykluczyć dane miejsce lub plik, należy najpierw kliknąć pole zawierające tekst <wpisz ścieżkę> a następnie wpisać miejsce lub plik podlegający wykluczeniu, albo kliknąć przycisk "Przeglądaj", zaznaczyć pole wyboru obok miejsca lub pliku podlegającego wykluczeniu, a następnie kliknąć "OK".

Jeśli użytkownik chce wykluczyć katalog wraz ze wszystkimi podkatalogami, konieczne jest dodanie "\* " na końcu nazwy takiego katalogu, np. C:\Windows\*.

Aby usunąć dane miejsce lub plik z listy wykluczeń, należy raz kliknąć taki element, by go wybrać, a następnie kliknąć przycisk "Usuń".


Ustawienia skanowania - Harmonogram

Harmonogram

Na tej stronie można zaplanować jednokrotne uruchomienie automatyczne zadania skanowania danego dnia o danej godzinie lub też uruchamianie go regularnie: codziennie, co tydzień lub co miesiąc.

Tutaj dostępnych jest także szereg opcji umożliwiających opóźnienie lub chwilowe wstrzymanie skanowania, jeśli komputer pracuje na akumulatorach, aktywację systemu (jeśli znajduje się w trybie czuwania) przed rozpoczęciem skanowania oraz zamknięcie systemu po zakończeniu skanowania.


Kwarantanna

Kwarantannę można sobie wyobrazić jako katalog na dysku, który ma specjalne właściwości, dzięki którym jest bezpieczny i odizolowany, co sprawia, że jest odpowiedni do przechowywania niebezpiecznych plików. Z plikami w Kwarantannie można jednak pracować, choć z pewnymi ograniczeniami zapewniającymi bezpieczeństwo.

Główną cechą katalogu kwarantanny jest pełna izolacja od reszty systemu operacyjnego. Żaden proces zewnętrzny, taki jak wirus, nie może uzyskać dostępu do plików wewnątrz kwarantanny, a ponieważ pliki wewnątrz katalogu kwarantanny nie mogą być uruchamiane, przechowywanie plików w tym katalogu nie wiąże się z niebezpieczeństwem.

Dzięki szczególnym właściwościom, katalog ten to rzeczywiście obszar kwarantanny, który można wykorzystywać do różnych celów:

  • Przechowywanie wirusów - Jeśli program avast! wykryje wirusa a użytkownik zdecyduje z jakiegoś powodu, że nie należy go usuwać, program da możliwość przeniesienia go do kwarantanny. Gdy wirus jest w Kwarantannie, użytkownik może być pewien, że nie zostanie uruchomiony, ani przypadkowo ani celowo.
  • Przechowywanie podejrzanych plików - Katalog kwarantanny jest użyteczny do przechowywania podejrzanych plików w celu dokonania późniejszej analizy.
  • Przechowywanie kopii innych plików, które powinny być odizolowane od reszty systemu.


Praca z plikami w Kwarantannie

Pliki w Kwarantannie należą do jednej z dwóch kategorii:

  • pliki zarażone lub podejrzane - pliki przeniesione do kwarantanny przez program avast! na podstawie ustawień skanowania lub zgodnie z poleceniem użytkownika
  • pliki użytkownika - pliki przeniesione przez użytkownika do kwarantanny.

Jeśli użytkownik wybierze plik klikając go jeden raz, może wyświetlić dostępne opcje klikając prawym klawiszem myszy. Wyświetlona zostanie lista opcji:

  • Usuń - polecenie nieodwracalnie usuwa plik, tj. nie jest on po prostu przenoszony do kosza.
  • Przywróć - Polecenie przenosi plik z kwarantanny w miejsce, gdzie się pierwotnie znajdował.
  • Przywróć i dodaj do listy wykluczonych – robi dokładnie to samo, co funkcja przywracania, ale dodaje również plik do listy wyjątków, więc nie będzie skanowany ponownie.
  • Wydobądź - Polecenie kopiuje plik do wybranego folderu.
  • Skanuj - Polecenie wywołuje ponowne przeskanowanie pliku na obecność znanych wirusów.
  • Wyślij do laboratorium badającego wirusy - opcja ta umożliwia wysłanie pliku do laboratorium wirusowego avast!, np. w sytuacji, gdy użytkownik uznał, że plik został niepoprawnie rozpoznany jako zarażony. Do pliku należy dołączyć możliwie dużo informacji, w tym nazwę pliku/programu, numer wersji oraz powód, dla którego użytkownik uważa, że plik lub program został fałszywie rozpoznany jako wirus.
  • Właściwości - Kliknięcie tej opcji wyświetla informacje o pliku i umożliwia dodanie komentarza zawierającego szczegółowe informacje.
  • Dodaj – Polecenie umożliwia użytkownikowi przeglądanie systemu i wybór innych plików, które mają zostać przeniesione do Kwarantanny.
  • Odśwież wszystkie pliki – Odświeża listę plików w folderze Kwarantanny, np. wtedy, gdy nowy plik został przeniesiony do kwarantanny, ale podgląd listy plików w Kwarantannie nie został jeszcze uaktualniony.

Uwaga - Pliki w Kwarantannie nie mogą zostać uruchomione. Jeśli użytkownik dwukrotnie kliknie plik, przypadkowo lub umyślnie, plik nie zostanie uruchomiony. Zamiast tego wyświetlone zostaną właściwości pliku. Jest to prosta funkcja zabezpieczająca przed przypadkowym uruchomieniem zarażonych plików, co może potencjalnie doprowadzić do uszkodzenia komputera.


Aktualizacje oprogramowania

Złośliwe oprogramowanie często rozprzestrzenia się wykorzystując znane luki bezpieczeństwa w powszechnie używanym oprogramowaniu. Oznacza to, że jeśli oprogramowanie będzie regularnie aktualizowane, większość złośliwego oprogramowania nie będzie mogła się rozprzestrzeniać!

Funkcja avast! Software Updater udostępnia zestawienie wszystkich aplikacji, które nie zostały zaktualizowane, tak że użytkownik może je regularnie aktualizować i wyeliminować potencjalne luki w zabezpieczeniach.

Wszelkie problemy można rozwiązać klikając przycisk "Aktualizuj". W rezultacie, dostępne aktualizacje zostaną pobrane a oprogramowanie zostanie automatycznie zaktualizowane.

W ustawieniach pakietu avast! Premier użytkownik może wybrać opcję automatycznego pobierania i instalowania aktualizacji, gdy tylko wykryte zostaną najnowsze ich wersje. W takim przypadku avast! zadba o to, by oprogramowanie było zawsze aktualne, a użytkownik nie będzie musiał podejmować żadnych działań.

W ustawieniach Software Updater we wszystkich wersjach avast! (dostępnych w zakładce Ustawienia, Narzędzia, "Dostosuj"), można zaznaczyć opcję "Powiadomienia (w wyskakujących okienkach) włączone". Domyślnie funkcja ta pozwala programowi avast! informować o nieaktualnym oprogramowaniu. Zalecamy pozostawienia jej włączonej, aby zawsze wiedzieć o nieaktualnych programach.

Przycisk "Aktualizuj"

Kliknięcie na ten przycisk pobierze lub zainstaluje aktualizacje. W niektórych przypadkach przełączy na stronę download.com w celu pobrania oprogramowania. Jest to całkowicie normalne - niektóre programy mogą zostać zaktualizowane jedynie z pomocą kanału download.com.

Przycisk "Wyłącz"

Funkcja ta umożliwia tymczasowe wyłączenie narzędzia Software Updater.

Przycisk "Włącz"

Przycisk ten służy do ponownego uruchomienia modułu.

"Pomiń aktualizacje"

Jeśli ta opcja jest włączona, avast! nie będzie informował o dostępnych aktualizacjach oprogramowania. Jest to rozwiązanie niepolecane, jeśli aktualizacje nie są sprawdzanie ręcznie. W innym przypadku można przeoczyć jakieś ważne poprawki.


SecureLine

SecureLine to usługa VPN oferowana przez Avast. VPN (wirtualna sieć prywatna) tworzy bezpieczny „tunel“ w Internecie w taki sposób, że połączenie jest bezpieczne nawet wtedy, gdy łączysz się z publiczną siecią WiFi (kawiarnie, restauracje, lotniska). Hakerzy mogą próbować ukraść dane osobowe za pośrednictwem publicznych sieci Wi-Fi, więc korzystanie z VPN jest zawsze dobrym pomysłem. Usługa oferuje możliwość podłączenia do serwerów w różnych lokalizacjach geograficznych. Można również pozwolić, aby wykryła najbliższe i najlepsze połączenie dzięki kliknięciu na "najbliższa lokalizacja". SecureLine jest oferowana w w miesięcznych i rocznych pakietach licencyjnych.


Wizualizacja procesów

Sandbox

Moduł avast! Sandbox to specjalny moduł zabezpieczający, który umożliwia użytkownikowi przeglądanie sieci lub ręczne uruchamianie aplikacji w całkowicie bezpiecznym środowisku, odizolowanym od reszty systemu.

Jest to szczególnie użyteczne, gdy wchodzi się na strony potencjalnie zainfekowane, lub jeśli użytkownik ma podejrzenie, że jakaś aplikacja może być zainfekowana. Użytkownik może uruchomić program (lub przeglądarkę internetową) wewnątrz strefy izolowanej Sandbox w celu określenia, czy jest bezpieczny, czy nie, a jednocześnie zachować pełną ochronę przed wszelkimi złośliwymi działaniami, które taki program może próbować wykonać.

Aby uruchomić aplikację lub przeglądać strony w sieci przeglądarką uruchomioną w strefie izolowanej wystarczy kliknąć "Uruchom program w Sandbox" a następnie przejrzeć pliki na komputerze w celu odszukania odpowiedniej aplikacji, np. przeglądarki Internet Explorer. Następnie przeglądarka lub inna aplikacja otworzy się w specjalnym oknie z czerwonym/pomarańczowym obramowaniem, które wskazuje, że uruchomiona została w strefie izolowanej Sandbox.

W sekcji Ustawienia Sandbox można również wskazać aplikacje, które zawsze powinny być uruchamiane w trybie wirtualizacji oraz aplikacje zaufane, które nigdy nie powinny być wirtualizowane.

Menu kontekstowe

Zaznaczając pole "Zintegruj z menu kontekstowym …" na ekranie Parametry można dodać tę opcję do menu kontekstowego, wywoływanego prawym klawiszem myszy. Można dodać tę opcję dla wszystkich użytkowników, albo dla użytkowników z uprawnieniami administratora.

Wtedy można uruchomić aplikację w strefie izolowanej po prostu klikając ją prawym klawiszem myszy i wybierając polecenie "Uruchamiaj w środowisku izolowanym".

Jeśli aplikacja powinna być uruchamiana w strefie izolowanej przy każdym jej uruchomieniu, należy wybrać "Zawsze uruchamiaj w strefie izolowanej" a dana aplikacja zostanie dodana do listy aplikacji na ekranie Ustawień zaawansowanych, które zawsze powinny być uruchamiane w trybie wirtualizacji. Przy każdym uruchomieniu, okno aplikacji obramowane jest czerwoną obwódką, co wskazuje, że aplikacja pracuje w strefie izolowanej.

Kliknięcie prawym klawiszem myszy aplikacji już pracującej w menu kontekstowym otwiera nowe menu kontekstowe, które umożliwia jednorazowe uruchomienie tej aplikacji poza strefą izolowaną lub, alternatywnie, całkowite usunięcie jej ze strefy izolowanej, tak by za każdym razem była uruchamiana w normalnym środowisku.


SafeZone

avast! SafeZone

Moduł SafeZone programu avast! to dodatkowy mechanizm zabezpieczający, dostępny w avast! Pro Antivirus, w pakiecie internetowym avast! Internet Security oraz avast! Premier, umożliwiający użytkownikowi korzystanie z Internetu w prywatnym, bezpiecznym środowisku, niewidocznym dla reszty systemu. Dla przykładu, jeśli użytkownik wykonuje w trybie online transakcje bankowe lub zakupy, albo inne transakcje wymagające szczególnego bezpieczeństwa, może być pewien, że jego prywatne dane nie mogą być monitorowane przez programy szpiegujące lub rejestrujące uderzenia w klawisze. Jeśli użytkownik wejdzie na stronę bankowości internetowej rozpoznawaną przez avast!, program automatycznie poprosi użytkownika o skorzystanie z przeglądarki dostępnej w SafeZone, w celu przeprowadzenia transakcji w trybie online. W przeciwieństwie do modułu strefy izolowanej Sandbox, który ma za zadanie utrzymanie w swym wnętrzu wszystkiego co zawiera, by elementy te nie mogły uszkodzić systemu, moduł SafeZone zaprojektowany jest tak, by wszystko inne było utrzymywane poza strefą bezpieczną.

Aby ręcznie otworzyć bezpieczny pulpit SafeZone, wystarczy przejść na zakładkę "Narzędzia", następnie "SafeZone" i kliknąć "Przełącz na SafeZone".

Po przejściu do strefy bezpiecznej SafeZone automatycznie uruchamiana jest przeglądarka internetowa SafeZone. Przeglądarka SafeZone to specjalna przeglądarka bez żadnych dodatkowych komponentów, takich jak "wtyczki", które często są wykorzystywane do rozprowadzania programów szpiegujących.

Po wykonaniu transakcji należy kliknąć menu Start i wybrać opcję “Wyłącz”, by zamknąć przeglądarkę i wrócić do normalnego pulpitu systemowego. Ustawienia przeglądarki i wszelkie pobrane pliki zostaną automatycznie zapisane i będą dostępne po kolejnym wejściu w strefę bezpieczną. Jeśli użytkownik nie chce nic zapisywać, wystarczy kliknąć przycisk "Wyzeruj SafeZone" a cała zawartość zostanie usunięta. Zawartość bezpiecznej strefy SafeZone, w tym wszystkie ustawienia przeglądarki, zostaną przywrócone do stanu pierwotnego.

Alternatywnie, użytkownik może po prostu kliknąć przycisk “Przełącz z powrotem” na pasku zadań (obok zegara), co przeniesie go do normalnego pulpitu bez zamykania przeglądarki internetowej, tak by później można było do niej wrócić.

SafeZone pozwala również utworzyć listę stron, które powinny być otwarte za jej pomocą. Spowoduje to przeniesienie do strefy SafeZone w momencie, gdy zostanie wpisany zdefiniowany wcześniej adres strony WWW (np. adres banku online).


Niszczarka danych

W normalnej sytuacji, gdy użytkownik usuwa pliki lub przenosi je do kosza, dane nie są całkowicie usuwane. Usuwane są tylko odniesienia do nich. Rzeczywiste wymazanie zostaje wykonane dopiero wtedy, gdy inny plik zostaje nadpisany w danym miejscu na dysku, gdzie znajdował się usunięty plik. Ponieważ istnieją narzędzia pozwalające odzyskać usunięte pliki, wszelkie pliki zawierające informacje wrażliwe powinny być usuwane w bardziej niezawodny sposób.

Przepuszczanie plików przez niszczarkę

Niszczarka danych avast! umożliwia użytkownikowi wymazywanie plików w taki sposób, że nie jest możliwe ich odzyskanie za pomocą tradycyjnych metod odzyskiwania danych. W ustawieniach dostępne są trzy sposoby, różniące się szybkością i niezawodnością:

1) Przypadkowe nadpisanie - jest to najprostsza, ale najmniej bezpieczna metoda. Polega na nadpisaniu pliku jeden lub więcej razy z pseudoprzypadkowych bajtów. Liczba nadpisań może być określona.

2) Algorytm DOD (Departamentu Obrony) czyszczenia i porządkowania - jest to bezpieczniejsza, ale wolniejsza metoda. Plik jest zastępowany bajtami zerowymi, następnie bajtami 0xFF (255), a na koniec poprzez przypadkowe dane.

3) Algorytm Gutmanna - jest to najwolniejsza, ale najbezpieczniejsza metoda. Powyższe dwie metody uniemożliwiają odzyskanie rozdrobnionych danych za pomocą narzędzi programistycznych, ale ktoś posiadający specjalistyczny sprzęt przywracania danych na dysku może odsłonić jeszcze kilka warstw danych wcześniej zapisanych w danym miejscu. Metoda Gutmanna korzysta z serii 26 nadpisań, z których każda obejmuje inny schemat kodowania dysku (MFM, RLL, itd.). Obejmuje również kilka przypadkowych nadpisów. Odzyskanie oryginalnych danych po zniszczeniu pliku tą metodą powinno być niemożliwe.

Czyszczenie wolnej przestrzeni dyskowej

Nawet jeśli użytkownik normalnie usunął dane wrażliwe, Niszczarka danych może mimo to pomóc usunąć te dane z komputera na stałe. Obszar, gdzie zapisane zostały te dane będzie widoczny jako wolna przestrzeń dyskowa. W rzeczywistości dane wciąż tam będą i wciąż będzie można je odzyskać, dopóki nie zostaną nadpisane przez nowy plik. Niszczarka danych zapobiega ich odzyskaniu, ponieważ potrafi całkowicie wyczyścić wolną przestrzeń dyskową z wszelkich danych. Proces ten polega na zapisaniu pliku tymczasowego w wolnej przestrzeni dyskowej, a następnie przepuszczeniu go przez niszczarkę wykorzystującą jedną z opisanych metod.

Jednak nie wszystkie wolne miejsce można zapełnić przydzieleniem dużego pliku.

Ponieważ pliki są przechowywane w klastrach a rozmiar pliku rzadko jest wielokrotnością rozmiaru klastra, w ostatnim klastrze każdego pliku często pozostaje niewykorzystane miejsce. Nazywa się to końcówka klastra (cluster tip) i może zawierać poufne informacje. Chociaż może to być długotrwały proces, Niszczarka danych avast! może bezpiecznie wymazać również te obszary.

Na partycji NTFS pliki wystarczająco małe (do około jednego kilobajta) przechowywane są bezpośrednio w Głównej Tablicy Plików (MFT), gdzie takich plików nie da się nadpisać dużym plikiem. Niewykorzystane miejsce jest więc zastępowane przez stworzenie wielu zerowej wielkości plików z bardzo długą nazwą.

Na partycji FAT, Niszczarka danych może nawet uniemożliwić przywrócenie nazw usuniętych plików dzięki nadpisaniu wszystkich usuniętych wpisów w całej strukturze katalogów. Niestety, nie jest to możliwe na NTFS, gdzie byłoby ryzykowne uzyskanie bezpośredniego dostępu do klastrów katalogów.

Przepuszczanie całej partycji przez niszczarkę

Opcja ta pozwala nieodwracalnie zniszczyć wszystkie dane przechowywane na partycji. Także tutaj można wybrać jedną z trzech metod nadpisywania. Należy pamiętać, że po zakończeniu procesu należy sformatować partycję, aby ponownie można było z niej korzystać.


Czyszczenie przeglądarki

To nowe narzędzie pomaga użytkownikowi usuwać z przeglądarki (przeglądarek) irytujące i niepożądane dodatki.

UWAGA: jest to bezpłatny, opcjonalny dodatek do oprogramowania Free Antivirus, Pro Antivirus i Internet Security. W ramach pakietu avast! Premier jest udostępniany standardowo i domyślnie jest już aktywny.

Często się zdarza, że instalowane oprogramowanie darmowe instaluje dodatki do przeglądarki, które mogą być niepożądane. W większości przypadków instalowany jest w przeglądarce pasek narzędzi. Niektóre z nich mogą być użyteczne, ale z zasady służą do analizowania zachowań użytkownika w sieci i wyświetlania konkretnych reklam.

Moduł avast! Czyszczenie Przeglądarki wyświetla listę pasków narzędzi w przeglądarce wraz z oceną, jaką uzyskały wśród użytkowników, i otwiera możliwość wyłączenia ich lub też całkowitego ich usunięcia. Daje również możliwość przywrócenia ustawień przeglądarek, takich jak strona domowa oraz domyślna wyszukiwarka internetowa. Zatem moduł avast! Czyszczenie Przeglądarki jest bardzo użytecznym narzędziem, dzięki któremu przeglądanie Internetu jest szybkie i wiarygodne.

Wystarczy kliknąć przycisk, aby uruchomić moduł Czyszczenie Przeglądarki, a avast! sprawdzi paski narzędzi dodane do wszystkich zainstalowanych przeglądarek.

Jeśli nie wykryje żadnych dodatkowych pasków narzędzi lub dodatków, przeglądarka uzyska status "Czysta".

W przeciwnym razie, jeśli wykryte zostaną jakieś dodatki mające niską ocenę użytkowników, status przeglądarki podany zostanie w kolorze żółtym lub czerwonym, z napisem "Uwaga".

  • Żółty oznacza, że dodatki można usunąć ręcznie, ale mimo to mogą pozostać jakieś elementy, które nie zostaną w pełni usunięte.
  • Czerwony oznacza, że jedna lub kilka przeglądarek ma zainstalowane dodatki i oprogramowanie, które użytkownicy nisko oceniają, i które nadają się do usunięcia.

Dodatki te można usuwać pojedynczo, tak że zostaną usunięte ze wszystkich przeglądarek, albo też można kliknąć przycisk, aby usunąć wszystkie i przywrócić ustawienia przeglądarki do wartości domyślnych.

Użytkownik może ewentualnie użyć zakładek po lewej, aby wyłączyć niepożądane dodatki w konkretnej przeglądarce.

Po wybraniu danej przeglądarki, użytkownik zobaczy listę dodatków zainstalowanych w niej, wraz z oceną, jakie uzyskały wśród użytkowników. Może wyłączyć te niepożądane lub całkowicie wyzerować ustawienia przeglądarki, przywracając ich wartości domyślne.

Zaznaczając pole wyboru u góry strony użytkownik może zdecydować, by wykluczyć wszelkie dodatki z dobrą oceną użytkowników, tak by wyświetlane były tylko te ze złymi ocenami. Następnie może zdecydować, jakie działania podejmować indywidualnie wobec pozostałych.

Usuwanie dodatków

Jeśli użytkownik zdecyduje się usunąć dodatek, polecenie Usuń usuwa dodatek na stałe. Nie da się go przywrócić. Usunąć można jednak tylko dodatki o złej lub bardzo złej reputacji. Dodatkowo, gdyby ustawienia przeglądarki zostały zmienione przez dodatek (strona główna, domyślna wyszukiwarka), zostaną przywrócone do wartości domyślnych.

Wyłączanie dodatków

Wyłączanie dodatku wstrzymuje tylko jego działanie i można odwrócić tę czynność ponownie włączając dodatek.

Należy pamiętać, by zamknąć przeglądarki, zanim przystąpimy do usuwania lub wyłączania jakichkolwiek dodatków oraz przed wprowadzaniem wszelkich innych zmian.

Obsługiwane przeglądarki i systemy operacyjne

Moduł avast! Czyszczenie przeglądarki obsługuje następujące przeglądarki internetowe:

  • Google Chrome wersja 14 lub nowsza
  • Mozilla Firefox wersja 10 lub nowsza
  • MS Internet Explorer wersja 7 lub nowsza

Obsługiwane są następujące systemy operacyjne:

  • Microsoft Windows XP (wszystkie wersje)
  • Microsoft Windows Server 2003 (wszystkie wersje)
  • Microsoft Windows Vista (wszystkie wersje)
  • Microsoft Windows Server 2008 (wszystkie wersje)
  • Microsoft Windows 7 (wszystkie wersje)
  • Microsoft Windows Server 2008 R2 (wszystkie wersje)
  • Microsoft Windows 8 (wszystkie wersje)
  • Microsoft Windows Server 2012 (wszystkie wersje)


AccessAnywhere

Moduł bardzo podobny do modułu Zdalnego Połączenia. Umożliwia uzyskanie zdalnego dostępu i kontroli nad komputerem z dowolnego miejsca. Jeśli użytkownik często podróżuje i podczas podróży potrzebuje dostępu do swojego komputera domowego, może go uzyskać za pomocą innego komputera, na którym zainstalowano program avast! 2014.

W odróżnieniu od modułu Zdalne Połączenie, połączenie jest tutaj nawiązywane przez użytkownika zdalnego, a nie przez komputer, który będzie kontrolowany. Aby to było możliwe, na komputerze udostępnianym zdalnie musi być uruchomiony program avast! Premier i musi zostać uprzednio skonfigurowany do nawiązywania zdalnego połączenia. Można to zrobić w programie avast! Premier.

Aby połączyć się zdalnie z innym komputerem, który został poprawnie skonfigurowany, wystarczy kliknąć przycisk pozwalający przejąć zdalnie kontrolę nad tym komputerem, a następnie wpisać adres e-mail i hasło Konta avast!, do którego jest podłączony.

Inne zastosowanie modułu AccessAnywhere to przypadek, gdy przyjaciel lub członek rodziny często potrzebuje Twojej pomocy, ale nie chce korzystać z funkcji Zdalnego Połączenia. W takim przypadku (pod warunkiem, że zainstalowano avast! Premier) można uprzednio skonfigurować komputer tak, by umożliwiał zdalny dostęp.

Aby połączyć się zdalnie z komputerem, wystarczy by użytkownik znał dane, potrzebne do zalogowania się na Koncie avast!, do którego przypisany jest ich komputer. Podłączając najpier komputer innej osoby do własnego Konta avast!, użytkownik uzyska możliwość kontrolowania go zdalnie, po podaniu własnych danych, potrzebnych do zalogowania na własnym Koncie avast!.


Dysk ratunkowy

Dysk ratunkowy pozwala utworzyć obraz własnej instalacji avast! na USB lub CD. Może zostać uruchomiony bez działającego na komputerze systemu operacyjnego. Jest to świetny sposób, aby naprawić zainfekowany komputer. Dysk ratunkowy znajduje się w części "Narzędzia" i jest dostępny we wszystkich wersjach programu antywirusowego avast! (bezpłatnych i płatnych). Po przejściu na zakładkę Dysk Ratunkowy należy wybrać typ nośnika, na którym ma być utworzony obraz: można wybrać przenośny nośnik USB (lub dysk zewnętrzny) lub CD. Następnie trzeba kliknąć na rodzaj włożonego nośnika, a potem przycisk Zainstaluj. Na ekranie pojawi się pasek postępu tworzenia obrazu, a następnie po udanym zapisie zostanie wyświetlone potwierdzenie, że obraz jest kompletny.


Zapora ogniowa

Pakiet ochrony internetowej avast! Internet Security oraz pakiet avast! Premier wyposażono we w pełni zintegrowaną zaporę ogniową, którą można sterować bezpośrednio z interfejsu użytkownika programu avast!. Zapora ogniowa zawiera pełne wsparcie dla sieci IPv6.

Zapora ogniowa monitoruje całą komunikację między komputerem i światem zewnętrznym i blokuje nieuprawnioną komunikację w oparciu o szereg reguł zezwalających lub dopuszczających. W ten sposób zapora ogniowa może zapobiec wyciekom danych poufnych i może też blokować próby ingerencji podejmowane z zewnątrz przez hakerów.

Zdefiniowano dwa poziomy bezpieczeństwa:

  • Prywatna - poziom odpowiedni dla użytkowania komputera podłączonego do sieci domowej/prywatnej. Wybór tej opcji powoduje, że zapora ogniowa będzie zezwalała na wszelką komunikację z taką siecią.
  • Publiczna - jest to poziom odpowiedni dla użytkowania komputera podłączonego do sieci publicznej, gdzie użytkownikowi zależy na zapewnieniu maksymalnego poziomu bezpieczeństwa. Jest to najbezpieczniejsza konfiguracja i jeśli zostanie wybrana, program nie będzie zezwalał na żadną komunikację przychodzącą, co w rezultacie sprawi, że komputer będzie niewidoczny dla innych. To ustawienie jest zalecane przy łączeniu się z Internetem w kawiarniach, na lotniskach i w innych miejscach publicznych.

Poziom bezpieczeństwa można regulować klikając na odpowiednią ikonkę.

Można całkowicie wyłączyć zaporę ogniową poprzez przejście do "Ustawień", a następnie należy wybrać zakładkę "Ochrona aktywna". Na liście będzie również zapora ogniowa oraz możliwość jej włączenia/wyłączenia. Jednak nie jest to zalecane w momencie, kiedy na komputerze nie ma innej zapory ogniowej.


Ustawienia zapory ogniowej

Pakiet ochrony internetowej avast! Internet Security oraz pakiet avast! Premier wyposażono we w pełni zintegrowaną zaporę ogniową, którą można sterować bezpośrednio z interfejsu użytkownika programu avast!. Zapora ogniowa zawiera pełne wsparcie dla sieci IPv6.

Zapora ogniowa monitoruje całą komunikację między komputerem i światem zewnętrznym i blokuje nieuprawnioną komunikację w oparciu o szereg reguł zezwalających lub dopuszczających. W ten sposób zapora ogniowa może zapobiec wyciekom danych poufnych i może też blokować próby ingerencji podejmowane z zewnątrz przez hakerów.

Zdefiniowano dwa poziomy bezpieczeństwa:

  • Prywatna - poziom odpowiedni dla użytkowania komputera podłączonego do sieci domowej/prywatnej. Wybór tej opcji powoduje, że zapora ogniowa będzie zezwalała na wszelką komunikację z taką siecią.
  • Publiczna - jest to poziom odpowiedni dla użytkowania komputera podłączonego do sieci publicznej, gdzie użytkownikowi zależy na zapewnieniu maksymalnego poziomu bezpieczeństwa. Jest to najbezpieczniejsza konfiguracja i jeśli zostanie wybrana, program nie będzie zezwalał na żadną komunikację przychodzącą, co w rezultacie sprawi, że komputer będzie niewidoczny dla innych. To ustawienie jest zalecane przy łączeniu się z Internetem w kawiarniach, na lotniskach i w innych miejscach publicznych.

Poziom bezpieczeństwa można regulować klikając na odpowiednią ikonkę.

Można całkowicie wyłączyć zaporę ogniową poprzez przejście do "Ustawień", a następnie należy wybrać zakładkę "Ochrona aktywna". Na liście będzie również zapora ogniowa oraz możliwość jej włączenia/wyłączenia. Jednak nie jest to zalecane w momencie, kiedy na komputerze nie ma innej zapory ogniowej.


Zapora ogniowa - połączenia sieciowe

Połączenia sieciowe

Ekran ten pokazuje użytkownikowi połączenia, które są w danym momencie otwarte lub były ostatnio otwarte na danym komputerze. Użytkownik może uzyskać więcej informacji klikając pola wyboru u góry strony. Kliknięcie danego połączenia prawym klawiszem myszy pozwala użytkownikowi uzyskać bardziej szczegółowe informacje o danym adresie IP lub prześledzić trasę, jaką pakiety danych przebywają po drodze do lub z komputera – patrz sekcja: Narzędzia sieciowe.


Zapora ogniowa - Reguły dotyczące aplikacji

Reguły dot. aplikacji

Na tej stronie można skonfigurować reguły komunikacji stosowane do poszczególnych aplikacji. Zapora ogniowa będzie działała zgodnie z zasad a dot. aplikacji gdy dana aplikacja podejmie próbę ustanowienia połączenia z Internetem lub z inną siecią.

Dla aplikacji pochodzących z zaufanych źródeł utworzone zostaną automatycznie reguły domyślne, gdy dana aplikacja zostanie uruchomiona po raz pierwszy. Aby dodać aplikację do istniejącej grupy, wystarczy kliknąć opcję "Nowa reguła dot. aplikacji" lub kliknąć dwukrotnie daną aplikację, wybrać grupę i wyszukać aplikację, która ma zostać dodana. Następnie wybrać poziom udzielanego jej dostępu za pomocą kliknięcia w nazwę grupy a następnie w pomarańczowe paski wyświetlone obok dodanej aplikacji. Alternatywnie można utworzyć nową grupę klikając przycisk "Nowa grupa" a następnie dodać nową regułę aplikacji. Nową grupę można nazwać w momencie jej tworzenia, albo zmienić jej nazwę później za pomocą menu kontekstowego, wywoływanego kliknięciem prawym klawiszem myszy. Można również przenieść daną aplikację do innej grupy klikając ją prawym klawiszem myszy i wybierając "Przenieś".

Można wybrać jeden z pięciu poziomów dostępu:

  • Przyjaciele – połączenia wychodzące
  • Przyjaciele – połączenia przychodzące/wychodzące
  • Internet – połączenia wychodzące
  • Przyjaciele – przychodzące oraz Internet - wychodzące
  • Wszystkie połączenia

Poziom "Przyjaciele – połączenia wychodzące" to najbezpieczniejsza konfiguracja, ponieważ nie dopuszcza połączeń przychodzących a połączenia wychodzące dopuszczane będą wyłącznie w przypadku sieci zdefiniowanych na stronie Przyjaciele w ustawieniach zaawansowanych.

Połączenia z Internetem automatycznie obejmują połączenia ze strefą Przyjaciele. Dla przykładu, grupa połączeń "Internet – wychodzące" automatycznie obejmuje grupę "Przyjaciele – wychodzące". Jeśli użytkownik wybierze "Przyjaciele – przychodzące oraz Internet – wychodzące", dopuszczane będą wychodzące połączenia z Internetem oraz połączenia wychodzące i przychodzące ze strefą Przyjaciele. Jeśli użytkownik wybierze "Wszystkie połączenia", wszystkie połączenia przychodzące i wychodzące będą dopuszczane.

Można uszczegółowić zasady postępowania z połączeniami powyżej wybranego poziomu. Dla przykładu, jeśli wykryte zostanie połączenie przychodzące z Internetu, ale ustawiono poziom dostępu "Internet – połączenia wychodzące", wtedy:

"Blokuj" oznacza, że takie połączenia nie będą nigdy dopuszczane.

"Decyduj automatycznie" oznacza, że połączenia będą w normalnej sytuacji dopuszczane, ale wszelkie podejrzane połączenia będą blokowane automatycznie. Decyzja będzie oparta częściowo na dużej bazie bezpiecznych aplikacji, z której avast! korzysta jak z białej listy.

Jeśli wybrano "Zapytaj", program wyświetli komunikat pytający użytkownika o potwierdzenie, czy zezwolić na dane połączenie, czy też nie.


Dzienniki zapory ogniowej

Na tej stronie użytkownik może przeglądać dzienniki zapory ogniowej dotyczące "Blokowanego ruchu" oraz "Reguł". Można również wybrać okres, dla którego dzienniki mają być wyświetlone.

Jeśli wybrana zostanie opcja "Blokowany ruch", wyświetlone zostaną szczegółowe dane o połączeniach, które zostały zablokowane w wyniku zastosowania reguł konfiguracji zapory ogniowej oraz reguł dotyczących aplikacji.

Jeśli wybrana zostanie opcja "Reguły", podane zostaną informacje o innych działaniach wykonanych przez zaporę ogniową, na przykład nowe reguły blokowania i dopuszczania, które zostały utworzone automatycznie (ponieważ w ustawieniach zapory ogniowej wybrano opcje "decyduj automatycznie" lub "zapytaj") i będą stosowane przy każdej próbie ustanowienia połączenia. Za każdym razem, gdy tworzona jest nowa reguła, jest ona dodawana do listy na stronie "Reguły dot. aplikacji", gdzie można ją także modyfikować w razie potrzeby.


Zdalne wsparcie

Narzędzie zdalnego wsparcia umożliwia udzielenie innej osobie zdalnego dostępu do komputera użytkownika. Jest to przydatne, gdy użytkownik ma jakieś kłopoty i chce, by inna osoba przejęła kontrolę nad jego komputerem i pomogła rozwiązać dany problem.

Jeśli użytkownik chce zwrócić się o pomoc od innej osoby, musi kliknąć przycisk "Uzyskaj Pomoc" w prawym górnym rogu ekranu.

avast! wygeneruje kod, który należy następnie przekazać osobie udzielającej pomocy. Aby przekazać kod osobie udzielającej wsparcia, należy użyć np. telefonu, programu pocztowego lub programu do "czatowania". Wysyłając kod, użytkownik udziela innej osobie zdalnego dostępu do swego komputera. To okno dialogowe znika automatycznie, gdy osoba ta przejmuje kontrolę nad komputerem.

Jeśli użytkownik zamierza udzielić zdalnego wsparcia, należy kliknąć "Steruj zdalnie innym komputerem". Następnie należy wprowadzić kod otrzymany od osoby potrzebującej pomocy i kliknąć przycisk "Połącz". Po ustanowieniu połączenia to okno dialogowe zniknie i wyświetlone zostanie okno zdalnego pulpitu.

Aby zamknąć połączenie, należy kliknąć link lub nacisnąć kombinację klawiszy Alt+Shift+End.


Ustawienia programu - podstawowe

Ustawienia podstawowe

Połączenie z kontem avast!

Ta sekcja pozwala użytkownikowi zalogować się do konta programu avast! oraz i skonfigurować ustawienia konta.

Społeczność użytkowników

Zaznaczając to pole wyboru można zgłosić swój udział we wspólnocie użytkowników programu avast! i w razie potrzeby dzielić się informacjami o charakterze technicznym. Wymiana nie dotyczy informacji o charakterze osobistym i ogranicza się do danych ściśle związanych z bezpieczeństwem, np. dotyczy złośliwego oprogramowania, które wykrył program avast! podczas pracy na danym komputerze, działań, które zablokował, itd. Informacje te będą wykorzystywane przez avast! do podnoszenia zdolności detekcyjnych programu oraz do celów pomocy technicznej na rzecz całej wspólnoty użytkowników programu avast!. Przynależność do wspólnoty użytkowników programu avast! daje również dostęp do wszystkich informacji wspólnotowych oraz statystyk dot. ostatnich ataków złośliwego oprogramowania.

Hasło

Na tym ekranie można zdefiniować hasło, które użytkownik będzie musiał podać przy próbie uruchomienia programu avast! albo uzyskania dostępu do niektórych części programu.

Aby ustawić hasło należy najpierw zaznaczyć pole wyboru "Zabezpiecz program avast! hasłem" a następnie wpisać hasło w wyświetlonych polach.

W następnej kolejności można wyszczególnić obszary, które będą chronione hasłem:

  • Ogólny dostęp do programu – Hasło będzie wymagane do otwarcia interfejsu użytkownika.
  • Ustawienia programu – Do opcji ustawień można wejść klikając "Ustawienia" w prawym górnym rogu interfejsu użytkownika.
  • Kontrola ochrony – Opcja ta dotyczy możliwości włączania lub wyłączania ochrony w czasie rzeczywistym.
  • Ustawienia ochrony – Ustawienia dotyczące ochrony w czasie rzeczywistym.
  • Kontrola zadań skanowania – Kontrolki używane do uruchamiania, wstrzymywania lub zatrzymywania zadań skanowania.
  • Ustawienia skanowania – Ustawienia określające szereg parametrów zadania skanowania.
  • Kontrola aktualizacji – Kontrolki programu używane do aktualizacji programu, silnika skanowania oraz definicji wirusów.
  • Kontrola Kwarantanny – Kontrolki wykorzystywane do pracy z plikami umieszczonymi w folderze Kwarantanny.

Praca w tle/uruchomiona gra pełnoekranowa

W momentach, gdy komputer jest uruchomiony, wiadomości mogą być wyświetlane na ekranie, np. gdy definicje wirusów zostały zaktualizowana, gdy przychodzące e-mail jest skanowany itp. Może to doprowadzić do przerwania pracy pełnoekranowych aplikacji (np. gier), ponieważ system Windows w chwili wyświetlenia komunikatu przełączy się z trybu pełnoekranowego do trybu normalnego.

Jeśli nie chcesz widzieć żadnych wyskakujących okienek avast! podczas uruchomienia aplikacji w trybie pełnoekranowym (podczas grania lub prezentacji PowerPoint), domyślnie nie powinno się to stać. Ale jeśli nie masz nic przeciwko wyskakującym okienkom, możesz odznaczyć tę opcję.

Konserwacja

Na tym ekranie użytkownik może określić, przez jaki czas mają być przechowywane dzienniki skanowania zanim zostaną usunięte oraz ich maksymalny rozmiar. Pozwala to zoptymalizować wykorzystanie przestrzeni dyskowej przez ograniczenie rozmiaru dzienników i usuwanie dzienników, które już nie są potrzebne.

Jeśli zaznaczona zostanie opcja "Włącz rejestrację błędów programowych", utworzony zostanie plik specjalnego dziennika w razie wystąpienia błędów podczas pracy programu. Jeśli błąd będzie się dalej pojawiał, plik dziennika można wysłać do działu wsparcia technicznego programu avast!, co może pomóc w zidentyfikowaniu przyczyny błędu.

Kopia zapasowa ustawień

Umożliwia wykonanie kopii zapasowej ustawień avast! do innej lokalizacji. Stamtąd można je później przywrócić, np. jeśli zajdzie potrzeba odinstalowania i ponownego zainstalowania programu avast!, lub jeśli użytkownik wymieni swój komputer i będzie musiał ponownie zainstalować program avast!.


Osłony działające w czasie rzeczywistym

Osłony działające w czasie rzeczywistym stanowią najważniejszą część programu, ponieważ nieprzerwanie chronią komputer przed zarażeniem. Monitorują wszystkie działania komputera, sprawdzają wszystkie programy i pliki w czasie rzeczywistym, tj. w chwili uruchomienia programu i przy każdym otwarciu lub zamknięciu pliku.

W normalnej sytuacji osłony działające w czasie rzeczywistym uruchamiane są automatycznie wraz z uruchomieniem komputera. Obecność pomarańczowej ikony avast! w prawym dolnym rogu ekranu komputera informuje, że osłony są uruchomione. Każdą z osłon można wyłączyć w dowolnym momencie, ale nie zaleca się takiego działania, ponieważ może ono obniżyć poziom bezpieczeństwa. Jeśli wyłączona zostanie którakolwiek z osłon, po każdym otwarciu interfejsu użytkownika wyświetlany będzie komunikat ostrzegawczy informujący, że komputer nie jest w pełni chroniony (jeśli wyłączona jest jedna lub kilka osłon) lub komunikat "Brak zabezpieczeń" (jeśli wszystkie osłony zostały wyłączone).

Program antywirusowy avast! antivirus 2014 wyposażono w następujące osłony działające w czasie rzeczywistym:

  • Osłona systemu plików - Sprawdza każdy program w momencie uruchomienia oraz każdy inny plik w momencie jego otwarcia lub zamknięcia. Jeśli wykryje coś podejrzanego, osłona systemu plików zapobiegnie uruchomieniu programu lub otwarciu pliku, aby zapobiec uszkodzeniu komputera i danych.
    • Osłona ta sprawdza także pliki z sieci peer-to-peer (wymiany plików), komunikatorów oraz czatów, oraz cały czas monitoruje komputer za pomocą specjalnych czujników do identyfikacji czegoś podejrzanego.
  • Osłona poczty - Sprawdza przychodzące i wychodzące wiadomości pocztowe i zapobiega przyjmowaniu lub wysyłaniu wiadomości, które mogą być zarażone wirusem.
  • Osłona WWW - Chroni komputer przed wirusami przenoszonymi przez Internet (przeglądanie stron, pobieranie plików, itd.). Wykryje i zablokuje znane lub potencjalne zagrożenia pochodzące z sieci, np. zhakowane strony internetowe, zainfekowane (potencjalnie lub rzeczywiście) złośliwymi skryptami. Jeśli wirus zostanie wykryty podczas pobierania pliku z Internetu, pobieranie zostanie wstrzymane, by zapobiec zarażeniu, gdy plik dotrze do komputera.
    • Ochrona WWW wykrywa również złośliwe skrypty i zapobiega ich uruchomieniu bez względu na to, czy pochodzą z sieci, pamięci podręcznej przeglądarki lub stron internetowych zapisanych na dysku.

Osłona WWW potrafi również wykryć i zablokować złośliwe skrypty, które pochodzą z połączeń HTTPS (szyfrowanych). Te funkcje były wcześniej obsługiwane przez oddzielną osłonę przed skryptami, ale zostały włączone do osłony WWW. Do Osłony WWW została dodana również funkcjonalność Osłony Sieciowej monitorującej wszelką aktywność sieciową i blokującej wszelkie zagrożenia wykryte w sieci. Blokuje także dostęp do stron internetowych znanych jako niebezpieczne, a to w oparciu o bazę danych zainfekowanych adresów URL wykorzystywaną przez avast!.


Osłona systemu plików

Osłona systemu plików sprawdza każdy program w momencie uruchomienia oraz każdy inny plik w momencie jego otwarcia lub zamknięcia. Jeśli wykryje coś podejrzanego, osłona systemu plików zapobiegnie uruchomieniu programu lub otwarciu pliku, aby zapobiec uszkodzeniu komputera i danych.

Osłona systemu plików sprawdza także pliki pobierane przy użyciu programów do udostępniania plików, a także pliki otrzymane przez czat lub inne komunikatory.


Skanuj podczas wykonywania

Tutaj można określić typy plików, które powinny być skanowane w chwili uruchomienia lub "wykonania". Zaleca się zaznaczenie wszystkich tych pól wyboru.

Zaznaczenie pól wyboru "Skanuj programy podczas wykonywania" oraz "Skanuj skrypty podczas wykonywania" sprawia, że wszystkie programy i skrypty będą skanowane w chwili ich uruchamiania w celu uzyskania pewności, że są czyste i nie spowodują uszkodzenia komputera lub danych.

Jeśli pole wyboru "Skanuj biblioteki (DLL) podczas ładowania" jest zaznaczone, wszystkie biblioteki DLL będą skanowane podczas ładowania. Może to spowodować wolniejsze uruchamianie niektórych aplikacji, ale znacząco zwiększy bezpieczeństwo systemu.


Skanuj podczas otwierania

Jeśli pole wyboru "Skanuj dokumenty podczas otwierania" zostanie zaznaczone, dokumenty Microsoft Office i inne pliki OLE będą skanowane w chwili ich otwarcia. Aby ustalić, które dokumenty mają być kontrolowane, avast! sprawdzi ich bieżącą zawartość, a nie tylko rozszerzenie pliku.

Można również wskazać pliki, które mają być skanowane na podstawie ich rozszerzenia.

Aby skanować pliki z określonym rozszerzeniem należy zaznaczyć odpowiednie pole wyboru i wpisać rozszerzenie w polu tekstowym. Można też użyć symbolu wieloznacznego "?". Dla przykładu, jeśli chcemy, by wszystkie pliki .htm i .html były skanowane w chwili otwarcia, można wpisać oba rozszerzenia, albo użyć symbolu wieloznacznego "ht?". Należy jednak zauważyć, że w takiej sytuacji skanowane będą wszystkie pliki, których rozszerzenie zaczyna się od "ht", np. pliki z rozszerzeniem .htt.

Można również zdecydować, że wszystkie pliki powinny być skanowane, ale ta opcja może poważnie spowolnić pracę całego systemu podczas wykonywania zadania skanowania.


Skanuj podczas zapisywania

Tutaj można określić typy plików, które będą skanowane w chwili ich zapisu. Można również wybrać skanowanie wszystkich plików ("Skanuj wszystkie pliki") lub skanowanie tych z określonymi rozszerzeniami:

  • Skanuj pliki podczas zapisywanie - skanowanie zostanie przeprowadzone podczas zapisywania pliku na dysku, lub gdy aplikacja zapisuje coś na dysku
  • Skanuj pliki z domyślnymi rozszerzeniami - Skanowane będą tylko pliki z rozszerzeniami uznanymi za potencjalnie niebezpieczne (np. ".exe").
  • Skanuj pliki z wybranymi rozszerzeniami - Tutaj można wyszczególnić typy plików, które powinny być skanowane ze względu na ich rozszerzenia. Można też użyć symbolu wieloznacznego "?"; Dla przykładu, jeśli chcemy, by wszystkie pliki .htm i .html były skanowane w chwili otwarcia, można wpisać oba rozszerzenia, albo użyć symbolu wieloznacznego "ht?". Należy jednak zauważyć, że w takiej sytuacji skanowane będą wszystkie pliki, których rozszerzenie zaczyna się od "ht", np. pliki z rozszerzeniem .htt.
  • Skanuj wszystkie pliki – wszystkie pliki będą skanowane podczas ich tworzenia lub modyfikacji.
  • Nie skanuj plików dzielonych - domyślnie pliki udostępniane na dysku sieciowym nie będą skanowane
  • Nie skanuj plików na nośnikach wymiennych – pozwala określić, czy nośniki wymienne, takie jak pamięć USB, nie powinny być skanowane


Skanuj podczas załączania

Tutaj można określić, czy w chwili podłączania do komputera dyski wymienne mają być skanowane w poszukiwaniu potencjalnych programów uruchamiających się automatycznie, które mogą próbować uruchomić się automatycznie w chwili podłączenia dysku.

Można również zdecydować, że sektory rozruchowe dyskietek mają być skanowane w celu wykrycia potencjalnych wirusów sektora rozruchowego.


Osłona systemu plików - wykluczenia

Wykluczenia

Tutaj można określić lub zmodyfikować miejsca, które nie powinny być skanowane przez osłonę systemu plików. Należy jednak zauważyć, że wykluczenia tutaj zdefiniowane stosują się tylko do Osłony systemu plików, a nie do innych zadań skanowania.

Niektóre pliki są domyślnie wykluczane w chwili odczytu i zapisu. Można również dodać inne typy plików podlegające wykluczeniu w chwili odczytu (R), zapisu (W) lub wykonania (X) klikając "wpisz ścieżkę" i wpisując ścieżkę, która ma być wykluczona, lub klikając przycisk "przeglądaj" i wybierając odpowiednią ścieżkę.

Aby wykluczyć pliki z zadań skanowania wykonywanych przez inne moduły programu avast!, w tym z zadań uruchamianych ręcznie i wpisanych do harmonogramu, pliki lub obszary podlegające wykluczeniu należy wskazać w ogólnych ustawieniach programu.


Osłona systemu plików - zaawansowane

Zaawansowane

Na tej stronie dostępna jest potencjalna możliwość redukcji czasu skanowania przez wskazanie typów plików, które nie powinny być skanowane.

Nie skanuj zweryfikowanych bibliotek systemowych DLL - Jeśli to pole wyboru zostanie zaznaczone, pliki bibliotek systemowych nie będą skanowane.

Użyj przejściowego zapisywania w pamięci podręcznej - Jeśli wykorzystane zostanie przejściowe zapisywanie w pamięci podręcznej, plik już przeskanowany i uznany za czysty nie będzie skanowany ponownie, gdy zostanie wywołany. Reguła ta obowiązuje jednak jedynie do następnej aktualizacji definicji wirusów, ponieważ plik taki może być zainfekowany czymś, czego wcześniej nie wykryto, ale co może zostać wykryte na podstawie nowych definicji wirusów. Również informacja o tym, że plik jest czysty będzie przechowywana jedynie w pamięci operacyjnej (tymczasowej) komputera. Oznacza to, że w chwili ponownego uruchomienia systemu informacja ta zostanie usunięta. Dlatego plik taki znowu będzie skanowany, gdy zostanie wywołany po ponownym uruchomieniu systemu. To pole wyboru jest zaznaczone w konfiguracji domyślnej. Jeśli użytkownik chce, by pliki były skanowane przy każdym wywołaniu, należy usunąć zaznaczenie tego pola.

Użyj stałego zapisywania w pamięci podręcznej - Jeśli wykorzystane zostanie stałe zapisywanie w pamięci podręcznej a plik zostanie zweryfikowany i uznany za czysty, informacja ta zostanie zapisana w pamięci trwałej. Oznacza to, że nie zostanie utracona po ponownym uruchomieniu systemu i nie będą na nią miały wpływu aktualizacje definicji wirusów. Pliki zweryfikowane jako czyste to pliki, które z całą pewnością nie zostały zarażone, np. niektóre pliki systemu operacyjnego, pliki podpisane przez zaufanych producentów lub inne pliki wymienione na białej liście programu avast!. To pole wyboru jest zaznaczone w konfiguracji domyślnej. Jeśli użytkownik chce, by wszystkie pliki były skanowane bez względu na grupę zaufania, do której przynależą, należy usunąć zaznaczenie tego pola.

Optymalizuj skanowanie podczas operacji kopiowania plików - Zaznaczenie tej opcji eliminuje niepotrzebne skanowanie kopiowanych plików. Skanowany jest tylko plik skopiowany, a nie oryginalny plik źródłowy.


Działania

Na tym ekranie można wskazać działania które powinny zostać podjęte automatycznie po każdym wykryciu wirusa, potencjalnie niepożądanego programu (PNP) lub podejrzanego pliku.

Domyślne działanie to przeniesienie do folderu "Kwarantanna". Jeśli użytkownik pozostawi je jako wybrane działanie, wszelkie podejrzane pliki będą automatycznie przenoszone do kwarantanny.

Użytkownik może też wybrać inne działanie, które avast! spróbuje wykonać automatycznie, mianowicie: Napraw, Usuń, Brak działań lub Zapytaj.

Jeśli wybrano "Zapytaj", program zapyta o potwierdzenie działania podejmowanego w chwili wykrycia wirusa, potencjalnie niepożądanego programu lub podejrzanego pliku.

Można również wskazać alternatywne działanie z tej samej listy opcji, które powinno zostać wykonane, jeśli preferowane działanie nie może być wykonane.

Opcje:

U dołu ekranu dostępne są dwa pola wyboru pod nagłówkiem "Opcje":

  • Pokaż okno powiadomienia, gdy działanie zostaje podjęte. Jeśli zostanie zaznaczone to pole wyboru, użytkownik zobaczy na ekranie komunikat informujący, kiedy wskazane działanie zostało podjęte.
  • W razie konieczności wykonaj działanie przy następnym uruchomieniu systemu. Jeśli to pole wyboru zostało zaznaczone, ale avast! nie był w stanie wykonać wskazanego działania, program spróbuje wykonać to działanie ponownie po następnym uruchomieniu komputera. Może się tak zdarzyć np. wtedy, gdy plik jest używany i nie może być usunięty lub przeniesiony.

Dostępne są również opcje dodatkowe, określające sposób postępowania z zainfekowanymi archiwami:

W konfiguracji domyślnej, po wykryciu zainfekowanego pliku w archiwum avast! podejmuje próbę usunięcia takiego pliku.

Jeśli pliku nie da się usunąć, można skonfigurować program avast! tak, by usuwał plik archiwum, w którym mieści się zarażony plik.

Można również wybrać opcję, która nakazuje usunięcie całego archiwum zawsze wtedy, gdy w jego wnętrzu wykryty zostanie zarażony plik.


Osłona poczty

Osłona poczty sprawdza przychodzące i wychodzące wiadomości pocztowe i zapobiega przyjmowaniu lub wysyłaniu wiadomości, które mogą być zarażone wirusem.


Osłona poczty - ustawienia ogólne

Ustawienia ogólne

Tutaj można określić, jakiego typu wiadomości będą skanowane, tj. wiadomości odbierane (przychodzące), wysyłane (wychodzące) oraz wiadomości z grup dyskusyjnych (NNTP).


Osłona poczty - Zachowanie osłony

Zachowanie

Tutaj można podać tekst, który powinien się pojawić się w temacie zarażonych lub podejrzanych wiadomości pocztowych. Można również kontrolować, jakie inne działania będą wykonywane podczas procesu skanowania.

  • Oznaczenie w polu tematu wiadomości zawierającej wirusa: ***WIRUS***
  • Oznaczenie w polu tematu wiadomości podejrzanej: ***PODEJRZANE***

Tylko MS Outlook

  • Pokaż ekran powitalny - Jeśli to pole wyboru zostanie zaznaczone, po każdym uruchomieniu programu MS Outlook wyświetlany będzie przez chwilę ekran powitalny, aby potwierdzić, że Osłona poczty jest uruchomiona.
  • Skanuj załącznik podczas załączania - Tutaj można wskazać, że załączniki powinny być skanowane w chwili ich dołączania do wiadomości, a nie dopiero w momencie wysyłania wiadomości.
  • Skanuj zarchiwizowane wiadomości podczas otwierania – w konfiguracji domyślnej zarchiwizowane wiadomości nie są skanowane. Zaznaczające to pole wyboru użytkownik może wymusić skanowanie wiadomości zarchiwizowanych. Można również zaznaczyć pole "tylko wiadomości nieprzeczytane", aby ta reguła była stosowana jedynie do wiadomości nieprzeczytanych.


Osłona poczty - heurystyka

Oprócz standardowej analizy heurystycznej, Osłona poczty wykonuje dodatkowe testy heurystyczne na obecność potencjalnie złośliwego, ale jeszcze nie rozpoznanego oprogramowania, np. robaków internetowych masowo rozsyłających pocztę. W ramach analizy moduł poszukuje pewnych cech charakterystycznych, które mogą być znakiem potencjalnego zarażenia:

  • Sprawdź sekwencję pustych znaków w nazwie załącznika. - Niektóre wirusy dodają kilka spacji (lub innych niewyświetlanych "białych" znaków) na końcu rozszerzenia pliku, po których następuje rzeczywiste rozszerzenie, które w normalnych warunkach zostałoby rozpoznane jako potencjalnie niebezpieczne. Jednak z powodu długości nazwy pliku osoba odbierająca wiadomość pocztową może nie zauważyć drugiego rozszerzenia i otworzyć taki załącznik w przekonaniu, że jest bezpieczny. Analiza heurystyczna ujawnia ten trik wykrywając sekwencję pustych znaków w nazwie załącznika. Domyślna liczba pustych znaków to 20. Jeśli liczba takich znaków przekracza tę wartość, wyświetlone zostanie ostrzeżenie.
  • Kontrola załącznika - Jeśli to pole zostanie zaznaczone, przeprowadzona zostanie analiza załącznika w oparciu o nazwę i rozszerzenie oraz, opcjonalnie, jego zawartość.
  • Jeśli wybrana została opcja "Tylko nazwa/rozszerzenie", ostrzeżenie zostanie wyświetlone na przykład wtedy, gdy załącznik ma w nazwie rozszerzenie pliku wykonywalnego ((EXE, COM, BAT, itd.). Jednak nie wszystkie takie pliki są niebezpieczne, a opcja ta może prowadzić do wyższej liczby fałszywych alarmów, tj. przypadków uznania czystych plików za potencjalnie podejrzane.
  • Jeśli wybrana została opcja "Typ zawartości oraz nazwa/rozszerzenie", program sprawdzi dodatkowo, czy zawartość rzeczywiście odpowiada typowi pliku, tj. czy plik z rozszerzeniem .jpg rzeczywiście zawiera grafikę i nie jest plikiem COM o zmienionej nazwie.
  • Local iframe / Remote iframe - Niektóre wirusy mogą wykorzystywać błędy w niektórych programach pocztowych, które pozwalają uruchomić wirus w czasie przeglądania wiadomości w okienku podglądu. avast! sprawdza, czy kod HTML wiadomości zawiera znacznik, który to umożliwia, a jeśli taki znacznik zostanie wykryty, będzie wyświetlony komunikat ostrzegawczy.


Osłona poczty – Konta SSL

Skanowanie SSL

Zaznacz to pole, jeśli chcesz, by skanowane były wiadomości e-mail szyfrowane w SSL/TLS.


Osłona WWW

Osłona WWW chroni komputer przed wirusami podczas korzystania z Internetu (przeglądanie stron, pobieranie plików, itd.). Wykryje i zablokuje znane lub potencjalne zagrożenia pochodzące z sieci, np. zhakowane strony internetowe, zainfekowane (potencjalnie lub rzeczywiście) złośliwymi skryptami. Jeśli wirus zostanie wykryty podczas pobierania pliku z Internetu, pobieranie zostanie wstrzymane, by zapobiec zarażeniu, gdy plik dotrze do komputera.

Osłona WWW obsługuje teraz funkcje wcześniej obsługiwane przez Osłonę Sieci oraz Osłonę przed skryptami. Oznacza to, że również monitoruje wszelką aktywność sieciową i blokuje wszelkie zagrożenia wykryte w sieci. Blokuje także dostęp do stron internetowych znanych jako niebezpieczne, a to w oparciu o bazę danych zainfekowanych adresów URL wykorzystywaną przez avast!. Wykrywa złośliwe skrypty i zapobiega ich wykonywaniu. Osłona WWW wykrywa i blokuje nie tylko złośliwe skrypty pochodzące z sieci (zagrożenia zewnętrzne), ale także skrypty pochodzące z innych źródeł, takich jak strony WWW zapisane na dysku lub przechowywane w pamięci podręcznej przeglądarki, itd. (zagrożenia lokalne). Potrafi również wykryć i zablokować złośliwe skrypty, które pochodzą z połączeń HTTPS (szyfrowanych).


Osłona WWW - ustawienia ogólne

Ustawienia ogólne

W ustawieniach Osłony WWW możesz znaleźć główną sekcją, umożliwiającą następujące funkcje:

  • Włącz skanowanie WWW - To pole wyboru jest zaznaczone w konfiguracji domyślnej. Usunięcie zaznaczenie tego pola powoduje wyłączenie funkcji skanowania odwiedzanych stron, ale nie wpływa na blokowanie adresów URL, które pozostaje aktywne.
  • Użyj inteligentnego skanowania strumieni - Również to pole jest zaznaczone w konfiguracji domyślnej. Gdy jest zaznaczone, pliki pobierane są skanowane w czasie rzeczywistym, tj. w trakcie samego procesu pobierania. Pakiety danych poddaje się skanowaniu w momencie odebrania, a następne pakiety są pobierane tylko jeśli poprzednie zostały zweryfikowane jako nie zawierające wirusów. Wyłączenie tej opcji (usunięcie zaznaczenia pola wyboru) sprawia, że pliki są pobierane w całości do katalogu tymczasowego i dopiero wtedy skanowane.
  • Blokuj złośliwe adresy URL – funkcja ta była wcześniej dostępna w Osłonie sieci. Blokuje dostęp do stron internetowych znanych jako niebezpieczne, a to w oparciu o bazę danych zainfekowanych adresów URL wykorzystywaną przez avast!.
  • Skanowanie skryptów – funkcja obsługiwana wcześniej w Osłonie przed skryptami. Umożliwia blokowanie niebezpiecznych skryptów pochodzący z sieci, stron HTTPS i innych stron internetowych.


Osłona WWW - Skanowanie WWW

Skanowanie WWW

Na tej stronie można określić, które pliki powinny być skanowane w trakcie pobierania z Internetu. Można wybrać skanowanie wszystkich plików lub skanowanie tylko tych z określonymi rozszerzeniami. Aby ta funkcja była aktywna, należy zaznaczyć pole wyboru "Włącz skanowanie WWW" na stronie głównej ustawień Osłony WWW.

Można również wpisać typy plików MIME, które mają być skanowane. W obu przypadkach można używać symboli wieloznacznych.

Można również wybrać, czy rozpakowywać archiwa z ważnym podpisem cyfrowym. Domyślnie pliki z ważnym podpisem cyfrowym nie będą rozpakowywane.


Osłona WWW - wykluczenia

Wykluczenia

Na tej stronie można wskazać adresy URL oraz typy MIME, które nie powinny być skanowane przez Osłonę WWW. Opcja może być użyteczna przy pobieraniu dużej liczby plików z jednego, zaufanego źródła.

Wykluczone adresy URL - Użyj przycisku "Dodaj", by wprowadzić adresy URL które powinny być pomijane. Jeśli użytkownik chce wykluczyć tylko pojedynczą stronę, powinien wpisać pełny adres, np. w celu wykluczenia strony index.html w portalu http://www.yahoo.com/ trzeba wpisać pełny adres: http://www.yahoo.com/index.html. Jeśli jednak użytkownik wpisze http://www.yahoo.com/*, żaden adres rozpoczynający się od http://yahoo.com nie będzie skanowany. Jeśli użytkownik chce wykluczyć ze skanowania konkretny typ plików, np. pliki z rozszerzeniem ".txt", wystarczy wpisać *.txt.

Wykluczone typy MIME - Tutaj można wskazać dowolne typy/podtypy MIME, które nie powinny być skanowane.

Ze skanowania można również wykluczyć poszczególne procesy, wskazując je po wyszukaniu za pomocą przycisku "Przeglądaj".


Osłona WWW - działania

Działania

Na tym ekranie można wskazać działania, które powinny zostać podjęte automatycznie po każdym wykryciu wirusa, potencjalnie niepożądanego programu (PNP) lub podejrzanego pliku.

Domyślna opcja to "Przerwij połączenie". Oznacza ona, że połączenie zostanie automatycznie zakończone w chwili wykrycia potencjalnych zagrożeń. Alternatywnie, jeśli użytkownik zmieni wybrane działanie na "Zapytaj", w razie wykrycia potencjalnego zagrożenia wyświetlony zostanie komunikat pytający, czy zakończyć połączenie.

Jeśli pole wyboru u dołu ekranu pozostanie zaznaczone, użytkownik zobaczy na ekranie komunikat informujący, że wskazane działanie zostało podjęte.


Blokowanie witryn

Na tej stronie można wprowadzić adresy URL dowolnych stron WWW, które powinny być blokowane, tak by nie mogły być oglądane za pomocą przeglądarki na danym komputerze. Funkcję tę można wykorzystywać do blokowania dostępu do stron, które mają pozostać niedostępne dla dzieci lub innych użytkowników, np. stron dla dorosłych.

Ustawienia Blokowanie WWW są dostępne na stronie ustawień Osłony WWW.


Osłona przed skryptami

Skanowanie skryptów

Skanowanie skryptów wykrywa złośliwe skrypty i zapobiega ich wykonywaniu. Funkcja ta wykrywa i blokuje nie tylko złośliwe skrypty pochodzące z sieci (zagrożenia zewnętrzne), ale także skrypty pochodzące z innych źródeł, takich jak strony WWW zapisane na dysku lub przechowywane w pamięci podręcznej przeglądarki, itd. (zagrożenia lokalne).

Potrafi również wykryć i zablokować złośliwe skrypty, które pochodzą z (szyfrowanych) połączeń HTTPS.

Dostępne tutaj pola wyboru można wykorzystać do wyboru przeglądarek, które będą chronione przez Skanowanie skryptów.

Jeśli usunięte zostanie zaznaczenie przy którejś przeglądarce, Skanowanie skryptów zostanie wyłączona dla tej przeglądarki.


Osłona przed skryptami - Wykluczenia

Wykluczenie skryptów

Tutaj można określić konkretne adresy URL, które nie powinny być skanowane. Wystarczy zaznaczyć pole wyboru a następnie wpisać adres URL, który ma być pomijany.


Filtr antyspamowy avast!

Pakiet ochrony internetowej avast! Internet Security oraz pakiet avast! Premier wyposażono we wbudowany filtr antyspamowy, wykrywający niechcianą pocztę.

Spam doręczany do skrzynki pocztowej może ją szybko zapełnić, co prowadzi do sytuacji, gdy właściwa poczta może nie zostać odebrana. Może również niepotrzebnie zwiększyć obciążenie serwera pocztowego, połączenia sieciowego, sieci lokalnych, itd.

Filtr antyspamowy avast! analizuje wszystkie nadchodzące wiadomości w oparciu o szereg kryteriów w celu określenia, czy są to wiadomości dopuszczalne. Analiza ta opiera się częściowo o "czarną listę", zawierającą adresy nadawców, których wiadomości pocztowe zawsze powinny być oznaczane jako spam, oraz o "białą listę", która zawiera adresy znanych i zaufanych nadawców. Listy te można znaleźć w ustawieniach antyspamowych.

W przypadku wiadomości od nadawców nie wymienionych na żadnej z list wykonywana jest także analiza zawartości w oparciu o wybraną czułość skanowania w celu wykrycia wiadomości, które powinny być traktowane jako spam.

Jeśli odebrana zostanie wiadomość, której adres nadawcy pasuje do pozycji tak na czarnej liście jak i na białej liście, adres e-mail będzie miał priorytet nad nazwami domen. Dla przykładu: jeśli blokowana jest domena "host.net", ale konkretny "adresjan@host.net" jest akceptowany, poczta e-mail będzie dostarczana normalnie.

W ustawieniach antyspamowych użytkownik może również określić sposób oznaczania "śmieciowych" wiadomości pocztowych. Oznaczenia zaś można wykorzystać do utworzenia nowej reguły w kliencie pocztowym, która będzie automatycznie przenosiła oznaczone wiadomości pocztowe do innego katalogu. Filtr antyspamowy działa skutecznie w stosunku do wiadomości dostarczanych na konta pocztowe w programach zainstalowanych na danym komputerze, np. w programach Microsoft Outlook, Outlook Express itd., ale nie w stosunku do kont obsługiwanych przez przeglądarkę, np. na serwerach Yahoo, Gmail itd., które zwykle posiadają własne opcje antyspamowe.


Osłona antyspamowa - ustawienia ogólne

Ustawienia ogólne

Na tej stronie można dostosować ustawienia czułości skanowania oraz określić dodatkowe czynności, które zostaną wykonane automatycznie:

  • Oznacz spam w polu tematu - Na tej stronie można również zdefiniować informację, która powinna być wstawiana w polu tematu wiadomości pocztowych rozpoznanych przez program avast! jako spam. Jeśli to pole wyboru zostanie zaznaczone, w polu tematu wstawiana będzie informacja "***SPAM***". Aby zmienić ten tekst, wystarczy wpisać żądany tekst w polu tekstowym.
  • Oznacz w temacie wiadomości wyłudzających dane. Jeśli to pole wyboru zostanie zaznaczone, w polu tematu wstawiana będzie informacja "***PHISHING***".
  • Odbiorcę wychodzących wiadomości dodaj automatycznie do białej listy - Domyślnie adresy wysyłanych wiadomości pocztowych dodawane są automatycznie do białej listy, tak że odpowiedzi odbierane z tych adresów nie będą traktowane jak spam. Dlatego też to pole wyboru jest zaznaczone w konfiguracji domyślnej.
  • Pobrać nowe reguły? - Tutaj można wskazać, jak często program avast! będzie sprawdzał dostępność aktualizacji reguł używanych do wykrywania potencjalnego spamu. Choć domyślna wartość to 5 minut, nie znaczy to, że aktualizacja będzie dokonywana rzeczywiście co 5 minut. Zwykle aktualizacje są dokonywane znacznie rzadziej, ale regularne sprawdzanie ich dostępności daje pewność, że w każdym momencie wykorzystywane są najbardziej aktualne reguły wykrywania potencjalnego spamu.
  • Włącz LiveFeed - Jeśli to pole zostanie zaznaczone, avast! będzie sprawdzał wszystkie nadchodzące wiadomości pocztowe według dostępnej online globalnej bazy danych spamu przed wykonaniem analizy heurystycznej i innych czynności kontrolnych. Większość wiadomości poczty śmieciowej wykrywa się w ten sposób. Zaleca się zatem pozostawienie zaznaczenia przy tym polu. Ilość przesyłanych danych jest bardzo mała. Jeśli jednak użytkownik chce zminimalizować ilość przesyłanych danych, można usunąć zaznaczenie tego pola, ale w rezultacie poziom wykrywania spamu będzie niższy.

Jeśli używasz MS Outlook jako klienta poczty, domyślnie wiadomości spamowe są automatycznie przenoszone do folderu wiadomości-śmieci. Po odznaczeniu tego pola wszystkie wiadomości będą dostarczane normalnie do skrzynki odbiorczej.

Można również wyszczególnić pozycje z książki adresowej, które powinny być dodawane automatycznie do białej listy znanych adresów e-mail, tak by nigdy nie były traktowane jako spam.


Osłona antyspamowa - Biała lista

Biała lista

Kliknięcie w dostępnym polu umożliwia wprowadzenie adresów e-mail nadawców, których wiadomości nigdy nie będą traktowane jako spam i zawsze będą dostarczane jako wiadomości czyste. Można wpisać konkretne adresy e-mail, np. jan.kowalski@domena.com, albo też nazwę domeny (np. domena.com), a wtedy wszystkie wiadomości pochodzące z tej domeny będą dostarczane do skrzynki odbiorczej.

Aby usunąć adres e-mail z białej listy należy kliknąć go raz a następnie kliknąć "Usuń".


Osłona antyspamowa - Czarna lista

Czarna lista

Kliknięcie w dostępnym polu umożliwia wprowadzenie adresów e-mail nadawców, których wiadomości zawsze będą traktowane jako spam. Można wpisać konkretne adresy e-mail, np. jan.kowalski@domena.com, albo też samą nazwę domeny (np. domena.com), a wtedy wszystkie wiadomości pochodzące z tej domeny będą traktowane jak spam.

Aby usunąć adres e-mail z czarnej listy należy kliknąć go raz a następnie kliknąć "Usuń".


Zapora ogniowa - Zasady polityki udostępniania połączenia

Zasady polityki Zapory ogniowej

Ta sekcja pozwala na ustawienie reguł dla programów, które nie mają określonych zasad w regułach dot. aplikacji. "Decyduj automatycznie" -jest to domyślne ustawienie i daje avast! kontrolę nad podejmowania decyzji o tym, co zrobić z programem. "Zezwól" oznacza, że wszystkie programy będą mogły zostać uruchomione, pod warunkiem, że nie mają określonych reguł aplikacji. "Blokuj" nie dopuści do uruchomienia jakiegokolwiek programu, a funkcja "Zapytaj" poprosi użytkownika o podjęcie decyzji w sprawie tego, czy uruchomić lub zablokować program.

Preferencje

Tutaj użytkownik może zdecydować, czy chce otrzymywać powiadomienie za każdym razem, gdy funkcja automatycznego decydowania tworzy nową regułę zezwalającą lub blokującą.

Opcję Tryb Współdzielenia Połączenia Internetowego (ICS) należy zaznaczyć tylko jeśli tryb Windows ICS jest również włączony. Ponieważ komputer użytkownika będzie funkcjonował jako brama między Internetem i innymi komputerami posiadającymi własne ustawienia zabezpieczeń, niektóre porty, które zwykle są zamknięte, będą musiały zostać otwarte. W rezultacie poziom bezpieczeństwa obniża się nieco, jeśli to pole wyboru zostanie zaznaczone.

Można również tutaj określić, czy połączenia z użytkownikami wymienionymi jako Przyjaciele powinno być dozwolone w momencie, gdy zapora jest ustawiona na tryb prywatny.


Zapora ogniowa – Profile sieciowe

Domyślnie włączone jest przełączanie profilu, co oznacza, że avast! automatycznie wykrywa, czy komputer jest używany w domu, w biurze, lub w publicznym miejscu i stosuje określone zasady w zależności od wybranego profilu. Możesz wybrać typ profilu z listy nazw na liście profili sieciowych. Można również ustawić profil sieciowy jako przyjazną sieć, zaznaczając pole wyboru obok pola, gdzie można wybrać profil (publiczny/prywatny).


Zapora ogniowa - Przyjaciele

Sekcja ta pozwala określić "przyjazne" sieci, które stanowią niewielkie zagrożenie bezpieczeństwa. Najbardziej typowe zastosowanie to pozwolenie znajomym/członkom rodziny na dostęp do serwera sieci domowej. Funkcję tę stosuje się tam, gdzie udzielanie dostępu ograniczane jest do sieci przyjaznych, wskazanych na stronie reguł dotyczących aplikacji.

Reguły dotyczące aplikacji są dostępne z ekranu głównego Zapory ogniowej.


Zapora ogniowa - zaawansowane

Zaawansowane ustawienia zapory ogniowej

Ta sekcja pozwala na ustalenie maksymalnej liczby zapisów w dziennikach zapory ogniowej. Dodatkowo funkcja "włącz automatyczne skanowanie portów" oznacza, że zapora wykrywa próby skanowania portów. Jest to popularna technika wśród hakerów wykorzystywane do identyfikacji urządzeń w sieci. Jeśli skanowanie portów jest wykrywane, adres IP jest umieszczany na czarnej liście, a cała komunikacja z tym IP jest zablokowana.


Ustawienia antywirusa

Usługi reputacyjne

Włączenie tej opcji powoduje, że avast! sprawdzi, czy plik jest bezpieczny jeszcze przed jego otwarciem, konsultując się z bazą danych o znanych plikach. Określenie pliku jako bezpiecznego lub nie zależy od tego, jak często plik jest wykorzystywany przez użytkowników programu avast! i od tego, od kiedy plik istnieje. Można przejść do funkcji Usług reputacyjnych, przechodząc do głównego ekranu Ustawienia, a następnie klikając zakładkę Antywirus na lewym pasku menu.

DeepScreen

Po włączeniu tej funkcji, podejrzane pliki (lub kod w pliku) przechodzą przez dodatkowe warstwy analizy wykorzystujące algorytmy sztucznej inteligencji, aby zidentyfikować potencjalnie szkodliwe oprogramowanie.

Utwardzenie systemu

Dostępne są dwie opcje ustawienia funkcji Utwardzenie systemu. Tryb umiarkowany oznacza, że żadne pliki o słabej reputacji nie będą mogły być uruchomione. Tryb agresywny oznacza, że tylko pliki z białej listy zostaną otworzone. Te dwa ustawienia zapewniają większą kontrolę i bezpieczeństwo dla komputera i są szczególnie przydatne dla początkujących użytkowników, którzy nie są świadomi ryzyka związanego z otwarciem niektórych plików.

Wykluczenia

Możliwe jest wykluczenie określonych miejsc lub nawet pojedynczych plików z procesu skanowania, co oznacza, że nie będą sprawdzane na obecność wirusów podczas żadnego zadania skanowania. Będą również wykluczane z zadań skanowania prowadzonych przez wszystkie osłony działające w czasie rzeczywistym. Opcja ta może być użyteczna z następujących powodów:

  • Unikanie fałszywych alarmów - Jeśli program doniesie o zarażeniu pliku wirusem a użytkownik jest pewien, że jest to fałszywy alarm, może wykluczyć dany plik z dalszych skanów i uniknąć dalszych fałszywych alarmów. Prosimy jednak o powiadomienie AVAST Software o problemie, aby można go było usunąć.
  • Przyspieszenie przetwarzania - Jeśli na dysku znajduje się folder zawierający wyłącznie pliki graficzne, można go wykluczyć ze skanowania, co skróci całkowity czas skanowania.

Należy pamiętać, że tutaj zdefiniowane wykluczenia stosują się do wszystkich zadań skanowania na żądanie (uruchamianych ręcznie i zdefiniowanych w harmonogramie) oraz do wszystkich działań osłon uruchomionych w czasie rzeczywistym. Jeśli użytkownik chce wykluczyć pliki jedynie z określonych zadań skanowania uruchamianych ręcznie i zdefiniowanych w harmonogramie, powinien skorzystać z opcji na stronie Wykluczenia w ustawieniach skanowania. Aby wykluczyć pliki jedynie ze skanowania przez daną osłonę działającą w czasie rzeczywistym, należy użyć opcji Wykluczenia w ustawieniach danej osłony.

Aby wykluczyć dane miejsce lub plik, należy najpierw kliknąć pole zawierające tekst <wpisz ścieżkę> a następnie wpisać miejsce lub plik podlegający wykluczeniu, albo kliknąć przycisk "Przeglądaj", zaznaczyć pole wyboru obok miejsca lub pliku podlegającego wykluczeniu, a następnie kliknąć "OK".

Jeśli użytkownik chce wykluczyć katalog wraz ze wszystkimi podkatalogami, konieczne jest dodanie "\* " na końcu nazwy takiego katalogu, np. C:\Windows\*.

Aby usunąć dane miejsce lub plik z listy wykluczeń, należy raz kliknąć taki element, by go wybrać, a następnie kliknąć przycisk "Usuń".

Specjalne zadania skanowania

Program avast! umożliwia skanowanie plików nawet wtedy, gdy komputer nie jest używany i uruchomiony jest wygaszacz ekranu. Wyświetla wtedy małe okienko w wygaszaczu ekranu, które powiadamia o postępie skanowania, tj. o liczbie przeskanowanych plików, itd.

Jeśli program avast! ma skanować komputer podczas pracy wygaszacza ekranu, należy odszukać opcje wygaszacza w panelu kontrolnym komputera a następnie wybrać "avast! antivirus".

Można również utworzyć możliwość uruchomienia skanowania z poziomu menu kontekstowego Eksploratora Windows.

Alerty

Program avast! może wysyłać komunikaty ostrzegawcze do innych użytkowników za każdym razem, gdy wykryje wirusa. Funkcja ta jest szczególnie użyteczna dla administratorów sieci, którzy będą natychmiast powiadamiani o zarażeniu wirusem jednego z komputerów w ich sieci: dzięki temu będą mogli szybko zareagować.

Aby utworzyć alert, należy najpierw wybrać z listy dostępnych opcji sposób jego wysyłania:

  • E-mail (SMTP) - Alert będzie wysyłany jako wiadomość pocztowa za pomocą protokołu SMTP, ale należy najpierw zdefiniować kilka innych parametrów - patrz poniżej.
  • E-mail (MAPI) - Alert będzie wysyłany jako wiadomość pocztowa za pomocą protokołu MAPI, ale konieczne jest również podanie nazwy profilu MAPI i hasła - patrz poniżej.
  • Drukarki - Alert zostanie wysłany na wskazaną drukarkę
  • Komunikat sieciowy (WinPopup) - Alert będzie wysyłany jako komunikat sieciowy, ale najpierw konieczne jest wprowadzenie adresu IP lub nazwy sieciowej użytkownika, do którego komunikat ma zostać wysłany.

Konfiguracja SMTP

Tutaj należy wprowadzić parametry serwera SMTP:

  • Adres serwera - adres serwera poczty wychodzącej, np. smtp.serwer.com lub 192.168.1.25
  • Port - standardowy port to 25
  • Adres wysyłającego - adres osoby wysyłającej komunikat

Jeśli serwer SMTP wymaga uwierzytelnienia podczas logowania, użytkownik powinien również zaznaczyć pole wyboru "Jeśli serwer SMTP wymaga autoryzacji" i wprowadzić nazwę użytkownika i hasło.

Konfiguracja MAPI

Tutaj można wprowadzić nazwę profilu MAPI i hasło, które będą wykorzystywane, jeśli alerty mają być wysyłane jako wiadomości pocztowe za pomocą protokołu MAPI.


Wygląd

Na tym ekranie można wybrać, czy ikona programu antywirusowego avast! pojawi się w zasobniku systemowym, oraz czy będzie animowana podczas skanowania. Na dole ekranu są również inne opcje, takie jak na przykład ustawienia wyświetlania komunikatu powitalnego avast! podczas uruchamiania systemu Windows, wyświetlanie wyników skanowania po zakończeniu tego procesu, czy widoczność funkcji społecznościowych w interfejsie avast!

Język

Na tym ekranie wyświetlane są obecnie dostępne języki interfejsu. Aby zobaczyć wszystkie dostępne języki, należy kliknąć strzałkę. Jeśli pojawi się żądany język, należy go wybrać klikając nazwę a następnie kliknąć "OK". Po następnym uruchomieniu programu język interfejsu zostanie zmieniony. Jeśli żądany język nie pojawi się na liście, należy kliknąć "Zainstaluj dodatkowe języki" a następnie zaznaczyć pole wyboru obok żądanego języka. Kliknięcie przycisku "OK" spowoduje pojawienie się nowego okna z informacją, że plik jest pobierany z naszego serwera i nowy język zostanie zainstalowany. Po zakończeniu procesu należy kliknąć "Zakończ". Na koniec należy wybrać nowy język w taki sposób, jak opisano powyżej.

Dźwięki

Na tym ekranie można włączyć lub wyłączyć różne efekty dźwiękowe i komunikaty głosowe generowane przez program avast! w wyniku zajścia określonych zdarzeń.

Domyślnie dźwięki zdarzeń i podkłady głosowe są włączone. Zaznaczenie pola wyboru "Używaj podkładów głosowych (gdy dostępne)" umożliwia generowanie komunikatów głosowych, np. gdy wykryty zostanie potencjalnie niebezpieczny plik lub po aktualizacji definicji wirusów.

Monitorowanie statusu

Tutaj można określić, które komponenty wykorzystywane są do wskazywania bieżącego poziomu ochrony. Jeśli jakiś komponent pozostanie nieoznaczony, nie będzie monitorowany. Oznacza to, że późniejsze wyłączenie tego komponentu nie będzie miało wpływu na wyświetlany poziom ochrony. Na poziom ochrony mają wpływ tylko elementy zaznaczone.

Wyskakujące okna

Tutaj można określić czas, przez jaki różne komunikaty w formie wyskakujących okienek będą wyświetlane na ekranie.

Można również przeglądać miesięczne raporty bezpieczeństwa. Co 30 dni tworzony jest spersonalizowany raport bezpieczeństwa, w którym użytkownik programu avast! może sprawdzić, jak program dyskretnie działał chroniąc komputer przed złośliwym oprogramowaniem. Można również przeglądać raporty indywidualne dot. liczby przeskanowanych plików i dokumentów, jak też zarażonych stron WWW oraz plików, których pobieranie zostało zablokowane. Można też przeglądać statystyki dot. liczby użytkowników programu avast! na całym świecie, informacji o zarażonych stronach WWW i wielu innych użytecznych i interesujących danych.


Ustawienia aktualizacji - ogólne

Ustawienia aktualizacji

Na tym ekranie można zobaczyć aktualną wersję silnika i definicji wirusów, oraz kiedy ostatnia zmiana została przyjęta. Można również sprawdzić używaną wersję programu.

Można zdecydować, czy program i definicje wirusów będą aktualizowane automatycznie, ręcznie, czy tylko na żądanie, po powiadomieniu o dostępności aktualizacji.

Na tym ekranie można również wskazać typ używanego połączenia internetowego, tj. określić, czy komputer łączy się z siecią przez modem telefoniczny, czy też jest podłączony na stałe do Internetu. Dzięki temu zoptymalizowany zostanie proces sprawdzania dostępności nowych aktualizacji programu, co zwiększa jego niezawodność. Można także określić, jak często program antywirusowy avast! powinien sprawdzać, czy dostępne są aktualizacje (jeśli nie są włączone aktualizacje strumieniowe).

Pod opcją "Szczegóły" można wybrać pojawianie się komunikatów po aktualizacji.

Aktualizacje w czasie rzeczywistym

Włączenie funkcji aktualizacji strumieniowych daje pewność, że nowe definicje wirusów przesyłane są do komputera użytkownika w czasie rzeczywistym i nie czekają na następną planową aktualizację. Ponieważ baza danych o wirusach będzie aktualizowana w trybie ciągłym, komputer będzie jeszcze lepiej chroniony nawet przed najnowszymi zagrożeniami. Można przejść do funkcji Aktualizacji strumieniowych przechodząc do głównego ekranu Ustawienia, a następnie klikając zakładkę Aktualizacje na lewym pasku menu. W tej lokalizacji jest możliwość włączenia aktualizacji strumieniowych definicji wirusów oraz programu.

Ustawienia serwera proxy

Ustawienia dostępne na tej stronie są istotne w sytuacji, gdy program avast! musi uzyskać dostęp do Internetu, np. podczas dokonywania aktualizacji.

Jeśli jest używane bezpośrednie łącze z Internetem (tj. bez proxy), nie należy nic robić, ponieważ "bezpośrednie połączenie" jest ustawieniem domyślnym. Proszę zwrócić uwagę, że połączenia dial-up nie wykorzystują serwerów proxy.

Jeśli użytkownik nie jest pewien, czy korzysta z serwera proxy, albo z którego serwera proxy korzysta, powinien wybrać opcję "Automatyczne wykrywanie" lub zapytać swojego dostawcę internetowego lub administratora sieci.

Jeśli komputer łączy się z Internetem poprzez serwer proxy a użytkownik zna dane serwera, nalezy wybrać "Wskaż serwer proxy" i wpisać jego dane:

  • Typ - HTTP lub SOCKS4
  • Adres - Wpisać adres serwera proxy.
  • Port - Wpisać port wykorzystywany przez serwer proxy.
  • Typ uwierzytelnienia - Tutaj należy wskazać, czy serwer proxy wymaga uwierzytelnienia, a jeśli tak, to także typ uwierzytelnienia.
  • Nazwa użytkownika i hasło - Należy wpisać, jeśli są wymagane do uwierzytelnienia.


Strefa izolowana Sandbox - Parametry

Parametry

  • Pokaż obramowanie wokół okien utworzonych przez aplikacje wirtualizowane

    Opcja ta włącza wyświetlanie strefy izolowanej Sandbox w oknie z kolorowym obramowaniem. W ten sposób użytkownik widzi wyraźnie, czy aplikacja pracuje w strefie izolowanej. Można również wybrać kolor i szerokość obramowania.

  • Pokaż znaczniki w tytułach okien utworzonych przez aplikacje wirtualizowane

    Jeśli zaznaczone zostanie to pole wyboru, w nazwie aplikacji pracującej w strefie izolowanej wyświetlany będzie specjalny znacznik.

  • Pokaż wyskakujące okienko informacyjne przy uruchomieniu aplikacji wirtualizowanej

    Jeśli zaznaczone zostanie to pole wyboru, w prawym dolnym rogu nad paskiem zadań zostanie wyświetlone niebieskie okienko informacyjne przed uruchomieniem dowolnej aplikacji w strefie izolowanej.

  • Dodaj to menu kontekstowego (prawy klawisz myszy)

    Umożliwia to użytkownikowi dodanie opcji wirtualizacji do menu kontekstowego. Można dodać tę opcję dla wszystkich użytkowników, albo dla użytkowników z uprawnieniami administratora. To zaś umożliwia użytkownikowi uruchamianie aplikacji w strefie izolowanej po prostu przez kliknięcie jej prawym klawiszem myszy i wybranie polecenia "Uruchom w trybie wirtualizacji".

  • Chroń wirtualizowane aplikacje przed zrzutami ekranu

    Wybór tej opcji powoduje, że zawartość dowolnego wirtualizowanego okna będzie zupełnie pusta na zrzutach ekranu z pulpitu systemowego. Daje to pewność, że wrażliwe dane nie mogą zostać przechwycone, jeśli ktoś obcy spróbuje zrobić zrzut ekranu, aby ukraść prywatne dane użytkownika.

  • Przypisz ograniczenia pamięci/CPU/czasu dla niepodpisanych procesów w strefie izolowanej

    Wybór tej opcji powoduje, że avast! zastosuje pewne ograniczenia na korzystanie z pamięci i CPU, aby zapobiec całkowitemu wykorzystaniu komputera przez wirtualizowaną aplikację. Dzięki temu część systemu będzie wciąż dostępna na potrzeby innych aplikacji, jeśli reszta zasobów zostanie przechwycona przez złośliwe oprogramowanie.

  • Odrzuć prawa administratora i uruchamiaj wirtualizowane aplikacje jako użytkownik o ograniczonych prawach.

    Jeśli strefa izolowana Sandbox zostanie otwarta, gdy użytkownik jest zalogowany jako administrator systemu, wszelkie aplikacje uruchamiane w tej strefie będą uruchamiane bez uprawnień administratora. Jest to kolejna warstwa zabezpieczeń mających na celu zapobieganie dostępowi do miejsc, do których dostęp może mieć wyłącznie administrator systemu.

USTAWIENIA ZAAWANSOWANE

  • Pomiń ograniczenie maksymalnego rozmiaru kopiowanego pliki i wskaż rozmiar ręcznie (MB)

    Dzięki tej opcji, użytkownik może zmienić maksymalny rozmiar pliku, który może być modyfikowany w strefie izolowanej Sandbox. Pliki wirtualizowane to kopie plików oryginalnych. Jeśli podjęta zostanie próba modyfikowania pliku przekraczająca ten rozmiar, avast! nie dopuści do wykonania tej operacji.


Strefa izolowana Sandbox - Przechowywanie

Magazyn strefy odizolowanej Sandbox

Lokalizacja

  • Wybierz napęd, gdzie ma być przechowywany magazyn strefy izolowanej Sandbox

    Tutaj można określić lokalizację folderów, w których przechowywane będą pliki ze strefy izolowanej Sandbox. W konfiguracji domyślnej folder magazynu danych ze strefy izolowanej zostanie utworzony w tym samym miejscu, co plik modyfikowany. W ten sposób magazyn rozkłada się na dostępne lokalizacje w celu możliwie najlepszego wykorzystania dostępnego miejsca.

    Ewentualnie można określić, czy powinien być wybrany jeden folder przechowywania folderu sandbox znajdujący się na dysku C:. Można również przejrzeć komputer w celu wybrania innej lokalizacji.

    Należy pamiętać, że jeśli użytkownik zmieni lokalizację magazynu danych ze strefy izolowanej, będzie musiał ponownie uruchomić system, aby ustawienie zadziałało, a bieżący folder i cała jego zawartość zostaną usunięte.


Strefa izolowana Sandbox – przeglądarki internetowe

Przeglądarki internetowe

  • Zapisz zaufane pobrane pliki poza strefą izolowaną

    Jeśli to pole zostanie zaznaczone, pliki zapisywane lub pobierane podczas pracy w strefie izolowanej zostaną zapisane poza strefą izolowaną Sandbox. Innymi słowy, proces zapisywania lub pobierania plików do tych lokalizacji nie będzie wirtualizowany. Pole to jest zaznaczane w konfiguracji domyślnej, ale jeśli usunąć zaznaczenie, wszelkie pliki, które użytkownik zapisuje lub pobiera podczas pracy w trybie wirtualizacji nie będą w rzeczywistości zapisywane.

  • Wykrywaj aktualizacje i uruchamiaj je poza środowiskiem izolowanym

    Włączenie tej opcji oznacza, że każda aktualizacja przeglądarki internetowej, która zostanie wykryta podczas surfowania w strefie izolowanej Sandbox będzie uruchamiana jako normalna aplikacja poza strefą izolowaną.

Wykluczenia

Tutaj można wskazać niektóre opcje, które nie powinny być wirtualizowane podczas korzystania z przeglądarki internetowej w strefie izolowanej, np. zakładki, historia przeglądanych stron, pliki "ciasteczek" [cookies]. Oznacza to, że nawet wtedy, gdy przeglądarka będzie uruchamiana w strefie izolowanej, opcje te nie będą wirtualizowane i będą dostępne dla każdej innej sesji przeglądania stron, która jest lub zostanie otwarta później, czy to w strefie izolowanej, czy też poza nią.

Konserwacja

  • Pliki przeglądarki umieszczaj w pamięci podręcznej (zawartość strefy izolowanej nie będzie automatycznie usuwana)

    W normalnej sytuacji, przy każdym uruchomieniu aplikacji w strefie izolowanej, avast! tworzy specjalny obszar przechowywania w strefie izolowanej dla tej aplikacji oraz do przechowywania wirtualizowanych plików/katalogów. Ten izolowany obszar przechowywania zostaje później usunięty po zamknięciu aplikacji.

    Jeśli zaznaczone zostanie to pole, dla przeglądarek internetowych wykorzystywany będzie całkiem osobny izolowany obszar przechowywania i nie będzie on automatycznie usuwany po zamknięciu przeglądarki. Oznacza to, że po następnym uruchomieniu, przeglądarka będzie wykorzystywała ten sam izolowany obszar przechowywania co w poprzedniej sesji, co usprawni działanie przeglądarki.

  • Automatycznie czyść magazyn strefy izolowanej Sandbox

    Tutaj można zdecydować, że zawartość strefy izolowanej powinna być automatycznie usuwana. Można również wskazać, jak często ma być usuwana, np. po określonej liczbie dni, co tydzień w danym dniu tygodnia lub w określonym dniu każdego miesiąca.


Wizualizacja procesów - Procesy wirtualizowane

Procesy wirtualizowane

Na tej stronie wskazuje się pliki, które zawsze powinny być uruchamiane w trybie wirtualizacji. Wystarczy kliknąć przycisk przeglądania a następnie odszukać i wybrać plik lub ścieżkę do pliku, który zawsze powinien być uruchamiany w strefie izolowanej. Aby usunąć plik lub ścieżkę ze strefy izolowanej wystarczy kliknąć przycisk usuwania.

Możesz również dodać lokalizacje folderów, z których każda uruchomiona aplikacja będzie automatycznie wirtualizowana.


Strefa izolowana Sandbox - Prywatność

Prywatność

Na tym ekranie można ograniczyć dostęp aplikacji wirtualizowanych do różnych miejsc w systemie komputerowym. Można użyć tych ustawień do blokowania dostępu do prywatnych plików i danych, np. plików MS Office, ciasteczek [cookies], ostatnio wpisywanych adresów URL, itd.

Użytkownik może całkowicie zablokować dostęp do własnych plików, tak by nie były w ogóle widoczne dla wirtualizowanej aplikacji. Zapobiega to dostępowi złośliwego oprogramowania do tych plików, pobierania i wysyłania ich do kogoś obcego przez Internet.

W domyślnej konfiguracji pliki zlokalizowane z folderach "System", "Internet Explorer" oraz "Application Data" są automatycznie blokowane.

Dostęp do dowolnych plików można odblokować zmieniając status na "Zezwalaj". Można również dodać własne foldery i określić dostęp do nich za pomocą opcji blokuj/zezwalaj.


Wizualizacja procesów - Wykluczenia

Wykluczenia

Na tej stronie wskazuje się pliki, które nigdy nie powinny być uruchamiane w trybie wirtualizacji. Wystarczy kliknąć przycisk przeglądania a następnie odszukać i wybrać plik lub ścieżkę, które powinny zostać wykluczone. Aby usunąć plik lub ścieżkę z listy wykluczeń wystarczy kliknąć przycisk usuwania.


Wizualizacja procesów – Dostęp do Internetu

Dostęp do Internetu

Tutaj można zdefiniować, którym (jeśli jakimkolwiek) aplikacjom w trybie wirtualizacji zezwala się na dostęp do Internetu.

Można wybrać opcje "Zezwól na wszystkie" lub "Blokuj wszystkie", albo też można wyszczególnić pewne aplikacje, które będą miały dostęp do Internetu, a wszystkie pozostałe będą automatycznie blokowane. Dla przykładu, można zezwolić na dostęp do sieci wszystkim przeglądarkom sieciowym, albo zdefiniować inne konkretne aplikacje klikając pole "Wybierz dodatkowe aplikacje" i za pomocą przycisku przeglądania lokalizując i wybierając aplikacje, które mają mieć dostęp do Internetu.


Wizualizacja procesów - Plik raportu

Plik raportu

Na tym ekranie można zdecydować, by tworzony był raport po uruchomieniu aplikacji w trybie wirtualizacji. Można określić typ pliku raportu (zwykły tekst lub xml) oraz okres, przez który raport powinien być przechowywany.

Raport będzie zawierał podstawowe informacje o aplikacji, które są uruchamiane w trybie wirtualizacji, datę i godzinę uruchomienia aplikacji w trybie wirtualizacji oraz szczegółowe dane o działaniach wykonywanych, gdy program pracował w trybie wirtualizacji.

Plik raportu zapisywany jest w katalogu C:\Documents and Settings\All Users\Application Data\AVAST Software\Avast\report (Windows 2000 i Windows XP) lub w katalogu C:\ProgramData\AVAST Software\Avast\report (Windows Vista, Windows 7, Windows 8).


Parametry SafeZone

Ekran ten umożliwia zmienianie parametrów funkcji SafeZone. Znajduje się w części Ustawienia, następnie Narzędzia. Tam należy wybrać przycisk "Dostosuj" znajdujący się obok SafeZone.

Dostępne są tutaj funkcje ułatwiające korzystanie z SafeZone, jak na przykład dodawanie skrótów SafeZone do Pulpitu czy wybranie skrótów klawiszowych do przełączania między standardową przeglądarką i SafeZone. Można również włączyć lub wyłączyć współdzielenie schowka przez Pulpit i SafeZone czy efekt zanikania przy przełączaniu pulpitu.

Chroń przed atakami w oparciu o DNS - po wpisaniu adresu internetowego jest on zamieniany na adres IP. Jeśli ta opcja zostanie wybrana, to tłumaczenie DNS jest wykonywane przez serwer DNS, a nie przez system Windows. Pozwala to uniknąć fałszywych tłumaczeń, które mogą być wykonywane przez niektóre rodzaje złośliwego oprogramowania.

Chroń przed programami logującymi uderzenia w klawisze i przechwytującymi hasła - Po wybraniu tej opcji wpisywane znaki będą wysyłane bezpośrednio z klawiatury do SafeZone. W ten sposób jakiekolwiek ukryte keyloggery nie będą w stanie monitorować tych klawiszy, ponieważ nie będą one dzielone z aplikacjami Windows.

Kliknięcie przycisku "Wyzeruj SafeZone" powoduje stałe usunięcie całej zawartości bezpiecznej strefy SafeZone.


Rozwiązywanie problemów

Zmiana ustawień na tej stronie może pomóc w rozwiązywaniu pewnych konkretnych problemów. Ustawień tych nie należy jednak zmieniać bez poważnego powodu. W razie wątpliwości należy najpierw skontaktować się z AVAST Software.

  • Włącz skanowanie w poszukiwaniu rootkitów w czasie uruchamiania systemu - W normalnej sytuacji program avast! skanuje komputer w poszukiwaniu rootkitów przy każdym ponownym uruchomieniu systemu. Należy usunąć zaznaczenie tego pola wyboru, jeśli użytkownik nie chce, by to zadanie było wykonywane przy każdym uruchomieniu systemu.
  • Włącz bezpośredni dostęp do dysku podczas skanowania w trakcie rozruchu - Podczas skanowania w trakcie rozruchu program avast! wykorzystuje specjalną metodę dostępu do surowych danych na dysku, w celu sprawdzenia go na obecność wirusów, które mogą się na nim ukrywać.
  • Pomiń sprawdzanie podpisów cyfrowych zarażonych plików - Aby zapobiec fałszywym alarmom, program avast! sprawdza podpisy cyfrowe plików. Jeśli plik zostanie zidentyfikowany jako podejrzany, ale zawiera on ważny podpis cyfrowy wydany przez wystawiony przez godnego zaufania wystawcę, prawdopodobnie jest to przypadek fałszywego alarmu. W tym przypadku plik nie zostanie zgłoszony jako podejrzany. Jeśli usunięte zostanie zaznaczenie tego pola wyboru, zgłaszane będą wszystkie podejrzane pliki, w tym te z ważnymi podpisami cyfrowymi.
  • Włącz moduł samoobrony programu avast! - Niektóre wirusy atakują oprogramowanie antywirusowe i próbują je wyłączyć usuwając lub modyfikując kluczowe pliki. Program avast! posiada funkcje samoobrony, które zapobiegają takim atakom przez zablokowanie niebezpiecznych operacji w systemie. Usunięcie zaznaczenia tego pola wyboru powoduje wyłączenie modułu samoobrony, co umożliwia usunięcie takich plików.
  • Załaduj usługi programu avast! dopiero po załadowaniu pozostałych usług systemowych - Usługa programu avast! w normalnej sytuacji ładowana jest dosyć wcześnie w trakcie procesu rozruchowego. W niektórych sytuacjach może to powodować problemy z ładowaniem innych usług systemowych, np. po uruchomieniu może się wydawać, że system chwilowo "zawiesił się". Zaznaczenie tego pola wyboru opóźnia ładowanie usług programu avast! aż do chwili, gdy inne usługi systemowe będą już uruchomione.
  • Nie stosować przeglądarki Chrome jako domyślnej przeglądarki avast!.
  • Ogranicz dostęp programu dla konta Gość.
  • Włącz wirtualizacje wspomaganą sprzętowo

Przywróć ustawienia domyślne

Klikając "Resetuj teraz", użytkownik może przywrócić ustawienia programu avast! do pierwotnych ustawień domyślnych. Można przywrócić wszystkie ustawienia programu, w tym także domyślne ustawienia skanowani, albo tylko ustawienia osłon. Warto pamiętać, że przywrócenia ustawień nie da się cofnąć. Jednak po przywróceniu ustawień można je dostosować wedle potrzeb.

Konfiguracja przekierowania

Ustawienia te umożliwiają użytkownikowi wskazanie portów używanych przez klienta e-mail i programy korzystające z sieci, jeśli porty standardowe nie są używane. Jest istotne, by poczta elektroniczna i przeglądanie stron w sieci były monitorowane przez avast!, bez względu na to, jakie porty są używane w tym celu.

Program avast! zakłada, że cała komunikacja ze stronami WWW przebiega przez port 80 i pomija wszystko inne. Jeśli użytkownik korzysta z jakiegoś serwera proxy przy dostępie do Internetu i chce skanować komunikację między serwerem proxy i komputerem, należy wprowadzić port używany do połączeń z serwerem proxy. Należy wpisać wyłącznie porty obsługujące ruch w protokole http, a nie te do obsługi ICQ, DC++, itd. Dla poczty elektronicznej portami domyślnymi są standardowe numery portów dla podstawowych protokołów pocztowych. Jeśli używany jest inny port (lub porty), należy tutaj wprowadzić ich numery. Przy wpisaniu kilku numerów portów należy oddzielić je przecinkami.

  • Adresy pomijane - Tutaj można wpisać adresy lub porty serwerów, które mają zostać wykluczone z procesu skanowania.
  • Pomijaj komunikację lokalną - Jeśli zaznaczone zostanie to pole, program avast! nie będzie skanował komunikacji między aplikacjami uruchomionymi na danym komputerze. Usunięcie zaznaczenia tego pola wyboru spowoduje skanowanie komunikacji lokalnej, co może nieco spowolnić pracę komputera.


Korzystanie z wiersza poleceń

Jak korzystać ze skanera sterowanego z wiersza poleceń

Funkcja a dostępna jest jedynie w avast! Pro antivirus i avast! Internet Security.

Program ashCmd wykorzystuje ten sam mechanizm skanowania avast! do wykrywania potencjalnych przypadków zarażenia złośliwym oprogramowaniem, tak że wyniki są dokładnie takie same jak w przypadku skanowania uruchomionego z normalnego interfejsu programu. Uruchamiany z wiersza poleceń skaner avast!, ashCmd.exe, jest instalowany domyślnie w katalogu C:\Program Files\AVAST Software\avast.

Zadanie skanowania można uruchomić z wiersza poleceń, korzystając przy tym z szeregu przełączników i parametrów. Aby zobaczyć opis tych parametrów, należy znaleźć plik ashCmd i kliknąć go dwukrotnie. Otworzy się nowe okno, w którym wyświetlane są różne parametry. Listę wszystkich parametrów można też znaleźć tutaj, w Pomocy do programu avast!.

Aby uruchomić zadanie skanowania, użytkownik powinien otworzyć konsolę wiersza poleceń i zmienić wyświetlany katalog na:

C:\Program Files\AVAST Software\avast

Następnie należy wpisać nazwę programu ashCmd.exe a po niej obszar do przeskanowania oraz odpowiednie parametry. Dla przykładu, aby przeskanować wszystkie dyski lokalne, w wierszu poleceń należy wpisać:

ashCmd.exe /*

Można dodać więcej parametrów w miarę potrzeb. Aby przeskanować konkretny plik, należy wpisać żądaną ścieżkę, pamiętając o ujęciu nazw zawierających spacje w cudzysłów (" "), np.

ashCmd.exe "C:\Program Files"

Aby uruchomić konkretne zadanie skanowania, należy wpisać nazwę programu, po której następuje /@=<nazwa zadania skanowania>. Dla przykładu, aby uruchomić zadanie skanowania o nazwie "Skanowanie cotygodniowe", w wierszu poleceń należy wpisać:

ashCmd.exe /@="Skanowanie cotygodniowe"

Skanowania zostanie przeprowadzone w oparciu o parametry zdefiniowane dla danego zadania skanowania. Wszelkie inne parametry wpisane w wierszu poleceń zostaną zignorowane.

Gdy skanowanie zostanie zakończone, wyniki mogą zostać zapisane w pliku za pomocą parametru "/_ >", tak że polecenie:

ashCmd.exe C:\Windows /_ >wyniki.txt

spowoduje przeskanowanie ścieżki C:\Windows i zapisanie wyników skanowania w nowym pliku o nazwie wyniki.txt


Parametry używane w wierszu poleceń

Parametry i przełączniki

Przykład: "C:\Program files" /p /u=virus@avast.com --soundoff /v="key kapt"

d:\ścieżka
Parametr ten wskazuje dysk i katalog do przetestowania. Jeśli parametr ten nie zostanie podany, skanowane są pliki w katalogu głównym bieżącego dysku. Można zdefiniować kilka dysków jednocześnie.

d:\ścieżka\plik
Gdy podana zostanie pełna ścieżka do pliku, ashCmd skanuje tylko ten plik. Plik ten musi istnieć na dysku!

/H lub /? (lub --help)
Polecenie wyświetla pomoc i listę dostępnych przełączników.

/# (lub --remote)
Polecenie uruchamia skanowanie dysków sieciowych.

/* (lub --local)
Polecenie uruchamia skanowanie dysków lokalnych.

/_ (lub --console)
Aplikacja będzie gotowa do STDIN/STDOUT. Wszystkie dane wyjściowe zostaną przekierowane do standardowego miejsca dla danych wyjściowych (STDOUT). Znaczy to, że dane wyjściowe można przetwarzać za pomocą różnych narzędzi wiersza poleceń pracujących w systemach UNIX.

/A (lub --testall)
Polecenie uruchamia skanowanie wszystkich plików.

/@=<nazwa zadania> (lub --task)
Polecenie uruchamia konkretne zadanie skanowania dla programu avast!. Wszystkie pozostałe parametry są pomijane. Jeśli nazwa zadania zawiera spacje, musi zostać umieszczona w cudzysłowie.

/C (lub --testfull)
Polecenie włącza skanowanie całych plików. Domyślnie testowane są tylko istotne części plików, co znacznie przyspiesza proces. Gdy zostanie znaleziony wirus, program przełącza się automatycznie na skanowanie całych plików.

/D (lub --dontpanic)
Polecenie wskazuje programowi avast!, że nie powinien przechodzić w "tryb paniki", gdy wykryty zostanie zainfekowany plik. Tryb paniki oznacza, że czułość skanowania zostaje automatycznie podniesiona do poziomu maksymalnego.

/E=<wartość> (lub --heuristics)
Polecenie ustawia czułość analizy heurystycznej dla zadania skanowania. Wartość może zawierać się w przedziale 0 -100, gdzie "0" oznacza wyłączenie analizy, a "100" oznacza maksymalną czułość analizy heurystycznej.

/F=<wartość> (lub --fileactions)
Polecenie określa sposób przetwarzania zarażonych plików przez program, np.

  • B = parametr zezwala programowi na opóźnione wykonywanie czynności (po ponownym uruchomieniu komputera) w przypadku plików zablokowanych.
  • P = jeśli pliku nie da się usunąć z archiwum, program podejmie próbę usunięcia całego archiwum macierzystego
  • S = parametr zabrania usuwania odniesień do automatycznego uruchamiania [Autostart] podczas usuwania pliku
  • W = jeśli wewnątrz archiwum wykryty zostanie zarażony plik, program zastosuje daną czynność do całego archiwum, a nie tylko do zarażonego pliku.

/G=<wartość> (lub --checkgenuine)
Polecenie wymusza sprawdzanie podpisów cyfrowych podejrzanych plików i określa, co program ma zrobić, jeśli podpis pochodzi z zaufanego źródła. Parametr może przybierać wartość "0" (co oznacza, że wszystkie pliki będą uwzględniane w raporcie) lub "1" (pliki z podpisami cyfrowymi zaufanych wystawców nie będą uwzględniane w raporcie)

/I (lub --ignoretype)
Polecenie włącza wyszukiwanie wszystkich wirusów we wszystkich plikach (tj. wirusy sektora rozruchowego będą szukane nawet w plikach EXE, itd.).

/J (lub --paging)
Polecenie dzieli wiersze na strony, jeśli program nie pracuje w trybie STDOUT (tj. zatrzymuje się po każdej pełnej stronie wyników).

/M (lub --boot)
Polecenie uruchamia testowanie sektorów rozruchowych oraz pamięci operacyjnej.

/P (lub --continue)
Przełącznik ten sprawia, że program będzie pracował bez przerw po sprawdzeniu obszarów systemowych dysku i nie będzie czekał na decyzje użytkownika, gdy znajdzie wirusa. Aby sprawdzić wyniki skanowania możesz skorzystać z kodów zwrotnych lub informacji przechowywanych w pliku raportu. Aby wskazać działanie podejmowane automatycznie wobec zarażonych plików należy użyć /P=[1234], gdzie 1 = usuń plik, 2 = przenieś do Kwarantanny, 3 = napraw, 4 = zatrzymaj.

/R=[*] [nazwa pliku] (lub --report)
Przełącznik ten sprawia, że utworzony zostanie plik tekstowy z listą znalezionych wirusów oraz tabela podsumowującą (plik raportu). Jeśli nazwa pliku nie zostanie podana, wyniki zostaną zapisane w pliku o nazwie ashCmd.rpt. Gdy po przełączniku /R wpiszemy znak "*", wszystkie przeskanowane pliki zostaną zapisane w pliku raportu (nawet te, gdzie nie wykryto wirusów).

/S (lub --soundoff)
Przełącznik ten wyłącza dźwięk alarmu. Domyślnie każde odnalezienie wirusa jest oznajmiane brzęczykiem.

/U=<adres> (lub --sendmessage)
Jeśli zostanie znaleziony wirus, komunikat ostrzegawczy zostanie wysłany na podany adres.

/T=[JZIMXRSTGCBWOEQHFVKPY7D6U123AN] (lub --archivetype)
Polecenie wskazuje typ archiwów do przeskanowania (J:ARJ, Z:ZIP, I:MIME, M:MAPI, X:Exec, R:RAR, S:Streams, T:TAR, G:GZ, C:CAB, B:BZIP2, W:WinExec, O:ZOO, E:ACE, Q:ARC, H:LHA, F:TNEF, V:CPIO, K:CHM, P:RPM, Y:ISO, 7:7ZIP, D:DBX, 6:SIS, U:OLE, 1:instalator, 1:Instalator, 2:zakraplacz, 3:emulator, A:wszystkie, N:żadne).

/X=<wartość> (lub --virustypes)
Parametr wskazuje konkretne typy złośliwego oprogramowania, które mają być wykrywane (typy, które nie są wykrywane w konfiguracji domyślnej)

  • P = PNP (potencjalnie niepożądane programy)


AutoSandbox

Moduł avast! AutoSandbox to specjalny mechanizm bezpieczeństwa, który umożliwia automatyczne uruchamianie podejrzanych aplikacji w całkowicie odizolowanym środowisku, bez żadnego ryzyka dla komputera lub plików użytkownika.

W konfiguracji domyślnej, jeśli uruchamiana jest aplikacja, avast! wykrywa jakiekolwiek podejrzane symptomy, uruchamia aplikację automatycznie w strefie izolowanej Sandbox. W ustawieniach AutoSandbox można zmienić to zachowanie tak, by avast! najpierw pytał użytkownika, czy uruchomić aplikację w strefie izolowanej. Jeśli użytkownik odpowie "Otwieraj w środowisku izolowanym", aplikacja zostanie uruchomiona w tej strefie, w której nie może wyrządzić żadnych szkód systemowi.

Umożliwia to użytkownikowi sprawdzenie wszelkich podejrzanych aplikacji przy jednoczesnym zachowaniu pełnej ochrony przed wszelkimi złośliwymi działaniami, które zainfekowana aplikacja może próbować wykonywać.

Następnie przeglądarka lub inna aplikacja otworzy się w specjalnym oknie z czerwonym obramowaniem, które wskazuje, że uruchomiona została w strefie izolowanej [Sandbox].

Ustawienia AutoSandbox umożliwiają również wyłączenie modułu lub wskazanie dowolnych plików lub aplikacji, które nie powinny być automatycznie uruchamiane w strefie izolowanej.

Ustawienia AutoSandbox dostępne są również w "Ustawieniach" Osłony systemu plików.

W programie avast! Pro Antivirus, w pakiecie avast! Internet Security oraz avast! Premier, główne ustawienia strefy izolowanej Sandbox będą również wykorzystywane przez moduł AutoSandbox, np. ustawienia określające, czy pobrane z sieci pliki lub opcje przeglądarki internetowej będą usuwane automatycznie po zamknięciu aplikacji uruchomionej w strefie izolowanej.

Ustawienia te nie są dostępne w darmowej wersji avast! Free Antivirus, w której wszystkie pobrane z sieci pliki są usuwane po zamknięciu modułu Sandbox.


Ustawienia modułu AutoSandbox

Wybierając "Pytaj" dla "Trybu AutoSandbox" można skonfigurować program avast! tak, by pytał użytkownika przed uruchamianiem jakichkolwiek podejrzanych aplikacji w strefie izolowanej Sandbox.

Można również wykluczyć określone pliki z uruchamiania w strefie izolowanej. Należy kliknąć "Wpisz ścieżkę" a następnie kliknąć przycisk "Przeglądaj", by wybrać pliki, które mają zostać wykluczone z takiej ochrony.

Aby całkowicie wyłączyć moduł AutoSandbox, wystarczy usunąć zaznaczenie pola wyboru "Włącz AutoSandbox".


Osłona antyspamowa - ustawienia podstawowe

W głównych ustawieniach można określić czułość skanowania na poziomie Niskim, Średnim lub Wysokim. Program avast! przeprowadzi analizę heurystyczną wszystkich przychodzących wiadomości w celu wykrycia poczty śmieciowej (spamu). Analiza heurystyczna obejmuje dużą liczbę testów opartych o elementy lub zachowania typowe dla spamu, a poziom czułości określa jaka liczba testów musi zakończyć się niepowodzeniem, by wiadomość pocztowa została uznana za spam. Im wyższa czułość, tym wyższy "próg przejścia", a zatem tym większa liczba wiadomości pocztowych, które nie przejdą testu heurystycznego i będą traktowane jako spam.

Jeśli okaże się, że dużo "czystych" wiadomości przesyłanych jest do folderu ze spamem, problem można rozwiązać obniżając czułość analizy heurystycznej.


Osłona poczty - ustawienia podstawowe

Ustawienia podstawowe

Tutaj można określić, jakiego typu wiadomości będą skanowane, tj. wiadomości odbierane (przychodzące), wysyłane (wychodzące), albo oba typy wiadomości.


Osłona WWW -ustawienia podstawowe

Ustawienia podstawowe

  • Skanuj ruch sieciowy (HTTP) - Pole wyboru włącza/wyłącza skanowanie stron WWW (nie ma to wpływu na blokowanie URL). Opcja ta jest zawsze włączona w konfiguracji domyślnej, ale można ją tutaj wyłączyć, jeśli użytkownik nie chce lub nie potrzebuje monitorowania ruchu związanego z surfowaniem po sieci.


Ustawienia modułu Monitorowania zachowań

Ustawienia ogólne

W ustawieniach osłony Monitorowanie zachowań można określić, jakiego typu działania powinny być monitorowane i jakie czynności należy podjąć, jeśli takie działanie zostanie wykryte. Domyślnym działaniem jest "Decyduj automatycznie", co oznacza, że avast! zadecyduje na podstawie różnych kryteriów, czy należy zezwolić na uruchomienie danego programu. Po kliknięciu na strzałkę rozwijanej listy można wybrać inne działanie i będzie one wykonywane zawsze: "Zezwól", "Blokuj" lub "Zapytaj ". Jeżeli działanie jest zmienione na "Zapytaj", za każdym razem, gdy działanie zostanie wykryte, pojawi się komunikat i trzeba będzie potwierdzić, czy powinno być dozwolone, czy nie.

Zaufane procesy:

Na tym ekranie można określić, jakie procesy (programy, pliki itd.) są godne zaufania i zawsze powinny być uruchomione. Niektóre programy mogą zachowywać się w sposób, który avast! uważa za podejrzany, ale jeśli są one określone jako "zaufane", ich działania będą automatycznie akceptowane.

Aby dodać zaufany proces trzeba kliknąć na przycisk "Przeglądaj", aby zlokalizować go na swoim komputerze, a następnie kliknąć przycisk "Dodaj". Aby usunąć zaufany proces należy zaznaczyć go kliknięciem, a następnie kliknąć przycisk "Usuń".


Monitorowanie zachowań

Osłona Monitorowanie zachowań monitoruje wszystkie wykonywane w komputerze działania, wykrywa i blokuje działania niecodzienne, które mogą wskazywać na obecność złośliwego oprogramowania. Czyni tak stale monitorując punkty wejścia komputera za pomocą specjalnych czujników, w celu wykrycia wszelkich podejrzanych zachowań.


Monitorowanie zachowań - ustawienia ogólne

Ustawienia modułu Monitorowania zachowań

W ustawieniach osłony Monitorowanie zachowań można określić, jakiego typu działania powinny być monitorowane i jakie czynności należy podjąć, jeśli takie działanie zostanie wykryte.

Można również przeglądać zawartość komputera, by zlokalizować konkretne "zaufane" procesy, które nie powinny być monitorowane.


Dodatki do przeglądarki

Użytkownicy programu avast! mogą również zainstalować dodatkowe narzędzia zabezpieczające, aby przeglądarki były lepiej chronione.

Można również zainstalować pakiet zabezpieczeń online, wyposażony w funkcje Anti-phishing, Do Not Track i SiteCorrect.

Dodatek Online Security jest obsługiwany przez przeglądarki Chrome, Firefox, Internet Explorer oraz Safari.

Funkcja Do Not Track wykrywa i blokuje firmy, które śledzą odwiedzane strony, w tym internetowe narzędzia analizy, śledzenia reklam i mediów społecznych. Ikona w prawym górnym rogu przeglądarki pokazuje liczbę aplikacji śledzenia na odwiedzanych witrynach. Klikając na numer można uzyskać informacje na temat oprogramowania, śledzenia, a także włączyć/wyłączyć oprogramowanie śledzące.

Wtyczka Anti-phishing oferuje dodatkową ochronę poprzez skanowanie stron internetowych i ostrzeżenia o potencjalnym szkodliwym oprogramowaniem i phishingiem w czasie rzeczywistym.

SiteCorrect zapyta, czy użytkownik zechce przejść do witryny, jeżeli uważa wpisany adres za niepoprawny (na przykład www.gaagle.com zamiast google.com) i może być ustawiona na automatyczne przekierowanie do strony, która miała być odwiedzona.


Osłona przeglądarek

Integracja z przeglądarką

Na tym ekranie można zdecydować, czy przeglądarki powinny zawsze być uruchamiane w strefie izolowanej Sandbox, tak by zawsze były chronione przed wszelkimi zagrożeniami z Internetu.

Użytkownik może zainstalować moduł WebRep oraz filtr zapobiegający wyłudzaniu poufnych informacji [phishing], jeśli są one dostępne dla danej przeglądarki.

Jeśli użytkownik korzysta z przeglądarki Google Chrome, wtyczki WebRep i Antiphishing do niej instalowane są automatycznie podczas instalacji programu avast!. Można je również odinstalować lub zainstalować dla innej obsługiwanej przeglądarki. Wystarczy kliknąć "Odinstaluj" lub "Instaluj". Po zainstalowaniu, użytkownik może wyłączyć każdy z tych modułów usuwając zaznaczenie z pola wyboru w ustawieniach "WebRep i Antiphishing".

WebRep pracuje w oparciu o informacje otrzymywane z globalnej społeczności użytkowników programu avast! i dotyczące zawartości i bezpieczeństwa odwiedzanych portali, a zbierane w celu polepszenia doświadczeń internetowych wszystkich użytkowników. Użytkownik może podzielić się własnymi ocenami oddając "głos" w sprawie zawartości i bezpieczeństwa odwiedzanych stron (patrz poniżej).

Gdy użytkownik odwiedzi jakiś portal, wyświetlona zostanie sekwencja trzech pasków (czerwony, żółty lub zielony), które informują go o ocenie danego portalu. Gdy użytkownik dokonuje przeszukiwania sieci za pomocą jednej z popularnych wyszukiwarek, ujrzy te same wskaźniki kodowane kolorem obok każdego portalu na liście wyników.

Kolor wskaźnika mówi, czy portal otrzymał ocenę "dobry" (zielony), "średni" (żółty), czy też "zły" (czerwony). Liczba podświetlonych pasków wskazuje poziom oceny. Jeden, dwa lub trzy podświetlone paski odpowiadają małej, ograniczonej lub dużej liczbie głosów.

Kliknięcie kolorowego wskaźnika otwiera okienko zawierające więcej informacji na temat tego, jak portal został oceniony. W tym okienku użytkownik może również oddać własny głos.

Po lewej wyświetlana jest ocena ogólna. Pod oceną wyświetlane są mniejsze ikonki, które odpowiadają kategoriom, do których należy dany portal.

Po prawej użytkownik może oddać własny głos. Tutaj wyświetlany jest pojedynczy pasek, podzielony na pięć kolorowych segmentów, których można użyć do przypisania danej domenie bardziej szczegółowej oceny. Poniżej tego paska wyświetlane są znów ikony kategorii. Należy kliknąć jedną lub kilka ikon, by przypisać domenę odpowiadającym jej kategoriom. Następnie należy kliknąć "Głosuj", aby przesłać własną ocenę.

Filtr zapobiegający wyłudzaniu poufnych informacji [Osłona przed phishingiem] zapewnia dodatkową ochronę, ponieważ ostrzega o wejściu na strony zaprojektowane tak, by ukraść osobiste dane logowania lub inne, wrażliwe dane finansowe.


Usługi Przetwarzania Rozproszonego

  • Aktualizacje strumieniowe (w czasie rzeczywistym)

    Włączenie funkcji aktualizacji strumieniowych daje pewność, że nowe definicje wirusów przesyłane są do komputera użytkownika w czasie rzeczywistym i nie czekają na następną planową aktualizację. Ponieważ baza danych o wirusach będzie aktualizowana w trybie ciągłym, komputer będzie jeszcze lepiej chroniony nawet przed najnowszymi zagrożeniami.

  • Usługi reputacyjne

    Włączenie tej opcji powoduje, że avast! sprawdzi, czy plik jest bezpieczny jeszcze przed jego otwarciem, konsultując się z bazą danych o znanych plikach. Określenie pliku jako bezpiecznego lub nie zależy od tego, jak często plik jest wykorzystywany przez użytkowników programu avast! i od tego, od kiedy plik istnieje.


Społeczność użytkowników

Zaznaczając to pole wyboru można zgłosić swój akces do wspólnoty użytkowników programu avast! i w razie potrzeby dzielić się informacjami o charakterze technicznym. Wymiana nie dotyczy informacji o charakterze osobistym i ogranicza się do danych ściśle związanych z bezpieczeństwem, np. dotyczy złośliwego oprogramowania, które wykrył program avast! podczas pracy na danym komputerze, działań, które zablokował, itd. Informacje te będą wykorzystywane przez avast! do podnoszenia zdolności detekcyjnych programu oraz do celów pomocy technicznej na rzecz całej wspólnoty użytkowników programu avast!. Przynależność do wspólnoty użytkowników programu avast! daje również dostęp do wszystkich informacji wspólnotowych oraz statystyk dot. ostatnich ataków złośliwego oprogramowania.

Pierwsze z dwóch pól wyboru u dołu ekranu służy do wyłączenia zakładki Market oraz przycisku "Lubisz avast?" na ekranie nawigacyjnym.

Drugie pole wyboru służy do usunięcia łączy do portali społecznościowych, takich jak Twitter, itp.


Ustawienia aktualizacji - Szczegóły

Szczegóły

Na tym ekranie można wskazać sposób dokonywania aktualizacji.

Opcje aktualizacji.

  • Nakazuj ponownie uruchomić komputer - Niektóre aktualizacje wymagają ponownego uruchomienia komputera, aby zaczęły działać. Jeśli pole to zostanie zaznaczone, ponowne uruchomienie systemu nie będzie wykonywane automatycznie. Program zapyta użytkownika, czy chce ponownie uruchomić system natychmiast, czy później.
  • Pokazuj okno komunikatu po aktualizacji automatycznej - Jeśli pole to zostanie zaznaczone, komunikat informacyjny zostanie wyświetlony przez chwilę nad zegarem systemowym po dokonaniu automatycznej aktualizacji.
  • Pokazuj okno komunikatu w razie wystąpienia błędu - Jeśli wystąpi błąd w trakcie automatycznej aktualizacji, program poinformuje o nim w komunikacie wyświetlanym nad zegarem systemowym.

Interwał aktualizacji automatycznej

Tutaj można ustawić częstotliwość automatycznych aktualizacji, tj. częstotliwość z jaką avast! sprawdza, czy dostępne są aktualizacje.


Ustawienia programu - wykluczenia

Wykluczenia globalne

Możliwe jest wykluczenie określonych miejsc lub nawet pojedynczych plików z procesu skanowania, co oznacza, że nie będą sprawdzane na obecność wirusów podczas żadnego zadania skanowania. Będą również wykluczane z zadań skanowania prowadzonych przez wszystkie osłony działające w czasie rzeczywistym. Opcja ta może być użyteczna z następujących powodów:

  • Unikanie fałszywych alarmów - Jeśli program doniesie o zarażeniu pliku wirusem a użytkownik jest pewien, że jest to fałszywy alarm, może wykluczyć dany plik z dalszych skanów i uniknąć dalszych fałszywych alarmów. Prosimy jednak o powiadomienie AVAST Software o problemie, aby można go było usunąć w przyszłych wersjach.
  • Przyspieszenie przetwarzania - Jeśli na dysku znajduje się folder zawierający wyłącznie pliki graficzne, można go wykluczyć ze skanowania, co skróci całkowity czas skanowania.

Należy pamiętać, że tutaj zdefiniowane wykluczenia stosują się do wszystkich zadań skanowania na żądanie (uruchamianych ręcznie i zdefiniowanych w harmonogramie) oraz do wszystkich działań osłon działających w czasie rzeczywistym. Jeśli użytkownik chce wykluczyć pliki jedynie z określonych zadań skanowania uruchamianych ręcznie i zdefiniowanych w harmonogramie, powinien skorzystać z opcji na stronie Wykluczenia w ustawieniach skanowania. Aby wykluczyć pliki jedynie ze skanowania przez daną osłonę działającą w czasie rzeczywistym, należy użyć opcji ze strony Wykluczenia w ustawieniach danej osłony.

Aby wykluczyć dane miejsce lub plik, należy najpierw kliknąć pole zawierające tekst <wpisz ścieżkę> a następnie wpisać miejsce lub plik podlegający wykluczeniu, albo kliknąć przycisk "Przeglądaj", zaznaczyć pole wyboru obok miejsca lub pliku podlegającego wykluczeniu, a następnie kliknąć "OK".

Jeśli użytkownik chce wykluczyć katalog wraz ze wszystkimi podkatalogami, konieczne jest dodanie "\* " na końcu nazwy takiego katalogu, np. C:\Windows\*.

Aby usunąć dane miejsce lub plik z listy wykluczeń, należy raz kliknąć taki element, by go wybrać, a następnie kliknąć przycisk "Usuń".


Osłona systemu plików - ustawienia ogólne

Ustawienia Osłony systemu plików

Ustawienia ogólne

  • Skanuj dokumenty podczas otwierania - Pole wyboru należy zaznaczyć, jeśli wszystkie dokumenty mają być skanowane w chwili ich otwarcia.
  • Skanuj pliki podczas zapisywania - Jeśli pole jest zaznaczone, wszystkie pliki będą skanowane w chwili ich tworzenia lub modyfikowania i zapisu na dysku.


Zapora ogniowa - narzędzia sieciowe

Narzędzia sieciowe

Tutaj użytkownik może uzyskać więcej informacji o konkretnych adresach IP. Może również zobaczyć mapę trasy, jaką pakiety danych przebywają po drodze do lub z komputera. Wystarczy wpisać adres IP i kliknąć polecenie "Uzyskaj dane szczegółowe" lub "Śledź trasę".

Na tym ekranie doświadczony użytkownik może również zresetować stos sieciowy sytemu Windows, jeśli został on zaatakowany w wyniku zrażenia serwera wirusem.


Osłona komunikatorów

Osłona komunikatorów sprawdza pliki pobierane przez komunikatory lub programy do "czatowania".


Osłona komunikatorów - ustawienia ogólne

Ustawienia Osłony komunikatorów

W ustawieniach Osłony komunikatorów można wskazać, które komunikatory powinny być monitorowane przez avast!.


Ustawienia programu - język

Język

Na tym ekranie wyświetlane są obecnie dostępne języki interfejsu. Aby zobaczyć wszystkie dostępne języki, należy kliknąć strzałkę. Jeśli pojawi się żądany język, należy go wybrać klikając nazwę a następnie kliknąć "OK". Po następnym uruchomieniu programu język interfejsu zostanie zmieniony. Jeśli żądany język nie pojawi się na liście, należy kliknąć "Zainstaluj dodatkowe języki" a następnie zaznaczyć pole wyboru obok żądanego języka. Następnie kliknąć "Dalej" aby zainstalować nowy język. Po zakończeniu procesu należy kliknąć "Zakończ". Na koniec należy wybrać nowy język w taki sposób, jak opisano powyżej.


Konserwacja

Na tym ekranie użytkownik może określić, przez jaki czas mają być przechowywane dzienniki skanowania zanim zostaną usunięte oraz maksymalny rozmiar dzienników skanowania. Pozwala to zoptymalizować wykorzystanie przestrzeni dyskowej przez ograniczenie rozmiaru dzienników i usuwanie dzienników, które już nie są potrzebne.

Jeśli zaznaczona zostanie opcja "Włącz rejestrację błędów programowych", utworzony zostanie plik specjalnego dziennika w razie wystąpienia błędów podczas pracy programu. Jeśli błąd będzie się dalej pojawiał, plik dziennika można wysłać do działu wsparcia technicznego programu avast!, co może pomóc w zidentyfikowaniu przyczyny błędu.

Kopia zapasowa ustawień

Umożliwia wykonanie kopii zapasowej ustawień avast! do innej lokalizacji. Stamtąd można je później przywrócić, np. jeśli zajdzie potrzeba odinstalowania i ponownego zainstalowania programu avast!, lub jeśli użytkownik wymieni swój komputer i będzie musiał ponownie zainstalować program avast!.

Wsparcie

Tutaj wskazać, by wszelkie pakiety wsparcia były zabezpieczane hasłem.

Ustawienia CreditAlert

Moduł avast! CreditAlert został zaprojektowany do ciągłego monitorowania reputacji użytkownika w oparciu o informacje, których udziela, a to w celu wykrycia oznak potencjalnej kradzieży tożsamości.

Po zarejestrowaniu się przez użytkownika, program avast! będzie aktywnie monitorował informacje przechowywane przez wszystkie trzy biura reputacji oraz skanował tysiące publicznych i prywatnych baz danych w imieniu użytkownika w poszukiwaniu wszelkich potencjalnych oznak kradzieży tożsamości.

Można również zarejestrować się w tym darmowym serwisie klikając przycisk "Zarejestruj". Wtedy użytkownik będzie otrzymywał automatyczne powiadomienia o ewentualnym wykryciu zmian. Jeśli użytkownik nie chce otrzymywać automatycznych powiadomień, wystarczy usunąć zaznaczenie pola "Włącz wyświetlanie alertów".

Jeśli użytkownik już się zarejestrował w serwisie CreditAlert, ale właśnie zainstalował program avast! ponownie na innym komputerze, może ponownie aktywować usługę CreditAlert klikając "Reaktywuj" i wpisując podstawowe dane. Należy pamiętać, że wpisane dane muszą być dokładnie takie same, jak dane podane przy pierwszej rejestracji w tym serwisie.


Osłona Sieciowa - ustawienia zaawansowane

Osłona ta nie ma ustawień zaawansowanych, które użytkownik może zmieniać.


Osłona sieciowa

Osłona Sieciowa monitoruje wszelką aktywność sieciową i blokuje wszelkie zagrożenia wykryte w sieci. Blokuje także dostęp do stron internetowych znanych jako niebezpieczne, a to w oparciu o bazę danych zainfekowanych adresów URL wykorzystywaną przez avast!.


Osłona sieciowa - ustawienia ogólne

Ustawienia Osłony Sieciowej

Na tym ekranie można wybrać, czy powinny być wyświetlane komunikaty ostrzegawcze, gdy zostanie wykryty potencjalnie szkodliwy ruch sieciowy lub potencjalnie zainfekowany adres URL.


Osłona P2P

Osłona P2P sprawdza pliki pobierane za pomocą popularnych programów peer-to-peer (P2P) do współdzielenia plików.


Osłona P2P - ustawienia ogólne

Ustawienia Osłony P2P

W ustawieniach Osłony P2p można wskazać, które programy P2P powinny być monitorowane przez Osłonę P2P.


Hasło

Na tym ekranie można zdefiniować hasło, które użytkownik będzie musiał podać przy próbie uruchomienia programu avast! albo uzyskania dostępu do niektórych części programu.

Aby ustawić hasło należy najpierw zaznaczyć pole wyboru "Zabezpiecz program avast! hasłem", a następnie wpisać hasło w wyświetlonych polach.

W następnej kolejności można wyszczególnić obszary, które będą chronione hasłem:

  • Ogólny dostęp do programu – Hasło będzie wymagane do otwarcia interfejsu użytkownika.
  • Ustawienia programu – Do opcji ustawień można wejść klikając "Ustawienia" w lewym dolnym rogu interfejsu użytkownika.
  • Kontrola ochrony – Opcja ta dotyczy możliwości włączania lub wyłączania ochrony w czasie rzeczywistym.
  • Ustawienia ochrony – Ustawienia dotyczące ochrony w czasie rzeczywistym.
  • Kontrola zadań skanowania – Kontrolki używane do uruchamiania, wstrzymywania lub zatrzymywania zadań skanowania.
  • Ustawienia zadań skanowania – Ustawienia określające szereg parametrów zadania skanowania.
  • Kontrola aktualizacji – Kontrolki programu używane do aktualizacji programu, silnika skanowania oraz definicji wirusów.
  • Kontrola Kwarantanny – Kontrolki wykorzystywane do pracy z plikami umieszczonymi w folderze Kwarantanny.


Wyskakujące okna

Na tym ekranie można określić czas, przez jaki różne komunikaty w formie wyskakujących okienek będą wyświetlane na ekranie.

Można również przeglądać miesięczne raporty bezpieczeństwa. Co 30 dni tworzony jest spersonalizowany raport bezpieczeństwa, w którym użytkownik programu avast! może sprawdzić, jak program dyskretnie działał chroniąc komputer przed złośliwym oprogramowaniem. Można również przeglądać raporty indywidualne dot. liczby przeskanowanych plików i dokumentów, jak też zarażonych stron WWW oraz plików, których pobieranie zostało zablokowane. Można również przeglądać statystyki dot. liczby użytkowników programu avast! na całym świecie, informacji o zarażonych stronach WWW i wielu innych użytecznych i interesujących danych.


Osłona komunikatorów - programy

Programy

Tutaj można wskazać komunikatory, które powinny być monitorowane.


Osłona P2P - programy

Programy

Na tym ekranie można wskazać programy P2P, które powinny być monitorowane.


Ustawienia aktualizacji - Proxy

Ustawienia serwera proxy

Ustawienia dostępne na tej stronie są istotne w sytuacji, gdy program avast! musi uzyskać dostęp do Internetu, np. podczas dokonywania aktualizacji.

Jeśli jest używane bezpośrednie łącze z Internetem (tj. bez proxy), nie należy nic robić, ponieważ "bezpośrednie połączenie" jest ustawieniem domyślnym. Proszę zwrócić uwagę, że połączenia dial-up nie wykorzystują serwerów proxy.

Jeśli użytkownik nie jest pewien, czy korzysta z serwera proxy, albo z którego serwera proxy korzysta, powinien wybrać opcję "Automatyczne wykrywanie" lub zapytać swojego dostawcę internetowego lub administratora sieci.

Jeśli komputer łączy się z Internetem poprzez serwer proxy a użytkownik zna dane serwera, należy wybrać "Wskaż serwer proxy" i wpisać jego dane:

  • Typ - HTTP lub SOCKS4
  • Adres - Wpisać adres serwera proxy.
  • Port - Wpisać port wykorzystywany przez serwer proxy.
  • Typ uwierzytelnienia - Tutaj należy wskazać, czy serwer proxy wymaga uwierzytelnienia, a jeśli tak, to także typ uwierzytelnienia.
  • Nazwa użytkownika i hasło - Należy wpisać, jeśli są wymagane do uwierzytelnienia.


Ustawienia osłon działających w czasie rzeczywistym

Ustawienia dowolnej osłony działającej w czasie rzeczywistym można zmienić w dowolnym momencie. Należy otworzyć interfejs użytkownika, kliknąć zakładkę "Antywirus" i wybrać odpowiednią osłonę.

Na wykresie u dołu każdego ekranu użytkownik widzi czynności wykonywane ostatnio przez osłonę – ilość danych przychodzących i wychodzących, które zostały przeskanowane przez osłonę. Aby uzyskać bardziej szczegółowy podgląd, należy kliknąć "Pokaż historię działania". Na ekranie Statystyki użytkownik ma podgląd danych o działaniu dowolnej osłony działającej w czasie rzeczywistym w wybranym okresie. Aby zmienić skalę dowolnej części wykresu, należy kliknąć pionową linię i przesunąć ją w prawo. Aby wrócić do poprzedniego podglądu, wystarczy kliknąć "Pokaż wszystko", a poprzedni podgląd zostanie przywrócony.

Klikając "Ustawienia" użytkownik uzyskuje dostęp do indywidualnych ustawień danej osłony.

Aby całkowicie wyłączyć konkretną osłonę, należy kliknąć "Zatrzymaj" i wybrać z menu rozwijalnego okres, przez jaki osłona ma być wyłączona.

Aby ponownie uruchomić zatrzymaną osłonę, wystarczy kliknąć "Uruchom".

Aby zatrzymać wszystkie osłony jednocześnie, należy kliknąć prawym klawiszem myszy pomarańczową ikonę programu avast! w polu systemowym, wybrać "kontrola osłon avast!" oraz okres, przez który mają być wyłączone.


Osłona przed skryptami - Wykluczenia

Wykluczenia z działania Osłony przed skryptami

Tutaj można określić konkretne adresy URL, które nie powinny być skanowane. Wystarczy zaznaczyć pole wyboru a następnie wpisać adres URL, który ma być pomijany.


Osłona przed skryptami - ustawienia zaawansowane

Osłona ta nie ma ustawień zaawansowanych, które użytkownik może zmieniać.


Osłona przed skryptami - ustawienia ogólne

Dostępne tutaj pola wyboru można wykorzystać do wyboru przeglądarek, które będą chronione przez Osłonę przed skryptami.

Jeśli usunięte zostanie zaznaczenie przy którejś przeglądarce, Osłona przed skryptami zostanie wyłączona dla tej przeglądarki.


Osłona przed skryptami

Osłona przed skryptami wykrywa złośliwe skrypty i zapobiega ich wykonywaniu. Osłona przed skryptami wykrywa i blokuje nie tylko złośliwe skrypty pochodzące z sieci (zagrożenia zewnętrzne), ale także skrypty pochodzące z innych źródeł, takich jak strony WWW zapisane na dysku lub przechowywane w pamięci podręcznej przeglądarki, itd. (zagrożenia lokalne).

W przeciwieństwie do Osłony WWW, Osłona przed skryptami potrafi również wykryć i zablokować złośliwe skrypty, które pochodzą z (szyfrowanych) połączeń HTTPS.


Osłona przed skryptami - ustawienia ogólne

Ustawienia Osłony przed skryptami

W ustawieniach Osłony przed skryptami użytkownik może wybrać przeglądarki, które będą chronione przez Osłonę przed skryptami.

Można również wykluczyć ze skanowania konkretne adresy URL oraz wygenerować plik raportu, który poda szczegółowe dane o plikach, które zostały przeskanowane, wykrytych plikach zarażonych, itd.


Zapora ogniowa – Kontrola procesów

Kontrola procesów

Tutaj użytkownik może wskazać programy, które mogą lub nie mogą uruchamiać innych aplikacji uzyskujących dostęp do Internetu lub mogących łączyć się z innymi komputerami w sieci lokalnej. Jest to użyteczna funkcja, ponieważ może zapobiec uruchomieniu przez przychodzące połączenie aplikacji, która może następnie zostać wykorzystana do przeprowadzenia nieupoważnionych działań. Jest to trik powszechnie używany przez hakerów w celu zbierania informacji osobistych lub poufnych bez wiedzy użytkownika.

Jeśli program nie został wymieniony w żadnej z kategorii, avast! przeprowadzi szereg testów i automatycznie zdecyduje, czy proces powinien uzyskać zezwolenie na działanie. Przykładowo, avast! sprawdza, czy program próbujący uruchomić inną aplikację to program powszechnie znany, który w normalnej sytuacji zachowuje się właśnie w taki sposób.


Instalacja automatyczna

Instalacja automatyczna programu avast!

Opcja ta, przeznaczona specjalnie dla administratorów sieci, umożliwia (i ułatwia) instalację programu avast! na innych komputerach, bez wikłania innych użytkowników komputerów w ten proces. Instalacja może zostać wykonana z wcześniej zdefiniowanymi ustawieniami programu i zadań skanowania.

Aby utworzyć instalację automatyczną:

  1. Należy zainstalować program avast! na jednym komputerze.
  2. Zmodyfikować ustawienia programu avast! na takie, które mają obowiązywać na innych komputerach.
  3. Ustawić parametry skanowania wedle potrzeb.
  4. W razie potrzeby, ustawić hasło dostępu do ustawień osłon działających w czasie rzeczywistym.
  5. Wybrać Plik ® Utwórz instalację automatyczną.
  6. Ustawienie parametrów instalacji automatycznej:
    • Praca w tle - W trakcie instalacji na komputerach docelowych wyświetlane będą tylko komunikaty o błędach.
    • Praca całkowicie automatyczna - W trakcie instalacji na komputerach docelowych nie będą wyświetlane żadne komunikaty.
    • Ścieżka instalacyjna - Wpisać folder, w którym avast! ma zostać zainstalowany (domyślnie: %PRGFILES%\Alwil Software\Avast5).
    • Bez ponownego uruchomienia systemu - Normalnie avast! wymaga ponownego uruchomienia systemu po instalacji. Jeśli wybrana zostanie ta opcja, nie zostanie wyświetlone żądanie ponownego uruchomienia systemu.
    • Nakazuj ponownie uruchomić komputer - Po zakończeniu instalacji użytkownik zostanie poproszony o ponowne uruchomienie komputera.
    Jeśli nie zostanie zaznaczona opcja Bez ponownego uruchomienia systemu ani opcja Nakazuj ponownie uruchomić komputer, system zostanie ponownie uruchomiony automatycznie po zakończeniu instalacji.
  7. Należy kliknąć przycisk Utwórz.
  8. Wybrać folder, gdzie pliki potrzebne do instalacji automatycznej powinny być przechowywane.
  9. W wybranym folderze zapisane zostaną następujące dwa pliki: admin.ini i tasks.xml. Plik admin.ini zawiera ustawienia programu avast!, zaś plik tasks.xml zawiera odnośne ustawienia skanowania. Jeśli zostało ustawione hasło dla osłon w czasie rzeczywistym, w docelowym folderze będzie znajdował się inny plik: aswResp.dat; zawiera on zaszyfrowane hasło dostępu do osłon w czasie rzeczywistym.
  10. Te dwa lub trzy pliki należy umieścić w udostępnianym folderze.
  11. Umieść instalator avast! w tym samym folderze.
  12. Instalację programu avast! na komputerach docelowych należy uruchomić z tego folderu.


Praca w tle

Praca w tle/uruchomiona gra pełnoekranowa

W momentach, gdy komputer jest uruchomiony, wiadomości mogą być wyświetlane na ekranie, np. gdy definicje wirusów zostały zaktualizowana, gdy przychodzące e-mail jest skanowany itp. Może to doprowadzić do przerwania pracy pełnoekranowych aplikacji (np. gier), ponieważ system Windows w chwili wyświetlenia komunikatu przełączy się z trybu pełnoekranowego do trybu normalnego.

Na tym ekranie można zdecydować, by komunikaty nie były w ogóle wyświetlane (Praca w tle), albo nie były wyświetlane podczas pracy aplikacji pełnoekranowych.


SiteCorrect

Jeśli ta opcja zostanie włączona a użytkownik popełni błąd przy wpisywaniu znanych adresów URL, program może zapytać, czy użytkownik nie chce w rzeczywistości przejść na stronę o poprawionym adresie URL, np. jeśli wpisze www.goolge.com, adres zostanie poprawiony na www.google.com.

  • Automatycznie przekierowuj

Jeśli ta opcja zostanie wybrana, przeglądarka będzie automatycznie przechodziła na strony z poprawionymi adresami URL. W przeciwnym razie, program zapyta użytkownika, co chce dalej zrobić.


Dźwięki

Na tym ekranie można włączyć lub wyłączyć różne efekty dźwiękowe i komunikaty głosowe generowane przez program avast! w wyniku zajścia określonych zdarzeń.

W domyślnych ustawieniach włączone są tylko efekty podstawowe. Jednak zaznaczenie pola wyboru "Używaj podkładów głosowych (gdy dostępne)" umożliwia generowanie komunikatów głosowych, np. gdy wykryty zostanie potencjalnie niebezpieczny plik, lub po aktualizacji definicji wirusów.


Kafelek Stan

Okno Stanu

W tej części można sprawdzić status ochrony.

Po wejściu w interfejs użytkownika wyświetlany jest pasek stanu, informujący użytkownika o bieżącym statusie zabezpieczeń. Jeśli uruchomione są wszystkie osłony działające w czasie rzeczywistym i zainstalowane są najnowsze wersje programu i definicje wirusów, kafelek będzie miał kolor zielony i wyświetli status "Jesteś chroniony". Komunikat "Uwaga" oznacza, że komputer nie jest w pełni chroniony, np. jeśli program lub definicje wirusów nie zostały zaktualizowane lub jeśli wyłączono jedną lub kilka osłon. Komunikat "Nie jesteś chroniony" oznacza, że komputer nie jest w danym momencie wcale chroniony, najprawdopodobniej dlatego, że wszystkie osłony zostały wyłączone.

Jeśli wyświetlony zostanie komunikat "Uwaga" lub "Nie jesteś chroniony", użytkownik może spróbować ponownie zabezpieczyć komputer klikając przycisk "Rozwiąż problemy".

W tym oknie można również dodać skróty innych funkcji, takich jak skanowanie, SafeZone, Czyszczenie przeglądarki itp.., dzięki czemu można uzyskać do nich szybki dostęp. Zmiany tego okna pozwalają dopasować je do potrzeb użytkownika.

W ustawieniach paska stanu umieszczonego pod zakładką "Wygląd" w głównych Ustawieniach można określić, które komponenty wykorzystywane są do wskazywania bieżącego poziomu ochrony. Jeśli jakiś komponent pozostanie nieoznaczony, nie będzie monitorowany. Oznacza to, że późniejsze wyłączenie tego komponentu nie będzie miało wpływu na wyświetlany poziom ochrony. Na poziom ochrony mają wpływ tylko elementy zaznaczone.


Aktualizacje

Każdy program antywirusowy jest tylko tak dobry, jak jego baza definicji wirusów. Dlatego tak ważne jest, by regularnie aktualizować program i definicje wirusów.


Alerty wirusowe

Program avast! może wysyłać komunikaty ostrzegawcze do innych użytkowników za każdym razem, gdy wykryje wirusa. Funkcja ta jest szczególnie użyteczna dla administratorów sieci, którzy będą natychmiast powiadamiani o zarażeniu wirusem jednego z komputerów w ich sieci: dzięki temu będą mogli szybko zareagować. Dostępna jest w zakładce Antywirus w Ustawieniach programu.

Aby utworzyć alert, należy najpierw wybrać z listy dostępnych opcji sposób jego wysyłania:

  • E-mail (SMTP) - Alert będzie wysyłany jako wiadomość pocztowa za pomocą protokołu SMTP, ale należy najpierw zdefiniować kilka innych parametrów - patrz poniżej.
  • E-mail (MAPI) - Alert będzie wysyłany jako wiadomość pocztowa za pomocą protokołu MAPI, ale konieczne jest również podanie nazwy profilu MAPI i hasła - patrz poniżej.
  • Drukarki - Alert zostanie wysłany na wskazaną drukarkę
  • Komunikat sieciowy (WinPopup) - Alert będzie wysyłany jako komunikat sieciowy, ale najpierw konieczne jest wprowadzenie adresu IP lub nazwy sieciowej użytkownika, do którego komunikat ma zostać wysłany.

Konfiguracja SMTP

Tutaj należy wprowadzić parametry serwera SMTP:

  • Adres serwera - adres serwera poczty wychodzącej, np. smtp.serwer.com lub 192.168.1.25
  • Port - standardowy port to 25
  • Adres wysyłającego - adres osoby wysyłającej komunikat

Jeśli serwer SMTP wymaga uwierzytelnienia podczas logowania, użytkownik powinien również zaznaczyć pole wyboru "Jeśli serwer SMTP wymaga autoryzacji" i wprowadzić nazwę użytkownika i hasło.

Konfiguracja MAPI

Tutaj można wprowadzić nazwę profilu MAPI i hasło, które będą wykorzystywane, jeśli alerty mają być wysyłane jako wiadomości pocztowe za pomocą protokołu MAPI.


Ustawienia Kwarantanny

Kwarantanna

Tutaj można określić maksymalny dopuszczalny rozmiar katalogu kwarantanny, a zatem maksymalną ilość miejsca zajmowanego przez ten katalog w komputerze. Można również określić maksymalny rozmiar dowolnego pliku wysyłanego do kwarantanny.


WebRep

Jeśli użytkownik korzysta z przeglądarki Google Chrome, wtyczki WebRep i Antiphishing do niej instalowane są automatycznie podczas instalacji programu avast!. Można je również odinstalować lub zainstalować dla innej obsługiwanej przeglądarki. Wystarczy kliknąć "Odinstaluj" lub "Instaluj". Po zainstalowaniu, użytkownik może wyłączyć każdy z tych modułów usuwając zaznaczenie z pola wyboru w ustawieniach "WebRep i Antiphishing".

Tutaj można również zobaczyć - przed zainstalowaniem modułu - czy obsługiwana jest zainstalowana przeglądarka internetowa.

WebRep pracuje w oparciu o informacje otrzymywane z globalnej społeczności użytkowników programu avast! i dotyczące zawartości i bezpieczeństwa odwiedzanych portali, a zbierane w celu polepszenia doświadczeń internetowych wszystkich użytkowników. Użytkownik może podzielić się własnymi ocenami oddając "głos" w sprawie zawartości i bezpieczeństwa odwiedzanych stron (patrz poniżej).

Oprócz ochrony przed zarażonymi stronami, moduł ten zapewnia ochronę przed stronami wyłudzającymi poufne informacje [phishingiem], ponieważ ostrzega o wejściu na strony zaprojektowane tak, by ukraść osobiste dane logowania lub inne, wrażliwe dane finansowe.

Gdy użytkownik odwiedzi jakiś portal, wyświetlona zostanie sekwencja trzech pasków (czerwony, żółty lub zielony), które informują go o ocenie danego portalu. Gdy użytkownik dokonuje przeszukiwania sieci za pomocą jednej z popularnych wyszukiwarek, ujrzy te same wskaźniki kodowane kolorem obok każdego portalu na liście wyników.

Kolor wskaźnika mówi, czy portal otrzymał ocenę "dobry" (zielony), "średni" (żółty), czy też "zły" (czerwony). Liczba podświetlonych pasków wskazuje poziom oceny. Jeden, dwa lub trzy podświetlone paski odpowiadają małej, ograniczonej lub dużej liczbie głosów.

Kliknięcie kolorowego wskaźnika otwiera okienko zawierające więcej informacji na temat tego, jak portal został oceniony. W tym okienku użytkownik może również oddać własny głos.

Po lewej wyświetlana jest ocena ogólna. Pod oceną wyświetlane są mniejsze ikonki, które odpowiadają kategoriom, do których należy dany portal.

Po prawej użytkownik może oddać własny głos. Tutaj wyświetlany jest pojedynczy pasek, podzielony na pięć kolorowych segmentów, których można użyć do przypisania danej domenie bardziej szczegółowej oceny. Poniżej tego paska wyświetlane są znów ikony kategorii. Należy kliknąć jedną lub kilka ikon, by przypisać domenę odpowiadającym jej kategoriom. Następnie należy kliknąć "Głosuj", aby przesłać własną ocenę.