System Pomocy Kreatora konfiguracji produktów programu SharePoint — Zapraszamy!

W tym systemie Pomocy można znaleźć następujące tematy:

  • Kreator konfiguracji produktów programu SharePoint — Zapraszamy!
  • Uaktualnienie wizualne
  • Łączenie z farmą serwerów
  • Określanie ustawień bazy danych konfiguracji
  • Określanie ustawień zabezpieczeń farmy
  • Konfigurowanie aplikacji sieci Web administracji centralnej programu SharePoint
  • Potwierdzanie ustawień
  • Ustawienia zaawansowane
  • Konfigurowanie produktów programu SharePoint
  • Zakończenie konfiguracji
  • Usuwanie witryny sieci Web administracji centralnej programu SharePoint
  • Modyfikowanie ustawień farmy serwerów
  • Zamienianie domyślnej witryny programu SharePoint
  • Jak skonfigurować ustawienia serwera proxy
  • Jak naprawiać produkty programu SharePoint
  • Aplety poleceń powłoki Windows PowerShell dla Kreatora konfiguracji produktów programu SharePoint


Konfigurowanie aplikacji sieci Web administracji centralnej programu SharePoint

Można skonfigurować aplikację sieci Web administracji centralnej programu SharePoint oraz ustawienia zabezpieczeń.

Numer portu

Aplikacja sieci Web administracji centralnej programu SharePoint umożliwia zarządzanie ustawieniami konfiguracji farmy serwerów programu SharePoint. Tę witrynę sieci Web obsługuje pierwszy serwer dodany do farmy serwerów. Jeśli trzeba określić numer portu, można wybrać dowolny numer z przedziału od 1 do 65535, ale zaleca się unikanie używania numerów z zakresu znanych portów.

Numery portów dzielą się na następujące trzy zakresy:

  • Znane porty należą do przedziału od 0 do 1023.
  • Porty zarejestrowane należą do przedziału od 1024 do 49151.
  • Porty dynamiczne lub prywatne należą do przedziału od 49152 do 65535.

Jeśli zajdzie potrzeba zmiany numeru portu w późniejszym czasie, należy ponownie uruchomić Kreatora konfiguracji produktów programu SharePoint. Kreator konfiguracji zaktualizuje numer portu w bazie danych konfiguracji i utworzy zadanie, które zaktualizuje numer portu w każdej aplikacji sieci Web administracji centralnej programu SharePoint na innych serwerach w tej farmie.

Uwaga Nie jest możliwa ręczna zmiana numeru portu aplikacji sieci Web administracji centralnej programu SharePoint w Menedżerze Internetowych usług informacyjnych (IIS). Należy ponownie uruchomić Kreatora konfiguracji.

Ustawienia zabezpieczeń

Obsługiwany jest zarówno protokół uwierzytelniania NTLM, jak i Kerberos.

NTLM

Protokół NTLM, czyli domyślne ustawienie, jest w przypadku klienta oparty na mechanizmie uwierzytelniania typu wyzwanie/odpowiedź. Protokół NTLM dostępny w produktach programu SharePoint umożliwia komunikację z systemami mogącymi korzystać jedynie z uwierzytelniania NTLM.

Negocjuj (Kerberos)

Protokół Kerberos w wersji 5 jest podstawowym protokołem zabezpieczeń uwierzytelniania w domenie. Uwierzytelnianie Kerberos korzysta z systemu biletu usługi, który weryfikuje tożsamość użytkownika oraz usług sieciowych. Ta podwójna weryfikacja jest określana jako wzajemne uwierzytelnianie. System w pierwszej kolejności próbuje uzgodnić uwierzytelnianie za pośrednictwem protokołu Kerberos, a gdy to się nie powiedzie, używany jest protokół NTLM.

Aby włączyć uwierzytelnianie Kerberos, należy przeprowadzić dodatkową konfigurację. Aby uzyskać dodatkowe informacje, zobacz Uwierzytelnianie Kerberos.


Usuwanie witryny sieci Web administracji centralnej programu SharePoint

Witryna sieci Web administracji centralnej programu SharePoint umożliwia wykonywanie zadań administracyjnych lokalnie lub zdalnie. W każdej farmie serwerów musi znajdować się przynajmniej jedna witryna sieci Web administracji centralnej programu SharePoint.

Opcji znajdujących się na tej stronie można używać w celu zachowania lub usunięcia witryny sieci Web administracji centralnej programu SharePoint.


Zakończenie konfiguracji

Po zakończeniu wymaganych zadań konfiguracji przez Kreatora konfiguracji produktów programu SharePoint zostanie udostępniona funkcja administracji centralnej programu SharePoint na potrzeby konfigurowania witryny sieci Web.

Powodzenie konfiguracji

Po pomyślnym zakończeniu niezbędnych zadań konfiguracji w przypadku instalacji autonomicznej można kliknąć przycisk Zakończ, aby zamknąć Kreatora konfiguracji. Zostanie otwarta strona główna domyślnej witryny sieci Web.

W przypadku przeprowadzania uaktualniania lub instalacji w trybie farmy serwerów zostaną wyświetlone wprowadzone ustawienia konfiguracji, po czym można kliknąć przycisk Zakończ, aby zamknąć Kreatora konfiguracji. W przeglądarce sieci Web zostanie wyświetlona witryna administracji centralnej programu SharePoint.

Jeśli wykonywane jest naprawianie, kliknij przycisk Zamknij, aby zakończyć pracę Kreatora konfiguracji.

Uwaga Jeśli użytkownik korzysta z programu Microsoft Internet Explorer i ustawienia domyślne nie zostały zmienione, zostaną włączone rozszerzone zabezpieczenia. Kiedy Kreator konfiguracji uruchomi program Internet Explorer, zostanie wyświetlone okno podręczne z monitem o dodanie witryny do listy zaufanych witryn.

Niepowodzenie konfiguracji

Jeśli co najmniej w jednym zadaniu konfiguracji wystąpi błąd, zdarzenia zostaną zapisane w dzienniku zdarzeń i dzienniku instalacji. W celu umożliwienia zbadania problemu zostaną wyświetlone szczegółowe informacje na temat zadania konfiguracji, które było uruchomione, gdy wystąpił błąd Kreatora konfiguracji, konkretne komunikaty o błędach i łącze do pliku dziennika.


Modyfikowanie ustawień farmy serwerów

Opcji znajdujących się na tej stronie można użyć w celu zmodyfikowania ustawień farmy serwerów. Zostanie wyświetlona nazwa serwera obsługującego bazę danych konfiguracji oraz nazwa bazy danych konfiguracji.

Aby odłączyć dany komputer od farmy serwerów, należy wybrać opcję Odłącz od tej farmy serwerów, a następnie kliknąć przycisk Dalej. Po zakończeniu pracy Kreatora konfiguracji witryna sieci Web administracji centralnej programu SharePoint na danym komputerze nie będzie obsługiwana i zostanie usunięta z farmy serwerów programu SharePoint.

Można uruchomić Kreatora konfiguracji później, aby podłączyć komputer do innej farmy serwerów.


Konfigurowanie produktów programu SharePoint

Kreator konfiguracji produktów programu SharePoint wykonuje następujące zadania:

  • Konfiguruje dostęp do bazy danych oraz tworzy bazy danych zawartości administracyjnej i konfiguracji. W przypadku instalacji autonomicznej jest instalowany i konfigurowany program SQL Server 2008.
  • Instaluje i konfiguruje funkcje oraz usługi.
  • Konfiguruje zabezpieczenia.
  • Tworzy przykładowe dane.

Uwaga Czas niezbędny na przeprowadzenie poszczególnych zadań konfiguracji jest różny.

Jeśli podczas wykonywania zadania konfiguracji Kreator konfiguracji napotka błąd, żadne dodatkowe zadania konfiguracji nie zostaną wykonane. Zostanie wyświetlona strona Konfiguracja została ukończona z komunikatem o niepowodzeniu konfiguracji oraz łączem do pliku dziennika, którego można użyć w celu rozwiązania problemu powodującego błąd.

Jeśli użytkownik anuluje działanie Kreatora konfiguracji, ukończone zadania konfiguracji nie zostaną wycofane. Aby ukończyć wdrażanie serwera, trzeba wykonać pozostałe zadania konfiguracji. W tym celu należy ponownie uruchomić Kreatora konfiguracji w późniejszym czasie.

Uruchamianie narzędzia sprawdzającego środowisko uaktualnienia

W przypadku wykonywania uaktualnienia zaleca się uaktualnienie w pierwszej kolejności narzędzia sprawdzającego środowisko uaktualnienia w celu przeskanowania witryn. Narzędzia sprawdzające środowisko uaktualnienia powinno zostać uruchomione na każdym komputerze farmy, na którym jest zainstalowany program SharePoint.

Uwaga Aby móc uruchomić to narzędzie, użytkownik musi być członkiem grupy Administratorzy na komputerze lokalnym.

W wierszu polecenia zmień bieżący folder na dysku twardym na następujący: %COMMONPROGRAMFILES%\Microsoft Shared\web server extensions\12\bin, po czym uruchom następujące polecenie, aby przeskanować wszystkie serwery w farmie serwerów:

stsadm.exe -o preupgradecheck

To narzędzie należy uruchomić na każdym serwerze w farmie serwerów. W zależności od wielkości zawartości środowiska wykonywanie zadań przez narzędzie może potrwać od kilku minut do kilku godzin.

Po zakończeniu skanowania można przejrzeć plik wyników, zawierający listę wszystkich znalezionych problemów oraz opisy sposobów ich rozwiązania. Plik znajduje się w folderze %COMMONPROGRAMFILES%\Microsoft Shared\web server extensions\12\LOGS. Nazwy plików dziennika mają następujący format: PreUpgradeCheck_RRRRMMDD-GGMMSS-SSS-liczba-losowa.log, gdzie parametr RRRRMMDD oznacza datę, parametr GGMMSS-SSS oznacza czas (godziny w formacie 24-godzinnym, minuty, sekundy i milisekundy), a liczba losowa jest używana do rozróżniania możliwych równoczesnych prób uruchomienia polecenia sprawdzania przed uaktualnieniem.

Uaktualnianie farmy serwerów

Aby uaktualnić farmę serwerów, wykonaj następujące czynności:

  1. Uruchom Instalatora, a następnie uruchom Kreatora konfiguracji produktów programu SharePoint na serwerze, na którym działa administracja centralna programu SharePoint w farmie.
  2. Gdy pojawi się komunikat dotyczący uruchamiania Instalatora na innych serwerach w farmie, należy uruchomić Instalatora i Kreatora konfiguracji produktów programu SharePoint na pozostałych serwerach w celu dotarcia do tego samego punktu.
  3. Gdy komunikat ten zostanie wyświetlony na wszystkich serwerach farmy, wróć do pierwszego serwera sieci Web, a następnie kliknij przycisk OK, aby kontynuować proces uaktualniania pierwszego serwera.
  4. Po zakończeniu działania kreatora na pierwszym serwerze można skonfigurować każdy z pozostałych serwerów.

Wymagania dotyczące konta zabezpieczeń

Aby wdrożyć produkty programu SharePoint w środowisku farmy serwerów, trzeba dysponować kontem użytkownika, z którego można instalować te produkty oraz uruchamiać Kreatora konfiguracji produktów programu SharePoint. To konto musi być unikatowym kontem użytkownika domeny, które można określić jako konto usługi. Służy ono do uzyskiwania dostępu do bazy danych konfiguracji. Konto dostępu do bazy danych będzie używane zarówno do początkowego konfigurowania baz danych, jak i do późniejszych połączeń serwerów tej farmy z bazami danych.

Ważne Upewnij się, że w domenie nie obowiązują zasady grupy, które mogłyby zabraniać kontu wybranemu jako konto dostępu do baz danych działania jako usługi.

To konto działa także jako tożsamość puli aplikacji dla puli aplikacji administracji centralnej programu SharePoint i jest kontem, na którym działa Usługa czasomierza programu SharePoint 2010. Zaleca się stosowanie reguły minimalnych przywilejów i niedołączanie tego konta do żadnej z konkretnych grup zabezpieczeń na serwerach sieci Web ani na serwerach baz danych.


Jak naprawiać produkty programu SharePoint

Za pomocą tej procedury można uruchomić Kreatora konfiguracji produktów programu SharePoint w trybie naprawy.

  1. Kliknij przycisk Start, polecenie Panel sterowania, a następnie polecenie Programy i funkcje.
  2. Wybierz instalację, która ma zostać naprawiona, a następnie kliknij przycisk Zmień.
  3. W Kreatorze instalacji wybierz opcję Napraw, a następnie kliknij przycisk Kontynuuj. Zostanie sprawdzony plik binarny.
  4. Na ostatnim ekranie Kreatora instalacji wybierz pozycję Uruchom teraz Kreatora konfiguracji produktów programu SharePoint, a następnie kliknij przycisk Zamknij.
  5. Kreator konfiguracji produktów programu SharePoint jest automatycznie wywoływany w trybie naprawy, wykrywa brakujące składniki, a następnie określa pierwotnie wybrany tryb instalacji.
  6. Jeśli instalacja była rozmieszczana na wielu serwerach, zostanie wyświetlony monit o poświadczenia puli.
  7. Podaj poświadczenia konta Uruchom jako dla puli aplikacji.
  8. Kreator konfiguracji sprawdzi wymagania wstępne i wykona zadania niezbędne do naprawienia konfiguracji.


Kreator konfiguracji produktów programu SharePoint — Zapraszamy!

Kreator konfiguracji produktów programu SharePoint wykonuje podstawowe zadania, które wymagają minimalnego udziału użytkownika i które są niezbędne do uruchomienia administracji centralnej programu SharePoint lub których nie można wykonać nigdzie indziej.

Poza korzystaniem z Kreatora konfiguracji do wykonywania początkowej konfiguracji w każdym momencie można użyć Kreatora konfiguracji do wykonania następujących czynności:

  • identyfikowanie brakujących składników;
  • sprawdzanie poprawności konfiguracji;
  • identyfikowanie, naprawianie lub resetowanie ustawień zabezpieczeń i konfiguracji niskiego poziomu.

Może być konieczne uruchomienie, zatrzymanie lub zresetowanie przez Kreatora konfiguracji Usługi administracji programu SharePoint, Usługi czasomierza programu SharePoint, usług Internet Information Services (IIS) i usług innych aplikacji, które są zależne od programu Microsoft SharePoint Foundation i zostały odpowiednio zarejestrowane.

Aby nie przerywać operacji serwera, należy kliknąć przycisk Nie w celu zakończenia pracy Kreatora konfiguracji.

Uwaga Przed zakończeniem rozmieszczania serwera zanim będzie możliwy dostęp do usługi Administracja centralna programu SharePoint w celu skonfigurowania witryny użytkownika należy pomyślnie zakończyć pracę Kreatora konfiguracji.

Po zakończeniu pracy Kreatora konfiguracji zostaną udostępnione usługi wymagane do uruchomienia usługi Administracja centralna. Następnie należy skorzystać z tej usługi, aby skonfigurować witrynę.

Wymagania dotyczące oprogramowania

Przed zainstalowaniem, konfiguracją lub obsługą serwera muszą zostać spełnione następujące warunki:

  • 64-bitowa wersja obsługiwanego systemu operacyjnego Windows Server 2008.
  • Program Microsoft SQL Server Express (w przypadku instalacji autonomicznych) lub obsługiwana wersja programu Microsoft SQL Server 2005 albo Microsoft SQL Server 2008.
  • Odpowiednie poświadczenia administracyjne na serwerach objętych instalacją oraz konto domeny, które będzie używane jako konto usługi.

Aby znaleźć szczegółowe informacje o tych wymaganiach oraz aktualne i obszerne artykuły na temat tego produktu, zobacz witrynę centrum technicznego produktów Microsoft SharePoint 2010.

Autonomiczna

W przypadku wdrażania produktów programu SharePoint w środowisku autonomicznym wszystkie składniki i funkcje zostaną zainstalowane na komputerze autonomicznym przy użyciu ustawień domyślnych. Kreator konfiguracji nie wyświetli żadnego monitu o określenie ustawień konfiguracji lub podanie poświadczeń. Zamiast tego Kreator konfiguracji użyje domyślnych wartości w celu utworzenia aplikacji sieci Web, usług podstawowych i standardowych grup zabezpieczeń wymaganych do uruchomienia administracji centralnej.

Kreator konfiguracji korzysta z ustawień domyślnych, jeśli w Kreatorze instalacji wybrano następujące opcje:

  • Autonomiczna
  • Farma serwerów, a następnie Autonomiczna

Farma serwerów

Jeśli w Kreatorze instalacji została wybrana opcja Farma serwerów, Kreator konfiguracji umożliwia instalację w farmie serwerów, użycie istniejącej bazy danych, wdrożenie nowej lub nawiązanie połączenia z istniejącą farmą serwerów. Można utworzyć nowe bazy danych lub skorzystać z istniejących baz danych. W farmie serwerów co najmniej jeden komputer może być serwerem sieci Web, a jeden lub więcej komputerów może świadczyć usługi bazy danych za pośrednictwem programu Microsoft SQL Server.

Kreator konfiguracji wyświetli monit o poświadczenia wymagane do utworzenia głównych elementów, takich jak aplikacja sieci Web Administracja centralna i nowa baza danych konfiguracji.

Napraw

Opcji Napraw można użyć w celu zastąpienia zmienionych lub uszkodzonych plików i ustawień rejestru.

Opcji Napraw można użyć na przykład wtedy, gdy jakiś wpis rejestru został zastąpiony innym wpisem i jest konieczne przywrócenie ustawienia domyślnego.

Podczas naprawiania instalacji zainstalowane pliki są sprawdzane, wykrywane są brakujące składniki, a następnie konfiguracja jest naprawiana.

Aby uzyskać informacje, zobacz temat Jak naprawiać produkty programu SharePoint.

Uaktualnij

Można dokonać uaktualnienia do najnowszej wersji produktów programu SharePoint.

Uruchamianie narzędzia sprawdzającego środowisko uaktualnienia

Przed przeprowadzeniem uaktualnienia należy użyć narzędzia sprawdzającego środowisko uaktualnienia w celu przeskanowania witryn.

Uwaga Aby móc uruchomić to narzędzie, użytkownik musi być członkiem grupy Administratorzy na komputerze lokalnym.

W wierszu polecenia zmień bieżący folder na dysku twardym na następujący: %COMMONPROGRAMFILES%\Microsoft Shared\web server extensions\12\bin, po czym uruchom następujące polecenie, aby przeskanować wszystkie serwery w farmie serwerów:

stsadm.exe -o preupgradecheck

Narzędzie należy uruchomić na każdym serwerze w farmie serwerów. W zależności od wielkości zawartości środowiska wykonywanie zadań przez narzędzie może potrwać od kilku minut do kilku godzin.

Po zakończeniu skanowania można przejrzeć plik wyników, zawierający listę wszystkich znalezionych problemów oraz opisy sposobów ich rozwiązania. Plik znajduje się w folderze %COMMONPROGRAMFILES%\Microsoft Shared\web server extensions\12\LOGS. Nazwy plików dziennika mają następujący format: PreUpgradeCheck_RRRRMMDD-GGMMSS-SSS-liczba-losowa.log, gdzie parametr RRRRMMDD oznacza datę, parametr GGMMSS-SSS oznacza czas (godziny w formacie 24-godzinnym, minuty, sekundy i milisekundy), a liczba losowa jest używana do rozróżniania możliwych równoczesnych prób uruchomienia polecenia sprawdzania przed uaktualnieniem.

Uaktualnianie farmy serwerów

Aby uaktualnić farmę serwerów, wykonaj następujące czynności:

  1. Uruchom Instalatora, a następnie uruchom Kreatora konfiguracji produktów programu SharePoint na serwerze, na którym działa administracja centralna programu SharePoint w farmie.
  2. Gdy pojawi się komunikat dotyczący uruchamiania Instalatora na innych serwerach w farmie, należy uruchomić Instalatora i Kreatora konfiguracji produktów programu SharePoint na pozostałych serwerach w celu dotarcia do tego samego punktu.
  3. Gdy komunikat ten zostanie wyświetlony na wszystkich serwerach farmy, wróć do pierwszego serwera sieci Web, a następnie kliknij przycisk OK, aby kontynuować proces uaktualniania pierwszego serwera.
  4. Po zakończeniu działania kreatora na pierwszym serwerze można skonfigurować każdy z pozostałych serwerów.

Stosowanie aktualizacji w farmie

Po zastosowaniu aktualizacji, takiej jak dodatek Service Pack lub aktualizacja zbiorcza, należy uruchomić Kreatora konfiguracji produktów programu SharePoint w celu uaktualnienia farmy do nowej wersji. Wszystkie serwery w farmie muszą być zaktualizowane do tej samej wersji i muszą mieć zainstalowane te same produkty i pakiety językowe, zanim będzie można uruchomić kreatora konfiguracji. Jeśli jakiekolwiek serwery w farmie nie zostaną zaktualizowane, pojawi się strona Stan produktów i poprawek w farmie z listą bieżących stanów poszczególnych serwerów w farmie. Na podstawie tej strony można określić, które serwery muszą zostać zaktualizowane. Aby zaktualizować serwery, należy zakończyć działanie Kreatora konfiguracji produktów programu SharePoint, przeprowadzić aktualizację na odpowiednich serwerach, a następnie ponownie uruchomić kreatora konfiguracji.


Łączenie z farmą serwerów

Można utworzyć nową farmę serwerów lub zarządzać połączeniem z istniejącą farmą serwerów programu SharePoint. Należy podać nazwę serwera bazy danych, nazwę bazy danych oraz poświadczenia konta użytkownika, za pomocą którego będzie uzyskiwany dostęp do bazy danych. Aby uzyskać więcej informacji, zobacz Określanie ustawień zabezpieczeń farmy.

Wszystkie serwery w farmie muszą korzystać z tej samej bazy danych konfiguracji. Jeśli baza danych nie istnieje, to zostanie utworzona nowa. Jeśli nazwa bazy danych jest identyczna jak istniejącej bazy danych, to baza danych nie może zawierać żadnych tabel, procedur przechowywanych ani innych obiektów.

Należy podać poświadczenia konta użytkownika, które będzie używane przez produkty programu SharePoint do łączenia się z bazą danych. Jeśli baza danych konfiguracji jest obsługiwana przez inny komputer, konto musi być kontem domeny.

Można wybrać jedną z następujących opcji:

  • Nie modyfikuj tych ustawień
  • Utwórz nową farmę serwerów
  • Połącz z istniejącą farmą serwerów
  • Odłącz od tej farmy serwerów

Uwaga Wszystkie te opcje mogą nie pojawić się w konkretnej instalacji. To, które opcje są wyświetlane, zależy od konfiguracji i stanu farmy serwerów.

Kreator konfiguracji sprawdza, czy istnieje połączenie z bazą danych konfiguracji. Jeśli połączenie nie istnieje, zostanie utworzona nowa farma serwerów. Jeśli połączenie istnieje, ustawienia nie są modyfikowane.

Podczas zarządzania połączeniem bazy danych z istniejącą farmą serwerów Kreator konfiguracji sprawdza, czy w farmie serwerów istnieje co najmniej jedna aplikacja sieci Web administracji centralnej programu SharePoint i czy jest ona zarejestrowana w bazie danych konfiguracji. Ma to na celu wykluczenie sytuacji, w której farma serwerów istnieje, ale aplikacja sieci Web administracji centralnej programu SharePoint nie jest zainstalowana w celu zarządzania instalacją.

W przypadku wybrania opcji Odłącz od tej farmy serwerów Kreator konfiguracji usuwa serwer z farmy serwerów, a następnie aktualizuje administrację centralną programu SharePoint dla farmy.

Jeśli odłączany komputer ma aplikację sieci Web administracji centralnej programu SharePoint, to jest ona usuwana razem z wpisem w bazie danych konfiguracji.


Jak skonfigurować ustawienia serwera proxy

Za pomocą tej procedury można skonfigurować ustawienia sieciowe serwera proxy.

  1. Kliknij przycisk Start, a następnie kliknij polecenia Panel sterowania, Centrum sieci i udostępniania, po czym w sekcji Zobacz też kliknij pozycję Opcje internetowe.
  2. W oknie dialogowym Właściwości internetowe kliknij kartę Połączenia.
  3. Kliknij przycisk Ustawienia sieci LAN.
  4. W oknie dialogowym Ustawienia sieci lokalnej (LAN) w sekcji Konfiguracja automatyczna upewnij się, że oba pola wyboru są wyczyszczone.
  5. W sekcji Serwer proxy wykonaj następujące czynności:
    1. Zaznacz pole wyboru Użyj serwera proxy dla sieci LAN.
    2. W polu Adres wpisz nazwę używanego serwera proxy.
    3. W polu Port wpisz numer portu używanego serwera proxy.
    4. Zaznacz pole wyboru Pomiń serwer proxy w przypadku adresów lokalnych (intranetowych).
  6. Kliknij przycisk OK, aby zamknąć okno dialogowe Ustawienia sieci lokalnej (LAN).
  7. Kliknij przycisk OK, aby zamknąć okno dialogowe Opcje internetowe.


Aplety poleceń powłoki Windows PowerShell dla Kreatora konfiguracji produktów programu SharePoint

W produktach programu SharePoint 2010 można używać apletów poleceń powłoki Windows PowerShell jako alternatywnego interfejsu umożliwiającego wykonanie operacji sterujących sposobem skonfigurowania produktów programu SharePoint. Aby móc wykonać te operacje, użytkownik musi należeć do grupy Administratorzy na komputerze lokalnym.

Aplety poleceń powłoki Windows PowerShell można uruchamiać z okna konsoli zarządzania programu SharePoint 2010. Aby uzyskać dostęp do okna konsoli zarządzania programu SharePoint 2010, należy kliknąć przycisk Start, wskazać kolejno polecenia Wszystkie programy i Narzędzia administracyjne, a następnie kliknąć polecenie Konsola zarządzania programu SharePoint 2010.

Aplety poleceń muszą być uruchamiane w określonej kolejności, aby odniosły prawidłowy skutek. W trakcie działania Kreatora konfiguracji produktów programu SharePoint w celu skonfigurowania instalacji polecenia (nazywane również zadaniami konfiguracji) są wywoływane w odpowiedniej kolejności. Jednak w wypadku używania apletów poleceń użytkownik sam musi zadbać o zapewnienie właściwej kolejności wykonywania zadań. Aplety poleceń powłoki Windows PowerShell muszą być wykonywane w następującej kolejności:

  1. New-SPConfigurationDatabase
  2. Install-SPHelpCollection
  3. Initialize-SPResourceSecurity
  4. Install-SPService
  5. Install-SPFeature
  6. New-SPCentralAdministration
  7. Install-SPApplicationContent


Określanie ustawień bazy danych konfiguracji

Baza danych konfiguracji jest używana do przechowywania informacji o konfiguracji i mapowaniu witryn na potrzeby farmy serwerów. Dla danej farmy serwerów musi istnieć jedna baza danych konfiguracji bez względu na to, czy farma serwerów to jeden komputer ze wszystkimi elementami czy wiele komputerów.

Ustawienia bazy danych

Użytkownik musi dostarczyć ustawienia połączenia z serwerem istniejącej bazy danych za pośrednictwem istniejącego konta użytkownika.

Serwer bazy danych

Należy wpisać nazwę komputera, na którym jest uruchomiona obsługiwana wersja programu Microsoft SQL Server 2005 lub Microsoft SQL Server 2008. Można wpisać nazwę komputera, na którym jest uruchomiony program SQL Server jako serwer lub serwer\wystąpienie.

Nazwa bazy danych

W przypadku tworzenia nowej bazy danych konfiguracji można wpisać nazwę bazy danych do utworzenia przez Kreatora konfiguracji lub nazwę dostarczonej wcześniej bazy danych. Jeśli ma być używana istniejąca baza danych, należy uruchomić program Psconfig.exe z wiersza polecenia, aby połączyć się z bazą danych, a baza danych nie może zawierać żadnych tabel, procedur składowanych ani innych obiektów.

Aby połączyć się z istniejącą bazą danych konfiguracji, można kliknąć przycisk Pobierz nazwy baz danych. Po zwróceniu baz danych konfiguracji istniejących na komputerze z uruchomionym programem SQL Server można wybrać odpowiednią bazę danych.

Konto dostępu do bazy danych

Należy wprowadzić poświadczenia dla istniejącego konta użytkownika, które będzie zawsze używane do połączenia z bazą danych konfiguracji. Jeśli baza danych konfiguracji jest obsługiwana na innym komputerze, należy dostarczyć poświadczenia dla konta domeny.

Chociaż dla instalacji, w których jest używana instalacja programu SQL Server, można wprowadzić konto lokalne lub konto domeny, konto lokalne będzie działać jedynie w przypadku wdrożeń pojedynczych serwerów. W celu dodania kolejnych komputerów do farmy zaleca się użycie konta domeny.

Do wdrożenia produktów programu SharePoint w środowisku farmy serwerów potrzebne jest unikatowe konto użytkownika domeny, które można określić jako konto usługi programu SharePoint. To konto służy do uzyskiwania dostępu do bazy danych konfiguracji. Konto dostępu do bazy danych będzie używane zarówno do początkowego konfigurowania baz danych, jak i do późniejszych połączeń serwerów tej farmy z bazami danych.

Ważne Upewnij się, że w domenie nie obowiązują zasady grupy, które mogłyby zabraniać kontu wybranemu jako konto dostępu do baz danych działania jako usługi.

To konto działa także jako tożsamość puli aplikacji dla puli aplikacji administracji centralnej programu SharePoint i jest kontem, na którym działa Usługa czasomierza programu SharePoint 2010. Kreator konfiguracji produktów programu SharePoint umożliwia dodanie tego konta do identyfikatorów logowania programu SQL Server, roli serwera twórcy bazy danych programu SQL Server oraz roli serwera administratorów zabezpieczeń programu SQL Server. Zalecane jest stosowanie reguły minimalnych przywilejów i niedołączanie tego konta do żadnej z konkretnych grup zabezpieczeń na serwerach sieci Web ani na serwerach baz danych.

Konto dostępu do bazy danych musi mieć następujące uprawnienia: administrator zabezpieczeń, twórca bazy danych i właściciel bazy danych (DBO) w odniesieniu do wszystkich baz danych programu SharePoint. Jeśli program Psconfig.exe jest uruchomiony z wiersza polecenia w celu zainstalowania i określenia konta używającego uwierzytelniania SQL, uprawnienia dla tego konta muszą być skonfigurowane w programie SQL Server. Kreator konfiguracji nie wykonuje tej konfiguracji, jeśli program Psconfig.exe zostanie uruchomiony z wiersza polecenia z opcją uwierzytelniania SQL.

Konto określone na potrzeby dostępu do bazy danych musi spełniać przynajmniej następujące warunki:

  • Możliwość odczytu bazy danych konfiguracji i zapisu w tej bazie.
  • Uprawnienia na całym serwerze (administrator zabezpieczeń) w programie SQL Server.
  • Podczas tworzenia i dodawania schematu konto musi mieć uprawnienia właściciela bazy danych.

Ponadto, jeśli Kreator konfiguracji tworzy nową bazę danych konfiguracji, konto dostępu do bazy danych musi mieć następujące uprawnienia:

  • Tworzenie bazy danych.
  • Tworzenie procedury.

Zadania

Aby utworzyć bazę danych konfiguracji, Kreator konfiguracji wykonuje następujące zadania:

  1. Sprawdź, czy program SQL Server spełnia minimalne wymagania.
  2. Utwórz nową bazę danych albo połącz się z istniejącą, pustą bazą danych.
  3. Dodaj schemat bazy danych do nowej bazy danych konfiguracji.
  4. Dodaj bieżący serwer do topologii.
  5. Do bazy danych konfiguracji dodaj poświadczenia konta dostępu do bazy danych.
  6. Zapisz parametry połączenia z bazą danych w rejestrze na komputerze lokalnym.

Aby rozłączyć z bazą danych konfiguracji, Kreator konfiguracji wykonuje następujące zadania:

  1. Usuń parametry połączenia z bazą danych konfiguracji.
  2. Zatrzymaj usługę NT planowania zadań działającą na komputerze lokalnym.
  3. Usuń dane określonego komputera ze starej bazy danych konfiguracji.


Ustawienia zaawansowane

Aby za pomocą usług domenowych w usłudze Active Directory (AD DS) automatycznie utworzyć nowe unikatowe konta użytkowników, należy włączyć tryb tworzenia kont usługi Active Directory.

Ponieważ dla każdej farmy serwerów jest wymagana co najmniej jedna aplikacja sieci Web administracji centralnej, na pierwszym serwerze farmy serwerów jest automatycznie instalowana aplikacja sieci Web administracji centralnej i prezentowany jest tylko jeden zestaw pól dla domeny Active Directory oraz jednostki organizacyjnej Active Directory. Gdy zostanie uruchomiony kreator konfiguracji na innym serwerze farmy, to na ekranie pojawi się opcja utworzenia aplikacji sieci Web administracji centralnej.

Jeśli ma zostać utworzony adres URL zrównoważonego obciążenia dla administracji centralnej lub w celu zapewnienia dublowania, to można utworzyć więcej niż jedną witrynę sieci Web administracji centralnej. Jednak w większości instalacji nie jest to konieczne.

Aby włączyć tryb tworzenia kont usługi Active Directory
  1. Na stronie Ustawienia zaawansowane wybierz opcję Włącz tryb tworzenia kont usługi Active Directory.
  2. W polu Domena usługi Active Directory wpisz nazwę domeny.
  3. W polu Jednostka organizacyjna usługi Active Directory wpisz nazwę jednostki organizacyjnej programu SharePoint.
  4. Aby wrócić do strony Kończenie pracy Kreatora konfiguracji produktów programu SharePoint, kliknij przycisk OK.

Ostrzeżenie Jeśli ta opcja zostanie włączona, uaktualnienie programu Microsoft SharePoint Foundation do innych produktów opartych na technologiach i produktach programu SharePoint może być niemożliwe. Jeśli na tym komputerze wystąpią problemy z zainstalowaniem produktów programu SharePoint, należy ponownie uruchomić Kreatora konfiguracji produktów programu SharePoint i wyłączyć tę opcję.


Potwierdzanie ustawień

Na stronie Kończenie pracy Kreatora konfiguracji produktów programu SharePoint należy potwierdzić wprowadzone ustawienia bazy danych i aplikacji sieci Web administracji centralnej.

Potwierdź poprawność ustawień, a następnie kliknij przycisk Dalej, aby kontynuować.

Kliknij opcję Ustawienia zaawansowane, aby włączyć tryb tworzenia kont usługi Active Directory. Aby uzyskać więcej informacji, zobacz Ustawienia zaawansowane.


Zamienianie domyślnej witryny programu SharePoint

Jeśli jest przeprowadzana instalacja autonomiczna lub uaktualnianie, a jest już zainstalowany produkt programu SharePoint, domyślna witryna programu SharePoint może już istnieć na porcie 80.

Jeśli użytkownik ma pewność, że istniejąca domyślna witryna sieci Web programu SharePoint nie jest wymagana, może wyłączyć istniejącą witrynę i utworzyć nową na porcie 80 lub może wybrać inny port do obsługi nowej witryny.


Określanie ustawień zabezpieczeń farmy

Wpisz hasło, aby zabezpieczyć dane konfiguracyjne farmy, a następnie kliknij przycisk Dalej.

Wprawdzie to hasło jest podobne do zwykłych haseł, ale z reguły jest dłuższe, aby zapewnić lepsze zabezpieczenia. Jest ono używane do szyfrowania poświadczeń kont zarejestrowanych w produktach programu SharePoint, na przykład konta systemowego podawanego podczas uruchamiania Kreatora konfiguracji produktów programu SharePoint. Hasło to należy zapamiętać, ponieważ jest wymagane przy każdym dodawaniu serwera do farmy.

Należy zadbać, aby hasło spełniało następujące kryteria:

  • Zawiera co najmniej osiem znaków.
  • Zawiera znaki z co najmniej trzech spośród następujących czterech grup znaków:
    • wielkie litery (od A do Z),
    • małe litery (od a do z),
    • cyfry (od 0 do 9),
    • znaki niealfabetyczne (takie jak !, $, #, %).

Hasło można zmienić po skonfigurowaniu farmy, uruchamiając aplet polecenia Set-SPPassphrase w powłoce Windows PowerShell. Domyślnie nowe hasło zostanie wdrożone na wszystkich serwerach w farmie. Jeśli jednak wystąpi niepowodzenie wdrożenia nowego hasła, należy ręcznie zaktualizować hasło na każdym serwerze, na którym nie udało się go wdrożyć. Aby ręcznie zaktualizować hasło, należy uruchomić aplet polecenia Set-SPPassphrase - LocalServerOnly w powłoce PowerShell.

Uwaga Podczas uaktualniania strona Określanie ustawień zabezpieczeń farmy nie jest wyświetlana.


Uaktualnianie wizualne

Uaktualnienie wizualne umożliwia użytkownikom zachowanie obecnego wyglądu i sposobu działania witryn programu SharePoint po uaktualnieniu do nowej wersji. Ogranicza to wpływ uaktualnienia na użytkowników, a także minimalizuje problemy z dostosowanymi stronami, składnikami Web Part, formantami sieci Web i widokami.

Właściciele witryn mogą decydować, czy i kiedy uaktualnić wygląd witryn do nowej wersji. Domyślnie nowe witryny tworzone po uaktualnieniu korzystają z nowego środowiska użytkownika.

  • Zmień istniejące witryny programu SharePoint w taki sposób, aby korzystały z nowego środowiska użytkownika

    • Zaznacz tę opcję w celu zmiany istniejących witryn programu SharePoint tak, aby korzystały z nowego środowiska użytkownika, w tym układu, organizacji poleceń i stylu. Po zaznaczeniu tej opcji trzeba zaznaczyć również następujące opcje:

    • Zachowaj dostosowane strony, ale zaktualizuj strony szablonu i aplikacji, tak aby korzystały z nowego środowiska użytkownika

      • Zaznacz tę opcję w celu zmiany istniejących witryn programu SharePoint tak, aby korzystały z nowego środowiska użytkownika, ale zachowując wszystkie wprowadzone dostosowania.

    • Przywróć oryginalne szablony dla wszystkich dostosowanych stron

      • Zaznacz tę opcję w celu zmiany istniejących witryn programu SharePoint tak, aby korzystały z nowego środowiska użytkownika, ale zastępując wszystkie wprowadzone dostosowania.

  • Zachowaj wygląd oraz działanie istniejących witryn programu SharePoint i zezwól użytkownikom końcowym na aktualizowanie środowiska użytkownika w swoich witrynach

    • Zaznacz tę opcję, aby zachować istniejące środowisko użytkownika, w tym układ, organizację poleceń i styl. Zostaną zachowane wszystkie dane i ustawienia oryginalnej witryny.

    Po uaktualnieniu farmy administratorzy farmy, administratorzy zbioru witryn oraz właściciele witryn mogą aktualizować witryny do najnowszego środowiska użytkownika.

    Jeżeli witryna korzysta z wcześniejszego środowiska użytkownika, niektóre nowe funkcje nie są dostępne. Te funkcje to między innymi Wstążka, edycja w miejscu stron typu wiki, interaktywne kalendarze oraz relacje list. Gdy witryna zostanie uaktualniona w taki sposób, aby używała najnowszego środowiska użytkownika, nowe funkcje automatycznie staną się dostępne.

    Niezależnie od wybranego typu uaktualnienia farmy administratorzy mogą korzystać z wszystkich możliwości zapewnianych przez uaktualnienie, w tym większej niezawodności i skalowalności oraz łatwego zarządzania.

    Zachowanie wcześniejszego środowiska użytkownika zmniejsza prawdopodobieństwo, że dostosowana zawartość przestanie działać. Dzięki temu administratorzy, deweloperzy i użytkownicy końcowi mają zagwarantowaną możliwość korzystania z witryny SharePoint do czasu zakończenia wszystkich prac związanych z uaktualnianiem.