O programie

    e-Poczta Podatkowa, to program do wysyłania i zarządzania danymi dla e-Deklaracji.
    Dodaje on nową funkcjonalność w aplikacjach przygotowujących dane do wysłania.
    Program oferuje dwa warianty pracy:

    on-line, czyli natychmiastowe wysyłanie danych,
    off-line, czyli gromadzenie danych w bazie i późniejsze wysłanie całej paczki danych za jednym podpisem.

    W obu wariantach umożliwia późniejsze odczytanie statusów e-Deklaracji wysłanych dokumentów.
    Program jest standardowo dostarczany z bazą danych SQLITE. Zastosowane mechanizmy pozwalają
    na naprzemienny dostęp wielu użytkowników do bazy danych umieszczonej na dysku sieciowym.
    Aplikacja umożliwia również import danych z plików XML w trybie wsadowym i interaktywnym.


Import z pliku XML

    Wybierając z menu Plik\Importuj (Ctrl+I) mamy możliwość zaimportowania danych do aplikacji.
    Program e-Poczta Podatkowa umożliwia import danych z pliku XML w następujący sposób:

    W trybie wsadowym
    W trybie interaktywnym


W trybie wsadowym

Import w trybie wsadowym

    Parametry wywołania
    Struktura pliku raportu


Parametry wywołania

    ePocztaPodatkowa.exe [[@]plik1[,[@]plik2,...[@]plikn] [OUT=PlikRaportu [OUTAPPEND] [SEND] [SHOW] [SILENT] [DEL]] ] [TEST]

    plik albo @plik
    względne lub pełne ścieżki do plików XML podane w formacie commatext albo plik tekstowy zawierający linie ze ścieżkami do plików XML.

    OUT=PlikRaportu
    ścieżka do pliku raportu zobacz strukturę pliku raportu.

    OUTAPPEND
    Dołącza raport do istniejącego pliku raportu.
    W przypadku braku parametru nadpisuje istniejący plik raportu.

    Istniejący plik zostanie roszerzony lub napisany tylko w przypadku gdy jest on pusty lub jest tekstowym plikiem zapisanym w formacie UTF8 z BOM oraz pierwsza linia tesktu zaczyna się od słowa RaportEPP=

    SEND
    Dane XML zostaną wysłane do e-Deklaracji.
    W przypadku braku tego parametru dane zostaną tylko dołączone do bazy danych.

    W czasie wysyłania danych będzie widoczne okno programu.
    Po pozytywnym zakończeniu zostanie zamknięte, chyba że użytko parametru SHOW.

    SHOW
    Zostanie otwarte okno programu nawet bez wysyłania danych (bez parametru SEND).

    SILENT
    Nie pojawią się komunikaty (MessageBox) w przypadku braku lub błędnych plików XML.

    DEL
    Usuwa pliki XML.

    TEST
    Ustawia program w tryb wysyłania do testowej bramki e-Deklaracji.
    W tym przypadku dane nie zostaną zapisane w bazie danych.


Struktura pliku raportu

    Plik jest zapisany jako UTF8 z nagłówkiem.

    Pierwsza linia zawiera tekst:
    RaportEPP=data raportu,czas raportu

      data raportu i czas raportu
      Czas ostatniego utworzenia raportu.
      Data jest w formacie rrrr-mm-dd, czas w formacie hh:mm:ss

    Kolejne linie zawierają:
    nazwa pliku xml,data dodania,czas dodania=Identyfikator w bazie/Numer referencyjny/kod i tekst błędu

      nazwa pliku xml
      Nazwa pliku tak jak została podana w parametrze wejściowym

      data dodania
      Data dodania do bazy w formacie yyyy-mm-dd

      czas dodania
      Czas dodania do bazy w formacie hh:mm:ss

      Identyfikator w bazie/Numer referencyjny:status/kod i tekst błędu

        Identyfikator w bazie
        Identyfikator danych w bazie ePocztyPodatkowej jeśli nie nastapiła wysyłka i odbiór numeru referencyjnego.
        Pierwszym znakiem identyfikatora jest znak zapytania (?),
        np: plik xml.txt,2014-03-07,12:56:22=?3879731241705.53915090281

        albo

        Numer referencyjny:status
        Numer otrzymany z e-Deklaracji i numer statusu e-Deklaracji,
        np: "plik xml.txt",2014-03-07,12:56:22=9bcd3b235528a4bc3e10790ab442ad9e:200

        albo

        kod i tekst błędu
        W przypadku niepowodzenia wysłania danych kod błędu i tekst o strukturze:
        error3CyfryNumeruBłędu:"Tekst błędu",
        np: "plik xml.txt",2014-03-07,12:56:22=Error002:"Niewłaściwy plik XML."

    Obecnie możliwe błędy:

    Error001:"Błąd dodania rekordu do bazy danych."
    Error004:"Nie znaleziono pliku XML."
    Error005:"Niewłaściwy plik XML."
    Error006:"Błąd odczytu pliku XML."
    Error100:"Wysyłanie zostało przerwane. Dane nie zostały wysłane ani dodane bazy ePP."


Import w trybie interaktywnym

    Wybierając z menu Plik\Importuj(Ctrl+I) zostanie wyświetlone okno Wybór plików do wysłania.

    W nim, po naciśnięciu na przycisk Wybierz zostanie otwarte okno Ścieżki z plikami XML.
    Wybieramy w polu Ścieżka edytowana lokalizacje do danych w plikach *.xml i *.txt, którą możemy:

  • Dodać,

    • Dodana ścieżka zostanie przedstawiona w polu Lista wybranych ścieżek.
  • Zmienić,

    • Wybieramy inną lub edytujemy lokalizację do plików XML i naciskamy na przycisk Zmień.
    Zmiana będzie widoczna w polu Lista wybranych ścieżek.
  • Usunąć,

    • Wybrana ścieżka zostanie ona usunięta z pola Lista wybranych ścieżek.
  • Usunąć wadliwą.

    • Zostaną usunięte niepoprawne lokalizacje do plików XML z pola Lista wybranych ścieżek.

    Po dokonanej czynności naciskamy na przycisk Zatwierdź.
    W dolnej części okna Wybór plików do wysłania pojawią się pliki do zaimportowania.
    Następnie zaznaczamy wybrane pliki lub wszystkie przy użyciu przycisku x i naciskamy na przycisk Importuj.
    Dodatkowo możemy zaznaczyć kwadrat Usuwaj pliki po wczytaniu.
    Zostanie wyświetlone okno Raport z informacją, że wybrane pliki zostały dodane do bazy danych.

    W celu dodania do bazy wybranego pliku XML, należy w oknie Wybór plików do wysłania nacisnąć na przycisk Dowolne.


Lista dokumentów

    Po przesłaniu z aplikacji IPS, która umożliwia edycję danych lub zaimportowaniu dokumentów są one dodawane
    do bazy danych e-Poczta Podatkowa. Lista dokumentów przedstawia następującą informacje o ich stanie:

  • oznaczone kolorem białym,

    • Dokumenty, które czekają na wysłanie.
  • oznaczone kolorem pomarańczowym,

    • Dokumenty, które zostały wstępnie przetworzone.
  • oznaczone kolorem czerwonym,

    • Dokumenty, które zostały odrzucone.
  • oznaczone kolorem zielonym,

    • Dokumenty, które zostały przyjęte.
  • oznaczony kolorem niebieskim.

    • Dokument do wysłania, dla którego jest widoczny podgląd szczegółów

    Przycisk X obok nazwy służy do zaznaczenia lub wyłączenia wszystkich dokumentów (kwadraty) w liście.
    Taki sam efekt możemy uzyskać naciskając w menu Plik/Zaznacz wszystkie dane/żadne(Ctrl+A).
    W celu usunięcia dokumentu wybieramy w menu Plik\Usuń zaznaczone\Usuń


Filtrowanie danych

    W celu posortowania listy dokumentów w programie e-Poczta Podatkowa na samym początku wybieramy zakres dat w części Pokaż za okres.

    Następnie dane możemy posortować według następujących filtrów:

  • według daty

    • - utworzenia,
    - wysłania,
    - przyjęcia.

  • według wysyłki

    • - do wysłania,
    - oczekujące,
    - przyjęte,
    - odrzucone.

  • według wprowadzonej frazy

    • - szukaj po nazwie,
    - szukaj w podatnikach.

  • szukaj podatnika

    • Przykład:
    Zostały zaimportowane dane VAT-7 w wersji 14 z plików XML w dniu 24 marca 2014 roku.

    WYSYŁKA
    1. Wybieramy okres od 2014-03-24 do data systemowa Windows.
    2. Wybieramy filtr wysyłki: Do wysłania i Oczekujące.
    3. Wybieramy filtr według daty: utworzenia.
    4. W pole Szukaj frazy wprowadzamy VAT7-14 i zaznaczamy kwadrat Szukaj po nazwie.

    PO WYSŁANIU
    1. Wybieramy okres od 2014-03-24 do data systemowa Windows.
    2. Wybieramy filtr według wysyłki: przyjęte lub/i odrzucone.
    3. W pole Szukaj frazy wprowadzamy VAT7-14 i zaznaczamy kwadrat Szukaj po nazwie.

    Filtr według daty w przypadku sprawdzenia stanu dokumentów wysłanych nie ma zastosowania.
    Opcje filtrowania dokumentów według wysyłki są również dostępne w menu Widok.


Wyślij i sprawdź

    Po przesłaniu, w trybie off-line lub zaimportowaniu danych do e-Poczta Podatkowa mamy możliwość
    wysłania ich hurtowo na bramkę Ministerstwa Finansów. W tym celu po posortowaniu danych wybieramy z
    listy dokumentów wybrane formularze do wysłania i naciskamy na przycisk Wyślij/sprawdź.

    Pojawi się okno Poczta: e-Deklaracje, w którym w górnej jego części będzie widoczna lista danych
    do podpisania    , gdzie cała paczka będzie podpisana wybranym certyfikatem.

    Zaznaczając nazwę dokumentu, w dolnej części okna, będą widoczne Dane XML przed podpisaniem.

    Naciskamy na przycisk Podpisz, pojawi się okno wyboru certyfikatu, o ile jest to wysyłka danych z podpisem
    kwalifikowanym. Zaznaczamy w górnej części okna certyfikat i naciskamy na przycisk Wybierz. Po wprowadzeniu
    PIN pojawi się okno z listą danych podpisanych i gotowych do wysłania, w którym naciskamy na przycisk Wyślij.

    W części Lista dokumentów zostanie przedstawiona informacja o wysłanych danych.


Sprawdź

    Po wysłaniu dokumentów do systemu e-Deklaracje otrzymamy status 302 - dokument wstępnie
    przetworzony.     Oznacza to, że dokument dotarł do urzędu ale centrum certyfikacji go jeszcze nie
    zaakceptowało. Należy wówczas poczekać na status 200, który potwierdzi prawidłowe przesłanie danych i
    umożliwi pobranie UPO (Urzędowe Potwierdzenie Odbioru).

    Dokument może być przetwarzany kilka godzin. Po tym czasie sortujemy dane i w liście dokumentów je
    wybieramy. Możemy nacisnąć na przycisk X lub wybrać w menu Plik\ opcję Zaznacz wszystkie
    dane/żadne(Ctrl+A)     w celu zaznaczenia wszystkich. Następnie naciskamy na przycisk Sprawdź(Ctrl+S).

    UWAGA!
    Dokumenty ze statusem innym niż 200 są uznane za niezłożone.
    W przypadku komunikatów innych niż 200 należy zwrócić uwagę w raporcie na opis statusu.

    100 - Błędny komunikat SOAP ,
    101 – Proszę o ponowne przesłanie dokumentu,
    102 - Proszę o ponowne przesłanie żądania UPO,
    200 - Przetwarzanie dokumentu zakończone poprawnie,
    300 - Brak dokumentu,
    301 - Dokument w trakcie przetwarzania,
    302 - Dokument wstępnie przetworzony,
    303 – Dokument w trakcie weryfikacji podpisu,
    400 - Przetwarzanie dokumentu zakończone błędem,
    401 - Dokument niezgodny ze schematem xsd,
    402 - Dokument wystawiony przez nieupoważniony podmiot,
    403 - Dokument z niepoprawnym podpisem,
    404 - Dokument z niepoprawnym certyfikatem,
    405 - Dokument z odwołanym certyfikatem,
    406 - Dokument z certyfikatem z nieobsługiwanym dostawcą,
    407 - Dokument z certyfikatem z nieprawidłową ścieżką,
    408 – Dokument zawiera błędy uniemożliwiające jego przetworzenie,
    409 - Dokument zawiera niewłaściwą ilość i/lub rodzaj elementów,
    411 - W systemie jest już złożony dokument (zeznanie) z takim numerem NIP,
    412 - Weryfikacja negatywna - niezgodność danych informacyjnych,
    414 - Weryfikacja negatywna - błąd danych identyfikacyjnych.


Podgląd szczegółów

    Podgląd szczegółów przedstawia następujące informacje, po wybraniu dokumentu z listy dokumentów:

  • XML

    • Przedstawia dane XML, które są lub będą wysłane.
  • UPO

    • Przedstawia informacje o dokumencie UPO.
  • Raport

    • Przedstawia status i opis wysłanego dokumentu.

    Podgląd szczegółów można wyłączyć/włączyć w menu Widok. Raport wybranych dokumentów można
    zapisać do pliku *.txt wybierając w menu Plik\Raport\Zapisz do pliku(Ctrl+R).


Drukowanie UPO

    Jeśli wysłane dane zostały przetworzone poprawnie i otrzymały status 200,
    to po wybraniu ich z listy dokumentów mamy możliwość wydrukowania dokumentu UPO.
    Naciskamy w tym celu na przycisk Drukuj UPO(Ctrl+U), zostanie otwarta strona z formularzem,
    do którego należy wprowadzić identyfikator dokumentu.

    Program kopiuje do schowka numer pierwszego wybranego dokumentu, który będzie można wkleić do
    formularza potwierdzenia odbioru. Numer referencyjny dla pozostałych danych w celu pobrania UPO
    można skopiować z raportu znajdującego się w podglądzie szczegółów.

    Aby wydrukować UPO potrzebny będzie program Acrobat Reader w wersji 8 lub nowszej.
    UPO to potwierdzenie, że zeznanie zostało pomyślnie zweryfikowane i przyjęte w urzędzie skarbowym.
    Dokument UPO można pobrać również bezpośrednio ze strony Ministerstwa Finansów.

    W celu seryjnego wydrukowania dokumentu UPO wymagane jest zainstalowane programu DrukForm IPS.
    Plik instalacyjny aplikacji znajduje się na stronie http://www.ips-infor.com.pl/pliki/drukformipssetup.exe
    W menu aplikacji e-Poczta Podatkowa, po zaznaczeniu w liście dokumentów danych, wybieramy
    Plik\Drukuj\UPO\własne - wersja A(Ctrl+A) lub własne - wersja B(Ctrl+B).
    Pojawi się okno Druk formularzy z "importu", w którym naciskamy na przycisk Drukuj.

    Pojawi się okno ustawień drukowanego dokumentu, w którym naciskamy na przycisk Wykonaj. Opcje dostępne w
    oknie Wydruk formularzy są opisane w oddzielnym pliku pomocy, który można otworzyć w menu Pomoc.

    Ustawienia wydruku UPO znajdują się we właściwościach programu w zakładce Drukowanie.


Właściwości programu

    Zmiany domyślnych ustawień programu e-Poczta Podatkowa możemy dokonać wybierając z menu Plik\Ustawienia

    Główne okno
    Baza danych
    Internet
    e-Deklaracje
    Drukowanie


Główne okno

    W zakładce Główne okno mamy dostępne następujące opcje:

  • Zawsze otwieraj główne okno
    • Jeśli opcja zostanie wyłączona, dane zostaną dodane do listy dokumentów,
    o ile jest wyłączona opcja Wysyłaj dane natychmiast po otrzymaniu.

  • Nie zamykaj głównego okna

    • Po wysłaniu danych program pozostanie otwarty.
  • Zamknij gdy OK

    • Po wysłaniu danych, gdy dane zostaną przetworzone poprawnie program zostanie zamknięty.
  • Zamknij gdy OK lub oczekiwanie na przyjęcie

    • Po wysłaniu danych, gdy dane zostaną przetworzone poprawnie lub/i są w trakcie program zostanie zamknięty.
  • Zawsze zamknij

    • Po wysłaniu danych program, bez znaczenia na status, zostanie zamknięty.

    Po dokonanych ustawieniach naciskamy na przycisk Zapamiętaj.


Baza danych

    W zakładce Baza danych mamy możliwość zmiany bazy danych i lokalizacji dodawanych dokumentów.

  • Standardowa baza danych - SQLite

    • W domyślnej bazie danych SQLite, dostarczanej z aplikacją e-Poczta Podatkowa,
    mamy możliwość edycji listy dokumentów do wysłania, tworzonej w lokalizacji:

      C:\Users\"nazwa_usera"\Documents\IPSPI\EPocztaPodatkowa\

    Po naciśnięciu na przycisk Dodaj nową lokalizację mamy możliwość dodania i zmiany domyślnej
    lokalizacji do bazy danych. Dodana lokalizacja będzie dostępna w liście Ścieżka do bazy danych.

  • Inna baza danych

    • OPCJA W PRZYGOTOWANIU

    Po dokonanych ustawieniach naciskamy na przycisk Zapamiętaj.


Internet i e-Deklaracje

Internet

    W zakładce Internet mamy dostępne następujące opcje:

  • Sprawdzaj automatycznie

    • Jeśli opcja będzie włączona program automatycznie sprawdzi czy jest nowa wersja,
    o ile będzie zaznaczony kwadrat nie pytaj o pozwolenie
  • nie pytaj o pozwolenie

    • Jeśli opcja nie będzie włączona po otworzeniu programu pojawi się okno
    Czy mogę sprawdzić dostępność aktualizacji programu?,
    o ile będzie zaznaczony kwadrat Sprawdzaj automatycznie.
  • Ustawienia połączenia internetowego

    • Jeśli łączymy się z internetem poprzez serwer proxy, to musimy wybrać odpowiednie dla niego ustawienie.
    W tym celu naciskamy na Ustawienia połączenia internetowego i wybieramy odpowiedni typ serwera
    proxy. Program automatycznie odczytuje ustawienia serwera proxy z ustawień Microsoft Internet Explorer i stosuje
    te ustawienia. Jeśli nie łączymy się z internetem poprzez serwer proxy, to nic nie zmieniamy.

    Po dokonanych ustawieniach naciskamy na przycisk Zapamiętaj.


e-Deklaracje

    W zakładce e-Deklaracje mamy dostępne następujące opcje:

  • Wysyłaj dane natychmiast

    • Jeśli opcja jest włączona, to dane zostaną wysyłane bezpośrednio na bramkę Ministerstwa Finansów.
    Jeśli opcja jest wyłączona, to dane zostaną dodane do listy dokumentów
  • Sprawdzaj statusy co:

    • Jeśli opcja jest włączona i program otwarty, to są sprawdzane statusy wysłanych dokumentów co wybrany czas.
  • Tryb przyśpieszony

    • Program wysyła dane w przyspieszonym trybie.
  • Testuj wysłanie

    • Umożliwia przesłanie danych na bramkę testową w celu sprawdzenia wysyłki dokumentów.
    Po zaznaczeniu opcji Użyj podpis test zostanie dokonany z użyciem posiadanego certyfikatu.

    Po dokonanych ustawieniach naciskamy na przycisk Zapamiętaj.


Drukowanie

    W zakładce Drukowanie mamy możliwość wyboru i ustawienia drukowanego UPO. Program e-Poczta
    Podatkowa     domyślnie posiada ustawione drukowanie UPO, które jest pobierane ze strony Ministerstwa Finansów.

    Po zmianie przełącznika na UPO Wewnętrzne przy drukowaniu UPO zostanie otwarty dokument w aplikacji
    DrukForm IPS. Naciskając na przycisk Ustawienia zostanie otwarte okno Druk formularzy z
    "importu"    , w którym po naciśnięciu na przycisk Pokaż, można otworzyć podgląd drukowanego UPO.

    Po dokonanych ustawieniach naciskamy na przycisk Zapamiętaj.