Składnik Access Web Datasheet — informacje

Składnik Access Web Datasheet jest środowiskiem podobnym do programu Excel, w którym można wyświetlać i edytować dane. W składniku tym jest wyświetlana zawartość listy lub biblioteki dokumentów w siatce wierszy i kolumn. W składniku Access Web Datasheet elementy i kolumny listy są wyświetlane jako wiersze i kolumny. Można je dodawać i edytować, stosować filtry i kolejności sortowania, wyświetlać obliczone wartości i sumy oraz wykonywać wiele innych czynności.

Na poniższej ilustracji pokazano listę pracowników w składniku Access Web Datasheet.

Lista pracowników w widoku arkusza danych

Objaśnienie 1 Wiersz odpowiada elementowi listy.

Objaśnienie 2 Kolumna odpowiada polu listy.

Objaśnienie 3 Strzałka rozwijana w nagłówku kolumny służy do filtrowania i sortowania danych.

Objaśnienie 4 W wierszu Suma są wyświetlane wartości zagregowane poszczególnych kolumn.

Początek strony

Wyświetlanie listy w składniku Access Web Datasheet

Większość typów list można wyświetlać w składniku Access Web Datasheet. Listę można wyświetlać na dwa sposoby:

  • Otwierając listę w widoku standardowym, a następnie przechodząc do widoku arkusza danych przez kliknięcie pozycji Edytuj w arkuszu danych na karcie Lista wstążki.

    Uwaga Jeśli widok standardowy nie obsługuje edytowania w widoku arkusza danych, polecenie Edytuj w arkuszu danych nie będzie dostępne. Na przykład edytowanie w widoku arkusza danych nie jest obsługiwane w widoku Eksploratora biblioteki dokumentów.

  • Tworząc widok arkusza danych. Należy zauważyć, że widok arkusza danych można ustawić jako widok domyślny listy.

Widok arkusza danych jest niezależny od wszystkich innych widoków listy. Jeśli w widoku standardowym zostanie dodana lub usunięta kolumna, nie będzie to miało wpływu na widok arkusza danych.

Do niektórych typów list, które nie obsługują widoku arkusza danych należą:

  • Tablica dyskusyjna
  • Ankieta
  • Galeria obrazów
  • Biblioteka szablonów sieci Web
  • Wykaz składników Web Part
  • Źródła danych
  • Skrzynka odbiorcza

Początek strony

Pozycje listy w składniku Access Web Datasheet

Wiersze W składniku Access Web Datasheet znajduje się co najmniej jeden wiersz. W każdym wierszu są przechowywane informacje dotyczące elementu listy. Na przykład w wierszu listy pracowników znajdują się informacje dotyczące pracownika.

Wiersz można dodać, przewijając na dół listy i wprowadzając dane w wierszu oznaczonym gwiazdką (*). Wiersz można także edytować lub usunąć. Wprowadzone zmiany są wysyłane do serwera po wyjściu z wiersza i są zatwierdzane asynchronicznie. Można kontynuować wprowadzanie zmian w innych wierszach. Zmiany te będą zatwierdzane w tle. Jeśli zmiany spowodują konflikt lub błąd, w widoku pojawią się informacje niezbędne do rozwiązania konfliktu lub usunięcia błędu.

Można zmieniać wysokość wiersza, sortować wiersze według co najmniej jednej kolumny i ukrywać wiersze przez zastosowanie filtrów.

Kolumny W widoku znajduje się co najmniej jedna kolumna. W każdej kolumnie są przechowywane określone typy informacji dotyczące wszystkich elementów widoku. Na przykład w kolumnie Imię i nazwisko na liście pracowników znajdują się imiona i nazwiska pracowników.

Kolumnę można dodawać do listy w widoku arkusza danych lub w widoku standardowym. Kolumna musi mieć nazwę i muszą w niej być przechowywane dane określonego typu. Można oznaczyć odpowiednio kolumnę, jeśli ma ona nie być pomijana podczas wprowadzania danych przez użytkownika. Można także określić dodatkowe ustawienia kolumn, takie jak wartość domyślna i długość maksymalna. Aby uzyskać więcej informacji na temat dodawania kolumny do listy, zobacz Pomoc programu Microsoft SharePoint Foundation 2010. Aby wyświetlić Pomoc programu Microsoft SharePoint Foundation 2010, kliknij przycisk Pomoc ( Ikona Pomocy).

Istniejącą kolumnę można zmodyfikować lub usunąć. Można dostosować wyświetlanie kolumn, pokazując lub ukrywając kolumny, zmieniając ich kolejność, ustawiając ich szerokość oraz filtrując i sortując wiersze według wartości w kolumnach. Można także dodawać do listy kolumny obliczeniowe.

Grupa Arkusz danych W grupie Arkusz danych wstążki w obszarze karty Lista są wyświetlane polecenia umożliwiające wykonywanie typowych zadań w widoku arkusza danych, takich jak wyświetlanie okienka zadań czy dodawanie nowego wiersza.

Pasek stanu Na pasku stanu w dolnej części widoku są wyświetlane przydatne informacje, takie jak:

  • komunikaty o błędach lub komunikaty ostrzegawcze;
  • informacje dotyczące bieżącego zaznaczenia, na przykład „Tylko do odczytu”;
  • stan komunikacji serwera.

Okienko zadań. Okienko zadań umożliwia łatwe uzyskanie dostępu kontekstowego do określonych akcji bez konieczności wychodzenia z widoku arkusza danych.

Na poniższym rysunku przedstawiono okienko zadań przykładowej listy:

Objaśnienie 1 U góry okienka zadań znajduje się pasek narzędzi. Znajdują się na nim przyciski umożliwiające uruchamianie typowych poleceń, takich jak Wytnij, Kopiuj, Wklej, Sortuj i Pomoc.

Objaśnienie 2 Kliknięcie paska służącego do modyfikowania okienka powoduje ukrycie lub wyświetlenie okienka zadań. Rozmiar okienka można zmienić, przeciągając pasek.

Objaśnienie 3 Poruszaj paskiem przewijania, aby przewijać okienko w pionie.

Objaśnienie 4 W okienku są wyświetlane różne polecenia.

Początek strony

Wymagania dotyczące oprogramowania na potrzeby pracy w składniku Access Web Datasheet

Aby można było wyświetlać listę w składniku Access Web Datasheet, komputer musi spełniać zestaw wymagań dotyczących oprogramowania.

Początek strony


Wymagania dotyczące oprogramowania dla składnika Access Web Datasheet

Aby otworzyć listę w składniku Access Web Datasheet, muszą zostać spełnione następujące wymagania:

  • Zainstaluj 32-bitową wersję pakietu Microsoft Office 2010 na komputerze.
  • Zainstaluj na komputerze składnik Microsoft Office Access Web Datasheet, który jest częścią pakietu Office 2010.

    Uwaga Składnik ten jest instalowany domyślnie podczas instalacji pakietu Office 2010.

  • Aby otworzyć listę w programie Microsoft Internet Explorer 6.0 lub nowszym, użyj programu Microsoft Internet Explorer 6.0.
  • Upewnij się, że ustawienia zabezpieczeń w przeglądarce obsługują formaty Microsoft ActiveX.

Jeśli przynajmniej jedno z tych wymagań nie zostanie spełnione, pojawi się komunikat z informacją, że lista zostanie wyświetlona w widoku standardowym. Skonfigurowane ustawienia widoku arkusza danych, takie jak kolejność kolumn, sortowanie i filtrowanie oraz ustawienia wiersza Suma, zostaną zastosowane w widoku standardowym, zanim zostanie wyświetlona lista. Jednak takie ustawienia, jak wysokość wiersza, szerokość kolumny i kolumny ukryte, będą ignorowane.

Należy zauważyć, że nawet jeśli nie zostaną spełnione wszystkie powyższe wymagania, będzie można wprowadzać zmiany w widoku arkusza danych. Zmiany zostaną zapisane i będzie można zobaczyć ich skutki przy następnym użyciu komputera spełniającego wszystkie wymienione wymagania dotyczące oprogramowania.


Wyświetlanie informacji o produkcie i komputerze

Otwierając okno dialogowe Informacje, można wyświetlić wersję składnika Microsoft Office Access Web Datasheet zainstalowanego na komputerze, numer identyfikacyjny produktu, informacje o systemie i inne informacje pokrewne.

  • Kliknij prawym przyciskiem myszy lewy górny róg listy, a następnie kliknij polecenie Informacje.


Uzyskiwanie pomocy w składniku Access Web Datasheet

  • Aby uzyskać pomoc w składniku Access Web Datasheet, kliknij prawym przyciskiem myszy dowolną komórkę w widoku arkusza danych i kliknij polecenie Pomoc.

    Ważne Tematy Pomocy w składniku Access Web Datasheet dotyczą tylko funkcji dostępnych w widoku arkusza danych. Aby uzyskać ogólną pomoc dotyczącą list programu SharePoint, kliknij przycisk Pomoc ( Ikona Pomocy).

  • Aby uzyskać pomoc dotyczącą strony programu SharePoint zawierającej widok arkusza danych, kliknij przycisk Pomoc ( Ikona Pomocy).
  • Aby uzyskać pomoc, gdy w widoku arkusza danych jest wyświetlany składnik Web Part widoku listy, kliknij menu Składnik Web Part, a następnie kliknij polecenie Pomoc. Tematy Pomocy dotyczą stron, właściwości i połączeń składnika Web Part.

Uwagi

  • W kilku oknach dialogowych oraz w komunikatach na pasku stanu znajdują się łącza do informacji pomocy kontekstowej. Można także kliknąć przycisk Pomoc ( Ikona Pomocy) na pasku narzędzi w okienku zadań.
  • Jeśli widok arkusza danych jest aktywny, naciśnięcie klawisza F1 spowoduje wyświetlenie pomocy dotyczącej tego widoku. W przeciwnym razie zostanie wyświetlona Pomoc programu Internet Explorer.


Rozwiązywanie problemów ze składnikiem Access Web Datasheet

Nie mogę otworzyć listy w składniku Access Web Datasheet albo lista otwiera się w widoku standardowym.

Nie widzę żadnych danych w widoku lub widzę tylko ich część.

Jest wyświetlany komunikat „Lista/Widok nie istnieje”.

Jest wyświetlany komunikat „Nie masz uprawnień”.

Jest wyświetlany komunikat „Nie można wyświetlić lub dodać załączników”.

Jest wyświetlany komunikat „Nie można odświeżyć listy”.

Jest wyświetlany komunikat „W widoku brakuje wymaganych pól”.

Widok lub jego części są dostępne tylko do odczytu.

Nie mogę otworzyć listy w składniku Access Web Datasheet albo lista otwiera się w widoku standardowym.

Może to być spowodowane co najmniej jedną z następujących przyczyn:

  • Komputer nie spełnia wszystkich wymagań programowych umożliwiających wyświetlanie składnika Access Web Datasheet.
    • Nie został zainstalowany składnik arkusza danych zgodny z programem SharePoint Foundation 2010.
    • Używana przeglądarka nie obsługuje formantów ActiveX.
    • Widok arkusza danych nie jest obsługiwany w 64-bitowych instalacjach pakietu Microsoft Office.
    • Obsługa formantów ActiveX jest wyłączona.
  • Jeśli lista lub bieżący widok nie obsługuje widoku arkusza danych, opcja Widok arkusza danych na Wstążce jest wyszarzona. Nie jest na przykład obsługiwane wyświetlanie biblioteki slajdów w widoku arkusza danych.
  • Podczas próby uzyskania dostępu do informacji dotyczących struktury listy lub definicji widoku wystąpił błąd. Spróbuj odświeżyć widok.

Początek strony

Nie widzę żadnych danych w widoku lub widzę tylko ich część.

Jeśli w widoku nie widać żadnych danych, może to być spowodowane tym, że serwer jest zajęty lub nie został znaleziony albo wystąpił inny błąd. Zamknij listę i spróbuj wyświetlić ją później.

Niektóre wiersze lub kolumny mogą być niewidoczne z co najmniej jednego z następujących powodów:

  • Zastosowano filtr lub filtr został określony jako część definicji widoku.

    Aby sprawdzić, czy w widoku zostały zastosowane filtry, zobacz, czy strzałki list rozwijanych w nagłówkach kolumn wyglądają normalnie. Jeśli kolumna jest filtrowana, strzałka listy rozwijanej ma inny kolor. W przypadku niektórych monitorów różnica kolorów może być trudna do zauważenia.

    Aby sprawdzić, czy filtr został określony jako część definicji widoku, na Wstążce w obszarze karty Lista kliknij pozycję Modyfikuj ten widok. Na stronie Edytowanie widoku w sekcji Filtr sprawdź, czy filtr został zastosowany.

  • Kolumna jest ukryta lub nie została uwzględniona w definicji widoku.

    Aby wyświetlić wszystkie ukryte kolumny, kliknij prawym przyciskiem myszy lewą górną komórkę w widoku i kliknij polecenie Odkryj.

    Aby sprawdzić, czy kolumna jest uwzględniona w widoku, na Wstążce w obszarze karty Lista kliknij pozycję Modyfikuj ten widok. Na stronie Edytowanie widoku w sekcji Kolumny sprawdź, czy pole wyboru Wyświetl nie jest zaznaczone. Aby uwzględnić kolumnę w widoku, zaznacz je.

  • Lista wymaga zatwierdzenia zawartości, a niektóre lub wszystkie elementy są nadal oczekujące lub zostały odrzucone.

    Aby sprawdzić stan zatwierdzenia elementów, na liście rozwijanej Widok kliknij opcję Przesłane elementy. Przejrzyj kolumny Stan zatwierdzenia oraz Komentarz. Jeśli element został odrzucony, przeprowadź jego edycję. Element zostanie ustawiony jako oczekujący, a następnie zostanie ponownie przesłany do zatwierdzenia.

Początek strony

Jest wyświetlany komunikat „Lista/Widok nie istnieje”.

Lista lub widok arkusza danych nie istnieje. Możliwe, że dany element został usunięty przez innego użytkownika. Upewnij się, że lista i widok istnieją, a następnie spróbuj ponownie.

Początek strony

Jest wyświetlany komunikat „Nie masz uprawnień”.

Może to być spowodowane co najmniej jedną z następujących przyczyn:

  • Nie masz odpowiednich uprawnień, aby wprowadzić zmianę.
  • Nie możesz dodawać zawartości do strony (blokada).
  • Zostały przekroczone limity miejsca na przechowywanie danych dla tej witryny.
Aby uniknąć tych błędów, skontaktuj się z administratorem systemu.

Początek strony

Jest wyświetlany komunikat „Nie można wyświetlić lub dodać załączników”.

Może to być spowodowane błędem serwera. Spróbuj dodać lub wyświetlić załączniki później.

Początek strony

Jest wyświetlany komunikat „Nie można odświeżyć listy”.

Z powodu błędu serwera nie można odświeżyć widoku. Kliknij przycisk Tak, aby spróbować ponownie. Jeśli błąd wystąpi ponownie, kliknij przycisk Nie i spróbuj ponownie później.

Początek strony

Jest wyświetlany komunikat „W widoku brakuje wymaganych pól”.

W widoku nie ma co najmniej jednej kolumny oznaczonej jako wymagana. W wymaganych kolumnach w wierszu muszą się znajdować wartości niepuste, aby można je było przesłać do serwera.

W związku z tym, że w widoku nie ma co najmniej jednej z wymaganych kolumn, nie będzie można wykonywać następujących czynności:

  • Dodawanie nowych wierszy.
  • Edytowanie wiersza, jeśli w jednej z jego wymaganych kolumn znajduje się pusta wartość.

    Uwaga W kolumnie oznaczonej jako wymagana nie mogą się znajdować wartości puste. Jednak w kolumnie, która nie została oznaczona jako wymagana, ale została później zmieniona w taki sposób, aby wymagać wartości niepustych, mogą się znajdować wartości puste. Jeśli więc zostanie zmienione ustawienie kolumny z Niewymagane na Wymagane, należy przeprowadzić edycję listy w widoku arkusza danych, tak aby w każdym wierszu w kolumnie znalazła się wartość niepusta.

Aby uniknąć pojawiania się tego komunikatu, dodaj wymagane pola do widoku lub skontaktuj się z autorem listy.

Początek strony

Widok lub jego części są dostępne tylko do odczytu.

Może to wynikać z jednej z kilku przyczyn. Aby uzyskać więcej informacji, na pasku stanu kliknij łącze Tylko do odczytu.

Początek strony


Ustawianie widoku arkusza danych jako widoku domyślnego

Gdy jest tworzona nowa lista, domyślnie jest dla niej definiowany nowy widok „standardowy”. Aby zmienić go na widok arkusza danych, na Wstążce w obszarze Narzędzia list należy kliknąć pozycję Lista, a następnie kliknąć pozycję Widok arkusza danych. Aby jednak widok arkusza danych stał się widokiem domyślnym dla listy, należy najpierw utworzyć dla niej nowy widok arkusza danych, a następnie ustawić go jako widok domyślny.

Aby utworzyć dla listy nowy widok arkusza danych i ustawić go jako widok domyślny
  1. Na wstążce kliknij kartę Lista, a następnie kliknij pozycję Utwórz widok.
  2. Na stronie Tworzenie widoku w obszarze Wybierz format widoku kliknij pozycję Widok arkusza danych.
  3. Na stronie Tworzenie widoku arkusza danych wpisz nazwę widoku. W nazwie widoku warto umieścić wyrazy „Arkusz danych”, aby łatwiej było zapamiętać, że jest to widok arkusza danych.
  4. Zaznacz pole wyboru Uczyń ten widok domyślnym.
  5. Upewnij się, że opcja Utwórz widok publiczny jest zaznaczona, aby inni odwiedzający mogli zobaczyć ten widok.
  6. U góry strony kliknij przycisk OK.
Aby ustawić istniejący widok arkusza danych jako widok domyślny
  1. Na wstążce kliknij kartę Lista, a następnie kliknij przycisk Ustawienia listy.
  2. Na stronie Ustawienia listy w obszarze Widoki kliknij nazwę widoku, który chcesz uczynić widokiem domyślnym.
  3. Na stronie Edytowanie widoku w sekcji Nazwa zaznacz pole wyboru Uczyń ten widok domyślnym.

    Uwaga Jeśli widok jest już widokiem domyślnym lub jeśli jest to widok osobisty, pole wyboru będzie niedostępne.


Wyświetlanie, ukrywanie lub zmienianie rozmiarów okienka zadań

  • Aby wyświetlić lub ukryć okienko zadań, na wstążce kliknij kartę Lista, a następnie w grupie Arkusz danych kliknij pozycję Pokaż okienko zadań.
  • Aby zmienić rozmiar okienka zadań, umieść kursor na pasku służącym do modyfikowania okienka (z lewej strony okienka). Gdy kursor zmieni się we wskaźnik zmiany rozmiaru, kliknij i przeciągnij w lewo lub w prawo.


Skróty klawiaturowe

Za pomocą klawiszy skrótów można uzyskać dostęp do często używanych poleceń lub operacji. W poniższych tematach przedstawiono listę klawiszy skrótów dostępnych w składniku Access Web Datasheet. Można także korzystać z klawiszy dostępu, aby przenosić fokus do różnych części widoku bez konieczności używania myszy.

Zaznaczanie części widoku

Wykonywanie poleceń

Edytowanie danych

Formatowanie komórki, w której jest obsługiwany sformatowany tekst HTML

Sortowanie i filtrowanie danych

Zaznaczanie części widoku

Czynność | Skrót klawiaturowy
Przeniesienie zaznaczenia z lewej do prawej, a następnie w dół. Jeśli zaznaczono wiele komórek, przeniesienie fokusu do następnej komórki w ramach zaznaczenia. | TAB
Przeniesienie zaznaczenia z góry na dół, a następnie w prawo. Jeśli zaznaczono wiele komórek, przeniesienie fokusu do następnej komórki w ramach zaznaczenia. | ENTER
Przeniesienie zaznaczenia z prawej do lewej. Jeśli bieżąca komórka jest komórką najbardziej wysuniętą w lewo, naciśnięcie klawiszy SHIFT+TAB spowoduje zaznaczenie ostatniej komórki w poprzednim wierszu. | SHIFT+TAB
Zaznaczenie komórki znajdującej się nad bieżącą komórką. Jeśli bieżąca komórka jest komórką najbardziej wysuniętą w górę, naciśnięcie klawiszy SHIFT+ENTER spowoduje zaznaczenie ostatniej komórki w poprzedniej kolumnie. | SHIFT+ENTER
Przeniesienie zaznaczenia w kierunku wskazywanym przez klawisz strzałki. | Klawisze strzałek
Rozszerzenie lub zmniejszenie zaznaczenia w kierunku wskazywanym przez klawisz strzałki. | SHIFT+klawisz strzałki
Przeniesienie zaznaczenia do ostatniej komórki w kierunku wskazywanym przez klawisz strzałki. Jeśli w obszarze wskazywanym przez ten klawisz istnieją puste komórki, przeniesienie do ostatniej komórki poprzedzającej pierwszą pustą komórkę. | CTRL+klawisz strzałki
Rozszerzenie zaznaczenia do ostatniej komórki w kierunku wskazywanym przez klawisz strzałki. Jeśli w obszarze wskazywanym przez ten klawisz istnieją puste komórki, rozszerzenie zaznaczenia do ostatniej komórki poprzedzającej pierwszą pustą komórkę. | CTRL+SHIFT+klawisz strzałki
Zaznaczenie pierwszej komórki w bieżącym wierszu. | Home
Zaznaczenie pierwszej komórki w pierwszym wierszu. | CTRL+Home
Zaznaczenie ostatniej komórki w ostatnim wierszu. | CTRL+End
Rozszerzenie zaznaczenia do początku bieżącego wiersza. | SHIFT+Home
Rozszerzenie zaznaczenia do końca bieżącego wiersza. | SHIFT+End
Rozszerzenie zaznaczenia do początku listy. | CTRL+SHIFT+Home
Rozszerzenie zaznaczenia do końca listy. | CTRL+SHIFT+End
Rozszerzenie zaznaczenia na całą kolumnę. Jeśli zaznaczono tekst w komórce, a w kolumnie jest obsługiwany sformatowany tekst HTML, usunięcie formatowania. | CTRL+SPACJA
Rozszerzenie zaznaczenia na cały wiersz. | SHIFT+SPACJA
Zaznaczenie całej listy. | CTRL+A
Przewinięcie do następnej strony listy. | PAGE DOWN
Wyświetlenie poprzedniej strony listy. | PAGE UP
Rozszerzenie zaznaczenia o jedną stronę w dół. | SHIFT+PAGE DOWN
Rozszerzenie zaznaczenia o jedną stronę w górę. | SHIFT+PAGE UP
Przewinięcie w celu wyświetlenia bieżącej komórki. | CTRL+Backspace

Początek strony

Wykonywanie poleceń

Czynność | Skrót klawiaturowy
Wyświetlenie menu skrótów dla bieżącego zaznaczenia. | SHIFT+F10
Wykonanie polecenia z menu skrótów zawierającego podkreśloną literę. | Podkreślona litera w menu skrótów
Anulowanie zmian w wierszach, które nie zostały jeszcze zatwierdzone. Jeśli menu skrótów jest widoczne, zamknięcie menu skrótów bez wykonania polecenia. W trybie edycji anulowanie trybu edycji i odrzucenie zmian. | ESC
Jeśli widok arkusza danych jest w fokusie, a nie w trybie edycji, wyświetlenie Pomocy widoku arkusza danych. W innym przypadku — wyświetlenie Pomocy programu Internet Explorer. | F1
Przejście do trybu edycji. | F2
Wyczyszczenie bieżącej komórki. | Delete
Wyświetlenie okienka zadań. | F8
Ukrycie okienka zadań. | SHIFT+F8
Skopiowanie zaznaczenia do Schowka. | CTRL+C
Wklejenie zawartości Schowka. | CTRL+V
Przeniesienie zaznaczenia do Schowka. | CTRL+X
Wyświetlenie okna dialogowego Rozwiązywanie konfliktów i poprawianie błędów. | F7
Zamknięcie okna przeglądarki. | ALT+F4

Początek strony

Edytowanie danych

Czynność | Skrót klawiaturowy
Anulowanie zmian wprowadzonych w bieżącej komórce. | CTRL+Z
Wstawienie myślnika nierozdzielającego. | CTRL+SHIFT+-
Wyświetlenie w wierszu Suma listy funkcji agregujących dostępnych w bieżącej komórce. W kolumnach typu „jeden wiersz tekstu” wyświetlenie listy istniejących wartości w kolumnie. | ALT+Down

Początek strony

Formatowanie komórki, w której jest obsługiwany sformatowany tekst HTML

Czynność | Skrót klawiaturowy
Przeniesienie fokusu do listy Czcionka. | CTRL+SHIFT+F
Przeniesienie fokusu do listy Rozmiar czcionki. | CTRL+SHIFT+P
Zastosowanie w zaznaczeniu stylu Pogrubienie. | CTRL+B
Podkreślenie zaznaczenia. | CTRL+U
Zastosowanie w zaznaczeniu stylu Kursywa. | CTRL+I
Wyjustowanie zaznaczenia do lewej. | CTRL+L
Wyśrodkowanie zaznaczenia. | CTRL+E
Wyjustowanie zaznaczenia do prawej. | CTRL+R
Dodanie punktorów do zaznaczenia. | CTRL+SHIFT+L
Zwiększenie wcięcia. | CTRL+M
Zmniejszenie wcięcia. | CTRL+SHIFT+M
Usunięcie sformatowanego tekstu HTML z bieżącej komórki. | CTRL+SPACJA

Początek strony

Sortowanie i filtrowanie danych

Czynność | Skrót klawiaturowy
Wyświetlenie listy rozwijanej filtrów dla wybranej kolumny. | ALT+SHIFT+DOWN
Zamknięcie listy rozwijanej filtrów. | ALT+SHIFT+UP
Przejście do poprzedniego elementu na liście rozwijanej filtrów, gdy ta lista jest wyświetlana. | UP
Przejście do następnego elementu na liście rozwijanej filtrów, gdy ta lista jest wyświetlana. | DOWN
Przejście do pierwszego elementu na liście rozwijanej filtrów, gdy ta lista jest wyświetlana. | HOME
Przejście do ostatniego elementu na liście rozwijanej filtrów, gdy ta lista jest wyświetlana. | END
Przejście o jedną stronę w górę lub w dół na liście rozwijanej filtrów, gdy ta lista jest wyświetlana. | Page Up, Page Down
Wykonanie zaznaczonego elementu z listy rozwijanej filtrów, gdy ta lista jest wyświetlana. | ENTER

Początek strony


Jak są pobierane i aktualizowane dane w składniku Access Web Datasheet?

Edytowanie danych w składniku Access Web Datasheet można przeprowadzić o wiele szybciej niż w widoku Standardowy.

W widoku Standardowy można edytować tylko jeden element naraz. Po przeprowadzeniu edycji elementu należy zatwierdzić zmiany na serwerze, aby można było rozpocząć edytowanie następnego elementu.

W składniku Access Web Datasheet można wprowadzić zmiany w wierszu, a następnie przejść do następnego wiersza i rozpocząć edytowanie zawartych w nim komórek. W tym widoku wysyłanie zmian do serwera oraz informacji o stanie z powrotem do użytkownika odbywa się automatycznie i nie wymaga przerywania pracy.

Aktualizacje asynchroniczne

Asynchroniczne pobieranie danych

Aktualizacje asynchroniczne

Podczas dodawania lub edytowania wiersza zmiana jest wysyłana przez składnik Access Web Datasheet do serwera. Następnie wiersz jest oznaczany jako oczekujący, a w nagłówku wiersza jest wyświetlana ikona oczekiwania ( Ikona oczekiwania ). Gdy wiersz zawiera oczekujące zmiany, nie można go edytować, dopóki nie zostaną one zatwierdzone. Można jednak kontynuować edytowanie innych wierszy podczas wysyłania ostatniego zestawu zmian do serwera.

Gdy serwer prześle odpowiedź, wiersz w widoku jest odpowiednio aktualizowany. Jeśli edycja powoduje konflikt lub błąd, w nagłówku wiersza jest wyświetlana ikona konfliktu ( Ikona konfliktu ) lub ikona błędu ( Ikona błędu ). Jeśli edycja została zatwierdzona, ikona oczekiwania znika i można rozpocząć edycję wiersza.

Zmiany w definicji widoku, takie jak zmiana kolejności kolumn lub ukrywanie wiersza Suma, są także wysyłane do serwera asynchronicznie. Nie można jednak wprowadzać zmian strukturalnych ani edytować kolumny obliczeniowej, jeśli nie ma zmian oczekujących. Aby zmienić strukturę lub edytować kolumnę obliczeniową, należy zaczekać na zatwierdzenie wszystkich zmian, a następnie rozwiązać zaistniałe konflikty i usunąć wszelkie błędy.

Przy próbie odświeżenia lub usunięcia widoku w sytuacji, gdy istnieją zmiany oczekujące, zostanie wyświetlony monit o zaczekanie do czasu zatwierdzenia wszystkich zmian. W zależności od odpowiedzi serwera będzie można wówczas rozwiązać wszelkie konflikty i usunąć błędy.

Początek strony

Asynchroniczne pobieranie danych

Podczas otwierania listy składnik Access Web Datasheet pobiera pierwsze 100 wierszy. Reszta jest pobierana asynchronicznie. Gdy dane są nadal pobierane z serwera, na pasku stanu jest wyświetlany komunikat Pobieranie danych. W razie próby filtrowania lub sortowania danych należy zaczekać na wynik, aż pobieranie wszystkich niezbędnych danych z serwera do listy zostanie zakończone.

Jeśli serwer jest zajęty, nie można go znaleźć lub gdy wystąpi inny błąd, nie można pobrać odpowiednich wierszy w widoku. Zostanie wyświetlony komunikat o błędzie.

Początek strony


Zaznaczanie komórki, wiersza, kolumny lub listy

Zaznaczanie pojedynczej komórki

  • Kliknij komórkę lub przejdź do niej, naciskając klawisze strzałek.

    Uwaga Po kliknięciu komórki zawierającej hiperłącze nastąpi przeniesienie do odpowiedniego adresu internetowego. Aby zaznaczyć komórkę zawierającą hiperłącze, należy użyć jednego ze skrótów klawiaturowych.

Zaznaczanie zawartości komórki

  • Zaznacz komórkę, kliknij wewnątrz tej komórki, a następnie zaznacz zawarty w niej tekst.

Zaznaczanie zakresu komórek

  • Kliknij pierwszą komórkę z zakresu, a następnie przeciągnij do ostatniej komórki. Możesz także kliknąć pierwszą komórkę z zakresu, nacisnąć i przytrzymać klawisz SHIFT, a następnie kliknąć ostatnią komórkę z zakresu.

Uwaga Do wyświetlenia ostatniej komórki może być przydatna funkcja przewijania.

Zaznaczanie wiersza lub kolumny

  • Kliknij wiersz lub nagłówek kolumny.

Zaznaczanie wielu wierszy lub kolumn

  • Kliknij pierwszy wiersz lub nagłówek kolumny, a następnie przeciągnij do ostatniego wiersza lub kolumny. Możesz także zaznaczyć pierwszy wiersz lub kolumnę, nacisnąć i przytrzymać klawisz SHIIFT, a następnie zaznaczyć ostatni wiersz lub kolumnę.


Dodawanie kolumny wyboru z wieloma wartościami

Korzystając z listy kolumny wyboru z wieloma wartościami, z listy opcji wyboru można wybrać kilka elementów jednocześnie. Na przykład na liście śledzenia zadań do każdego zadania można przypisać więcej niż jedną osobę. Opcje wyboru, które mają być dostępne, należy wprowadzić podczas dodawania kolumny do listy.

Dodawanie kolumny wyboru z wieloma wartościami

  1. Kliknij prawym przyciskiem myszy dowolny nagłówek kolumny lub dowolną komórkę na liście, a następnie kliknij polecenie Dodaj kolumnę.
  2. W obszarze Nazwa i typ wprowadź nazwę kolumny, a następnie kliknij opcję Wybór.
  3. W obszarze Dodatkowe ustawienia kolumny wpisz opcje wyboru, które mają być dostępne w kolumnie, a następnie kliknij opcję Pola wyboru (zezwala na wiele zaznaczeń).
  4. W razie potrzeby ustaw jeszcze inne opcje, a następnie kliknij przycisk OK.

Aby skorzystać z kolumny wyboru z wieloma wartościami podczas wyświetlania arkusza danych, należy kliknąć strzałkę listy rozwijanej w komórce, a następnie zaznaczyć lub wyczyścić pole wyboru obok każdej wartości, która ma zostać dodana do komórki lub z niej usunięta.

Edytowanie listy opcji wyboru w kolumnie wyboru z wieloma wartościami

Aby dodać, poddać edycji lub usunąć elementy z kolumny wyboru z wieloma wartościami, należy wykonać następującą procedurę:

  1. Kliknij prawym przyciskiem myszy dowolny nagłówek kolumny lub dowolną komórkę kolumny, którą chcesz edytować, a następnie kliknij polecenie Edytuj/Usuń kolumnę.
  2. W obszarze Dodatkowe ustawienia kolumny przeprowadź edycję listy opcji wyboru.
  3. W razie potrzeby ustaw jeszcze inne opcje, a następnie kliknij przycisk OK.

Korzystanie z kolumny wyboru z wieloma wartościami

Aby skorzystać z kolumny wyboru z wieloma wartościami, należy wykonać następującą procedurę:

  1. W komórce, którą chcesz edytować, kliknij strzałkę listy rozwijanej.
  2. Zaznacz lub wyczyść pole wyboru obok każdego elementu, który chcesz dodać do komórki lub z niej usunąć.
  3. Kliknij przycisk OK.

Wybrane opcje wyboru zostaną wyświetlone w komórce oddzielone średnikami (;).


Dodawanie kolumny odnośnika z wieloma wartościami

Korzystając z kolumny odnośnika z wieloma wartościami, z listy opcji wyboru można wybrać więcej niż jeden element jednocześnie. Na przykład na liście śledzenia zadań do każdego zadania można przypisać więcej niż jedną osobę. Wartości wyświetlane w kolumnie odnośnika pochodzą z istniejącej kolumny bieżącej listy lub z istniejącej kolumny innej listy.

Dodawanie kolumny odnośnika z wieloma wartościami

  1. Kliknij prawym przyciskiem myszy dowolny nagłówek kolumny lub dowolną komórkę na liście, a następnie kliknij polecenie Dodaj kolumnę.
  2. W obszarze Nazwa i typ wprowadź nazwę kolumny, a następnie kliknij opcję Odnośnik (informacje znajdujące się już w tej witrynie).
  3. W obszarze Dodatkowe ustawienia kolumny z listy rozwijanej Pobierz informacje z wybierz listę zawierającą wartości, które mają się znaleźć w kolumnie odnośnika.
  4. Z listy rozwijanej W tej kolumnie wybierz kolumnę, która zawiera odpowiednie wartości.
  5. Zaznacz opcję Zezwalaj na wiele wartości.
  6. W razie potrzeby ustaw jeszcze inne opcje, a następnie kliknij przycisk OK.

Aby skorzystać z kolumny odnośnika z wieloma wartościami podczas wyświetlania arkusza danych, należy kliknąć strzałkę listy rozwijanej w komórce, a następnie zaznaczyć lub wyczyścić pole wyboru obok każdej wartości, która ma zostać dodana do komórki lub z niej usunięta.

Edytowanie listy opcji wyboru w kolumnie odnośnika z wieloma wartościami

Ponieważ elementy kolumny odnośnika z wieloma wartościami pochodzą z innej kolumny bieżącej listy lub z kolumny innej listy, należy edytować listę, z której korzysta kolumna odnośnika. Jeśli na przykład kolumna odnośnika korzysta z kolumny Tytuł pochodzącej z listy Zadania, to aby zmienić wartości w tej kolumnie odnośnika, należy przeprowadzić edycję listy Zadania.

Korzystanie z kolumny odnośnika z wieloma wartościami

Aby skorzystać z kolumny odnośnika z wieloma wartościami, należy wykonać następującą procedurę:

  1. W komórce, którą chcesz edytować, kliknij strzałkę listy rozwijanej.
  2. Zaznacz lub wyczyść pole wyboru obok każdego elementu, który chcesz dodać do komórki lub z niej usunąć.
  3. Kliknij przycisk OK.

Wybrane opcje wyboru zostaną wyświetlone w komórce oddzielone średnikami (;).


Dodawanie wiersza lub kolumny

Dodawanie wiersza

Domyślnie wiersz z gwiazdką (*) — pusty wiersz oznaczony symbolem gwiazdki (*) w nagłówku wiersza — jest wyświetlany po ostatnim wierszu listy. Przy użyciu tego wiersza można dodawać nowy element do listy.

Uwaga Nie można wstawiać pustego wiersza między dwoma istniejącymi wierszami. Jeśli widok jest tylko do odczytu, wiersz oznaczony gwiazdką nie jest wyświetlany.

Aby dodać wiersz, należy wykonać dowolny z następujących kroków:

  • Jeśli pusty wiersz nie jest widoczny, kliknij prawym przyciskiem myszy dowolną komórkę, a następnie kliknij polecenie Dodaj wiersz. — lub —
  • Na wstążce kliknij kartę Lista, a następnie w grupie Arkusz danych kliknij pozycję Nowy wiersz.

Dodawanie kolumny

  1. Kliknij prawym przyciskiem myszy komórkę na liście.
  2. Kliknij polecenie Dodaj kolumnę.
  3. Na stronie Utwórz kolumnę określ szczegóły dotyczące kolumny, a następnie kliknij przycisk OK.

    Nowa kolumna jest dodawana po prawej stronie istniejących kolumn. Aby przenieść ją w nowe miejsce, należy przeciągnąć jej nagłówek do odpowiedniej lokalizacji.


Zmienianie szerokości kolumn

  1. Kliknij prawym przyciskiem myszy nagłówek kolumny, a następnie kliknij polecenie Szerokość kolumny.
  2. W oknie dialogowym Szerokość kolumny wpisz liczbę od 1 do 255.

Uwagi

  • Wpisanie wartości 0 jako szerokości spowoduje ukrycie kolumny.
  • Możesz także przeciągać krawędź po prawej stronie nagłówka kolumny do momentu uzyskania odpowiedniej szerokości. Aby ustawić odpowiedni rozmiar kolumny, tj. by zawartość poszczególnych komórek mieściła się w jednym wierszu, przesuń kursor w stronę prawej krawędzi nagłówka kolumny. Gdy pojawi się kursor zmiany rozmiaru, kliknij dwukrotnie linię krawędzi.


Zmienianie wysokości wiersza

  1. Kliknij prawym przyciskiem myszy nagłówek wiersza i kliknij polecenie Wysokość wiersza.
  2. W oknie dialogowym Wysokość wiersza wpisz liczbę od 1 do 409.

Uwagi

  • Zmiana wysokości jednego wiersza powoduje zmianę wysokości wszystkich wierszy listy.
  • Możesz także przeciągać górną lub dolną krawędź nagłówka wiersza do momentu uzyskania odpowiedniej wysokości. Aby ustawić rozmiar wiersza tak, by jego zawartość była całkowicie widoczna, przesuń kursor do dolnej krawędzi nagłówka wiersza. Gdy pojawi się kursor zmiany rozmiaru, kliknij dwukrotnie linię krawędzi.


Usuwanie wiersza lub kolumny

Usuwanie wiersza

  1. Kliknij nagłówek wiersza, który ma zostać usunięty.

    Uwaga Aby usunąć wiele wierszy, kliknij nagłówek pierwszego wiersza i przeciągnij go do ostatniego wiersza. Możesz także zaznaczyć pierwszy wiersz, a następnie przytrzymując naciśnięty klawisz SHIFT, zaznaczyć ostatni wiersz.

  2. Kliknij prawym przyciskiem myszy zaznaczenie i kliknij polecenie Usuń wiersze.

Usuwane wiersze są umieszczane w Koszu witryny i w razie potrzeby można je przywrócić na liście. Więcej informacji o korzystaniu z Kosza można znaleźć w Pomocy programu Microsoft SharePoint Foundation 2010, dostępnej po kliknięciu przycisku Pomoc ( Ikona Pomocy ).

Usuwanie kolumny

  1. Kliknij prawym przyciskiem myszy nagłówek kolumny, która ma zostać usunięta, a następnie kliknij polecenie Edytuj/Usuń kolumnę.
  2. Na stronie Zmiana kolumny kliknij przycisk Usuń.

Uwagi

  • Usuwane kolumny nie są umieszczane w Koszu witryny. Są trwale usuwane.
  • Kolumny można usuwać tylko pojedynczo. Jeśli zostaną zaznaczone komórki w wielu kolumnach, to jako zaznaczona będzie traktowana ta kolumna, w której znajduje się aktywna komórka.
  • Jeśli kolumna jest tylko do odczytu, nie można jej usunąć. Nie można także usunąć niektórych kolumn z list określonych typów, ponieważ kolumny te są niezbędne do właściwego funkcjonowania tych list.


Modyfikowanie kolumny

Można zmieniać nazwę kolumny, opis i typ danych lub ustawienia dotyczące typu danych w tej kolumnie.

  1. Kliknij prawym przyciskiem myszy komórkę w kolumnie, którą chcesz zmodyfikować, a następnie kliknij polecenie Edytuj/Usuń kolumnę.
  2. Na stronie Zmień kolumnę wprowadź zmiany i kliknij przycisk OK.

Uwagi

  • Kolumny można modyfikować tylko pojedynczo. Jeśli zostaną zaznaczone komórki w wielu kolumnach, jako zaznaczona będzie traktowana ta kolumna, w której znajduje się aktywna komórka.
  • Jeśli kolumna jest tylko do odczytu, nie można jej zmodyfikować.


Zmienianie kolejności kolumn

W widoku arkusza danych można szybko i łatwo zmieniać kolejność kolumn.

  1. Aby przenieść kolumnę, umieść wskaźnik myszy na nagłówku kolumny i zaczekaj, aż pojawi się wskaźnik przenoszenia ( Wskaźnik przenoszenia ).

    Aby przenieść kilka kolumn, kliknij nagłówek pierwszej kolumny, a następnie naciśnij klawisz SHIFT i trzymając naciśnięty klawisz SHIFT, kliknij ostatnią kolumnę z zakresu. Umieść wskaźnik po jednej ze stron prostokąta pokrywającego wybrane kolumny, aby wyświetlić wskaźnik przenoszenia.

  2. Kliknij i przeciągnij zaznaczone kolumny w nowe miejsce.

Podczas przenoszenia kolumny definicja widoku jest aktualizowana automatycznie.

Uwaga Nie można przenosić wierszy. Można zmieniać ich kolejność przez sortowanie.


Wyświetlanie lub ukrywanie kolumny

Wyświetlanie ukrytej kolumny

Grubsza linia pionowa z prawej strony nagłówka kolumny oznacza, że kolumna znajdująca się obok jest ukryta.

  • Aby odkryć kolumnę, zaznacz kolumny widoczne z obu stron kolumny ukrytej, kliknij prawym przyciskiem myszy zaznaczenie i kliknij polecenie Odkryj.
  • Aby odkryć wszystkie ukryte kolumny na liście, kliknij prawym przyciskiem myszy lewy górny róg listy i kliknij polecenie Odkryj.

Ukrywanie kolumny

  • Aby ukryć kolumnę, kliknij jej nagłówek prawym przyciskiem myszy i kliknij polecenie Ukryj.


Wyświetlanie poprzednich pozycji w kolumnie z wieloma wierszami tekstu

Kolumnę typu Wiele wierszy tekstu można tak skonfigurować, aby podczas edytowania w niej danych poprzednie pozycje były zachowywane, a nie zastępowane. Dzięki tej funkcji można zachować informacje o poprzednich pozycjach w kolumnie, dacie wprowadzenia zmian oraz osobie, która je wprowadziła.

Tworzenie nowej kolumny, którą można tylko dołączać

  1. Kliknij prawym przyciskiem myszy dowolną komórkę na liście i kliknij polecenie Dodaj kolumnę.
  2. Wpisz nazwę kolumny w polu Nazwa kolumny, a następnie kliknij opcję Wiele wierszy tekstu.
  3. W obszarze Dodatkowe ustawienia kolumny w obszarze Dołącz zmiany do istniejącego tekstu kliknij opcję Tak.
  4. Wprowadź inne wymagane zmiany, a następnie kliknij przycisk OK.

    Nowa kolumna jest dodawana po prawej stronie istniejących kolumn. Aby przenieść ją w nowe miejsce, należy przeciągnąć jej nagłówek do odpowiedniej lokalizacji.

Modyfikowanie istniejącej kolumny, aby była kolumną, którą można tylko dołączać

  1. Kliknij prawym przyciskiem myszy nagłówek kolumny, którą chcesz zmodyfikować, a następnie kliknij polecenie Edytuj/Usuń kolumnę.
  2. Jeśli kolumna nie obsługuje jeszcze typu danych Wiele wierszy tekstu, kliknij opcję Wiele wierszy tekstu. Jeśli ta opcja nie jest dostępna, nie można zmodyfikować typu danych tej kolumny. Aby skorzystać z opcji Dołącz zmiany, należy utworzyć nową kolumnę.
  3. W obszarze Dodatkowe ustawienia kolumny w obszarze Dołącz zmiany do istniejącego tekstu kliknij opcję Tak.
  4. Wprowadź inne wymagane zmiany, a następnie kliknij przycisk OK.

Wyświetlanie poprzednich pozycji w kolumnie, którą można tylko dołączać

W przypadku komórki arkusza składnika Access Web Datasheet w kolumnach, które można tylko dołączać, jest wyświetlana tylko najnowsza pozycja. Aby wyświetlić poprzednie pozycje, należy wykonać następujące czynności:

  • Kliknij prawym przyciskiem myszy komórkę, której poprzednie pozycje chcesz wyświetlić, a następnie kliknij polecenie Wyświetl pozycje.

    W programie Microsoft SharePoint Foundation 2010 są wyświetlane wszystkie dane związane z tym elementem, w tym wszystkie poprzednie pozycje kolumny, którą można tylko dołączać.


Typy danych — informacje

Aby uzyskać pomoc dotyczącą typów danych, zobacz Pomoc programu Microsoft SharePoint Foundation 2010.

Aby wyświetlić Pomoc programu Microsoft SharePoint Foundation 2010, na stronie programu SharePoint kliknij przycisk Pomoc ( Ikona Pomocy).


Określanie wartości domyślnej kolumny

Wartość domyślną można określić dla kolumn typu jeden wiersz, opcja, liczba, waluta lub data i godzina. Wartość domyślna będzie wyświetlana automatycznie w kolumnie we wszystkich nowych wierszach. Wartość domyślną można pozostawić w komórce lub edytować w dowolnej chwili.

  1. Kliknij prawym przyciskiem myszy kolumnę, a następnie kliknij polecenie Edytuj/Usuń kolumnę.
  2. W obszarze Wartość domyślna wybierz jedną z następujących wartości:
    • Tekst Jeśli typem kolumny jest Pojedynczy wiersz tekstu, jako wartość domyślną zdefiniuj ciąg.
    • Opcja Jeśli typem kolumny jest Opcja, określ jedną z opcji z listy opcji zdefiniowanej powyżej.
    • Liczba Jeśli typem kolumny jest Liczba, określ wartość numeryczną.
    • Waluta Jeśli typem kolumny jest Waluta, określ wartość walutową.
    • Bieżąca data Jeśli typem kolumny jest Data i godzina i chcesz, aby wartością domyślną była bieżąca data, wybierz tę opcję.
    • Dowolna data Jeśli typem kolumny jest Data i godzina i chcesz określić odpowiednią datę, wybierz ostatni przycisk opcji i wprowadź datę w formacie RRRR-MM-DD.
    • Opcja Tak w polu Wartość domyślna Jeśli typem kolumny jest Tak/Nie (pole wyboru) i chcesz, aby pole wyboru było domyślnie zaznaczone, wybierz opcję Tak.
    • Obliczeniowy Jeśli jako wartości domyślnej chcesz używać wartości obliczeniowej, wprowadź formułę. Zwróć uwagę, że formuła nie może odwoływać się do innych kolumn z listy.


Rozwiązywanie problemów z typami danych

Pomoc dotyczącą rozwiązywania problemów związanych z typami danych można znaleźć w Pomocy programu Microsoft SharePoint Foundation 2010.

Aby wyświetlić Pomoc programu Microsoft SharePoint Foundation 2010, kliknij przycisk Pomoc ( Ikona Pomocy).


Dodawanie, edytowanie i usuwanie zawartości komórek

Wprowadzanie zmian kolejno w poszczególnych komórkach

W trybie edycji można dodawać, edytować i usuwać zawartość komórek.

  1. Jeśli komórka przeznaczona do edycji nie jest zaznaczona, kliknij ją.

    Uwaga Jeśli komórka zawiera hiperłącze, nastąpi przeniesienie do odpowiedniego adresu internetowego.

  2. Ponownie kliknij komórkę, aby przejść do trybu edycji, a następnie wprowadź zmiany w komórce.

    Uwaga Do trybu edycji można także przejść, naciskając klawisz F2.

  3. Po zakończeniu naciśnij klawisz TAB lub ENTER.

Uwaga Naciśnij klawisze CTRL+Z, aby cofnąć ostatnią zmianę wprowadzoną w komórce. Naciśnij klawisz ESC, aby odrzucić zmiany wprowadzone w komórce i wyjść z trybu edycji.

Zbiorcza edycja komórek

Zbiorczej edycji komórek, wierszy lub kolumn można dokonać, korzystając z jednego z następujących sposobów:

  • Kopiowanie i wklejanie danych.
  • Przeciąganie uchwytu wypełniania.


Edytowanie hiperłącza

To polecenie jest dostępne tylko wtedy, gdy w zaznaczonej komórce znajduje się hiperłącze.

  1. Kliknij prawym przyciskiem myszy komórkę, w której znajduje się hiperłącze, wskaż polecenie Hiperłącze, a następnie kliknij polecenie Edytuj hiperłącze.
  2. W oknie dialogowym Edytowanie hiperłącza wpisz prawidłowy adres URL w polu tekstowym Wpisz adres sieci Web. Prawidłowe adresy URL muszą rozpoczynać się od nazwy protokołu, takiej jak „http://” lub „ftp:”, i nie mogą przekraczać 255 znaków.
  3. W polu tekstowym Wpisz opis wpisz tekst, który ma być wyświetlany.


Wprowadzanie danych w komórce przez wybranie tych danych z listy wartości

Podczas wprowadzania danych w kolumnie komórek z pojedynczym wierszem tekstu można wybrać wartość dla komórki na dwa sposoby.

  • Kliknij komórkę, w której chcesz wprowadzić dane. Jeśli z boku pojawi się strzałka w dół, kliknij ją, a następnie kliknij wartość, którą chcesz wybrać dla komórki.

    Wybieranie z listy

  • Zacznij wpisywać dane w komórce. Dane wprowadzone w innym miejscu w kolumnie będą dopasowywane do wpisywanej wartości i w komórce pojawi się najbardziej zgodny element. Gdy pojawi się poprawna wartość, naciśnij klawisz Enter, aby ją wybrać.

    Wpisywanie z listy


Uzyskiwanie powiadomienia o zmodyfikowaniu zawartości listy

Pokaż Otrzymywanie powiadomienia o zmianach jednego z następujących elementów: wiersza, dokumentu lub komórki

  1. Kliknij prawym przyciskiem myszy nagłówek wiersza lub komórkę, dla której chcesz włączyć funkcję powiadamiania, i kliknij polecenie Prześlij mi alert.
  2. Na stronie Nowy alert określ, jak i kiedy chcesz otrzymywać powiadomienie.

Pokaż Otrzymywanie powiadomienia o zmianach na liście lub w bibliotece dokumentów

  1. Kliknij prawym przyciskiem myszy lewy górny róg listy lub biblioteki i kliknij polecenie Prześlij mi alert.
  2. Na stronie Nowy alert określ, jak i kiedy chcesz otrzymywać powiadomienie.


Cofanie zmian

Zmiany, które nie zostały jeszcze zapisane na liście, można cofnąć. W trybie edycji można cofnąć zmiany wprowadzone w bieżącej komórce.

  • Na pasku narzędzi okienka zadań kliknij przycisk Cofnij lub naciśnij klawisze CTRL+Z.

Uwagi

  • W przypadku komórek, w których jest obsługiwany tekst sformatowany HTML, każde polecenie formatowania jest traktowane jako edycja.
  • Polecenie Cofnij działa inaczej niż wyłączenie trybu edycji przez naciśnięcie klawisza Esc.
  • Po dodaniu załącznika do rekordu lub usunięciu załącznika z rekordu nie można cofnąć zmian wprowadzonych na liście. Po zapisaniu wiersza nie można cofnąć wprowadzonych w nim zmian.


Sprawdzanie poprawności danych

Pomoc dotyczącą sprawdzania poprawności danych można znaleźć w Pomocy programu Microsoft SharePoint Foundation 2010.

Aby wyświetlić Pomoc programu SharePoint Foundation 2010, kliknij przycisk Pomoc ( Ikona Pomocy).


Formatowanie danych

Sformatować można zawartość kolumny, w której jest obsługiwany format wielu wierszy tekstu oraz tekst sformatowany.

Aby włączyć obsługę tekstu sformatowanego w kolumnie

  1. Kliknij prawym przyciskiem myszy kolumnę, którą chcesz włączyć dla tekstu sformatowanego, a następnie kliknij polecenie Edytuj/Usuń kolumnę.
  2. W obszarze Nazwa i typ zaznacz opcję Wiele wierszy tekstu, jeśli nie została jeszcze zaznaczona.
  3. W obszarze Dodatkowe ustawienia kolumny wybierz opcję Tekst sformatowany (pogrubienie, kursywa, wyrównanie tekstu).
  4. Kliknij przycisk OK.

Po dostosowaniu tych ustawień można formatować tekst w jednej lub większej liczbie komórek albo tylko fragment tekstu w komórce:

  1. Zaznacz komórki lub tekst, który chcesz sformatować.
  2. Jeśli okienko zadań nie jest otwarte, kliknij na wstążce kartę Lista, a następnie kliknij pozycję Pokaż okienko zadań.
  3. Zastosuj wybrany format. Możesz zmieniać ustawienia czcionki, kolor tekstu i tła oraz wcięcia i wyrównanie. Możesz także zorganizować tekst w postaci listy numerowanej lub punktowanej.

Uwagi

  • Tekst sformatowany można wyczyścić, zaznaczając go, a następnie naciskając klawisze CTRL+Spacja. Naciśnięcie klawiszy CTRL+Spacja nie powoduje jednak usunięcia ustawień wyrównania.
  • Nie można sformatować komórek tylko do odczytu ani wiersza Suma.
  • Formatowanie nie dotyczy wierszy ukrytych w wyniku filtrowania.


Włączanie lub wyłączanie funkcji zawijania tekstu w kolumnie

Jeśli w danej kolumnie jest włączona funkcja zawijania tekstu, zawartość komórki w kolumnie będzie wyświetlana w kilku wierszach. Jeśli funkcja zawijania tekstu jest wyłączona, w poszczególnych komórkach będzie widoczny tylko tekst mieszczący się w jednym wierszu. Funkcja zawijania tekstu jest domyślnie włączona we wszystkich kolumnach.

Funkcja zawijania tekstu jest obsługiwana przez następujące typy danych: pojedynczy wiersz tekstu, wiele wierszy tekstu, wybór, osoba lub grupa, hiperłącze lub obraz i obliczeniowy.

  • Kliknij prawym przyciskiem myszy nagłówek kolumny, którego ustawienia chcesz zmienić, i kliknij polecenie Wyłącz zawijanie tekstu lub Włącz zawijanie tekstu.


Rozwiązywanie problemów z formatowaniem danych

W okienku zadań nie ma przycisków formatowania.

Formatowanie nie jest stosowane we wszystkich wierszach kolumny.

Tekst został skopiowany do kolumny typu „wiele wierszy tekstu”, ale nie został sformatowany.

Jest wyświetlany komunikat, że rozmiar komórki przekracza rozmiar maksymalny.

W okienku zadań nie ma przycisków formatowania.

Aby włączyć formatowanie tekstu, w kolumnie musi być obsługiwanych wiele wierszy tekstu oraz tekst sformatowany.

Aby włączyć obsługę tekstu sformatowanego w kolumnie

  1. Kliknij prawym przyciskiem myszy kolumnę, którą chcesz włączyć dla tekstu sformatowanego, a następnie kliknij polecenie Edytuj/Usuń kolumnę.
  2. Na stronie Zmień kolumnę w sekcji Nazwa i typ wybierz pozycję Wiele wierszy tekstu, jeśli nie została jeszcze określona jako typ kolumny.
  3. W sekcji Dodatkowe ustawienia kolumny wybierz opcję Tekst sformatowany (pogrubienie, kursywa, wyrównanie tekstu).
  4. Kliknij przycisk OK.

Po dostosowaniu tych ustawień można formatować tekst w jednej lub większej liczbie komórek albo tylko fragment tekstu w komórce:

  1. Na wstążce kliknij kartę Lista, a następnie w grupie Arkusz danych kliknij pozycję Pokaż okienko zadań.
  2. Zaznacz komórki lub tekst, który chcesz sformatować.
  3. Zastosuj odpowiedni format przy użyciu narzędzi tekstu sformatowanego dostępnych w okienku zadań. Możesz zmienić ustawienia czcionki, kolor tekstu i tła oraz wcięcia i wyrównanie. Możesz także zorganizować tekst w postaci listy numerowanej lub punktowanej.

Początek strony

Formatowanie nie jest stosowane we wszystkich wierszach kolumny.

Jeśli zostanie zaznaczona cała kolumna i zostanie zastosowane formatowanie, wiersz Suma i wiersze ukryte na skutek filtrowania nie zostaną sformatowane.

Początek strony

Tekst został skopiowany do kolumny typu „wiele wierszy tekstu”, ale nie został sformatowany.

Być może formatowanie tekstu źródłowego nie jest w pełni rozpoznawane na liście. Upewnij się, że w tekście źródłowym nie zostały zastosowane formaty, które nie są obsługiwane na liście.

Aby zobaczyć, jakie formaty są obsługiwane, w kolumnie, w której jest obsługiwany tekst sformatowany, zaznacz odpowiednią komórkę i przeglądaj przyciski pod paskiem narzędzi w okienku zadań.

Początek strony

Jest wyświetlany komunikat, że rozmiar komórki przekracza rozmiar maksymalny.

W sformatowanej komórce znajduje się tekst i informacje dotyczące formatowania. Jeśli dane i informacje o formatowaniu wykraczają poza maksymalny rozmiar komórki, zostanie wyświetlony ten komunikat. Spróbuj zmniejszyć ilość tekstu lub liczbę zastosowanych w nim formatów.

Początek strony


Filtrowanie danych — informacje

Filtrowanie jest procesem wyodrębniania i wyświetlania tylko tych elementów listy, które spełniają określone warunki. Zastosowanie wielu filtrów do listy umożliwia szybkie wyświetlenie elementów listy.

Na przykład widok Kierownicy listy Pracownik powstaje dzięki filtrowaniu w poszukiwaniu pracowników, w przypadku których dla kolumny Kierownik ustawiono wartość Tak. Można dalej filtrować tę listę w celu wyświetlenia kierowników, w przypadku których dla kolumny Kraj/region ustawiono wartość USA, a dla kolumny Województwo — wartość Kalifornia. Poniższy rysunek przedstawia kierowników pracujących w stanie Kalifornia.

Widok Kierownicy listy Pracownik

Należy zwrócić uwagę na obecność strzałki listy rozwijanej w nagłówkach kolumn Województwo i Kraj/region.

Przy przechodzeniu między widokami lub zamykaniu widoku Kierownicy filtry Kraj/region i Województwo nie są zapisywane. Po następnym otwarciu listy w widoku Kierownicy na liście zostaną wyświetleni wszyscy kierownicy.

Filtr można zastosować do listy na dwa sposoby:

  • Można go zastosować do listy w widoku arkusza danych. Filtr jest resetowany po przejściu użytkownika do innej strony i wymaga ponownego zastosowania, gdy użytkownik chce jeszcze raz wyświetlić te same wyniki.
  • Gdy filtr zostanie określony jako część definicji widoku, kryteria filtrowania są zapisywane, a następnie są stosowane po każdym otwarciu listy w określonym widoku.

Filtrowanie nie jest obsługiwane w kolumnach z danymi typu wiele wierszy tekstu i hiperłączami albo obrazami. Kolumny z załącznikami można filtrować przy użyciu wartości Tak i Nie. W kolumnach zawierających wiele opcji do wyboru zostaną uwzględnione komórki zawierające wybraną wartość.


Stosowanie filtru

  1. W nagłówku kolumny kliknij strzałkę listy rozwijanej.

    Uwaga Jeśli w kolumnie nie jest dostępna funkcja filtrowania, polecenia filtrowania będą wyłączone w tej kolumnie.

  2. Na liście wykonaj jedną z następujących czynności:
    • Kliknij wartość komórki, aby filtrować w poszukiwaniu rekordów mających pasującą wartość. W kolumnach, w których można wybrać kilka opcji, zostaną zaznaczone rekordy zawierające wybraną wartość.
    • Kliknij opcję (Puste), aby filtrować w poszukiwaniu rekordów, które nie mają wartości.
    • Kliknij opcję (Niepuste), aby filtrować w poszukiwaniu rekordów, które mają wartość.
    • Kliknij opcję (Filtr niestandardowy), aby zdefiniować kryteria filtru niestandardowego. W oknie dialogowym Filtr niestandardowy określ operatory porównania i wartości. Na przykład, aby wyszukać nazwy rozpoczynające się od litery „A” lub „B”, w lewej górnej liście wybierz opcję zaczyna się od, a w prawej górnej liście wpisz literę A. W lewej środkowej liście wybierz opcję zaczyna się od, a w prawej środkowej liście wybierz literę B. Wybierz górny operator Lub, aby połączyć oba kryteria i kliknij przycisk OK.
  3. Kliknij opcję (Pokaż wszystko), aby usunąć filtry z tej kolumny.

Uwaga W widoku można filtrować i sortować wiele kolumn.


Usuwanie filtru lub kolejności sortowania

Aby sprawdzić, czy kolumna była filtrowana, w nagłówku kolumny należy kliknąć strzałkę listy rozwijanej. Jeśli w kolumnie zastosowano filtr, na liście rozwijanej będzie zaznaczona inna pozycja niż Pokaż wszystko.

Pokaż Aby usunąć filtr z kolumny

  1. W nagłówku kolumny kliknij strzałkę listy rozwijanej.
  2. Na liście kliknij pozycję Pokaż wszystko.

Pokaż Aby usunąć wszystkie filtry i kolejności sortowania

  • Na pasku narzędzi okienka zadań kliknij przycisk Usuń filtr/sortowanie.


Sortowanie wierszy

Sortowanie służy do rozmieszczania elementów na liście w wymaganej kolejności. Może to być przydatne, gdy trzeba znaleźć konkretne wpisy lub zidentyfikować określone grupy wpisów.

Listę można posortować na dwa sposoby:

  • Można ją posortować w widoku arkusza danych. Po przejściu do innej strony sortowanie jest resetowane i należy je ponownie zastosować, aby jeszcze raz uzyskać te same wyniki.
  • Gdy sortowanie zostanie określone jako część definicji widoku, kryteria sortowania są zapisywane, a następnie są stosowane po każdym otwarciu listy w określonym widoku.

Aby posortować jedną kolumnę

  1. W nagłówku kolumny kliknij strzałkę listy rozwijanej.
  2. Kliknij opcję Sortuj rosnąco lub Sortuj malejąco.
  3. Możesz powtórzyć ten proces dla innych kolumn, aby dokładniej zorganizować listę.

Aby posortować wiele kolumn za jednym razem

Podczas sortowania wielu kolumn kolejność ich sortowania wyznacza sposób, w jaki zostaną zorganizowane dane. Zwykle najważniejsze informacje wymagają sortowania w pierwszej kolejności. Na przykład, aby wyświetlić listę pracowników w kolejności alfabetycznej według działów, niezbędne jest pogrupowanie wszystkich osób według działów. W związku z tym najpierw należy posortować kolumnę Dział, a następnie kolumnę Pracownicy.

  1. Na wstążce kliknij kartę Lista, a następnie w grupie Arkusz danych kliknij pozycję Pokaż okienko zadań.
  2. W okienku zadań kliknij przycisk Sortuj.
  3. W oknie dialogowym Sortowanie niestandardowe w obszarze Sortuj według zaznacz kolumnę najbardziej wysuniętą na zewnątrz i kliknij opcję Rosnąco lub Malejąco.
  4. Ponownie wykonaj powyższą czynność dla jeszcze dwóch kolumn, kończąc na kolumnie o najmniej ważnych kryteriach sortowania.
  5. Kliknij przycisk OK.

Uwagi

  • W sortowanym widoku można zastosować więcej niż jeden filtr.
  • W kolumnach typu Wiele wierszy tekstu, Wybór wielowartościowy lub Odnośnik wielowartościowy sortowanie nie jest obsługiwane. Jeśli w kolumnie nie jest obsługiwane sortowanie, polecenia sortowania są dla niej wyłączone.
  • Kolejność wierszy po sortowaniu zależy od typu danych w kolumnach objętych sortowaniem.

    Domyślne kolejności sortowania dla różnych typów danych

    W przypadku kolejności rosnącej w widoku arkusza danych jest używana kolejność przedstawiona poniżej. W przypadku kolejności malejącej ta kolejność jest odwracana. Nie dotyczy to pustych komórek, które są zawsze ostatnie.

    Typ danych | Kolejność sortowania
    Liczby | Sortowanie jest przeprowadzane od najmniejszej liczby ujemnej do największej liczby dodatniej.
    Alfanumeryczne Sortowanie jest przeprowadzane od lewej do prawej, znak po znaku. Na przykład, jeśli w komórce znajduje się tekst „A100”, jest on umieszczany po komórce, w której znajduje się wpis „A1”, a przed komórką, w której znajduje się wpis „A11”.

    Sortowanie tekstu i tekstu zawierającego liczby jest przeprowadzane w następującej kolejności: 0 1 2 3 4 5 6 7 8 9 (spacja) ! " # $ % & ( ) * , . / : ; ? @ [ \ ] ^ _ ` { | } ~ + < = > A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

    Apostrofy (') i łączniki (-) są ignorowane, z jednym wyjątkiem: jeśli jedyna różnica między dwoma tekstami dotyczy łącznika, tekst zawierający łącznik jest umieszczany na końcu.
    Wartości logiczne | „Nie” znajduje się przed „Tak”.
    Wartości błędów | Na potrzeby sortowania wszystkie wartości błędów są traktowane tak samo.


Rozwiązywanie problemów z sortowaniem i filtrowaniem

Nie mogę zapisać kolejności sortowania ani kryteriów filtrowania w widoku.

Polecenia sortowania i filtrowania są niedostępne.

W oknie dialogowym Filtr niestandardowy brakuje kilku operatorów.

Nie widzę kolumny, według której chcę sortować wiersze lub filtrować dane.

Kolejność sortowania nie jest zgodna z ustawieniami mojego komputera.

Mimo zastosowania filtru lub kolejności sortowania widok nie został przefiltrowany ani posortowany.

Nie mogę zapisać kolejności sortowania ani kryteriów filtrowania w widoku.

Sortowanie lub filtrowanie zastosowane w liście po jej otwarciu w widoku arkusza danych nie jest zapisywane. Po zamknięciu widoku lub przejściu do innego widoku ustawienia zostaną utracone. Aby zapisać kolejność sortowania lub kryteria filtrowania, określ je w ramach definicji widoku.

Początek strony

Polecenia sortowania i filtrowania są niedostępne.

Jeśli w kolumnie nie jest obsługiwane sortowanie ani filtrowanie, polecenia nie są wyświetlane po kliknięciu nagłówka kolumny.

Początek strony

W oknie dialogowym Filtr niestandardowy brakuje kilku operatorów.

Zawartość listy operatorów wyświetlanej w oknie dialogowym Filtr niestandardowy zmienia się w zależności od typu danych zaznaczonej kolumny. Na przykład operatory Zaczyna się od i Zawiera są niedostępne w kolumnach numerycznych.

Początek strony

Nie widzę kolumny, według której chcę sortować wiersze lub filtrować dane.

Sprawdź, czy kolumna nie jest ukryta w widoku arkusza danych. Kliknij prawym przyciskiem myszy komórkę w lewym górnym rogu listy, a następnie kliknij polecenie Odkryj. Jeśli polecenie Odkryj jest wyłączone, sprawdź w definicji widoku, czy kolumna została uwzględniona w widoku.

Początek strony

Kolejność sortowania nie jest zgodna z ustawieniami mojego komputera.

Może to być spowodowane przez ustawienia regionalne serwera programu SharePoint. Więcej informacji można znaleźć w Pomocy programu Microsoft SharePoint Foundation 2010. Aby wyświetlić Pomoc programu Microsoft SharePoint Foundation 2010 kliknij przycisk Pomoc ( [image]).

Początek strony

Mimo zastosowania filtru lub kolejności sortowania widok nie został przefiltrowany ani posortowany.

Jeśli po zastosowaniu filtru lub kolejności sortowania zostaną dodane dane lub jeśli dane będą edytowane, nie zostaną one automatycznie zaktualizowane w widoku. Spróbuj odświeżyć widok lub ponownie zastosuj filtr albo kolejność sortowania.

Początek strony


Przenoszenie, kopiowanie i wklejanie zawartości komórek

Fragmenty listy można przenosić lub kopiować w inne miejsce tej samej listy albo do innego dokumentu. W przypadku przenoszenia zaznaczonego fragmentu jest on usuwany z listy i przenoszony do Schowka. W przypadku kopiowania zaznaczonego fragmentu pozostaje on na liście, a jego kopia jest umieszczana w Schowku. Wklejenie zawartości Schowka powoduje przeniesienie jej do miejsca docelowego.

Przenoszenie lub kopiowanie części listy

Wklejanie zawartości Schowka do listy

Przenoszenie lub kopiowanie części listy

Jeśli w zaznaczonym obszarze znajdują się komórki, które nie mogą pozostać puste lub są tylko do odczytu, operacja przenoszenia nie powiedzie się. Następujące kolumny nie mogą pozostać puste (aby nie zostały usunięte w wyniku operacji przenoszenia): pole wyboru i obliczeniowa.

W poniższej tabeli przedstawiono zawartość Schowka po wykonaniu operacji przenoszenia lub kopiowania.

Przenieś lub kopiuj... | Zawartość Schowka
Dane lub co najmniej jedna komórka (zaznaczenie nie obejmuje całych wierszy lub kolumny) | Zawartość komórki jest czyszczona lub kopiowana i umieszczana w Schowku.
Co najmniej jeden wiersz | Zaznaczone wiersze zostaną usunięte lub skopiowane i umieszczone w Schowku.
Kolumna (można ją tylko skopiować, nie można jej przenieść) | Zaznaczenie zostanie umieszczone w Schowku.
Wiersz Suma | Jeśli jest przenoszony, wyrażenie dla komórek w wierszu Suma to Brak. Operacja kopiowania nie ma wpływu na wiersz Suma. Wartości zagregowane są umieszczane w Schowku.
Komórka Pole wyboru | Nie jest czyszczona podczas operacji przenoszenia. W Schowku jest umieszczana wartość Tak lub Nie.
Kolumna obliczeniowa | Nie jest czyszczona podczas operacji przenoszenia. Wartości obliczeniowe są umieszczane w Schowku.

Początek strony

Wklejanie zawartości Schowka do listy

Podczas wklejania zawartości Schowka nowe wiersze są dodawane w dolnej części widoku arkusza danych, jeśli to konieczne. Jeśli jednak w widoku nie ma odpowiedniej liczby kolumn, operacja wklejania nie powiedzie się. Operacja wklejania nie powiedzie się także w następujących sytuacjach:

  • Niektóre lub wszystkie komórki docelowe są komórkami tylko do odczytu.
  • Wklejenie zawartości do wybranych komórek spowoduje naruszenie reguł sprawdzania poprawności.
  • Podjęto próbę wklejenia danych, które nie są zgodne z typem danych komórek docelowych.
  • Podjęto próbę wklejenia danych do kolumny obliczeniowej.

Przy próbie wklejenia danych danego typu w kolumnie innego typu na liście zostanie przeprowadzona próba konwertowania danych źródłowych na dane zgodne z typem kolumny docelowej. Na przykład, jeśli dane źródłowe są numeryczne, a komórki docelowe obsługują tekst, dane źródłowe zostaną przekonwertowanie na tekst, a następnie umieszczone w komórkach docelowych. Jeśli danych źródłowych nie można przekonwertować na typ zgodny z typem komórki docelowej, operacja wklejania nie powiedzie się.

W poniższej tabeli znajdują się wyniki różnych operacji wklejania:

Zawartość Schowka | Próba wklejenia zawartości do... | Wynik operacji wklejania
Pojedyncza komórka | Zakres komórek | Zawartość jest kopiowana do każdej komórki w zaznaczonej grupie.
Zakres komórek | Pojedyncza komórka | Zakres docelowy jest powiększany, tak aby zmieściła się w nim cała zawartość Schowka, gdzie zaznaczona komórka staje się komórką położoną w lewym górnym rogu zakresu docelowego.
Co najmniej jeden wiersz lub kolumna | Pierwsza komórka wiersza lub kolumny | Zakres docelowy jest powiększany, tak aby zmieściła się w nim cała zawartość Schowka, gdzie zaznaczona komórka staje się komórką położoną w lewym górnym rogu zakresu docelowego.
Co najmniej jeden wiersz | Komórka inna niż pierwsza komórka wiersza | Operacja wklejania nie powiedzie się.
Co najmniej jedna kolumna | Komórka inna niż pierwsza komórka kolumny | Operacja wklejania powiedzie się, chyba że zakres docelowy wykracza poza ostatni wiersz w widoku, a w widoku znajdują się wymagane kolumny. W związku z tym, że wymagane kolumny w nowych wierszach będą puste, nowe wiersze nie zostaną dodane i zostanie wyświetlony komunikat z informacją o pominięciu niektórych wierszy.
Zakres komórek | Zakres komórek | Jeśli wymiary są zgodne, operacja wklejania powiedzie się. W przeciwnym wypadku operacja zakończy się niepowodzeniem.
Komórki w wierszu Suma | Wiersz Suma | Wyrażenie znajdujące się w komórkach źródłowych zostanie umieszczone w komórkach docelowych.
Komórki w wierszu Suma | Wszędzie poza wierszem Suma | Wartości zagregowane zostaną umieszczone w komórkach docelowych.

Początek strony


Automatyczne wypełnianie komórek danymi

Zakres komórek można wypełnić określoną wartością, zakresem wartości lub wartościami rosnącymi liniowo.

Kopiowanie zawartości komórki do innych komórek w kolumnie

Kopiowanie zakresu wartości do innych komórek w kolumnie

Liniowe zwiększanie wartości w zakresie komórek w kolumnie

Kopiowanie zawartości komórki do innych komórek w kolumnie

Na przykład kolumna Rok w wierszu 1 zawiera wartość 1980 i ma zostać skopiowana do wierszy 2, 3, 4 i 5.

  1. Zaznacz komórki, których zawartość ma zostać skopiowana.
  2. Umieść wskaźnik myszy na przeciąganym uchwycie wypełniania w prawym dolnym rogu komórki.

    Wskaźnik myszy na przeciąganym uchwycie wypełniania

  3. Gdy pojawi się wskaźnik przeciągania (+), przeciągnij nim tak, aby zostały zaznaczone komórki docelowe. Możesz przeciągać nad i pod zaznaczoną komórką.

    Komórki docelowe zaznaczone przy użyciu przeciąganego uchwytu wypełniania

  4. Po zwolnieniu przycisku myszy zawartość pierwszej komórki zostanie skopiowana do komórek docelowych.

    Komórki docelowe wypełnione danymi z komórki źródłowej

Początek strony

Kopiowanie zakresu wartości do innych komórek w kolumnie

Załóżmy, że chcesz wypełnić komórki w kolumnie Kwartał wartościami 1, 2, 3, 4, 1, 2, 3, 4 itd.

  1. W pierwszym wierszu wpisz 1, w drugim wierszu wpisz 2, w trzecim wierszu wpisz 3, a w czwartym wierszu wpisz 4.
  2. Zaznacz wszystkie cztery komórki.
  3. Umieść wskaźnik myszy na przeciąganym uchwycie wypełniania w prawym dolnym rogu zaznaczenia.
  4. Gdy pojawi się wskaźnik przeciągania (+), naciśnij klawisz CTRL i przytrzymując go, przeciągnij tak, aby objąć wszystkie komórki docelowe. Możesz przeciągać nad lub pod zaznaczoną komórką.

Początek strony

Liniowe zwiększanie wartości w zakresie komórek w kolumnie

W niektórych kolumnach tekstowych i numerycznych komórki można wypełniać seriami zwiększanych liniowo wartości, które przyrastają, począwszy od komórki lub komórek źródłowych. Typy kolumn, które nie obsługują tej operacji, zostały zamieszczone w sekcji uwag znajdującej się poniżej.

Załóżmy, że chcesz wypełnić komórki w kolumnie Rok wartościami 1910, 1920, 1930 itd.

  1. W pierwszym wierszu wpisz 1910, a w drugim wierszu wpisz 1920.
  2. Zaznacz komórkę Rok w pierwszym i drugim wierszu.
  3. Umieść wskaźnik myszy na przeciąganym uchwycie wypełniania w prawym dolnym rogu zaznaczenia.
  4. Gdy pojawi się wskaźnik przeciągania (+), przeciągnij nim tak, aby zostały zaznaczone komórki docelowe. Możesz przeciągać nad i pod zaznaczoną komórką.

Uwaga Jeśli pierwsza seria zawiera jedną wartość, przytrzymaj klawisz CTRL i jednocześnie przeciągnij uchwyt wypełniania w celu wygenerowania serii.

Przykłady wartości rosnących liniowo

W poniższej tabeli przedstawiono kilka serii, które można wygenerować, przeciągając uchwyt wypełniania.

Wartości początkowe | Uzyskana seria
1, 2, 3 | 4, 5, 6...
pn | wt, śr, cz...
poniedziałek | wtorek, środa, czwartek...
sty | lut, mar, kwi...
sty, kwi | lip, paź, sty...
2005-01-01 | 2005-01-02, 2005-01-03...
2005-01-15, 2005-03-15 | 2005-05-15, 2005-07-15...
1999, 2000 | 2001, 2002, 2003...
Kw. 3 | Kw. 4, Kw. 1, Kw. 2...
K3 | K4, K1, K2...
tekst1, tekstA | tekst2, tekstA, tekst3, tekstA...
1. okres | 2. okres, 3. okres...
Produkt 1 | Produkt 2, Produkt 3...

Uwagi

  • Podczas jednej operacji można automatycznie wypełnić kilka kolumn. Zaznaczone komórki w każdej kolumnie zostaną użyte do wypełnienia komórek docelowych.
  • Funkcja wypełniania wartościami rosnącymi liniowo nie jest obsługiwana w kolumnach zawierających następujące typy danych:
    • Wiele wierszy tekstu
    • Opcja
    • Odnośnik
    • Tak/Nie (pole wyboru)
    • Osoba lub grupa
    • Hiperłącze lub obraz
    • Obliczeniowy
  • Przy próbie wypełnienia komórki tylko do odczytu lub wprowadzenia nieprawidłowej wartości operacja wypełniania nie powiedzie się.

Początek strony


Rozwiązywanie problemów z automatycznym wypełnianiem komórek danymi

Jest wyświetlany komunikat „Komórki w regionie docelowym są tylko do odczytu”.

Przeciągasz uchwyt wypełniania na komórki, które są komórkami tylko do odczytu.

Jest wyświetlany komunikat „Pominięto wiersze, ponieważ nowe wiersze zawierają nieprawidłowe wartości w wymaganych polach”.

Przeciągasz uchwyt wypełniania na wiersze, w których w co najmniej jednej kolumnie oznaczonej jako wymagana nie ma żadnych wartości.

Jest wyświetlany komunikat „Nie można wykonać tej operacji na kolumnach obliczeniowych”.

Nie można wypełniać kolumny obliczeniowej wartościami, przeciągając uchwyt wypełniania. Dane są umieszczane w kolumnie obliczeniowej przez ocenę formuły. Aby wyświetlić lub edytować formułę kolumny obliczeniowej, kliknij komórkę w kolumnie, a następnie kliknij ją ponownie.

Jest wyświetlany komunikat „Próba wypełnienia komórek lub wierszy nieprawidłowymi wartościami”.

Próbujesz wypełnić komórki wartościami niezgodnymi z regułami sprawdzania poprawności komórki lub wiersza.

Jest wyświetlany komunikat „Niektóre dane zostały obcięte”.

Próbujesz wypełnić komórki wartościami, których długość przekracza maksymalną dozwoloną długość w komórkach docelowych.


Rozwiązywanie problemów z przenoszeniem, kopiowaniem i wklejaniem zawartości komórek

Nie mogę wkleić danych w kolumnie lub jest wyświetlany komunikat „Nie można wkleić następującej liczby komórek: N”.

Jest wyświetlany komunikat „Niektóre dane zostały obcięte”.

Jest wyświetlany komunikat „Komórki są wymagane w tym regionie i nie można ich wyczyścić".

Jest wyświetlany komunikat „Komórki/Wiersze w tym regionie są tylko do odczytu”.

Jest wyświetlany komunikat „Nie można wkleić informacji, ponieważ obszar wklejania nie jest w całości na liście".

Jest wyświetlany komunikat „Nie można wkleić informacji, ponieważ obszar wycinania lub kopiowania nie ma takiego samego rozmiaru jak obszar wklejania".

Jest wyświetlany komunikat „Niektóre wiersze zostały pominięte”.

Nie mogę wkleić danych w kolumnie lub jest wyświetlany komunikat „Nie można wkleić następującej liczby komórek: N”.

Wykonaj jedną lub więcej z następujących czynności:

  • Upewnij się, że kolumna nie jest kolumną obliczeniową.
  • Upewnij się, że typ danych, które próbujesz wkleić, jest zgodny z typem komórek docelowych.
  • Upewnij się, że reguły sprawdzania poprawności komórki lub wiersza nie zostaną naruszone przez operację wklejania.

Początek strony

Jest wyświetlany komunikat „Niektóre dane zostały obcięte”.

Próbujesz wkleić więcej znaków niż można w co najmniej jednej komórce docelowej. Jeśli na przykład próbujesz wkleić ponad 255 znaków w komórce typu pojedynczy wiersz tekstu, dodatkowe znaki zostaną obcięte.

Początek strony

Jest wyświetlany komunikat „Komórki są wymagane w tym regionie i nie można ich wyczyścić".

Próbujesz przenieść co najmniej jedną komórkę w kolumnie, która jest oznaczona jako wymagana. Kolumna oznaczona jako wymagana nie może być pusta. Zamiast próbować przenieść dane, spróbuj skopiować je do miejsca docelowego, a następnie usunąć zbędne wiersze.

Początek strony

Jest wyświetlany komunikat „Komórki/Wiersze w tym regionie są tylko do odczytu”.

Próbujesz przenieść dane z co najmniej jednej komórki lub co najmniej jednego wiersza tylko do odczytu albo wkleić dane w komórkach lub wierszach tylko do odczytu. Nie można zmieniać zawartości komórek i wierszy tylko do odczytu.

Początek strony

Jest wyświetlany komunikat „Nie można wkleić informacji, ponieważ obszar wklejania jest w całości na liście".

Może to być spowodowane jedną z następujących przyczyn:

  • Próbujesz wkleić co najmniej jeden wiersz w komórce innej niż pierwsza komórka wiersza.
  • Próbujesz wkleić zakres komórek w komórce, ale w widoku nie ma wymaganej liczby wierszy i kolumn z prawej strony komórki docelowej i pod tą komórka.

Początek strony

Jest wyświetlany komunikat „Nie można wkleić informacji, ponieważ obszar wycinania lub kopiowania nie ma takiego samego rozmiaru jak obszar wklejania".

Próbujesz wkleić zakres komórek w zakresie docelowym, ale wymiary obu zakresów nie są zgodne. Upewnij się, że liczba zaznaczonych komórek i wierszy jest taka sama w zakresach docelowym i źródłowym.

Początek strony

Jest wyświetlany komunikat „Niektóre wiersze zostały pominięte”.

Może to być spowodowane jedną z następujących przyczyn:

  • Próbujesz skopiować co najmniej jedną kolumnę do komórki innej niż pierwsza komórka w kolumnie docelowej.
  • Próbujesz wkleić dane w wierszu z gwiazdką (*), ale dodanie danych do wszystkich wymaganych kolumn w widoku nie jest możliwe.

Wszystkie operacje, które wymagają dodania nowych wierszy, ale powodują pozostawienie wymaganych kolumn pustych, nie powiodą się. Operacja wklejania powiedzie się tylko w istniejących wierszach przy jednoczesnym pominięciu pozostałych wierszy.

Początek strony


Zatwierdzanie lub odrzucanie elementów oczekujących

Jeśli dla danej listy skonfigurowano wymaganie zatwierdzania zawartości, użytkownicy mający odpowiednie prawa do zarządzania mogą przeglądać elementy dodane do listy przez inne osoby i zatwierdzać je lub odrzucać, zanim te informacje zostaną upublicznione. Użytkownicy witryny będą widzieli tylko elementy zatwierdzone.

  1. W widoku arkusza danych zaznacz kolumnę Stan zatwierdzenia, aby sprawdzić, czy są elementy oczekujące na zatwierdzenie.
  2. Przejdź do widoku zatwierdzania/odrzucania elementów:
    1. Na wstążce kliknij kartę Lista, a następnie w grupie Widok bieżący kliknij pozycję Zatwierdź/Odrzuć elementy dostępną w menu rozwijanym Widok bieżący.
    2. Upewnij się, że nadal pracujesz w widoku arkusza danych. W razie potrzeby kliknij opcję Widok arkusza danych.
  3. Opcjonalnie możesz zastosować filtr do listy, aby wyświetlić tylko elementy oczekujące. W nagłówku kolumny Stan zatwierdzania kliknij strzałkę listy rozwijanej i kliknij pozycję Oczekujące.
  4. Aby zatwierdzić lub odrzucić pojedynczy wiersz, kliknij bieżący stan pozycji w kolumnie Stan zatwierdzania, kliknij strzałkę w dół, a następnie na liście rozwijanej kliknij pozycję Zatwierdzono lub Odrzucono.

    Aby uwzględnić ten sam stan lub komentarz w sąsiednich wierszach, wprowadź wartość w pierwszym wierszu i przeciągnij uchwyt wypełniania, aby zaktualizować wybrane wiersze. Wartości można także kopiować i wklejać w kolumnach.

  5. Wpisz komentarze w kolumnie Komentarze osoby zatwierdzającej.

Uwaga Można także zmienić stan pozycji zatwierdzonej lub odrzuconej z powrotem na oczekujący. To spowoduje, że pozycja przestanie być widoczna dla użytkowników odwiedzających witrynę.


Przesyłanie zmian danych do menedżera listy w celu zatwierdzenia

Jeśli użytkownik dodaje dane do listy wymagającej zatwierdzenia zawartości lub modyfikuje dane z tej listy, zmiany nie będą widoczne dla innych użytkowników, dopóki nie zostaną zatwierdzone przez osobę mającą odpowiednie prawa do zatwierdzania zawartości.

Uwaga Jeśli użytkownik ma prawa do zatwierdzania zawartości modyfikowanej przez siebie listy, wszelkie zmiany wprowadzone na tej liście są zatwierdzane automatycznie.

Tworzenie nowego elementu listy i przesyłanie go do przeglądu

  1. Na Wstążce kliknij kartę Element, a następnie w grupie Nowe kliknij pozycję Nowy element.
  2. Na stronie Nowy element wprowadź informacje dotyczące nowego elementu, a następnie kliknij przycisk OK.

    W widoku arkusza danych nowy element jest wyświetlany na liście ze stanem zatwierdzenia Oczekujący. Aby ten element stał się widoczny dla osób odwiedzających witrynę, musi zostać przejrzany i zatwierdzony przez użytkownika mającego prawa do zatwierdzania zawartości.

Edytowanie elementu, który został już zatwierdzony

  1. Przejdź do widoku Przesłane elementy.
    1. Na Wstążce kliknij kartę Lista, a następnie w grupie Widoki niestandardowe kliknij pozycję Przesłane elementy dostępną w menu rozwijanym Widok bieżący.
    2. Upewnij się, że nadal pracujesz w widoku arkusza danych. W razie potrzeby kliknij opcję Widok arkusza danych.

    W tym widoku są wyświetlane wszystkie elementy dodane do listy, w tym elementy odrzucone. W widoku oprócz wszystkich innych kolumn listy są wyświetlane kolumny Stan zatwierdzenia i Komentarz. Kolumny Stan zatwierdzenia, Komentarz, Zmodyfikowany i Zmodyfikowany przez są jednak tylko do odczytu. Po zatwierdzeniu elementu może go edytować tylko osoba będąca jego inicjatorem.

  2. Wprowadź odpowiednie zmiany w wierszu, w którym znajduje się element wymagający edycji.

    W widoku arkusza danych stan zatwierdzenia edytowanego elementu zostanie automatycznie zmieniony na Oczekujący. Po zakończeniu edytowania wiersza należy przeprowadzić proces zatwierdzania w taki sam sposób jak w przypadku nowych pozycji.


Praca z bibliotekami dokumentów — informacje

W widoku Arkusz danych jest dostępny ten sam poziom obsługi bibliotek dokumentów co w przypadku list. W widoku Arkusz danych można otwierać bibliotekę dokumentów w celu wyświetlenia jej zawartości, dodawać i usuwać foldery oraz dokumenty, a także edytować dokumenty oraz zmieniać ich właściwości.

Praca z dokumentami w widoku Arkusz danych

Zarządzanie dokumentami i folderami w widoku Arkusz danych

Praca z dokumentami w widoku Arkusz danych

Biblioteka w widoku Arkusz danych

W widoku Arkusz danych z biblioteką można pracować na dwa sposoby.

  • Na Wstążce w obszarze karty Biblioteka kliknij pozycję Widok arkusza danych.
  • Utwórz dla biblioteki co najmniej jeden widok niestandardowy na podstawie widoku arkusza danych. W tym celu:
    1. Na Wstążce w obszarze karty Biblioteka kliknij pozycję Utwórz widok.
    2. Na stronie Tworzenie widoku w sekcji Wybierz format widoku kliknij pozycję Widok arkusza danych.
    3. W polu Nazwa widoku wpisz nazwę widoku. W nazwie widoku warto umieścić tekst „Arkusz danych”, aby później można było łatwo sprawdzić, jakiego rodzaju jest to widok.
    4. W razie potrzeby ustaw inne właściwości widoku.
    5. Kliknij przycisk OK.
    6. Nowo utworzony widok będzie dostępny na liście rozwijanej Bieżący widok.

      Uwaga Jeśli ustawienie folderu widoku ma wartość Pokaż elementy wewnątrz folderów, po otwarciu biblioteki zostaną wyświetlone tylko dokumenty i foldery najwyższego poziomu. Jeśli ustawienie folderu widoku ma wartość Pokaż wszystkie elementy bez folderów, po otwarciu biblioteki zostaną wyświetlone wszystkie dokumenty, w tym dokumenty znajdujące się w innych folderach.

Aby zmienić ustawienia istniejącego widoku Arkusz danych:

  1. Na Wstążce w obszarze karty Biblioteka kliknij pozycję Modyfikuj ten widok.
  2. Na stronie Edytowanie widoku wybierz lub zmień właściwości tego widoku.
  3. Kliknij przycisk OK.

Początek strony

Zarządzanie dokumentami i folderami w widoku Arkusz danych

  • Dokumenty można dodawać i przekazywać do biblioteki w ten sam sposób, w jaki dodaje się i przekazuje dokumenty w widoku Wszystkie dokumenty lub w innym widoku standardowym.
  • Jeśli ustawienie folderu widoku ma wartość Pokaż dokumenty wewnątrz folderów, można dodawać nowe foldery i przechodzić do innych folderów w bibliotece.
  • Można otwierać, edytować, ewidencjonować i wyewidencjonowywać dokumenty.
  • W widoku Arkusz danych można usuwać dokumenty i foldery. Gdy folder jest usuwany, z biblioteki jest usuwana jego zawartość, w tym podfoldery.
  • Można dodawać kolumny oraz usuwać i modyfikować kolumny dodane do widoku przez użytkowników. Można także wprowadzić i edytować dane przechowywane w takich kolumnach w wierszach zawierających dokumenty. Wierszy odpowiadających folderom nie można edytować. Należy zauważyć, że kolumny takie, jak Typ i Zmodyfikowany przez, są kolumnami tylko do odczytu. Nie można ich modyfikować ani usuwać; nie można także wprowadzać informacji w tych kolumnach ani edytować ich zawartości.
  • Można wyświetlać lub ukrywać wiersz Suma.
  • Można sortować i filtrować bibliotekę według różnych kolumn, w tym kolumny Typ.
  • W widoku Arkusz danych nie jest wyświetlany wiersz z gwiazdką (*) dla biblioteki dokumentów.
  • W kolumnie Nazwa nie można wprowadzać wartości przez przeciąganie uchwytu wypełniania ani przez wybranie wartości z listy rozwijanej komórki.

Początek strony


Dodawanie, wyświetlanie lub usuwanie dokumentów dołączonych do wiersza

Do wierszy w określonych typach list można dołączyć jeden lub większą liczbę dokumentów. Załączniki są wyświetlane w postaci ikony spinacza w kolumnie Załączniki w wierszu. Jeśli żaden z elementów na liście nie ma załączników, kolumna Załączniki nie jest wyświetlana.

Dodawanie załącznika do nowego elementu

  1. Na wstążce kliknij kartę Element, a następnie w grupie Nowe kliknij pozycję Nowy element.
  2. Na stronie Nowy załącznik wpisz nazwę elementu i określ inne jego właściwości.
  3. Kliknij łącze Dołącz plik.
  4. Wybierz plik lub pliki, które chcesz dołączyć do nowego elementu, a następnie kliknij przycisk Otwórz.
  5. Kliknij przycisk OK.
  6. Kliknij przycisk OK.

Dodawanie załącznika do istniejącego elementu

  1. W widoku arkusza danych kliknij prawym przyciskiem myszy kolumnę Załączniki w wierszu, a następnie kliknij polecenie Edytuj załącznik.

    Uwaga Nie można dodawać załączników do wiersza, który nie został jeszcze zatwierdzony.

  2. W oknie dialogowym Załączniki do elementu listy:
    • Aby dodać załącznik, kliknij przycisk Dodaj. Wybierz plik lub pliki, które chcesz dołączyć do wiersza, a następnie kliknij przycisk Otwórz.

      Aby wyświetlić podgląd pliku przed jego dołączeniem, kliknij dwukrotnie ten plik w oknie dialogowym Załączniki do elementu listy.

    • Aby usunąć załącznik, zaznacz go i kliknij przycisk Usuń.
  3. Kiedy w oknie dialogowym Załączniki do elementu listy znajdą się już wszystkie wymagane załączniki, kliknij przycisk OK, aby dołączyć je do wiersza. W kolumnie Załączniki zostanie wyświetlona ikona spinacza, co oznacza, że do wiersza dołączono jeden lub więcej plików.


Ewidencjonowanie i wyewidencjonowywanie dokumentu

Aby zaewidencjonować dokument, który został wyewidencjonowany dla danego użytkownika, ale nie jest aktualnie otwarty

  1. Kliknij prawym przyciskiem myszy nagłówek wiersza lub dowolną komórkę w wierszu odpowiadającą dokumentowi, który ma zostać zaewidencjonowany, wskaż polecenie Dokument, a następnie kliknij polecenie Zaewidencjonuj dokument.
  2. Na stronie Ewidencjonowanie wybierz opcję pozostawienia dokumentu wyewidencjonowanego dla siebie po jego zaewidencjonowaniu na serwerze lub opcję zwolnienia dokumentu, aby inni mogli nad nim pracować.
  3. Opcjonalnie w polu Komentarze możesz opisać zmiany wprowadzone w dokumencie.
  4. Kliknij przycisk OK.

Aby wyewidencjonować dokument

  • Kliknij prawym przyciskiem myszy nagłówek wiersza lub dowolną komórkę w wierszu odpowiadającą dokumentowi, który chcesz wyewidencjonować, wskaż polecenie Dokument, a następnie kliknij polecenie Wyewidencjonuj dokument.

Uwaga Nie można edytować dokumentu aktualnie wyewidencjonowanego przez innego użytkownika.


Usuwanie folderu lub dokumentu

Usunięcie folderu spowoduje usunięcie całej jego zawartości, w tym wszystkich jego podfolderów.

  1. Kliknij prawym przyciskiem myszy nagłówek wiersza lub dowolną komórkę w wierszu odnoszącą się do danego folderu lub dokument, który ma zostać usunięty, a następnie kliknij polecenie Usuń folder lub Usuń dokument.
  2. Aby potwierdzić, kliknij przycisk Tak.

Uwaga Foldery można usuwać tylko pojedynczo.


Edytowanie dokumentu

Podczas otwierania dokumentu do edycji program Microsoft SharePoint Foundation 2010 może automatycznie wykonywać kilka wymaganych zadań, takich jak wyewidencjonowywanie pliku, pobieranie go na komputer i otwieranie odpowiedniego programu.

  • Kliknij prawym przyciskiem myszy nagłówek wiersza lub dowolną komórkę w wierszu odpowiadającą dokumentowi, który ma być edytowany, wskaż polecenie Dokument, a następnie kliknij polecenie Edytuj dokument.

    Jeśli przed rozpoczęciem edycji jest wymagane wyewidencjonowanie dokumentu, program Microsoft SharePoint Foundation 2010 powiadamia użytkownika, że nastąpi wyewidencjonowanie i będzie można edytować dokument. Kliknij przycisk OK, aby kontynuować.

Dokument zostanie otwarty w odpowiedniej aplikacji pakietu Office. Można go edytować i zapisać z powrotem w bibliotece lub innej lokalizacji. Podczas zamykania wyewidencjonowanego dokumentu można wybrać opcję jego ponownego zaewidencjonowania lub opcję zaktualizowania go na serwerze przy zachowaniu stanu wyewidencjonowania.

Uwaga Nie można edytować dokumentu wyewidencjonowanego przez innego użytkownika. Nie można także edytować żadnych kolumn w wierszu odpowiadających dokumentowi, dopóki nie zostanie on ponownie zaewidencjonowany.


Określanie uprawnień na poziomie elementu

Określając uprawnienia na poziomie elementu, można zapobiec wyświetlaniu lub edytowaniu elementów z danej listy przez użytkowników. Można na przykład ustawić uprawnienia dotyczące listy zezwalające użytkownikom na wyświetlanie tylko ich własnych elementów lub uprawnienia zezwalające użytkownikom na wyświetlanie wszystkich elementów, ale na edytowanie tylko tych elementów, których są właścicielami. Podczas tworzenia nowej listy są ustawiane uprawnienia domyślne umożliwiające wszystkim użytkownikom wyświetlanie i edytowanie wszystkich elementów bez względu na to, przez kogo zostały utworzone.

Uniemożliwianie użytkownikom odczytu elementów innych użytkowników

Aby ustawić uprawnienia do odczytu, należy skorzystać z następującej procedury:

  1. Na wstążce kliknij kartę Lista, a następnie w grupie Ustawienia kliknij przycisk Ustawienia listy.
  2. Na stronie Ustawienia listy kliknij pozycję Ustawienia zaawansowane.
  3. Na stronie Ustawienia zaawansowane w obszarze Uprawnienia na poziomie elementu kliknij jedną z następujących opcji w obszarze Dostęp do odczytu:
    • Kliknij opcję Odczytywanie wszystkich elementów, aby zezwolić wszystkim użytkownikom na odczyt wszystkich elementów listy.
    • Kliknij opcję Odczytywanie elementów utworzonych przez użytkownika, aby zezwolić użytkownikom na odczyt wyłącznie tych elementów, które sami utworzyli.
  4. Kliknij przycisk OK.

Uniemożliwianie użytkownikom edytowania elementów

Aby ustawić uprawnienia do edytowania, należy skorzystać z następującej procedury:

  1. Na wstążce kliknij kartę Lista, a następnie w grupie Ustawienia kliknij przycisk Ustawienia listy.
  2. Na stronie Ustawienia listy kliknij pozycję Ustawienia zaawansowane.
  3. Na stronie Ustawienia zaawansowane w obszarze Uprawnienia na poziomie elementu kliknij jedną z następujących opcji w obszarze Dostęp do edytowania:
    • Kliknij opcję Tworzenie i edytowanie wszystkich elementów, aby zezwolić wszystkim użytkownikom na edytowanie wszystkich elementów listy.
    • Kliknij opcję Tworzenie elementów i edytowanie elementów utworzonych przez użytkownika, aby zezwolić użytkownikom na edytowanie wyłącznie tych elementów, które sami utworzyli.
    • Kliknij opcję Brak, aby uniemożliwić wszystkim użytkownikom edytowanie wszystkich elementów.
  4. Kliknij przycisk OK.


Udostępnianie dokumentu do dyskusji

  • Kliknij prawym przyciskiem myszy nagłówek wiersza lub dowolną komórkę w wierszu odpowiadającym dokumentowi, który chcesz udostępnić do dyskusji i kliknij przycisk Dyskutuj.

Dokument zostanie otwarty w programie Internet Explorer. W oknie przeglądarki pojawi się pasek narzędzi Dyskusje.


Otwieranie folderu lub dokumentu

  • Aby przejść do folderu lub otworzyć dokument, kliknij ikonę w kolumnie Typ odpowiedniego folderu lub pliku.

    Jeśli dokument został utworzony za pomocą programu z pakietu Microsoft Office, zostanie otwarty w odpowiedniej aplikacji tego pakietu. Pozostałe dokumenty będą otwierane w programie Internet Explorer.


Śledzenie i wyświetlanie informacji o wersji dla elementów listy

Użytkownik może przechowywać informacje o zmianach wprowadzonych w poszczególnych elementach listy. Może wówczas zobaczyć, jakie zmiany zostały wprowadzone w każdym z elementów, a także sprawdzić datę ich wprowadzenia oraz autora zmian.

Włączanie śledzenia wersji dla elementów listy

  1. Na wstążce kliknij kartę Lista, a następnie w grupie Ustawienia kliknij przycisk Ustawienia listy.
  2. Na stronie Ustawienia listy kliknij pozycję Ustawienia przechowywania wersji.
  3. Na stronie Ustawienia przechowywania wersji w sekcji Historia wersji elementu kliknij opcję Tak, aby po każdej edycji elementu była tworzona jego wersja.
  4. Aby ograniczyć liczbę przechowywanych wersji, zaznacz pole wyboru Zachowaj następującą liczbę wersji i wprowadź maksymalną liczbę wersji do przechowywania.
  5. Kliknij przycisk OK.

Wyświetlanie wersji elementu listy

  1. Kliknij prawym przyciskiem myszy nagłówek wiersza lub dowolną komórkę wiersza odpowiadającą elementowi, dla którego chcesz wyświetlić informacje o wersji.
  2. Wskaż opcję Element, a następnie kliknij opcję Wersje.

    Zostaną wyświetlone informacje o wersji.


Wyświetlanie wersji dokumentu

Jeśli ustawienia wersji dokumentów biblioteki dokumentów umożliwiają przechowywanie wersji dokumentów, można wyświetlać informacje o różnych wersjach poszczególnych dokumentów w bibliotece.

Wyświetlanie wersji dokumentu

  • Kliknij prawym przyciskiem myszy nagłówek wiersza lub dowolną komórkę w wierszu odpowiadającą dokumentowi, którego wersje chcesz wyświetlić, wskaż polecenie Dokument, a następnie kliknij polecenie Wersje dokumentu.

Zmienianie ustawień wersji dokumentów

  1. Na wstążce kliknij kartę Biblioteka, a następnie w grupie Ustawienia kliknij przycisk Ustawienia biblioteki.
  2. Na stronie Ustawienia listy w obszarze Ustawienia ogólne kliknij pozycję Ustawienia przechowywania wersji.
  3. Na stronie „Biblioteka dokumentów — ustawienia przechowywania wersji” w obszarze Historia wersji dokumentu wybierz odpowiedni schemat przechowywania wersji, a następnie kliknij przycisk OK.


Rozwiązywanie konfliktów wywołanych przez zmiany — informacje

Konflikt występuje wtedy, gdy dwóch użytkowników wprowadza zmianę w tej samej części danych lub struktury listy. Zostaną uwzględnione zmiany użytkownika wprowadzającego je w pierwszej kolejności, ale drugi użytkownik zostanie powiadomiony o konflikcie.

Na przykład użytkownik A zmienia zawartość trzeciego wiersza kolumny Miasto z Warszawa na Olsztyn i jednocześnie użytkownik B zmienia zawartość komórki z Warszawa na Gdańsk. Zmiany wprowadzone przez użytkownika A są przesyłane do serwera w pierwszej kolejności, po czym są przesyłane zmiany wprowadzone przez użytkownika B. Serwer informuje użytkownika B o konflikcie i umożliwia jego rozwiązanie.

Uwaga Konflikt wystąpi, nawet jeśli użytkownicy edytują różne komórki w tym samym wierszu.

Na poniższym rysunku pokazano listę z ikoną Konflikt w nagłówku trzeciego wiersza.

Wiersz powodujący konflikt

W wierszu powodującym konflikt nie można wprowadzać żadnych zmian do momentu rozwiązania tego konfliktu.

Kliknięcie ikony Konflikt powoduje wyświetlenie okna dialogowego Rozwiązywanie konfliktów.

Uwaga Przy próbie usunięcia wiersza, który został zaktualizowany przez innego użytkownika, wystąpi konflikt, ale nie zostanie wyświetlona ikona Konflikt, ponieważ wiersz został już zaktualizowany. W tym przypadku na pasku stanu należy kliknąć przycisk Rozwiąż, aby otworzyć okno dialogowe Rozwiązywanie konfliktów.

Okno dialogowe Rozwiązywanie konfliktów

W siatce szczegółów są wyświetlane wszystkie kolumny widoczne w bieżącym widoku. W danym wierszu są wyświetlane wprowadzone zmiany i zmiany wprowadzone przez innego użytkownika. Kolumny, w których wprowadzono zmiany, są wyróżnione. Należy zauważyć, że nie można edytować wartości wyświetlanych w siatce szczegółów. W górnej części okna dialogowego jest widoczna nazwa użytkownika wprowadzającego zmianę oraz data i godzina wprowadzenia tej zmiany.

Jeśli co najmniej dwóch użytkowników wprowadza całą serię zmian, może wystąpić wiele konfliktów. Nowy konflikt może wystąpić przy próbie rozwiązania istniejącego konfliktu. Jeśli wystąpiło kilka konfliktów, to klikając przyciski Poprzedni i Następny w górnej części okna dialogowego Rozwiązywanie konfliktów, można wyświetlać szczegóły poszczególnych konfliktów. Konflikty są sortowane według numerów wierszy. Innymi słowy, konflikt w trzecim wierszu jest wyświetlany przed konfliktem w czwartym wierszu. Podczas przewijania konfliktów odpowiedni wiersz jest wyróżniany na arkuszu danych. Można także wyświetlać szczegóły danego konfliktu, klikając ikonę Konflikt w odpowiednim wierszu. Zawartość okna dialogowego zostanie automatycznie przewinięta do wybranego konfliktu, ale klikając przycisk Poprzedni lub Następny można wyświetlać także szczegóły innych konfliktów.

Uwaga Jeśli oprócz konfliktów w widoku występuje co najmniej jeden błąd, w oknie dialogowym Rozwiązywanie konfliktów będą wyświetlane szczegóły umożliwiające rozwiązanie tych błędów.

Na podstawie informacji z siatki szczegółów można zignorować wprowadzone zmiany lub spróbować ponownie je wprowadzić. Jeśli zmiany zostały wprowadzone w różnych kolumnach wiersza, ponowna próba ich wprowadzenia spowoduje scalenie zmiany użytkownika B ze zmianą wprowadzoną przez użytkownika A. Jeśli zmiany zostały wprowadzone w tej samej komórce, zmiany użytkownika A zostaną zastąpione zmianami użytkownika B. Jeśli wystąpiło wiele konfliktów, można je rozwiązywać indywidualnie lub rozwiązać je wszystkie za jednym razem. Aby zignorować wszystkie zmiany lub spróbować je ponownie wprowadzić, należy kliknąć przycisk Odrzuć wszystkie moje zmiany lub Ponów próbę wprowadzenia wszystkich moich zmian.

Można zamknąć okno dialogowe bez wykonania jakichkolwiek czynności, ale do momentu rozwiązania konfliktu nie będzie można zamknąć ani odświeżyć listy, ani też wprowadzić zmian w kolumnie obliczeniowej.

Pokaż Scenariusze specjalne w oknie dialogowym Rozwiązywanie konfliktów

Poniżej przedstawiono przypadki specjalne, w których w oknie dialogowym Rozwiązywanie konfliktów mogą być wyświetlane inne informacje.
  • Użytkownik aktualizuje wiersz, który został usunięty przez innego użytkownika. W tym przypadku w oknie dialogowym nie będzie wyświetlana nazwa tego drugiego użytkownika ani data i godzina wprowadzenia przez niego zmiany. W siatce szczegółów w wierszu odpowiadającym temu użytkownikowi jest po prostu wyświetlana informacja Usunięty wiersz. Jedyną dostępną opcją jest odrzucenie zmian. Ponowna próba wprowadzenia zmian nie będzie możliwa.
  • Użytkownik A aktualizuje kolumnę, która nie jest wyświetlana w widoku bieżącym użytkownika B. W tym przypadku w siatce szczegółów nie będzie uwzględniana kolumna zmieniona przez użytkownika A. Ponowna próba wprowadzenia zmian przez użytkownika B nie spowoduje zastąpienia zmian wprowadzonych przez użytkownika A w kolumnach, które nie są wyświetlane w widoku użytkownika B.
  • Użytkownik A edytuje kolumnę, po czym edytuje ją ponownie w taki sposób, że w komórce znajduje się ponownie pierwotna wartość. W tym przypadku w oknie dialogowym będzie wyświetlana tylko najnowsza zmiana.
  • Jeśli bieżący filtr powoduje ukrycie wiersza, w którym występuje konflikt, filtr zostanie tymczasowo usunięty z okna dialogowego, aby można było wyświetlić ten wiersz w arkuszu danych. Po zamknięciu okna dialogowego nastąpi automatyczne ponowne zastosowanie filtru.
  • Jeśli użytkownik A dodaje lub usuwa załącznik przy użyciu przeglądarki, a drugi użytkownik aktualizuje wiersz, wystąpi konflikt. Jednak w oknie dialogowym kolumna w wierszu Zmiany innego użytkownika zostanie wyróżniona tylko wtedy, gdy ten drugi użytkownik doda pierwszy lub usunie ostatni załącznik. W kolumnie w siatce szczegółów będzie wyświetlany napis Tak, jeśli jest dostępny co najmniej jeden załącznik, lub napis Nie, jeśli nie są dostępne żadne załączniki.
  • Jeśli dana komórka jest hiperłączem, w przypadku braku nazwy wyświetlanej w siatce szczegółów będzie wyświetlany adres URL. W przypadku obrazu w siatce będzie wyświetlana ścieżka. Jeśli w danej kolumnie znajduje się tekst sformatowany, w siatce pojawi się tekst bez formatowania. Kolumna będzie jednak wyróżniona, jeśli formatowanie zostało zmienione.

Początek strony

Rozwiązywanie konfliktów strukturalnych

Może także wystąpić konflikt strukturalny, gdy co najmniej dwóch użytkowników edytuje różne części listy. Konflikt strukturalny występuje wtedy, gdy nie można rozpoznać zmian. Na przykład użytkownik A usuwa kolumnę, a użytkownik B próbuje ją zaktualizować. Albo użytkownik A zmienia typ danych kolumny, a użytkownik B wprowadza dane, które nie są zgodne z nowym typem danych. W takich sytuacjach użytkownik B będzie musiał odświeżyć listę. Odświeżenie spowoduje pobranie najnowszej wersji listy, ale zmiany wprowadzone przez użytkownika B zostaną odrzucone.

Początek strony

Rozwiązanie konfliktu może prowadzić do nowego konfliktu lub błędu

Rozwiązanie konfliktu może spowodować wystąpienie nowych konfliktów lub błędów. Na przykład trzeci użytkownik, użytkownik C, wprowadza serię zmian powodujących konflikty, a użytkownik B rozwiązuje konflikty spowodowane zmianami wprowadzonymi przez użytkownika A. Jeśli ponowna próba wprowadzenia zmian przez użytkownika B spowoduje wystąpienie nowego konfliktu, konflikt ten zostanie dodany do listy istniejących konfliktów, a okno dialogowe zostanie odpowiednio zaktualizowane.

Początek strony


Naprawianie błędów — informacje

Podczas pracy w widoku arkusza danych może wystąpić jeden lub kilka błędów. Niektóre błędy można naprawić, powtarzając po prostu odpowiednią akcję lub odświeżając widok, podczas gdy naprawienie innych wymaga większego wysiłku. W zależności od błędu w widoku będą dostępne odpowiednie informacje pomocne w naprawieniu tego błędu.

Kiedy mogą wystąpić błędy

Typy błędów

Naprawianie błędów

Kiedy mogą wystąpić błędy

Błędy mogą wystąpić w następujących sytuacjach:
  • Przy otwieraniu widoku arkusza danych. Na przykład widok może nie zostać załadowany lub dane w tym widoku mogą być niewidoczne.
  • Przy wyświetlaniu lub edytowaniu danych w widoku. Na przykład zatwierdzanie zmian w danych może się nie powieść, jeśli nie można znaleźć serwera.
  • Przy wyświetlaniu lub edytowaniu struktury listy. Na przykład usunięcie kolumny może spowodować błąd wynikający z braku uprawnień.
  • Przy wyświetlaniu lub edytowaniu definicji. Na przykład zmiana kolejności kolumn może się zakończyć niepowodzeniem z powodu przekroczenia limitu czasu serwera.

Początek strony

Typy błędów

Istnieją dwa typy błędów — błędy, które można naprawić przez ponowienie próby wprowadzenia zmian, i błędy, które można naprawić przez odrzucenie zmian.

Błędy, które można naprawić przez ponowienie próby wprowadzenia zmian:

  • Brak odpowiedzi z serwera. Może to być spowodowane przekroczeniem limitu czasu.
  • Serwer jest zajęty lub nie można go znaleźć.
  • Odpowiedź serwera jest nieprawidłowa.
  • Wystąpił inny nieoczekiwany błąd.

Błędy, które można naprawić przez odrzucenie zmian:

  • Nie masz wymaganych uprawnień, aby wprowadzić zmianę.
  • Nie możesz dodawać zawartości do witryny (blokada).
  • Zostały przekroczone limity miejsca na przechowywanie danych dla tej witryny.
Aby uniknąć tych błędów, skontaktuj się z administratorem systemu.

Początek strony

Naprawianie błędów

Gdy wystąpi błąd, w widoku w odpowiednim wierszu oraz na pasku stanu pojawi się ikona Błąd ( Ikona Błąd ). Na pasku stanu pojawi się także tekst Kliknij, aby naprawić błędy. Jeśli wystąpiły konflikty i błędy, pojawi się tekst Kliknij, aby rozwiązać konflikty danych i naprawić błędy.

Ilustracja przedstawia okno dialogowe Naprawianie błędów.

Okno dialogowe Naprawianie błędów

W siatce szczegółów są wyświetlane wszystkie kolumny widoczne w bieżącym widoku. Widoczna jest zmiana wprowadzona w odpowiednim wierszu. Należy zauważyć, że nie można edytować wartości wyświetlanych w siatce szczegółów. W górnej części okna dialogowego jest wyświetlany opis błędu.

Jeśli wystąpiło wiele błędów, szczegółowe informacje o każdym z nich można wyświetlić, klikając przyciski Dalej i Wstecz w górnej części okna dialogowego.

Na podstawie informacji o błędzie z siatki szczegółów można zignorować wprowadzone zmiany lub spróbować wprowadzić je ponownie. Jeśli wystąpiło wiele błędów, można je naprawiać kolejno lub spróbować naprawić wszystkie błędy jednocześnie. Aby zignorować wszystkie błędy lub ponowić próbę wprowadzenia zmian, należy kliknąć przycisk Odrzuć wszystkie moje zmiany lub przycisk Ponów próbę wprowadzenia wszystkich moich zmian.

Należy zauważyć, że wszystkie czynności wykonywane w celu naprawienia błędu mogą powodować nowy błąd. W takim przypadku w oknie dialogowym zostaną wyświetlone informacje o nowym błędzie.

Można zamknąć okno dialogowe i nie wykonywać żadnych czynności, ale do momentu naprawienia tego błędu nie będzie można zamknąć ani odświeżyć listy ani też wprowadzić zmian w kolumnie obliczeniowej.

Początek strony


Rozwiązywanie konfliktów i poprawianie błędów spowodowanych zmianami

  1. Na pasku stanu kliknij przycisk Napraw , aby wyświetlić okno dialogowe Rozwiązywanie konfliktów i poprawianie błędów.

  2. Wykonaj jedną z następujących czynności:

    • Aby rozwiązać aktualnie wyświetlany konflikt lub poprawić błąd, ignorując zmiany wprowadzone w wierszu, kliknij przycisk Odrzuć moje zmiany. Zmiany zostaną utracone.
    • Aby rozwiązać wszystkie oczekujące konflikty i poprawić wszystkie oczekujące błędy przez zignorowanie wszystkich zmian na liście, kliknij przycisk Odrzuć wszystkie moje zmiany.
    • Aby rozwiązać aktualnie wyświetlany konflikt lub poprawić aktualnie wyświetlany błąd przez ponowne wprowadzenie zmian, kliknij przycisk Ponów próbę wprowadzenia moich zmian. W przypadku konfliktu, jeśli dwie osoby zmieniły tę samą kolumnę, Twoje zmiany zastąpią zmiany drugiego użytkownika. W przypadku edytowania różnych kolumn Twoje zmiany zostaną połączone ze zmianami wprowadzonymi przez drugiego użytkownika.
    • Aby rozwiązać wszystkie oczekujące konflikty i poprawić wszystkie zaległe błędy przez ponowne wprowadzenie zmian, kliknij przycisk Ponów próbę wprowadzenia wszystkich moich zmian.
    • Aby wyświetlić szczegóły następnego konfliktu lub błędu, w prawym górnym rogu okna dialogowego kliknij przycisk Dalej.
    • Aby wyświetlić szczegóły poprzedniego konfliktu lub błędu, w prawym górnym rogu okna dialogowego kliknij przycisk Wstecz.
    • Aby rozwiązać konflikty lub poprawić błędy później, na pasku tytułu okna dialogowego kliknij polecenie Zamknij.

Uwagi

  • W siatce szczegółów są wyświetlane wszystkie kolumny w bieżącym widoku. Jeśli kolumny nie są widoczne, należy użyć poziomego paska przewijania, aby przewinąć lub przeciągnąć prawą krawędź okna dialogowego w celu zwiększenia szerokości siatki szczegółów.

    Aby skalować zawartość kolumny, kliknij kolumnę w siatce szczegółów. Zmiany wprowadzone przez obu użytkowników będą wyświetlane w oknie dialogowym Szczegóły pola. W tym oknie dialogowym można także wyświetlać zmiany wprowadzone w tekście sformatowanym.

  • Jeśli jeden z użytkowników usunie wiersz danych, zamiast tego wiersza w siatce szczegółów jest wyświetlana informacja Usunięty wiersz. Jeśli wiersz zostanie usunięty przez innego użytkownika, w oknie dialogowym nie pojawi się nazwa tego użytkownika ani data i godzina usunięcia. Ponowne wprowadzenie danych także nie będzie możliwe.


Kiedy występują konflikty?

Konflikt występuje wtedy, gdy dwóch użytkowników wprowadza zmianę w tej samej części danych lub struktury listy. Zostaną uwzględnione zmiany użytkownika wprowadzającego je w pierwszej kolejności, ale drugi użytkownik zostanie powiadomiony o konflikcie.

Typy zmian, które można wprowadzać na liście

Scenariusze, które wywołują konflikt

Scenariusze, które nie wywołują konfliktu

Scenariusze, które wywołują konflikt strukturalny

Scenariusze, w których nie zostanie wyświetlony komunikat o błędzie ani nie wystąpi konflikt

Typy zmian, które można wprowadzać na liście

Na liście można wprowadzać trzy typy zmian. W poniższej tabeli przedstawiono poszczególne typy wraz z przykładami:

Typ zmiany | Przykłady
Zmiana danych listy | Dodawanie, modyfikowanie lub usuwanie wiersza Wklejanie zawartości Schowka Dodawanie danych do komórek przez przeciąganie uchwytu wypełniania Dodawanie lub usuwanie załączników Formatowanie zawartości co najmniej jednej komórki
Modyfikowanie struktury listy | Dodawanie lub usuwanie kolumny Zmienianie ustawień kolumny Wprowadzanie zmian w kolumnie obliczeniowej Zmienianie ustawień listy
Zmienianie definicji widoku | Stosowanie filtru lub kolejności sortowania Zmienianie szerokości kolumny lub wysokości wiersza Zmienianie kolejności kolumn Wyświetlanie lub ukrywanie wiersza Suma

Początek strony

Scenariusze, które wywołują konflikt

W poniższej tabeli zestawiono scenariusze, które powodują konflikt:

Użytkownik A | Użytkownik B
Usuwa wiersz | Aktualizuje ten sam wiersz
Aktualizuje wiersz | Aktualizuje lub usuwa ten sam wiersz Uwaga Konflikt nie wystąpi, jeśli w bibliotece dokumentów użytkownik A zaktualizuje wiersz lub dokument, a użytkownik B usunie ten sam wiersz lub dokument.
Dodaje lub usuwa załącznik za pomocą przeglądarki | Aktualizuje lub usuwa ten sam wiersz
Usuwa dokument | Aktualizuje ten sam wiersz
Edytuje lub zapisuje dokument albo zmienia jego nazwę | Aktualizuje ten sam wiersz
Aktualizuje wiersz, ale nie edytuje dokumentu | Aktualizuje ten sam wiersz
Zmienia tekst sformatowany | Aktualizuje lub usuwa ten sam wiersz

Jeśli w bibliotece dokumentów użytkownik A otwiera dokument, a użytkownik B edytuje dokument lub zmienia jego ustawienia, użytkownik B otrzyma komunikat o błędzie z informacją o tym, że dokument jest zablokowany.

Początek strony

Scenariusze, które nie wywołują konfliktu

W poniższej tabeli zestawiono scenariusze, które nie powodują konfliktu:

Użytkownik A | Użytkownik B | Przykład
Zmienia dane | Zmienia definicję widoku | Użytkownik A dodaje wiersz, a użytkownik B stosuje w widoku kolejność sortowania
Zmienia strukturę | Zmienia definicję widoku | Użytkownik A dodaje kolumnę, a użytkownik B stosuje w widoku kolejność sortowania
Zmienia definicję widoku | Zmienia dane | Użytkownik A stosuje kolejność sortowania, a użytkownik B dodaje wiersz
Zmienia definicję widoku | Zmienia strukturę | Użytkownik A stosuje kolejność sortowania, a użytkownik B dodaje kolumnę
Zmienia definicję widoku | Zmienia definicję widoku | Użytkownik A stosuje kolejność sortowania, po czym użytkownik B stosuje inną kolejność sortowania Uwaga W związku z tym, że jest uwzględniana ostatnia zmiana, zmiana wprowadzona przez użytkownika B zastępuje zmianę wprowadzoną przez użytkownika A.

Uwaga Jeśli w bibliotece dokumentów użytkownicy A i B otworzą dokument w trybie tylko do odczytu, a następnie zdecydują się edytować i zapisać ten dokument, zastępując jego istniejącą wersję, użytkownik zapisujący dokument jako drugi spowoduje zastąpienie zmian wprowadzonych przez pierwszego użytkownika.

Początek strony

Scenariusze, które wywołują konflikt strukturalny

W poniższej tabeli zestawiono scenariusze, w których będzie wyświetlany komunikat o błędzie. Użytkownik B będzie monitowany o odświeżenie listy, a wprowadzone zmiany zostaną odrzucone.

Użytkownik A | Użytkownik B
Usuwa kolumnę | Aktualizuje dane w tej samej kolumnie
Zmienia typ danych kolumny | Dodaje lub aktualizuje dane, powodując niezgodność typów
Dodaje lub usuwa kolumnę, zmienia jej nazwę, typ jej danych lub inne właściwości | Edytuje kolumnę obliczeniową
Wprowadza zmiany na poziomie listy, np. zmienia nazwę listy, zmienia jej opis lub ustawienia zabezpieczeń, zmienia kolejność kolumn, włącza lub wyłącza załączniki lub dodaje listę do paska Szybkie uruchamianie | Edytuje kolumnę obliczeniową
Edytuje kolumnę obliczeniową | Dodaje lub usuwa kolumnę, zmienia jej nazwę, typ jej danych lub inne właściwości. Uwaga Użytkownik B musi przejść do strony Dodaj kolumnę lub Zmień kolumnę, zanim użytkownik A rozpocznie edytowanie kolumny obliczeniowej.
Edytuje kolumnę obliczeniową | Wprowadza zmiany na poziomie listy, np. zmienia nazwę listy, zmienia jej opis lub ustawienia zabezpieczeń, zmienia kolejność kolumn, włącza lub wyłącza załączniki lub dodaje listę do paska Szybkie uruchamianie Uwaga Użytkownik B musi przejść do strony Ustawienia listy, zanim użytkownik A rozpocznie edytowanie kolumny obliczeniowej.

Początek strony

Scenariusze, w których nie zostanie wyświetlony komunikat o błędzie ani nie wystąpi konflikt

W poniższej tabeli zestawiono scenariusze, w których nie wystąpi ani błąd, ani konflikt:

Użytkownik A | Użytkownik B
Usuwa kolumnę | Usuwa tę samą kolumnę
Usuwa załącznik | Usuwa ten sam załącznik
Usuwa dokument | Usuwa ten sam dokument lub wiersz
Usuwa wiersz | Usuwa ten sam wiersz

Początek strony


Eksportowanie widoku arkusza danych — informacje

Dane można eksportować z programu Microsoft SharePoint Foundation 2010 do programu Microsoft Access 2010 lub Microsoft Excel 2010. W przypadku programu Access 2010 eksport można przeprowadzić do tabeli statycznej lub tabeli połączonej w nowej lub istniejącej bazie danych. W przypadku programu Excel 2010 można utworzyć kwerendę widoku arkusza danych w nowym lub istniejącym arkuszu albo w nowym skoroszycie.

Eksportowanie do programu Access

W przypadku eksportowania danych z programu Microsoft SharePoint Foundation 2010 do programu Access 2010 jest tworzona statyczna tabela bazy danych zawierająca dane z widoku arkusza danych. Ta tabela nie jest połączona z widokiem arkusza danych i nie jest aktualizowana po wprowadzeniu zmian danych w programie Microsoft SharePoint Foundation 2010.

Śledzenie listy w programie Access

Po wybraniu w okienku zadań opcji Śledź tę listę w programie Access w programie Access jest tworzona tabela, która jest dynamicznie połączona z programem Microsoft SharePoint Foundation 2010. Zmiany danych wprowadzone w widoku arkusza danych są automatycznie uwzględniane w tabeli programu Access. Podobnie zmiany danych wprowadzone w tabeli programu Access są automatycznie uwzględniane w widoku arkusza danych.

Uwaga W niektórych typach list istnieją kolumny, które można modyfikować w widoku arkusza danych w programie Microsoft SharePoint Foundation 2010, ale nie można ich modyfikować w tabelach połączonych programu Access.

Tworzenie kwerendy dotyczącej listy przy użyciu programu Excel

W przypadku badania kwerendami widoku arkusza danych przy użyciu programu Excel w programie Excel jest tworzona kwerenda, za pomocą której są pobierane dane z widoku arkusza danych. Po wyeksportowaniu widoku arkusza danych do programu Excel 2010 wszelkie zmiany danych wprowadzane w widoku arkusza danych są automatycznie aktualizowane w arkuszu programu Excel. Zmiany wprowadzane w arkuszu programu Excel nie są jednak przesyłane z powrotem do programu Microsoft SharePoint Foundation 2010.


Tworzenie kwerendy dotyczącej listy przy użyciu programu Excel

  1. Na wstążce kliknij kartę Lista, a następnie w grupie Arkusz danych kliknij pozycję Pokaż okienko zadań.
  2. W okienku zadań kliknij pozycję Utwórz kwerendę dotyczącą listy przy użyciu programu Excel.

Program Microsoft Excel eksportuje widok arkusza danych jako plik kwerendy sieci Web.

Jeśli podczas klikania pozycji Utwórz wykres w programie Excel program Excel jest uruchomiony, użytkownik może skorzystać z opcji importowania danych zawartych w pliku kwerendy sieci Web do istniejącego arkusza, nowego arkusza lub nowego skoroszytu. W innych sytuacjach jest otwierany nowy skoroszyt i program Excel importuje do niego dane. Zaimportowane dane są wyświetlane w postaci listy w arkuszu z łączem do informacji programu Microsoft SharePoint Foundation 2010.

Uwzględnianie w arkuszu zmian wprowadzonych w widoku arkusza danych

Po wprowadzeniu zmian danych w programie Microsoft SharePoint Foundation 2010 arkusz w programie Excel można zaktualizować za pomocą funkcji odświeżania danych zewnętrznych. Aby uzyskać więcej informacji na temat kwerend, zobacz Pomoc programu Excel.


Eksportowanie informacji o kontaktach lub wydarzeniach

Eksportowanie informacji o kontaktach

W widoku standardowym i widoku arkusza danych listy kontaktów do programu Microsoft Outlook można wyeksportować całą listę kontaktów lub pojedynczą pozycję listy kontaktów.

Eksportowanie listy kontaktów

  1. Na wstążce kliknij kartę Lista, a następnie w grupie Łączenie i eksportowanie kliknij pozycję Połącz z programem Outlook.
  2. W programie Outlook zostanie wyświetlony monit o potwierdzenie połączenia listy kontaktów z programem Outlook. Kliknij przycisk Tak.

Po wyeksportowaniu listy kontaktów do programu Outlook wszelkie zmiany wprowadzane na liście kontaktów w programie Microsoft SharePoint Foundation 2010 są automatycznie przekazywane do listy kontaktów programu Outlook i na niej uwzględniane. Zmiany te są wyświetlane przy następnym ponownym ładowaniu listy kontaktów w programie Outlook.

Eksportowanie wybranego kontaktu

  1. Wykonaj jedną z następujących czynności:
    • W widoku standardowym w komórce Nazwisko kliknij strzałkę listy rozwijanej dla kontaktu, który chcesz wyeksportować, a następnie kliknij pozycję Eksportuj kontakt.
    • W widoku arkusza danych kliknij prawym przyciskiem myszy kontakt, który chcesz wyeksportować. Kliknij polecenie Eksportuj kontakt.
  2. Zostanie wyświetlony monit o potwierdzenie pobierania pliku wizytówki wirtualnej (z rozszerzeniem nazwy pliku vcf). Kliknij przycisk Otwórz.

Kontakt zostanie wyeksportowany do domyślnej listy kontaktów programu Outlook o nazwie Kontakty. Następnie można zdecydować, czy kontakt ma zostać zapisany na liście Kontakty czy na innej liście kontaktów.

Początek strony

Eksportowanie informacji o wydarzeniu

Do programu Outlook można wyeksportować całą listę wydarzeń lub pojedyncze wydarzenie z listy wydarzeń. Aby wyświetlić kalendarz jako listę wydarzeń, na Wstążce w obszarze Narzędzia list należy kliknąć pozycję Lista, a następnie na liście rozwijanej Widok bieżący kliknąć pozycję Wszystkie wydarzenia.

Eksportowanie listy wydarzeń

  1. Na wstążce kliknij kartę Lista, a następnie w grupie Łączenie i eksportowanie kliknij pozycję Połącz z programem Outlook.
  2. W programie Outlook zostanie wyświetlony monit o potwierdzenie połączenia kalendarza programu Microsoft SharePoint Foundation 2010 z programem Outlook. Kliknij przycisk Tak.

Po wyeksportowaniu listy wydarzeń do programu Outlook wszelkie zmiany wprowadzane na liście wydarzeń w programie Microsoft SharePoint Foundation 2010 są automatycznie przekazywane do kalendarza programu Outlook i w nim uwzględniane. Zmiany te są wyświetlane przy następnym ponownym ładowaniu kalendarza w programie Outlook.

Eksportowanie wybranego wydarzenia

  1. Wykonaj jedną z następujących czynności:
    • W widoku arkusza danych kliknij prawym przyciskiem myszy w dowolnym miejscu wiersza wydarzenia, które chcesz wyeksportować, a następnie kliknij polecenie Eksportuj wydarzenie.
    • W widoku standardowym kliknij wydarzenie, które chcesz wyeksportować, a następnie na karcie Polecenia niestandardowe kliknij polecenie Eksportuj wydarzenie.
  2. Zostanie wyświetlony monit o potwierdzenie pobierania pliku kalendarza internetowego (z rozszerzeniem nazwy pliku ics). Kliknij przycisk Otwórz.

Wydarzenie zostanie wyeksportowane do domyślnego kalendarza programu Outlook o nazwie Kalendarz. Następnie można zdecydować, czy wydarzenie ma zostać zapisane w kalendarzu o nazwie Kalendarz czy w innym kalendarzu.

Początek strony


Eksportowanie lub podłączanie widoku arkusza danych do programu Access

Eksportowanie widoku arkusza danych do programu Access

  1. Na wstążce kliknij kartę Lista, a następnie w grupie Arkusz danych kliknij pozycję Pokaż okienko zadań.
  2. W okienku zadań kliknij pozycję Eksportuj do programu Access.
  3. Wybierz opcję eksportowania widoku arkusza danych do istniejącej lub nowej bazy danych i kliknij przycisk OK.

W programie Microsoft Access zostanie wyświetlony monit o określenie lokalizacji bazy danych i zostanie otwarta tabela z wyeksportowanymi danymi.

Śledzenie listy w programie Access

  1. Na wstążce kliknij kartę Lista, a następnie w grupie Arkusz danych kliknij pozycję Pokaż okienko zadań.
  2. W okienku zadań kliknij pozycję Śledź tę listę w programie Access.
  3. Wybierz opcję eksportowania widoku arkusza danych do istniejącej lub nowej bazy danych, a następnie kliknij przycisk OK.

W programie Access zostanie wyświetlony monit o określenie lokalizacji bazy danych i zostanie utworzona tabela połączona z łączem do danych programu Microsoft SharePoint Foundation 2010.

Aktualizowanie widoku arkusza danych przy użyciu zmian wprowadzonych w tabeli połączonej

  1. Dokonaj edycji tabeli połączonej w programie Access.
  2. W widoku arkusza danych na wstążce kliknij kartę Lista, a następnie w grupie Arkusz danych kliknij pozycję Odśwież dane.

Aktualizowanie tabeli połączonej przy użyciu zmian wprowadzonych w programie SharePoint

  • Aby w tabeli połączonej były wyświetlane wszelkie zmiany wprowadzone do danych w programie Microsoft SharePoint Foundation 2010, należy użyć polecenia Odśwież programu Access.


Tworzenie raportu programu Access

Podczas tworzenia raportu w programie Microsoft Access w widoku arkusza danych powstaje tabela połączona z danymi znajdującymi się w tym widoku i na podstawie tych danych jest generowany raport.

  1. Na wstążce kliknij kartę Lista, a następnie w grupie Arkusz danych kliknij pozycję Pokaż okienko zadań.
  2. Kliknij przycisk Utwórz raport w programie Access.
  3. Wybierz opcję eksportowania widoku arkusza danych do istniejącej lub nowej bazy danych i kliknij przycisk OK.

W programie Access zostanie wyświetlony monit o określenie lokalizacji bazy danych i zostanie utworzona tabela połączona z łączem do danych programu Microsoft SharePoint Foundation 2010. Następnie zostanie wygenerowany prosty raport, w którym znajdą się wszystkie pola i rekordy z tabeli połączonej. Aby uzyskać więcej informacji o raportach programu Access, zobacz temat „Tworzenie raportu” w Pomocy programu Access.


Tworzenie wykresu programu Excel

W przypadku tworzenia wykresu programu Microsoft Excel w widoku arkusza danych najpierw jest tworzona kwerenda danych znajdujących się w tym widoku, a następnie na podstawie przebadanych danych jest tworzony wykres.

  1. Na wstążce kliknij kartę Lista, a następnie w grupie Arkusz danych kliknij pozycję Pokaż okienko zadań.
  2. W okienku zadań kliknij pozycję Utwórz wykres w programie Excel.

Program Excel eksportuje widok arkusza danych jako plik kwerendy sieci Web.

Jeśli podczas klikania pozycji Utwórz wykres w programie Excel program Excel jest uruchomiony, użytkownik może skorzystać z opcji importowania danych zawartych w pliku kwerendy sieci Web do istniejącego arkusza, nowego arkusza lub nowego skoroszytu. W innych sytuacjach jest otwierany nowy skoroszyt i program Excel importuje do niego dane. Zaimportowane dane są wyświetlane w postaci listy w arkuszu z łączem do informacji programu Microsoft SharePoint Foundation 2010. Następnie jest wyświetlany monit o utworzenie wykresu przy użyciu Kreatora wykresów.


Tworzenie tabeli przestawnej programu Excel

W przypadku tworzenia tabeli przestawnej programu Microsoft Excel w widoku arkusza danych najpierw jest tworzona kwerenda danych znajdujących się w tym widoku, a następnie na podstawie przebadanych danych jest tworzona tabela przestawna.

  1. Na wstążce kliknij kartę Lista, a następnie w grupie Arkusz danych kliknij pozycję Pokaż okienko zadań.
  2. W okienku zadań kliknij pozycję Utwórz raport w formie tabeli przestawnej programu Excel.

Program Excel eksportuje widok arkusza danych jako plik kwerendy sieci Web.

Jeśli podczas klikania pozycji Utwórz raport w formie tabeli przestawnej programu Excel program Excel jest uruchomiony, użytkownik może skorzystać z opcji importowania danych zawartych w pliku kwerendy sieci Web do istniejącego arkusza, nowego arkusza lub nowego skoroszytu. W innych sytuacjach jest otwierany nowy skoroszyt i program Excel importuje do niego widok arkusza danych. Zaimportowane dane są wyświetlane w postaci listy w arkuszu z łączem do informacji programu Microsoft SharePoint Foundation 2010. W programie Excel są wyświetlane: lista pól tabeli przestawnej i pasek narzędzi tabeli przestawnej, a następnie jest wyświetlany monit o utworzenie tabeli przestawnej.


Drukowanie widoku arkusza danych w programie Excel

W przypadku drukowania widoku arkusza danych w programie Microsoft Excel najpierw jest tworzona kwerenda danych znajdujących się w tym widoku, a następnie program Excel drukuje dane zwrócone przez tę kwerendę.

  1. Na wstążce kliknij kartę Lista, a następnie w grupie Arkusz danych kliknij pozycję Pokaż okienko zadań.
  2. W okienku zadań kliknij pozycję Drukuj w programie Excel.

Program Excel eksportuje widok arkusza danych jako plik kwerendy sieci Web.

Jeśli podczas klikania pozycji Drukuj w programie Excel program Excel jest uruchomiony, użytkownik może skorzystać z opcji importowania danych zawartych w pliku kwerendy sieci Web do istniejącego arkusza, nowego arkusza lub nowego skoroszytu. W innych sytuacjach jest otwierany nowy skoroszyt i program Excel importuje do niego widok arkusza danych. Zaimportowane dane są wyświetlane w postaci listy w arkuszu z łączem do informacji programu Microsoft SharePoint Foundation 2010. Następnie jest wyświetlany monit o wydrukowanie listy programu Excel.


Operatory obliczeniowe — informacje

Operatory określają typ obliczenia, które ma zostać wykonane na elementach formuły. W listach są obsługiwane trzy typy operatorów obliczeniowych: arytmetyczne, porównania i tekstowe.

Typy operatorów

Kolejność, w jakiej na liście są wykonywane operacje określone w formule

Ważne Formuł można używać tylko w kolumnach o typie danych Obliczeniowy. Typu danych kolumny nie można zmieniać na Obliczeniowy.

Typy operatorów

Operatory arytmetyczne Aby wykonywać podstawowe działania matematyczne, takie jak dodawanie, odejmowanie lub mnożenie, łączyć liczby, uzyskiwać wyniki numeryczne, należy użyć poniższych operatorów arytmetycznych.

Operator arytmetyczny | Znaczenie (przykład)
+ (znak plus) | Dodawanie (3+3)
– (znak minus) | Odejmowanie (3–1) Negacja (–1)
* (gwiazdka) | Mnożenie (3*3)
/ (kreska ułamkowa) | Dzielenie (3/3)
% (znak procent) | Procent (20%)
^ (daszek) | Potęgowanie (3^2)

Operatory porównania Za pomocą poniższych operatorów można porównywać dwie wartości. Wynik porównywania dwóch wartości za pomocą tych operatorów jest wartością logiczną Tak albo Nie.

Operator porównania | Znaczenie (przykład)
= (znak równości) | Równa się (A=B)
> (znak większości) | Większy niż (A>B)
< (znak mniejszości) | Mniejszy niż (A<B)
>= (znak większe lub równe) | Większy lub równy (A>=B)
<= (znak mniejsze lub równe) | Mniejszy lub równy (A<=B)
<> (znak nierówności) | Nie jest równy (A<>B)

Operator łączenia tekstów Operator & (handlowe i) służy do łączenia jednego lub kilku ciągów tekstowych w celu utworzenia pojedynczego fragmentu tekstu.

Operator tekstowy | Znaczenie (przykład)
& (handlowe i) | Łączy dwie wartości w celu utworzenia jednej ciągłej wartości tekstowej ("Północ"&"ny")

Początek strony

Kolejność, w jakiej na liście są wykonywane operacje określone w formule

Formuły obliczają wartości w określonej kolejności. Formuła listy może rozpoczynać się znakiem równości (=). Po znaku równości znajdują się elementy, które mają być obliczane (operandy), rozdzielone operatorami obliczeń. W listach formuła jest obliczana od lewej do prawej, według określonej kolejności dla poszczególnych operatorów w formule.

Priorytety operatorów

Jeśli kilka operatorów zostanie połączonych w jedną formułę, na listach będą wykonywane działania w kolejności przedstawionej w poniższej tabeli. Jeśli formuła zawiera operatory o tym samym priorytecie — na przykład operator mnożenia i operator dzielenia — operatory te będą oceniane na liście od lewej do prawej.

Operator | Opis
– | Negacja (tak jak w –1)
% | Procent
^ | Potęgowanie
* i / | Mnożenie i dzielenie
+ i – | Dodawanie i odejmowanie
& | Łączy dwa ciągi tekstu (złączanie)
= < > <= >= <> | Porównanie

Korzystanie z nawiasów

Aby zmienić kolejność obliczeń, należy umieścić w nawiasach część formuły, która ma zostać obliczona w pierwszej kolejności. Na przykład wykonanie poniższej formuły daje wynik 11, ponieważ na liście mnożenie jest wykonywane przed dodawaniem. W formule 2 jest mnożone przez 3, a następnie do wyniku tego działania jest dodawane 5.

=5+2*3

Jeśli jednak składnia formuły zostanie zmieniona przez wprowadzenie nawiasów, na liście zostaną dodane liczby 5 i 2, a wynik tego działania zostanie następnie pomnożony przez 3, co da wynik 21.

=(5+2)*3

W poniższym przykładzie nawiasy, w których znajduje się pierwsza część formuły, wymuszają wykonanie obliczenia na liście [Koszt]+25 w pierwszej kolejności, po czym wynik tego działania jest dzielony przez sumę wartości w kolumnach EC1 i EC2.

=([Koszt]+25)/SUMA([EC1]+[EC2])

Początek strony


Odwołania do kolumn w formule — informacje

Odwołanie określa komórkę w bieżącym wierszu arkusza danych i definiuje, gdzie lista ma szukać wartości lub danych, które mają zostać użyte w formule. Na przykład [Koszt] odwołuje się do wartości w kolumnie Koszt w bieżącym wierszu. Jeśli dla bieżącego wiersza w kolumnie Koszt znajduje się wartość 100, to =[Koszt]*3 da wynik 300.

Ważne Formuł można używać tylko w kolumnach o typie danych Obliczeniowy. Typu danych kolumny nie można zmieniać na Obliczeniowy.

Dzięki odwołaniom dane znajdujące się w różnych kolumnach listy mogą być używane w co najmniej jednej formule. W formule mogą znajdować się odwołania do kolumn z danymi następujących typów: jeden wiersz tekstu, liczba, waluta, data i godzina, opcja, tak/nie. Te typy danych mogą być obliczane.

Aby odwołać się do kolumny w formule, należy użyć nazwy wyświetlanej kolumny. Jeśli w nazwie znajduje się spacja lub znak specjalny, należy ją ująć w nawiasy kwadratowe ([ ]). W odwołaniach nie jest uwzględniana wielkość liter. Na przykład odwołanie do kolumny Cena jednostkowa można umieścić w formule jako [Cena jednostkowa] lub [cena jednostkowa].

Uwaga Odwołania do wartości nie można umieszczać w innym wierszu niż bieżący. W formule określonej jako wartość domyślna kolumny nie można umieszczać odwołań do kolumn.


Stałe w formułach — informacje

Stała jest wartością, która nie jest obliczana. Na przykład stałymi są: data 2008-10-09, liczba 210 i tekst „Dochody kwartalne”. Stałe można podzielić według następujących typów danych:

  • Ciąg (Przykład: =[Nazwisko] = "Kowalski")

    Stałe w postaci ciągów umieszcza się w cudzysłowach; mogą one mieć maksymalną długość 255 znaków.

  • Liczba (Przykład: =[Koszt] >= 29,99)

    Stałe numeryczne mogą zawierać kilka miejsc dziesiętnych, mogą być dodatnie lub ujemne.

  • Data (Przykład: =[Data] <> 2002-07-07)

    Stałe w postaci dat nie wymagają ograniczników.

  • Wyrażenie logiczne (Przykład: =JEŻELI([Koszt]>[Zysk]; "Strata"; "Bez straty")

    Tak i Nie są stałymi logicznymi. Można ich używać w wyrażeniach warunkowych. W powyższym przykładzie, jeśli koszt jest większy od zysku, użycie funkcji JEŻELI powoduje uzyskanie wyniku Tak, a formuła zwraca ciąg „Strata”. Jeśli koszt jest mniejszy lub równy zyskowi, użycie funkcji powoduje uzyskanie wartości Nie, a formuła zwraca ciąg „Bez straty”.


Wyświetlanie sum i obliczonych wartości — informacje

Na liście składnika Access Web Datasheet można wykonywać różne obliczenia. Dla danej kolumny listy można wyświetlać wartości zagregowane, takie jak suma i średnia. Można dodawać kolumny obliczeniowe, w których jest używana formuła umożliwiająca obliczanie wartości dla poszczególnych wierszy listy. Podczas określania wartości domyślnej kolumny można także korzystać z formuł.

Na poniższej ilustracji pokazano listę płac pracowników w składniku Access Web Datasheet. U dołu listy w wierszu Suma są wyświetlane wartości zagregowane, a kolumna obliczeniowa ma tytuł Wypłata netto.

Arkusz danych z obliczeniem i sumami

W wierszu Suma jest wyświetlana liczba wierszy w kolumnie Osoba i suma wartości w kolumnie Wypłata netto. W kolumnie Wypłata netto jest używana formuła wyświetlana na etykietce ekranowej, dzięki której są obliczane wartości poszczególnych wierszy.

Wyświetlanie wartości zagregowanych — informacje

Wyświetlanie obliczonych wartości w kolumnie — informacje

Obliczanie wartości domyślnych kolumny przy użyciu formuły — informacje

Wyświetlanie wartości zagregowanych — informacje

W widoku arkusza danych można wyświetlić lub ukryć wiersz Suma, klikając pozycję Pokaż sumy na karcie Lista wstążki. Początkowo w wierszu Suma są wyświetlane sumy dla poszczególnych kolumn liczbowych na liście. Jeśli lista nie zawiera żadnych kolumn liczbowych, w ostatniej kolumnie listy jest wyświetlana liczba elementów. Wartości wyświetlanych w wierszu Suma nie można edytować.

Po włączeniu wiersza Suma można wyświetlać i ukrywać wartości zagregowane danej kolumny. Można także zmieniać funkcję agregującą używaną w kolumnie, wybierając po prostu inną funkcję z listy rozwijanej w wierszu Suma. Etykietka ekranowa wyświetlana po ustawieniu wskaźnika myszy na wartości zagregowanej określa funkcję agregującą używaną w kolumnie.

Nie można filtrować danych z listy na podstawie wartości zagregowanych. Jeśli jednak lista jest filtrowana, wartości zagregowane są obliczane tylko na podstawie elementów zawartych w zwracanym zestawie. Wiersz Suma nie jest sortowany wraz z innymi wierszami listy.

W poniższej tabeli przedstawiono funkcje agregujące obsługiwane na liście oraz typy danych obsługujące poszczególne funkcje.

Nazwa funkcji | Opis | Typy danych obsługujące funkcję
Średnia | Zwraca średnią wartości w sumowanej kolumnie. | Liczba, Waluta, Data/godzina
Ile liczb | Kontroluje liczbę wartości. W przypadku typów Wartość logiczna, Załącznik i kolumn Ikona dokumentu są uwzględniane tylko wartości Tak. | Liczba, Waluta, Data/godzina, Wartość logiczna, Załącznik, Ikona dokumentu, Tekst krótki, Tekst wielowierszowy, Wybór pojedynczy, Wybór wielokrotny, Odnośnik, Hiperłącze
Maksimum | Zwraca największą wartość w sumowanej kolumnie. | Liczba, Waluta, Data/godzina
Minimum | Zwraca najmniejszą wartość w sumowanej kolumnie. | Liczba, Waluta, Data/godzina
Suma | Oblicza sumę wartości w kolumnie. | Liczba, Waluta
Odchylenie standardowe | Zwraca standardowe odchylenie wartości w sumowanej kolumnie przy założeniu, że wartości stanowią próbkę większej populacji. | Liczba, Waluta
Wariancja | Zwraca wariancję wartości w sumowanej kolumnie przy założeniu, że wartości stanowią próbkę większej populacji. | Liczba, Waluta

Kliknięcie strzałki listy rozwijanej w komórce w wierszu Suma spowoduje wyświetlenie na liście opcji Brak oraz innych funkcji agregujących. Opcję Brak należy wybrać w przypadku kolumny, która nie ma być sumowana.

Można sumować wartości w kolumnie obliczeniowej. Dostępność funkcji w kolumnie zależy od typu danych wartości uzyskanej w wyniku obliczeń.

Początek strony

Wyświetlanie obliczonych wartości w kolumnie — informacje

Kolumnę obliczeniową można dodać do listy wartości obliczeniowych przy użyciu odpowiedniej formuły. Formuła może odwoływać się tylko do wartości w innych kolumnach w tym samym wierszu. Nie można odwoływać się do określonej komórki lub zakresu komórek w formule.

Obliczone wartości są przechowywane w kolumnie, ale nie można ich edytować. Gdy wartości, do których formuła się odwołuje, ulegną zmianie, wartość w kolumnie obliczeniowej na liście zostanie przeliczona automatycznie.

Etykietka ekranowa wyświetlana po umieszczeniu wskaźnika myszy na obliczonej wartości zawiera informacje o formule używanej w kolumnie. Formułę można edytować przez zaznaczenie komórki, w której ta formuła jest używana, i przejście do trybu edycji. Po zakończeniu edytowania formuły i wyjściu z trybu edycji nowe wartości są automatycznie obliczane i wyświetlane w kolumnie.

Wartości w kolumnie obliczeniowej można sortować i filtrować.

Początek strony

Obliczanie wartości domyślnych kolumny przy użyciu formuły — informacje

W przypadku dodawania do listy kolumny określonego typu, takiego jak pojedynczy wiersz, opcja, liczba, waluta lub data i godzina, jako wartość domyślną można określić formułę zamiast stałej. Po dodaniu nowego wiersza formuła zostanie wykonana na liście i zostanie wyświetlony wynik, który będzie wartością domyślną w kolumnie.

W przypadku określania formuły jako wartości domyślnej można wywołać dowolną z obsługiwanych funkcji, ale formuła nie może odwoływać się do innych kolumn. W związku z tym, że formuła będzie wykonywana przed wprowadzeniem danych w innych kolumnach, używanie odwołań kolumn jest niedozwolone.

Początek strony


Formuły — informacje

Formuły są równaniami wykonującymi obliczenia na wartościach z listy. Formuła rozpoczyna się znakiem równości (=). Na przykład poniższa formuła mnoży 2 przez 3, a następnie dodaje do wyniku 5.

=5+2*3

Formuły można użyć w kolumnie obliczeniowej i w celu obliczenia wartości domyślnych kolumny.

Ważne Formuł można używać tylko w kolumnach o typie danych Obliczeniowy. Typu danych kolumny nie można zmieniać na Obliczeniowy.

Formuła może także zawierać dowolne z następujących elementów: funkcje, odwołania kolumn, operatory i stałe.

Składniki formuły
=PI()*[Wynik]^2

Funkcje Funkcja PI() zwraca wartość pi: 3,142...

Odwołania (lub nazwy kolumn) [Wynik] reprezentuje wartość w kolumnie Wynik dla bieżącego wiersza.

Stałe Liczby lub wartości tekstowe wprowadzane bezpośrednio w formule, np. 2.

Operatory Operator ^ (karetka) podnosi liczbę do potęgi, a operator * (gwiazdka) mnoży liczbę.

Przykłady

W formule może zostać użyty co najmniej jeden z powyższych elementów. Poniżej przedstawiono kilka przykładowych formuł (według złożoności).

  • Formuły proste (np. =128+345)

    Poniższe formuły zawierają wartości literałów i operatory.

    Przykład | Opis
    =128+345 | Dodaje 128 i 345.
    =5^2 | Podnosi 5 do kwadratu.
  • Formuły zawierające odwołania do kolumn (np. =[Zysk] – [Koszt])

    Poniższe formuły odnoszą się do kolumn na tej samej liście.

    Przykład | Opis
    =[Zysk] | Użyj wartości w kolumnie Zysk.
    =[Zysk]*10/100 | 10% wartości w kolumnie Zysk.
    =[Zysk] > [Koszt] | Zwraca Tak, jeśli wartość w kolumnie Zysk jest większa niż wartość w kolumnie Koszt.
  • Formuły, które mogą wywoływać funkcje (np. =ŚREDNIA(1; 2; 3; 4; 5))

    Poniższe formuły wywołują funkcje wbudowane.

    Przykład | Opis
    =MAX(K1; K2; K3; K4) | Zwraca największą wartość w zestawie wartości.
    =JEŻELI(Koszt>Zysk; "Nie OK"; "OK") | Zwraca komunikat Nie OK, jeśli koszt jest większy niż zysk. W przeciwnym wypadku zwraca komunikat OK.
    =DZIEŃ("15-kwi-2008") | Zwraca część daty określającą dzień. Ta formuła zwraca liczbę 15.
  • Formuły z funkcjami zagnieżdżonymi (np. =SUMA(ZAOKR([Koszt];2);[Zysk])

    Poniższe formuły określają co najmniej jedną funkcję jako argumenty funkcji.

    Przykład Opis
    =SUMA(JEŻELI(A>B; A–B; 10); C) Funkcja JEŻELI zwraca różnicę między wartościami w kolumnach A i B lub 10.

    Funkcja SUMA dodaje wartość zwróconą przez funkcję JEŻELI i wartość w kolumnie C.

    =STOPNIE(PI()) Funkcja PI zwraca liczbę 3,14159265358979.

    Funkcja STOPNIE konwertuje wartość w radianach na wartość w stopniach. Ta formuła zwraca wartość 180.
    =CZY.LICZBA(ZNAJDŹ("BD";Kolumna1)) Funkcja ZNAJDŹ wyszukuje ciąg BD w Kolumnie1 i zwraca informacje o pozycji początkowej ciągu. Jeśli ciąg nie zostanie znaleziony, zwraca błędną wartość.

    Funkcja CZY.LICZBA zwraca wartość Tak, jeśli funkcja ZNAJDŹ zwróciła wartość numeryczną. W przeciwnym wypadku zwraca wartość Nie.


Edytowanie formuły

  1. Kliknij dowolną komórkę w kolumnie obliczeniowej.
  2. Kliknij ponownie komórkę, aby wyświetlić bieżącą formułę.
  3. Przeprowadź edycję formuły i naciśnij klawisz Enter.

    Uwaga Po wpisaniu w kolumnie obliczeniowej znaku równości (=) można wkleić odwołanie do kolumny, po prostu klikając komórkę w tej kolumnie, która należy do bieżącego wiersza. Jeśli jednak dla tej kolumny ustawiono typ danych, który uniemożliwia wykonywanie obliczeń, przy próbie zaznaczenia komórki w innym wierszu lub wybrania więcej niż jednej komórki odwołanie do kolumny nie zostanie wklejone do formuły na liście.

  4. Kliknij przycisk Kontynuuj, aby potwierdzić zmiany.
  5. Jeśli wystąpiły konflikty lub błędy albo istnieją zmiany oczekujące na wprowadzenie na liście, zostanie wyświetlony monit o zastosowanie lub odrzucenie wprowadzonych zmian. Zmiana formuły powoduje zmianę struktury listy, więc nowa formuła zadziała dopiero po przesłaniu wszystkich zmian do serwera lub ich odrzuceniu oraz wyeliminowaniu wszystkich konfliktów i błędów z listy.

    Kliknij przycisk OK, aby zatwierdzić zmiany, rozwiązać konflikty i usunąć błędy.

  6. Zmiany oczekujące zostaną wysłane z listy do serwera. Jeśli wystąpiły konflikty i błędy, zostanie wyświetlone okno dialogowe Rozwiązywanie konfliktów i poprawianie błędów. Zaakceptuj lub odrzuć zmiany.

Ważne Formuł można używać tylko w kolumnach o typie danych Obliczeniowy. Typu danych kolumny nie można zmieniać na Obliczeniowy.


Przykłady typowych formuł

Poniższych przykładowych formuł można używać w kolumnach obliczeniowych. Przykłady, w których nie występują odwołania do kolumn, można wykorzystać przy określaniu domyślnej wartości kolumny.

Ważne Formuł można używać tylko w kolumnach o typie danych Obliczeniowy. Typu danych kolumny nie można zmieniać na Obliczeniowy.

Formuły warunkowe

Pokaż Sprawdzanie, czy liczba jest większa lub mniejsza niż inna liczba

W tym celu należy użyć funkcji JEŻELI.

Kolumna1 | Kolumna2 | Formuła | Opis
15 000 | 9000 | =Kolumna1>Kolumna2 | Czy wartość Kolumna1 jest większa niż wartość Kolumna2? (Tak)
15 000 | 9000 | =JEŻELI(Kolumna1<=Kolumna2; "OK"; "Nie OK") | Czy wartość Kolumna1 jest mniejsza niż wartość Kolumna2 lub jej równa? (Nie OK)

Pokaż Zwracanie wartości logicznej po porównaniu zawartości kolumn

W przypadku wyniku, który jest wartością logiczną (Tak lub Nie), należy użyć funkcji ORAZ, LUB i NIE.
Kolumna1 | Kolumna2 | Kolumna3 | Formuła | Opis
15 | 9 | 8 | =ORAZ(Kolumna1>Kolumna2; Kolumna1<Kolumna3) | Czy 15 jest większe niż 9 i mniejsze niż 8? (Nie)
15 | 9 | 8 | =LUB(Kolumna1>Kolumna2; Kolumna1<Kolumna3) | Czy 15 jest większe niż 9 lub mniejsze niż 8? (Tak)
15 | 9 | 8 | =NIE(Kolumna1+Kolumna2=24) | Czy 15 plus 9 nie jest równe 24? (Nie)

Aby uzyskać wynik, który jest innym obliczeniem, lub inną dowolną wartość różną od Tak lub Nie, należy użyć funkcji JEŻELI, ORAZ i LUB.

Kolumna1 | Kolumna2 | Kolumna3 | Formuła | Opis
15 | 9 | 8 | =JEŻELI(Kolumna1=15; "OK"; "Nie OK") | Jeśli wartość w Kolumnie1 równa się 15, zwracany jest tekst „OK”. (OK)
15 | 9 | 8 | =JEŻELI(ORAZ(Kolumna1>Kolumna2; Kolumna1<Kolumna3); "OK"; "Nie OK") | Jeśli 15 jest większe niż 9 i mniejsze niż 8, zwracany jest tekst „OK”. (Nie OK)
15 | 9 | 8 | =JEŻELI(LUB(Kolumna1>Kolumna2; Kolumna1<Kolumna3); "OK"; "Nie OK") | Jeśli 15 jest większe niż 9 lub mniejsze niż 8, zwracany jest tekst „OK”. (OK)

Pokaż Wyświetlanie zer jako pustych miejsc lub znaków łącznika

W tym celu należy użyć funkcji JEŻELI.
Kolumna1 | Kolumna2 | Formuła | Opis
10 | 10 | =Kolumna1-Kolumna2 | Druga liczba odjęta od pierwszej (0)
10 | 10 | =JEŻELI(Kolumna1-Kolumna2;"";Kolumna1-Kolumna2) | Zwraca zero, gdy wartość wynosi zero (pusta kolumna)
15 | 9 | =JEŻELI(Kolumna1-Kolumna2;"-";Kolumna1-Kolumna2) | Zwraca kreskę, gdy wartość jest równa zero (-)

Formuły daty i godziny

Pokaż Dodawanie dat

Aby dodać liczbę dni do daty, należy użyć operatora dodawania (+). Należy zauważyć, że przy manipulowaniu datami zwracanym typem obliczanej kolumny musi być Data i godzina.
Kolumna1 | Kolumna2 | Formuła | Opis
2007-06-09 | 3 | =Kolumna1+Kolumna2 | Dodanie 3 dni do daty 2007-06-09 (2007-06-12)
2008-12-10 | 54 | =Kolumna1+Kolumna2 | Dodanie 54 dni do daty 2008-12-10 (2009-02-02)

Aby dodać liczbę miesięcy do daty, należy użyć funkcji DATA, ROK, MIESIĄC i DZIEŃ.

Kolumna1 | Kolumna2 | Formuła | Opis
2007-06-09 | 3 | =DATA(ROK(Kolumna1);MIESIĄC(Kolumna1)+Kolumna2;DZIEŃ(Kolumna1)) | Dodanie 3 miesięcy do daty 2007-06-09 (2007-09-09)
2008-12-10 | 25 | =DATA(ROK(Kolumna1);MIESIĄC(Kolumna1)+Kolumna2;DZIEŃ(Kolumna1)) | Dodanie 25 miesięcy do daty 2008-12-10 (2011-01-10)

Aby dodać liczbę lat do daty, należy użyć funkcji DATA, ROK, MIESIĄC i DZIEŃ.

Kolumna1 | Kolumna2 | Formuła | Opis
2007-06-09 | 3 | =DATA(ROK(Kolumna1)+Kolumna2;MIESIĄC(Kolumna1);DZIEŃ(Kolumna1)) | Dodanie 3 lat do daty 2007-06-09 (2010-06-09)
2008-12-10 | 25 | =DATA(ROK(Kolumna1)+Kolumna2;MIESIĄC(Kolumna1);DZIEŃ(Kolumna1)) | Dodanie 25 lat do daty 2008-12-10 (2033-12-10)

Aby dodać kombinację dni, miesięcy i lat do daty, należy użyć funkcji DATA, ROK, MIESIĄC i DZIEŃ.

Kolumna1 | Formuła | Opis
2007-06-09 | =DATA(ROK(Kolumna1)+3;MIESIĄC(Kolumna1)+1;DZIEŃ(Kolumna1)+5) | Dodanie 3 lat, 1 miesiąca i 5 dni do daty 2007-06-09 (2010-07-14)
2007-06-09 | =DATA(ROK(Kolumna1)+1;MIESIĄC(Kolumna1)+7;DZIEŃ(Kolumna1)+5) | Dodanie 1 roku, 7 miesięcy i 5 dni do daty 09-06-2007 (2009-01-14)

Pokaż Obliczanie różnicy między dwiema datami

W tym celu należy użyć funkcji DATA.RÓŻNICA.
Kolumna1 | Kolumna2 | Formuła | Opis
01-sty-1995 | 15-cze-1999 | =DATA.RÓŻNICA(Kolumna1; Kolumna2;"d") | Zwrócenie liczby dni między dwiema datami (1626)
01-sty-1995 | 15-cze-1999 | =DATARÓŻNICA(Kolumna1; Kolumna2;"rm") | Zwrócenie liczby miesięcy między datami, bez uwzględnienia roku (5)
01-sty-1995 | 15-cze-1999 | =DATARÓŻNICA(Kolumna1; Kolumna2;"rd") | Zwrócenie liczby dni między datami, bez uwzględnienia roku (165)

Pokaż Obliczanie różnicy między dwiema wartościami czasu

Aby wyświetlić wynik w standardowym formacie (godziny:minuty:sekundy), należy użyć operatora odejmowania (-) i funkcji TEKST.

Aby ta metoda była skuteczna, liczba godzin nie może przekraczać 24, a liczba minut i sekund nie może przekraczać 60.

Kolumna1 | Kolumna2 | Formuła | Opis
2007-06-09 10:35 | 2007-06-09 15:30 | =TEKST(Kolumna2-Kolumna1;"g") | Liczba godzin między dwoma wskazaniami czasu (4)
2007-06-09 10:35 | 2007-06-09 15:30 | =TEKST(Kolumna2-Kolumna1;"g:mm") | Liczba godzin i minut między dwoma wskazaniami czasu (4:55)
2007-06-09 10:35 | 2007-06-09 15:30 | =TEKST(Kolumna2-Kolumna1;"g:mm:ss") | Godziny, minuty i sekundy między dwoma wskazaniami czasu (4:55:00)

Aby wyświetlić cały wynik na podstawie jednostki czasu, należy użyć funkcji ZAOKR.DO.CAŁK lub funkcji GODZINA, MINUTA i SEKUNDA.

Kolumna1 | Kolumna2 | Formuła | Opis
2007-06-09 10:35 | 2007-06-10 15:30 | =ZAOKR.DO.CAŁK((Kolumna2-Kolumna1)*24) | Całkowita liczba godzin między dwiema wartościami czasu (28)
2007-06-09 10:35 | 2007-06-10 15:30 | =ZAOKR.DO.CAŁK((Kolumna2-Kolumna1)*1440) | Całkowita liczba minut między dwiema wartościami czasu (1735)
2007-06-09 10:35 | 2007-06-10 15:30 | =ZAOKR.DO.CAŁK((Kolumna2-Kolumna1)*86 400) | Całkowita liczba sekund między dwiema wartościami czasu (104 100)
2007-06-09 10:35 | 2007-06-10 15:30 | =GODZINA(Kolumna2-Kolumna1) | Liczba godzin między dwoma wskazaniami czasu, gdy różnica nie przekracza 24 (4)
2007-06-09 10:35 | 2007-06-10 15:30 | =MINUTA(Kolumna2-Kolumna1) | Liczba minut między dwoma wskazaniami czasu, gdy różnica nie przekracza 60 (55)
2007-06-09 10:35 | 2007-06-10 15:30 | =SEKUNDA(Kolumna2-Kolumna1) | Liczba sekund między dwoma wskazaniami czasu, gdy różnica nie przekracza 60 (0)

Pokaż Konwertowanie wartości czasu

Aby przekonwertować godziny ze standardowego formatu czasu na liczbę dziesiętną, należy użyć funkcji ZAOKR.DO.CAŁK.
Kolumna1 | Formuła | Opis
10:35 | =(Kolumna1-ZAOKR.DO.CAŁK(Kolumna1))*24 | Liczba godzin, jakie upłynęły od północy (10,583333)
12:15 | =(Kolumna1-ZAOKR.DO.CAŁK(Kolumna1))*24 | Liczba godzin, jakie upłynęły od północy (12,25)

Aby konwertować godziny z formatu dziesiętnego na standardowy (godziny:minuty:sekundy), należy użyć operatora dzielenia i funkcji TEKST.

Kolumna1 | Formuła | Opis
10,5833 | =TEKST(Kolumna1/24; "g:mm") | Godzina liczona od północy (10:35)
12,25 | =TEKST(Kolumna1/24; "g:mm") | Godzina liczona od północy (12:15)

Pokaż Wstawianie dat w formacie juliańskim

Określenie „data juliańska” czasami dotyczy formatu daty, który jest połączeniem bieżącego roku i liczby dni od początku roku. Na przykład data 1 stycznia 2007 r. ma postać 2007001, a data 31 grudnia 2007 r. ma postać 2003356.

Daty juliańskie są zwykle stosowane w astronomii; jest to system dat kolejnych rozpoczynających się 1 stycznia 4713 p.n.e.

Uwaga Ten format nie jest oparty na kalendarzu juliańskim.

Aby przekonwertować datę na format juliański, należy użyć funkcji TEKST i DATA.WARTOŚĆ.

Kolumna1 | Formuła | Opis
2007-06-23 | =TEKST(Kolumna1;"rr")&TEKST((Kolumna1-DATA.WARTOŚĆ("1/1/"& TEKST(Kolumna1;"rr"))+1);"000") | Data w formacie juliańskim z rokiem wyrażonym za pomocą dwóch cyfr (07174)
2007-06-23 | =TEKST(Kolumna1;"rrrr")&TEKST((Kolumna1-DATA.WARTOŚĆ("1/1/"&TEKST(Kolumna1;"rr"))+1);"000") | Data w formacie juliańskim z rokiem wyrażonym za pomocą czterech cyfr (2007174)

Aby przekonwertować datę na format juliański używaną w astronomii, należy użyć stałej 2415018,50.

Ta formuła działa tylko w przypadku dat po 1901-03-01 oraz gdy jest używany system datowania 1900.

Kolumna1 | Formuła | Opis
2007-06-23 | =Kolumna1+2415018,50 | Data w formacie juliańskim używana w astronomii (2454274,50)

Pokaż Wyświetlanie dat jako dni tygodnia

Aby przekonwertować daty na tekst nazwy dnia tygodnia, należy użyć funkcji TEKST i DZIEŃ.TYG.
Kolumna1 | Formuła | Opis
19-lut-2007 | =TEKST(DZIEŃ.TYG(Kolumna1); "dddd") | Obliczenie dnia tygodnia daty i zwrócenie pełnej nazwy dnia (poniedziałek)
3-sty-2008 | =TEKST(DZIEŃ.TYG(Kolumna1); "ddd") | Obliczenie dnia tygodnia daty i zwrócenie skróconej nazwy dnia (czw)

Formuły matematyczne

Pokaż Dodawanie liczb

Aby dodać liczby w co najmniej dwóch kolumnach w wierszu, należy użyć operatora dodawania lub funkcji SUMA.

Kolumna1 | Kolumna2 | Kolumna3 | Formuła | Opis
6 | 5 | 4 | =Kolumna1+Kolumna2+Kolumna3 | Dodanie wartości w pierwszych trzech kolumnach (15)
6 | 5 | 4 | =SUMA(Kolumna1;Kolumna2;Kolumna3) | Dodanie wartości w pierwszych trzech kolumnach (15)
6 | 5 | 4 | =SUMA(JEŻELI(Kolumna1>Kolumna2; Kolumna1-Kolumna2; 10), Kolumna3) | Jeśli wartość Kolumna1 jest większa niż wartość Kolumna2, zostanie dodana różnica i wartość Kolumna3. W przeciwnym wypadku zostanie dodana wartość 10 i wartość Kolumna3. (5)

Pokaż Odejmowanie liczb

W tym celu należy użyć operatora odejmowania (-).
Kolumna1 | Kolumna2 | Kolumna3 | Formuła | Opis
15 000 | 9000 | -8000 | =Kolumna1-Kolumna2 | Odjęcie 9000 od 15 000 (6000)
15 000 | 9000 | -8000 | =SUMA(Kolumna1; Kolumna2; Kolumna3) | Dodanie liczb w pierwszych trzech kolumnach, w tym wartości ujemnych (16 000)

Pokaż Obliczanie różnicy procentowej między dwiema liczbami

Należy użyć operatorów odejmowania (-) i dzielenia (/) oraz funkcji MODUŁ.LICZBY.
Kolumna1 | Kolumna2 | Formuła | Opis
2342 | 2500 | =(Kolumna2-Kolumna1)/MODUŁ.LICZBY(Kolumna1) | Zmiana procentowa (6,75% lub 0,06746)

Pokaż Mnożenie liczb

W tym celu należy użyć operatora mnożenia (*) lub funkcji ILOCZYN.
Kolumna1 | Kolumna2 | Formuła | Opis
5 | 2 | =Kolumna1*Kolumna2 | Mnoży liczby w pierwszych dwóch kolumnach. (10)
5 | 2 | =ILOCZYN(Kolumna1; Kolumna2) | Mnoży liczby w pierwszych dwóch kolumnach. (10)
5 | 2 | =ILOCZYN(Kolumna1;Kolumna2;2) | Mnoży liczby w pierwszych dwóch kolumnach i liczbę 2. (20)

Pokaż Dzielenie liczb

W tym celu należy użyć operatora dzielenia (/).

Kolumna1 | Kolumna2 | Formuła | Opis
15 000 | 12 | =Kolumna1/Kolumna2 | Dzieli liczbę 15 000 przez liczbę 12. (1250)
15 000 | 12 | =(Kolumna1+9000)/Kolumna2 | Dodaje 15 000 i 9000, a następnie dzieli sumę przez 12. (2000)

Pokaż Obliczanie średniej liczb

Średnia jest również zwana wartością przeciętną. Aby obliczyć średnią liczb z co najmniej dwóch kolumn w wierszu, należy użyć funkcji ŚREDNIA.

Kolumna1 | Kolumna2 | Kolumna3 | Formuła | Opis
6 | 5 | 4 | =ŚREDNIA(Kolumna1; Kolumna2;Kolumna3) | Średnia liczb w pierwszych trzech kolumnach (5)
6 | 5 | 4 | =ŚREDNIA(JEŻELI(Kolumna1>Kolumna2; Kolumna1-Kolumna2; 10); Kolumna3) | Jeśli wartość Kolumna1 jest większa niż wartość Kolumna, oblicza średnią różnicy i wartości Kolumna3. W przeciwnym wypadku oblicza średnią wartości 10 i wartości Kolumna3. (2,5)

Pokaż Obliczanie mediany liczb

Mediana jest wartością w środku uporządkowanego ciągu liczb. Funkcja MEDIANA służy do obliczania mediany zbioru liczb.
A | B | C | D | E | F | Formuła | Opis
10 | 7 | 9 | 27 | 0 | 4 | =MEDIANA(A; B; C; D; E; F) | Mediana liczb w pierwszych 6 kolumnach (8)

Pokaż Obliczanie najmniejszej lub największej liczby w zakresie

Aby obliczyć najmniejszą lub największą liczbę w co najmniej dwóch kolumnach w wierszu, należy użyć funkcji MIN i MAX.
Kolumna1 | Kolumna2 | Kolumna3 | Formuła | Opis
10 | 7 | 9 | =MIN(Kolumna1; Kolumna2; Kolumna3) | Najmniejsza liczba (7)
10 | 7 | 9 | =MAX(Kolumna1; Kolumna2; Kolumna3) | Największa liczba (10)

Pokaż Obliczanie wartości

Aby obliczyć wartości numeryczne, należy użyć funkcji ILE.LICZB.
Kolumna1 | Kolumna2 | Kolumna3 | Formuła | Opis
Jabłoń |  | 2007-12-12 | =ILE.LICZB(Kolumna1; Kolumna2; Kolumna3) | Oblicza liczbę kolumn zawierających wartości numeryczne, w tym datę i wartości czasu, z pominięciem tekstu i wartości zerowych. (1)
12 PLN | #DZIEL/0! | 1,01 | =ILE.LICZB(Kolumna1; Kolumna2; Kolumna3) | Oblicza liczbę kolumn zawierających wartości numeryczne, ale z pominięciem wartości błędnych i wartości logicznych. (2)

Pokaż Zmniejszanie lub zwiększanie liczby o wartość procentową

W tym celu należy użyć operatora procentowego (%).
Kolumna1 | Kolumna2 | Formuła | Opis
23 | 3% | =Kolumna1*(1+5%) | Zwiększenie liczby w Kolumnie1 o 5% (24,15)
23 | 3% | =Kolumna1*(1+Kolumna2) | Zwiększenie liczby w Kolumnie1 o wartość procentową w Kolumnie2: 3% (23,69)
23 | 3% | =Kolumna1*(1-Kolumna2) | Zmniejszenie liczby w Kolumnie1 o wartość procentową w Kolumnie2: 3% (22,31)

Pokaż Podnoszenie liczby do potęgi

W tym celu należy użyć operatora potęgowania (^) lub funkcji POTĘGA.
Kolumna1 | Kolumna2 | Formuła | Opis
5 | 2 | =Kolumna1^Kolumna2 | Oblicza drugą potęgę liczby pięć. (25)
5 | 3 | =POTĘGA(Kolumna1; Kolumna2) | Oblicza trzecią potęgę liczby pięć. (125)

Pokaż Zaokrąglanie liczby

Aby zaokrąglić liczbę w górę, należy użyć funkcji ZAOKR.GÓRA, ZAOKR.DO.NPARZ i ZAOKR.DO.PARZ.

Kolumna1 | Formuła | Opis
20,3 | =ZAOKR.GÓRA(Kolumna1;0) | Zaokrągla liczbę 20,3 w górę do najbliższej liczby całkowitej. (21)
-5,9 | =ZAOKR.GÓRA(Kolumna1;0) | Zaokrągla liczbę -5,9 w górę. (-6)
12,5493 | =ZAOKR.GÓRA(Kolumna1;2) | Zaokrągla liczbę 12,5493 w górę do najbliższej setnej, czyli dwóch miejsc dziesiętnych. (12,55)
20,3 | =ZAOKR.DO.PARZ(Kolumna1) | Zaokrągla liczbę 20,3 w górę do najbliższej liczby parzystej. (22)
20,3 | =ZAOKR.DO.NPARZ(Kolumna1) | Zaokrągla liczbę 20,3 w górę do najbliższej liczby nieparzystej. (21)

Aby zaokrąglić liczbę w dół, należy użyć funkcji ZAOKR.DÓŁ.

Kolumna1 | Formuła | Opis
20,3 | =ZAOKR.DÓŁ(Kolumna1;0) | Zaokrągla liczbę 20,3 w dół do najbliższej liczby całkowitej. (20)
-5,9 | =ZAOKR.DÓŁ(Kolumna1;0) | Zaokrągla liczbę -5,9 w dół. (-5)
12,5493 | =ZAOKR.DÓŁ(Kolumna1;2) | Zaokrągla liczbę 12,5493 w dół do najbliższej setnej, dwa miejsca po przecinku (12,54)

Aby zaokrąglić liczbę do najbliższej liczby lub ułamka, należy użyć funkcji ZAOKR.

Kolumna1 | Formuła | Opis
20,3 | =ZAOKR(Kolumna1;0) | Zaokrągla liczbę 20,3 w dół, ponieważ część po przecinku jest mniejsza niż 0,5. (20)
5,9 | =ZAOKR(Kolumna1;0) | Zaokrągla liczbę 5,9 w górę, ponieważ część po przecinku jest większa niż 0,5. (6)
-5,9 | =ZAOKR(Kolumna1;0) | Zaokrągla liczbę -5,9 w dół, ponieważ część po przecinku jest mniejsza niż -0,5. (-6)
1,25 | =ZAOKR(Kolumna1; 1) | Zaokrągla liczbę do najbliższej dziesiętnej (jednego miejsca dziesiętnego). W związku z tym, że zaokrąglana część jest większa niż lub równa 0,05, liczba jest zaokrąglana w górę (wynik: 1,3).
30,452 | =ZAOKR(Kolumna1; 2) | Zaokrągla liczbę do najbliższej setnej (dwóch miejsc dziesiętnych). W związku z tym, że zaokrąglana część, 0,002, jest mniejsza niż 0,005, liczba jest zaokrąglana w dół (wynik: 30,45).

Aby zaokrąglić liczbę do cyfry znaczącej większej niż 0, należy użyć funkcji ZAOKR, ZAOKR.GÓRA, ZAOKR.DÓŁ, ZAOKR.DO.CAŁK i DŁ.

Kolumna1 | Formuła | Opis
5 492 820 | =ZAOKR(Kolumna1;3-DŁ(ZAOKR.DO.CAŁK(Kolumna1))) | Zaokrągla liczbę do 3 cyfr znaczących. (5 490 000)
22 230 | =ZAOKR.DÓŁ(Kolumna1;3-DŁ(ZAOKR.DO.CAŁK(Kolumna1))) | Zaokrągla dolną liczbę w dół do 3 cyfr znaczących. (22 200)
5 492 820 | =ZAOKR.GÓRA(Kolumna1; 5-DŁ(ZAOKR.DO.CAŁK(Kolumna1))) | Zaokrągla górną liczbę w górę do 5 cyfr znaczących. (5 492 900)

Formuły tekstowe

Pokaż Zmienianie wielkości liter

W tym celu należy użyć funkcji LITERY.WIELKIE, LITERY.MAŁE lub Z.WIELKIEJ.LITERY.
Kolumna1 | Formuła | Opis
greta Szypuła | =LITERY.WIELKIE(Kolumna1) | Zmiana liter tekstu na wielkie (GRETA SZYPUŁA)
greta Szypuła | =LITERY.MAŁE(Kolumna1) | Zmiana liter tekstu na małe (greta szypuła)
greta Szypuła | =Z.WIELKIEJ.LITERY(Kolumna1) | Zmiana liter tekstu zgodnie z zasadami obowiązującymi w nazwach własnych (Greta Szypuła)

Pokaż Łączenie imion i nazwisk

W tym celu należy użyć znaku handlowego „i” (&) lub funkcji ZŁĄCZ.TEKSTY.
Kolumna1 | Kolumna2 | Formuła | Opis
Anna | Misiec | =Kolumna1&Kolumna2 | Połączenie dwóch ciągów (AnnaMisiec)
Anna | Misiec | =Kolumna1&" "&Kolumna2 | Połączenie dwóch ciągów i oddzielenie ich spacją (Anna Misiec)
Anna | Misiec | =Kolumna2&","&Kolumna1 | Połączenie dwóch ciągów i oddzielenie ich przecinkiem (Misiec, Anna)
Anna | Misiec | =ZŁĄCZ.TEKSTY(Kolumna2; ","; Kolumna1) | Połączenie dwóch ciągów i oddzielenie ich przecinkiem (Misiec,Anna)

Pokaż Łączenie tekstu i liczb z różnych kolumn

W tym celu należy użyć funkcji ZŁĄCZ.TEKSTY i TEKST oraz znaku handlowego „i” (&).
Kolumna1 | Kolumna2 | Formuła | Opis
Bochenek | 28 | =Kolumna1&" sprzedał(a) "&Kolumna2&" sztuk." | Połączenie podanej zawartości w wyrażenie (Bochenek sprzedał(a) 28 sztuk.)
Dubicki | 40% | =Kolumna1&" uzyskał(a) wynik "&TEKST(Kolumna2;"0%")&" całkowitej sprzedaży." | Połączenie podanej zawartości w wyrażenie (Dubicki uzyskał(a) wynik 40% całkowitej sprzedaży.) Uwaga Funkcja TEKST dołącza wartość sformatowaną z Kolumny2 zamiast wartości podstawowej, którą było 0,4.
Bochenek | 28 | =ZŁĄCZ.TEKSTY(Kolumna1;" sprzedał(a) ";Kolumna2;" sztuk.") | Połączenie podanej zawartości w wyrażenie (Bochenek sprzedał(a) 28 sztuk.)

Pokaż Łączenie tekstu z datą lub wartością czasu

W tym celu należy użyć funkcji TEKST i znaku handlowego „i” (&).
Kolumna1 | Kolumna2 | Formuła | Opis
Data wystawienia faktury | 5-cze-2007 | ="Data raportu: "&TEKST(Kolumna2; "d-mmm-rrrr") | Połączenie tekstu z datą (Data raportu: 5-cze-2007)
Data wystawienia faktury | 5-cze-2007 | =Kolumna1&" "&TEKST(Kolumna2; "rrrr-mm-dd") | Połączenie tekstu i daty z różnych kolumn w jednej kolumnie (Data wystawienia faktury 2007-06-05)

Pokaż Porównywanie zawartości kolumn

Aby porównać kolumnę z inna kolumną lub listą wartości, należy użyć funkcji PORÓWNAJ i LUB.
Kolumna1 | Kolumna2 | Formuła | Opis
BD122 | BD123 | =PORÓWNAJ(Kolumna1;Kolumna2) | Porównanie zawartości dwóch pierwszych kolumn (Nie)
BD122 | BD123 | =PORÓWNAJ(Kolumna1; "BD122") | Porównanie zawartości Kolumny1 i ciągu „BD122” (Tak)
BD122 | BD123 | =LUB(PORÓWNAJ("BD121"; Kolumna1; Kolumna2) | Porównanie ciągu „BD121” i zawartości dwóch pierwszych kolumn (Nie)

Pokaż Sprawdzanie, czy wartość kolumny lub jej część pasuje do określonego tekstu

Aby sprawdzić, czy wartość w kolumnie lub jej część zawiera określony tekst, należy użyć funkcji JEŻELI, ZNAJDŹ, SZUKAJ.TEKST i CZY.LICZBA.

Kolumna1 | Formuła | Opis
Szypuła | =JEŻELI(Kolumna1="Szypuła"; "OK"; "Nie OK") | Sprawdza, czy w Kolumnie1 znajduje się tekst „Szypuła”. (OK)
Szypuła | =JEŻELI(CZY.LICZBA(ZNAJDŹ("z";Kolumna1)); "OK"; "Nie OK") | Sprawdza, czy w kolumnie Kolumna1 znajduje się litera „z”. (OK)
BD123 | =CZY.LICZBA(ZNAJDŹ("BD";Kolumna1)) | Sprawdza, czy w Kolumnie1 znajduje się ciąg „BD”. (Tak)

Pokaż Liczenie niepustych kolumn

W tym celu należy użyć funkcji ILE.NIEPUSTYCH.
Kolumna1 | Kolumna2 | Kolumna3 | Formuła | Opis
Sprzedaż | 19 |  | =ILE.NIEPUSTYCH(Kolumna1; Kolumna2) | Określa liczbę niepustych kolumn. (2)
Sprzedaż | 19 |  | =ILE.NIEPUSTYCH(Kolumna1; Kolumna2; Kolumna3) | Określa liczbę niepustych kolumn. (2)

Pokaż Usuwanie znaków z tekstu

W tym celu należy użyć funkcji DŁ, LEWY i PRAWY.
Kolumna1 | Formuła | Opis
Witamina A | =LEWY(Kolumna1;DŁ(Kolumna1)-2) | Zwraca 7 (9 – 2) znaków z początkiem od lewej. (Witamina)
Witamina B1 | =PRAWY(Kolumna1; DŁ(Kolumna1)-8) | Zwraca 2 (10 – 8) znaki z początkiem od prawej. (B1)

Pokaż Usuwanie spacji na początku i na końcu kolumny

W tym celu należy użyć funkcji USUŃ.ZBĘDNE.ODSTĘPY.
Kolumna1 | Formuła | Opis
Witajcie, kochani! | =USUŃ.ZBĘDNE.ODSTĘPY(Kolumna1) | Usunięcie spacji na początku i na końcu (Witajcie, kochani!)

Pokaż Powtarzanie znaku w kolumnie

W tym celu należy użyć funkcji POWT.
Formuła | Opis
=POWT(".";3) | Użycie kropki 3 razy (...)
=POWT("-";10) | Użycie znaku łącznika 10 razy (----------)

Inne formuły

Pokaż Ukrywanie błędnych wartości w kolumnach

Aby wyświetlić znak łącznika, #N/D lub Brak zamiast błędnej wartości, należy użyć funkcji
Kolumna1 | Kolumna2 | Formuła | Opis
10 | 0 | =Kolumna1/Kolumna2 | Wynikiem jest błąd (#DZIEL/0).
10 | 0 | =JEŻELI(CZY.BŁĄD(Kolumna1/Kolumna2);"BRAK";Kolumna1/Kolumna2) | Jeśli wynikiem funkcji jest błąd, funkcja zwraca wartość BRAK.
10 | 0 | =JEŻELI(CZY.BŁĄD(Kolumna1/Kolumna2);"-";Kolumna1/Kolumna2) | Jeśli wynikiem funkcji jest błąd, funkcja zwraca kreskę.


Wyświetlanie lub ukrywanie wartości zagregowanych

  • Aby wyświetlić lub ukryć wartości zagregowane dla wszystkich kolumn na liście, na wstążce kliknij kartę Lista, a następnie w grupie Arkusz danych kliknij pozycję Pokaż sumy.

    Wiersz Suma znajduje się u dołu listy. Jest w nim wyświetlana suma wartości z kolumn numerycznych, a jeśli lista nie zawiera kolumn numerycznych, jest wyświetlana liczba niepustych wierszy w ostatniej kolumnie listy. Jeśli w chwili kliknięcia pozycji Pokaż sumy wiersz był widoczny, to zostanie ukryty.

  • Aby wyświetlić lub ukryć wartości zagregowane z co najmniej jednej kolumny listy, wykonaj następujące czynności:
    1. Kliknij komórkę w wierszu Suma.
    2. Kliknij wyświetloną w komórce strzałkę w dół.
    3. Na liście rozwijanej funkcji agregujących wybierz pozycję Brak, aby ukryć wartość całkowitą. Aby wyświetlić wartość całkowitą, wybierz inną funkcję niż Brak.


Rozwiązywanie problemów z sumami i obliczonymi wartościami

Jest wyświetlany komunikat z informacją, że wyniki formuły zostaną wysłane do serwera.

Występuje błąd składni.

W komórce zamiast wyniku jest wyświetlana formuła.

Podczas edytowania kolumny obliczeniowej jest wyświetlany komunikat o oczekujących zmianach.

Jest wyświetlany komunikat o osiągnięciu limitu czasu lub nieoczekiwanym błędzie.

Jest wyświetlany komunikat o błędzie z informacją, że struktura listy uległa zmianie.

Jest wyświetlany komunikat o błędzie z informacją, że nie mam uprawnień do zmieniania kolumn obliczeniowych listy.

Nie mogę edytować formuły, ponieważ w co najmniej jednej kolumnie trzeba wprowadzić wartości.

Jest wyświetlany komunikat o błędzie z informacją, że co najmniej jedno odwołanie kolumny jest niedozwolone.

Jest wyświetlany komunikat o błędzie z informacją, że kolumna nie istnieje.

Podczas edytowania kolumny obliczeniowej nie mogę zaznaczyć wybranej kolumny.

W komórkach w kolumnie obliczeniowej jest wyświetlana wartość #NAZWA?

W komórkach w kolumnie obliczeniowej jest wyświetlana wartość #CYKL!

W komórkach w kolumnie obliczeniowej jest wyświetlana wartość #ARG!

W komórkach w kolumnie obliczeniowej jest wyświetlana wartość #LICZBA!

W komórkach w kolumnie obliczeniowej jest wyświetlana wartość #DZIEL/0!

W komórkach w kolumnie obliczeniowej jest wyświetlana wartość #ZERO!

W komórkach w kolumnie obliczeniowej jest wyświetlana wartość #N/D

Jest wyświetlany komunikat z informacją, że wyniki formuły zostaną wysłane do serwera.

Formuła była edytowana i jest wykonywana próba przesłania nowych wyników z listy do serwera. Wykonaj jedną z następujących czynności:

  • Kliknij przycisk Kontynuuj, aby dokończyć operację edycji. Jeśli istnieją oczekujące zmiany, konflikty lub błędy, zostanie wyświetlony monit o wykonanie odpowiednich czynności.
  • Kliknij przycisk Anuluj, aby powrócić do komórki zawierającej formułę.

Początek strony

Występuje błąd składni.

Może to być spowodowane co najmniej jedną z następujących przyczyn:

  • Nawiasy użyte w formule są nieprawidłowe. Upewnij się, że dla każdego nawiasu otwierającego istnieje nawias zamykający.
  • W formule znajduje się znak specjalny inny niż znak równości (=) i operatory obliczeniowe.
  • Formuła wywołuje co najmniej jedną funkcję, ale dla co najmniej jednej z tych funkcji została określona nieprawidłowa liczba argumentów.
  • Formuła korzysta z funkcji, która nie jest obsługiwana na liście. Na listach nie są obsługiwane funkcje Los i Teraz. W kolumnie obliczeniowej nie można używać funkcji Dziś i Ja, ale można z nich korzystać do określania wartości domyślnej kolumny.

Początek strony

W komórce zamiast wyniku jest wyświetlana formuła.

Upewnij się, że komórka zawierająca formułę jest częścią kolumny obliczeniowej. Jeśli formuła zostanie wprowadzona w kolumnie innej niż kolumna obliczeniowa, np. w kolumnie typu „pojedynczy wiersz tekstu”, formuła zostanie potraktowana i wyświetlona na liście jako ciąg tekstowy.

Początek strony

Podczas edytowania kolumny obliczeniowej jest wyświetlany komunikat o oczekujących zmianach.

Wszelkie zmiany w kolumnie obliczeniowej powodują zmianę struktury listy. Na liście można wprowadzać zmiany strukturalne tylko wtedy, gdy nie ma oczekujących zmian, konfliktów ani błędów. Jeśli na liście zostanie znaleziony jeden z tych elementów, zostanie wyświetlony monit o zaczekanie do momentu przesłania wszystkich zmian do serwera oraz o rozwiązanie wszelkich konfliktów i usunięcie wszelkich błędów. Dopiero wówczas będzie można dodawać lub edytować kolumnę.

Początek strony

Jest wyświetlany komunikat o osiągnięciu limitu czasu lub nieoczekiwanym błędzie.

Odśwież listę i ponownie wprowadź zmianę wprowadzoną w kolumnie obliczeniowej.

Początek strony

Jest wyświetlany komunikat o błędzie z informacją, że struktura listy uległa zmianie.

Edytowanie kolumny obliczeniowej powoduje zmianę w strukturze listy. Jeśli na liście wystąpi konflikt między wprowadzoną zmianą a zmianą strukturalną wprowadzoną przez innego użytkownika, zostanie wyświetlony monit o odświeżenie listy. Odświeżenie listy powoduje zaktualizowanie widoku, ale również odrzucenie zmian wprowadzonych w kolumnie obliczeniowej. Spróbuj ponownie wprowadzić zmianę.

Początek strony

Jest wyświetlany komunikat o błędzie z informacją, że nie mam uprawnień do zmieniania kolumn obliczeniowych listy.

Edytowanie kolumny obliczeniowej powoduje zmianę w strukturze listy. Jeśli nie masz uprawnień do wprowadzania zmian w strukturze listy, edytowanie kolumn obliczeniowych listy nie będzie możliwe.

Początek strony

Nie mogę edytować formuły, ponieważ w co najmniej jednej kolumnie trzeba wprowadzić wartości.

Aby można było edytować formułę, na liście muszą zostać zatwierdzone wszystkie wprowadzone zmiany. Wiersz nie może zostać zatwierdzony, jeśli jedna z jego kolumn została ustawiona jako wymagana, ale jest pusta. Wprowadź prawidłowe wartości we wszystkich wymaganych kolumnach, a następnie spróbuj przeprowadzić edycję formuły.

Początek strony

Jest wyświetlany komunikat o błędzie z informacją, że co najmniej jedno odwołanie kolumny jest niedozwolone.

W formule znajduje się odwołanie do kolumny, której typ danych nie obsługuje obliczeń. Przeprowadź edycję formuły, aby usunąć odwołania do nieobsługiwanych kolumn.

Początek strony

Jest wyświetlany komunikat o błędzie z informacją, że kolumna nie istnieje.

Ciąg został zdefiniowany jako operand, ale na liście nie można znaleźć kolumny z nazwą odpowiadającą ciągowi. Wykonaj co najmniej jedną z następujących czynności:

  • Upewnij się, że istnieją kolumny, których dotyczą odwołania zdefiniowane w formule.
  • Upewnij się, że nazwy kolumn zawierających spacje lub znaki specjalne znajdują się w nawiasach kwadratowych ([]).
  • Sprawdź pisownię odwołań kolumn.

Początek strony

Podczas edytowania kolumny obliczeniowej nie mogę zaznaczyć wybranej kolumny.

Po wpisaniu w kolumnie obliczeniowej znaku równości (=) odwołanie do kolumny można wkleić, klikając po prostu komórkę w kolumnie, która należy do bieżącego wiersza. Jeśli jednak typ danych tej kolumny nie obsługuje obliczeń, przy próbie zaznaczenia komórki w innym wierszu lub zaznaczenia więcej niż jednej komórki odwołanie do kolumny nie zostanie wklejone do formuły na liście.

Początek strony

W komórkach w kolumnie obliczeniowej jest wyświetlana wartość #NAZWA?

Kolumna, do której istnieje odwołanie w formule, nie istnieje. Dodaj kolumnę do listy lub przeprowadź edycję tej formuły, aby usunąć odwołanie.

Początek strony

W komórkach w kolumnie obliczeniowej jest wyświetlana wartość #CYKL!

Ten błąd jest spowodowany przez co najmniej jedno odwołanie cykliczne. Odwołanie cykliczne występuje w następujących sytuacjach:

  • Formuła używana w kolumnie zawiera odwołanie do samej siebie. Na przykład formuła, która służy do obliczania wartości w kolumnie Przychód do opodatkowania, odwołuje się do kolumny Przychód do opodatkowania.
  • Co najmniej dwie kolumny obliczeniowe odwołują się do siebie. Na przykład w kolumnie Kalk1 jest używana formuła =[Kalk2]+2, a w kolumnie Kalk2 jest używana formuła =[Kalk1]-1.
Aby usunąć odwołanie cykliczne, wykonaj co najmniej jedną z następujących czynności:
  • Upewnij się, że formuła nie odwołuje się do kolumny zawierającej tę formułę.
  • Jeśli formuła odwołuje się do innej kolumny, upewnij się, że formuła w kolumnie, do której odnosi się dane odwołanie, nie odwołuje się do pierwszej kolumny.
  • Sprawdź pisownię odwołań kolumn.

Początek strony

W komórkach w kolumnie obliczeniowej jest wyświetlana wartość #ARG!

Ten błąd może wystąpić w jednej z dwóch następujących sytuacji:

  • W formule użyto nieprawidłowego typu operandu.
  • Dla funkcji użytej w formule określono nieprawidłowy typ argumentu.
Sprawdź typ danych operandów i argumentów.

Początek strony

W komórkach w kolumnie obliczeniowej jest wyświetlana wartość #LICZBA!

Ten błąd występuje, gdy w formule znajdują się nieprawidłowe wartości numeryczne, na przykład:

  • Wartość zwracana przez formułę jest zbyt duża, aby mogła znaleźć się na liście.
  • Formuła napotkała wartość daty, która jest wcześniejsza niż 1900-01-01.
  • Funkcja użyta w formule wymaga argumentu numerycznego, ale został zdefiniowany argument nienumeryczny. Dla funkcji użytej w formule określono nieprawidłowy typ argumentu.

Początek strony

W komórkach w kolumnie obliczeniowej jest wyświetlana wartość #DZIEL/0!

Ten błąd występuje, gdy liczba jest dzielona przez zero (0), np.:

  • Wyraźnie zdefiniowano dzielenie przez zero (0), np. =133/0.
  • W formule znajdują się odwołania kolumn i podczas obliczeń wartości w kolumnach, których dotyczą odwołania, powodują dzielenie przez zero (0). Na przykład w niektórych wierszach kolumn [Liczba1] i [Liczba2] znajdują się takie same wartości, więc formuła =[Ilość]/[Liczba1]-[Liczba2] powoduje wystąpienie błędu dla tych wierszy.

Początek strony

W komórkach w kolumnie obliczeniowej jest wyświetlana wartość #ZERO!

Ten błąd występuje, gdy argument lub operand określony w formule ma wartość zero. Jeśli jeden element formuły ma wartość zero, cała formuła zwraca wartość zero. Aby uniknąć tego błędu, zastąp wartości zero liczbą zero (0). Możesz także zmienić ustawienie kolumn, których dotyczy odwołanie, wartością Wymagane, tak aby wszystkie wiersze miały wartości inne niż zero.

Początek strony

W komórkach w kolumnie obliczeniowej jest wyświetlana wartość #N/D

Ten błąd występuje, gdy funkcja nie ma wartości. Upewnij się, że zostały określone wszystkie wymagane argumenty funkcji.

Początek strony


Funkcje — informacje

Funkcje są wstępnie zdefiniowanymi formułami, które wykonują obliczenia w odpowiedniej kolejności lub strukturze przy użyciu określonych wartości, nazywanych argumentami. Za pomocą funkcji można wykonywać obliczenia proste i złożone. Na przykład funkcja ZAOKR służy do zaokrąglania liczby w kolumnie Koszt.

=ZAOKR(Koszt; 2)

Poniżej przedstawiono podstawowe zagadnienia, o których należy pamiętać podczas korzystania z funkcji:

  • Struktura Struktura funkcji zaczyna się od znaku równości (=), po którym następuje nazwa funkcji, nawias otwierający, argumenty funkcji oddzielone średnikami i nawias zamykający.
  • Nazwa funkcji Nazwa funkcji obsługiwana przez listy. Każda funkcja obsługuje określoną liczbę argumentów, przetwarza te argumenty i zwraca wartość.
  • Argumenty Argumenty mogą być liczbami, tekstem, wartościami logicznymi, takimi jak Prawda lub Fałsz, albo odwołaniami kolumn. Zdefiniowany argument musi gwarantować uzyskanie prawidłowej wartości. Argumenty mogą być także stałymi, formułami lub innymi funkcjami.
  • Etykietka argumentu Etykietka ze składnią i argumentami pojawia się podczas wpisywania funkcji. Pojawia się na przykład podczas wpisywania funkcji =ZAOKR(. Etykietki są wyświetlane tylko w przypadku funkcji wbudowanych.

Uwaga Listy nie obsługują funkcji LOS i TERAZ. Funkcje DZIŚ i JA nie są obsługiwane w kolumnach obliczeniowych, ale są obsługiwane przy ustawianiu wartości domyślnej kolumny.

Początek strony

Funkcje zagnieżdżone

W niektórych przypadkach może być konieczne użycie funkcji jako jednego z argumentów innej funkcji. Na przykład poniższa formuła używa funkcji zagnieżdżonej ŚREDNIA i porównuje wynik z sumą dwóch wartości kolumn.

=ŚREDNIA([Koszt1]; SUMA([Koszt2]+[Rabat]))

Prawidłowość zwracanych wartości Gdy funkcja jest używana jako argument, musi zwracać taki sam typ wartości, jaki jest używany przez argument. Jeśli na przykład argument używa wartości Tak lub Nie, funkcja zagnieżdżona musi zwracać wartość Tak lub Nie. Jeśli tak nie jest, na liście pojawia się wartość błędu #ARG!

Ograniczenia poziomu zagnieżdżania Formuła może zawierać maksymalnie osiem poziomów funkcji zagnieżdżonych. Gdy Funkcja B jest używana jako w Funkcji A, Funkcja B jest funkcją drugiego poziomu. Na przykład funkcja SUMA jest funkcją drugiego poziomu, ponieważ jest argumentem funkcji ŚREDNIA. Funkcja zagnieżdżona w funkcji SUMA będzie funkcją trzeciego poziomu itd.

Początek strony


Dodawanie i edytowanie kolumny obliczeniowej

Można dodać kolumnę, w której będą obliczane wartości poszczególnych wierszy na podstawie innych wartości z tego samego wiersza.

Dodawanie kolumny obliczeniowej

  1. Na wstążce kliknij kartę Lista, a następnie w grupie Ustawienia kliknij pozycję Utwórz kolumnę.
  2. Na stronie Utwórz kolumnę określ nazwę kolumny.
  3. Zaznacz opcję Obliczeniowy, aby określić typ informacji, które będą przechowywane w kolumnie.
  4. W obszarze tekstu Formuła wpisz nową formułę. Aby wstawić odwołania kolumn, na liście Wstaw kolumnę zaznacz odpowiednią kolumnę i kliknij przycisk Dodaj do formuły.
  5. Określ format wartości, która będzie zwracana po użyciu formuły, oraz inne ustawienia pokrewne.

Edytowanie kolumny obliczeniowej

  1. Kliknij prawym przyciskiem myszy kolumnę, a następnie kliknij polecenie Edytuj/Usuń kolumnę.
  2. W obszarze tekstu Formuła edytuj istniejącą formułę. Aby wstawić odwołania kolumn, na liście Wstaw kolumnę zaznacz odpowiednią kolumnę i kliknij przycisk Dodaj do formuły.
  3. Określ format wartości, która będzie zwracana po użyciu formuły, oraz inne ustawienia pokrewne.

Uwagi

  • Dodawanie lub edytowanie kolumny powoduje zmianę struktury listy. Na liście można wprowadzać zmiany strukturalne tylko wtedy, gdy nie ma oczekujących zmian, konfliktów ani błędów. Jeśli jeden z tych elementów zostanie znaleziony na liście, zostanie wyświetlony monit o zaczekanie do czasu przesłania wszystkich zmian do serwera oraz o rozwiązanie wszelkich konfliktów i usunięcie błędów. Dopiero wówczas będzie można dodawać lub edytować kolumnę.
  • Typu danych kolumny nie można zmieniać na Obliczeniowy. Aby użyć formuły z kolumny nieobliczeniowej, należy usunąć tę kolumnę, a następnie dodać kolumnę obliczeniową.


Zmienianie typu sumy wyświetlanej w kolumnie

  1. Kliknij wiersz Suma w kolumnie, dla której ma zostać zmieniony typ sumy.
  2. Kliknij strzałkę listy rozwijanej i wybierz z listy odpowiednią funkcję.

Uwaga Wybranie z listy pozycji Brak dla kolumny powoduje wyłączenie wartości sumy dla tej kolumny.


DATA

Zwraca liczbę kolejną reprezentującą określoną datę.

Składnia

DATA(rok;miesiąc;dzień)

Rok Argument „rok” może zawierać od jednej do czterech cyfr.

  • Jeśli wartość argumentu „rok” jest z zakresu od 0 (zero) do 1899 (włącznie), w celu obliczenia roku jest ona dodawana do 1900. Na przykład formuła

    DATE(108,1,2)
    zwraca datę 2 stycznia 2008 r. (1900+108).

  • Jeśli wartość argumentu „rok” jest z zakresu od 1900 do 9999 (włącznie), jest ona używana jako rok. Na przykład formuła

    DATE(2008,1,2)
    zwraca datę 2 stycznia 2008 r.

Miesiąc to liczba reprezentująca miesiąc w roku. Jeśli wartość jest większa niż 12, jest ona dodawana do pierwszego miesiąca podanego roku. Na przykład formuła

DATE(2008,14,2)
zwraca liczbę kolejną reprezentującą datę 2 lutego 2009 r.

Dzień to liczba reprezentująca dzień miesiąca. Jeśli wartość jest większa niż liczba dni w podanym miesiącu, jest ona dodawana do pierwszego dnia tego miesiąca. Na przykład formuła

DATE(2008,1,35)
zwraca liczbę kolejną reprezentującą datę 4 lutego 2008 r.

Spostrzeżenia

  • Daty są przechowywane jako liczby kolejne, co pozwala używać ich w obliczeniach. Domyślnie dacie 31 grudnia 1899 r. odpowiada liczba kolejna 1, a dacie 1 stycznia 2008 r. odpowiada liczba kolejna 39 448, ponieważ przypada 39 448 dni po 1 stycznia 1900 r.
  • Funkcja DATA jest najbardziej przydatna w formułach, w których rok, miesiąc i dzień są formułami, a nie stałymi.

Przykład

Rok | Miesiąc | Dzień | Formuła | Opis (wynik)
2008 | 1 | 1 | =DATA([Rok];[Miesiąc];[Dzień]) | Data kolejna względem podanej (2008-01-01 lub 39 448)


DATA.RÓŻNICA

Oblicza liczbę dni, miesięcy lub lat między dwiema datami. Funkcja ta służy zapewnieniu zgodności z arkuszem Lotus 1-2-3.

Składnia

DATA.RÓŻNICA(data_początkowa;data_końcowa;jednostka)

Data_początkowa Wartość oznaczająca pierwszą, czyli początkową, datę okresu. Daty można wprowadzać jako ciągi tekstowe w cudzysłowach (np. "2001-01-30"), liczby kolejne (np. 36 921, co oznacza datę 30 stycznia 2001 r., jeśli używany jest system datowania 1900) lub jako wyniki innych formuł lub funkcji (np. DATA.WARTOŚĆ("2001-01-30")).

Data_końcowa Wartość oznaczająca ostatnią, czyli końcową, datę okresu.

Jednostka Typ informacji, które mają zostać zwrócone:

Jednostka | Zwraca
"R" | Liczba pełnych lat w okresie.
"M" | Liczba pełnych miesięcy w okresie.
"D" | Liczba dni w okresie.
"MD" | Różnica dni między datą_początkową i datą_końcową. Miesiące i lata w datach są ignorowane.
"RM" | Różnica miesięcy między datą_początkową i datą_końcową. Dni i lata w datach są ignorowane
"RD" | Różnica dni między datą_początkową i datą_końcową. Lata w datach są ignorowane.

Spostrzeżenia

  • Daty są przechowywane jako liczby kolejne, co pozwala używać ich w obliczeniach. Domyślnie dacie 31 grudnia 1899 r. odpowiada liczba kolejna 1, a dacie 1 stycznia 2008 r. odpowiada liczba kolejna 39 448, ponieważ przypada 39 448 dni po 1 stycznia 1900 r.
  • Funkcja DATA.RÓŻNICA jest przydatna w formułach, w których trzeba obliczać wiek.

Przykład

Data_początkowa | Data_końcowa | Formuła | Opis (wynik)
2001-01-01 | 2003-01-01 | DATA.RÓŻNICA(Data_początkowa;Data_końcowa;"R") | Dwa pełne lata w tym okresie (2)
2001-06-01 | 2002-08-15 | DATA.RÓŻNICA(Data_początkowa;Data_końcowa;"D") | 440 dni między 1 czerwca 2001 r. a 15 sierpnia 2002 r. (440)
2001-06-01 | 2002-08-15 | DATARÓŻNICA(Data_początkowa;Data_końcowa;"RD") | 75 dni między 1 czerwca a 15 sierpnia; ignorowane są lata w datach (75)
2001-06-01 | 2002-08-15 | DATA.RÓŻNICA(Data_początkowa;Data_końcowa;"MD") | Różnica między 1 a 15 — dniem określonym przy użyciu argumentu data_początkowa a dniem określonym przy użyciu argumentu data_końcowa — ignorowane są miesiące i lata w datach (14)


DATAGODZINA

Funkcja DATAGODZINA jest połączeniem funkcji DATA i funkcji GODZINA.

Funkcja DATA zwraca liczbę kolejną reprezentującą określoną datę.

Funkcja GODZINA zwraca czas w formacie dziesiętnym jako liczbę o wartości z zakresu od 0 (zero) do 0,99999999, oznaczającą godziny od 0:00:00 do 23:59:59.

Składnia

DATAGODZINA(rok;miesiąc;dzień;godzina;minuta;sekunda)

Rok Argument „rok” może zawierać od jednej do czterech cyfr. Nie można używać roku wcześniejszego niż 1900. Jeśli wartość tego argumentu zawiera się w przedziale od 0 (zero) do 1899, w celu obliczenia roku jest ona dodawana do liczby 1900. Na przykład formuła DATAGODZINA(108;1;2;n;n;n) zwraca datę jako liczbę 39 449, czyli liczbę kolejną reprezentującą datę 2 stycznia 2008 r. (1900+108). Jeśli wartość argumentu „rok” zawiera się w przedziale od 1900 do 9999, jest ona używana jako rok. Na przykład formuła DATAGODZINA(2008;1;2;n;n;n) również zwraca datę jako liczbę 39 449.

Miesiąc to liczba reprezentująca miesiąc w roku. Jeśli wartość jest większa niż 12, jest ona dodawana do pierwszego miesiąca podanego roku. Na przykład formuła DATAGODZINA(2008;14;2;n;n;n) zwraca liczbę kolejną reprezentującą datę 2 lutego 2009 r.

Dzień to liczba reprezentująca dzień miesiąca. Jeśli wartość jest większa niż liczba dni w podanym miesiącu, jest ona dodawana do pierwszego dnia tego miesiąca. Na przykład formuła DATAGODZINA(2008;1;35;n;n;n) zwraca liczbę kolejną reprezentującą datę 4 lutego 2008 r.

Godzina to liczba z zakresu od 0 (zero) do 32 767 reprezentująca godzinę. Każda wartość większa niż 23 zostanie podzielona przez 24, a reszta będzie traktowana jako wartość godziny. Na przykład formuła DATAGODZINA(n;n;n;27;0;0) zwraca godzinę jako liczbę 0,125, czyli godzinę 3:00.

Minuta to liczba z zakresu od 0 do 32 767 reprezentująca minutę. Każda wartość większa niż 59 zostanie przekonwertowana na godziny i minuty. Na przykład formuła DATAGODZINA(n;n;n;0;750;0) zwraca godzinę jako liczbę 0,520833, czyli godzinę 12:30.

Sekunda jest liczbą z zakresu od 0 do 32 767 reprezentującą sekundę. Każda wartość większa niż 59 zostanie przekonwertowana na godziny, minuty i sekundy. Na przykład formuła DATAGODZINA(n;n;n;0;0;2000) zwraca godzinę jako liczbę 0,023148, czyli godzinę 24:33:20.

Spostrzeżenia

Daty są przechowywane jako liczby kolejne, co pozwala używać ich w obliczeniach. Domyślnie dacie 31 grudnia 1899 r. odpowiada liczba kolejna 1, a dacie 1 stycznia 2008 r. odpowiada liczba kolejna 39 448, ponieważ przypada 39 448 dni po 1 stycznia 1900 r.

Przykład

Rok | Miesiąc | Dzień | Godzina | Minuta | Sekunda | Formuła | Opis
2006 | 12 | 1 | 12 | 45 | 25 | =DATAGODZINA([Rok];[Miesiąc];[Dzień];[Godzina];[Minuta];[Sekunda]) | Liczba kolejna oznaczająca datę oraz dziesiętna reprezentacja godziny w tym dniu (39 052,5315393519)

Początek strony


DATA.WARTOŚĆ

Zwraca liczbę kolejną daty określonej przy użyciu parametru data_tekst. Za pomocą funkcji DATA.WARTOŚĆ można konwertować datę określoną tekstem na liczbę kolejną.

Składnia

DATA.WARTOŚĆ(data_tekst)

Data_tekst jest tekstem określającym datę w formacie daty. Na przykład „2008-01-30” lub „30 stycznia 2008” są ciągami tekstowymi w cudzysłowach określającymi daty.

Jeśli część daty data_tekst określająca rok zostanie pominięta, funkcja DATA.WARTOŚĆ używa bieżącego roku z wbudowanego zegara serwera. Informacje dotyczące czasu w parametrze data_tekst są ignorowane.

Spostrzeżenia

  • Daty są przechowywane jako liczby kolejne, co pozwala używać ich w obliczeniach. Domyślnie dacie 31 grudnia 1899 r. odpowiada liczba kolejna 1, a dacie 1 stycznia 2008 r. odpowiada liczba kolejna 39 448, ponieważ przypada 39 448 dni po 1 stycznia 1900 r.
  • Większość funkcji automatycznie konwertuje wartości daty na liczby kolejne.

Przykład

Formuła | Opis (wynik)
=DATA.WARTOŚĆ("2008-08-22") | Liczba kolejna daty w formacie tekstowym (39 682)
=DATA.WARTOŚĆ("22-sie-2008") | Liczba kolejna daty w formacie tekstowym (39 682)
=DATA.WARTOŚĆ("2008/02/23") | Liczba kolejna daty w formacie tekstowym (39 501)
=DATA.WARTOŚĆ("5-LIP") | Liczba kolejna daty w formacie tekstowym przy założeniu, że w wewnętrznym zegarze komputera jest ustawiony rok 2000 (37 807)


DZIEŃ

Zwraca dzień daty reprezentowanej przez argument „liczba_kolejna”. Dzień jest wyświetlany jako liczba całkowita z zakresu od 1 do 31.

Składnia

DZIEŃ(liczba_kolejna)

Liczba_kolejna to data poszukiwanego dnia.

Spostrzeżenia

  • Daty są przechowywane jako liczby kolejne, co pozwala używać ich w obliczeniach. Domyślnie dacie 31 grudnia 1899 r. odpowiada liczba kolejna 1, a dacie 1 stycznia 2008 r. odpowiada liczba kolejna 39 448, ponieważ przypada 39 448 dni po 1 stycznia 1900 r.
  • Wartości zwracane przez funkcje ROK, MIESIĄC i DZIEŃ są wartościami gregoriańskimi, bez względu na format wyświetlania wprowadzonej wartości daty. Na przykład, jeśli formatem wyświetlania wprowadzonej daty jest Hidżra, wartości zwracane przez funkcje ROK, MIESIĄC i DZIEŃ będą skojarzone z odpowiednią datą z kalendarza gregoriańskiego.

Przykład

Formuła | Opis (wynik)
=DZIEŃ("15-kwi-2008") | Dzień daty (15)


DNI.360

Zwraca liczbę dni między dwiema datami na podstawie roku składającego się z 360 dni (dwanaście miesięcy po 30 dni), który jest używany w niektórych obliczeniach księgowych. Przy użyciu tej funkcji można wykonywać płatności, jeśli system księgowy opiera się na kalendarzu, w którym występują miesiące składające się z 30 dni.

Składnia

DNI.360(data_początkowa;data_końcowa;metoda)

Data_początkowa i data_końcowa to dwie daty, między którymi ma być ustalona liczba dni. Jeśli argument „data_początkowa” występuje po argumencie „data_końcowa”, funkcja DNI.360 zwraca wartość ujemną.

Metoda to wartość logiczna określająca, czy ma być używana amerykańska czy europejska metoda obliczeniowa.

Metoda | Definicja
FAŁSZ lub pominięcie | Metoda USA (NASD). Jeśli datą początkową jest 31. dzień miesiąca, staje się on równy 30. dniowi tego samego miesiąca. Jeśli datą końcową jest 31. dzień miesiąca, a data początkowa jest wcześniejsza niż 30. dzień miesiąca, data końcowa staje się równa 1. dniowi następnego miesiąca; w przeciwnym wypadku data końcowa staje się równa 30. dniowi tego samego miesiąca.
PRAWDA | Metoda europejska. Daty początkowe i daty końcowe przypadające 31. dnia miesiąca stają się równe 30. dniowi tego samego miesiąca.

Spostrzeżenia

Daty są przechowywane jako liczby kolejne, co pozwala używać ich w obliczeniach. Domyślnie dacie 31 grudnia 1899 r. odpowiada liczba kolejna 1, a dacie 1 stycznia 2008 r. odpowiada liczba kolejna 39 448, ponieważ przypada 39 448 dni po 1 stycznia 1900 r.

Przykład

Kol1 | Kol2 | Formuła | Opis (wynik)
2008-01-30 | 2008-02-01 | =DNI.360([Kol1];[Kol2]) | Liczba dni między dwiema datami na podstawie roku składającego się z 360 dni (1)


GODZINA

Zwraca godzinę wartości czasu. Godzina jest podawana jako liczba całkowita z zakresu od 0 (północ) do 23 (11:00 wieczór).

Składnia

GODZINA(liczba_kolejna)

Liczba_kolejna to czas zawierający godzinę, którą należy znaleźć. Czas może być wprowadzany jako ciąg tekstowy w cudzysłowie (na przykład "18:45"), jako liczba dziesiętna (na przykład jako wartość 0,78125 reprezentująca godzinę 18:45) lub jako wynik innych formuł lub funkcji (na przykład CZAS.WARTOŚĆ("18:45")).

Spostrzeżenia

Wartości czasu są częścią wartości daty i są reprezentowane przez liczby dziesiętne (na przykład godzina 12:00 jest reprezentowana przez wartość 0,5, ponieważ jest to połowa dnia).

Przykład

Formuła | Opis (wynik)
=GODZINA("3:30:30") | Godzina czasu (3)
=GODZINA("15:30:30") | Godzina czasu (15)
=GODZINA("15:30") | Godzina czasu (15)


MINUTA

Zwraca minuty jako wartość czasu. Minuta jest podawana jako liczba całkowita z zakresu od 0 do 59.

Składnia

MINUTA(liczba_kolejna)

Liczba_kolejna to czas zawierający minutę, którą należy znaleźć. Czas może być wprowadzany jako ciąg tekstowy w cudzysłowie (na przykład "18:45"), jako liczba dziesiętna (na przykład 0,78125, co reprezentuje godzinę 18:45) lub jako wynik innych formuł lub funkcji (na przykład CZAS.WARTOŚĆ("18:45")).

Spostrzeżenia

Wartości czasu są częścią wartości daty i są reprezentowane przez liczby dziesiętne (na przykład godzina 12:00 jest reprezentowana przez wartość 0,5, ponieważ jest to połowa dnia).

Przykład

Formuła | Opis (wynik)
=MINUTA("16:48:00") | Minuty podanej godziny (48)


MIESIĄC

Zwraca miesiąc daty reprezentowanej przez liczbę kolejną. Miesiąc jest wyświetlany jako liczba całkowita z zakresu od 1 (styczeń) to 12 (grudzień).

Składnia

MIESIĄC(liczba_kolejna)

Liczba_kolejna to data zawierająca miesiąc, który należy znaleźć.

Spostrzeżenia

Daty są przechowywane jako liczby kolejne, co pozwala używać ich w obliczeniach. Domyślnie dacie 31 grudnia 1899 r. odpowiada liczba kolejna 1, a dacie 1 stycznia 2008 r. odpowiada liczba kolejna 39 448, ponieważ przypada 39 448 dni po 1 stycznia 1900 r.

Wartości zwracane przez funkcje ROK, MIESIĄC i DZIEŃ są wartościami gregoriańskimi, bez względu na format wyświetlania wprowadzonej wartości daty. Na przykład, jeśli formatem wyświetlania wprowadzonej daty jest Hidżra, wartości zwracane przez funkcje ROK, MIESIĄC i DZIEŃ będą skojarzone z odpowiednią datą z kalendarza gregoriańskiego.

Przykład

Formuła | Opis (wynik)
=MIESIĄC("15-kwi-2008") | Miesiąc daty (4)


TERAZ.GODZINA

Zwraca bieżącą godzinę w formacie dziesiętnym. Liczba dziesiętna zwracana przez funkcję TERAZ.GODZINA jest wartością z zakresu od 0 (zero) do 0,99999999 i oznacza godziny od 0:00:00 do 23:59:59.

Uwaga Funkcja TERAZ.GODZINA zwraca tylko bieżącą godzinę. Aby uzyskać określoną inną godzinę, należy skorzystać z funkcji CZAS. Więcej informacji można znaleźć w temacie CZAS, funkcja.

Składnia

TERAZ.GODZINA()

Spostrzeżenie

Składnia funkcji TERAZ.GODZINA nie zawiera żadnych argumentów. Do nazwy funkcji należy dołączyć puste nawiasy okrągłe. W przeciwnym przypadku program Microsoft SharePoint Foundation 2010 nie rozpozna nazwy jako funkcji.


SEKUNDA

Zwraca sekundy wartości czasu. Sekunda jest podawana jako liczba całkowita z zakresu od 0 do 59.

Składnia

SEKUNDA(liczba_kolejna)

Liczba_kolejna to czas zawierający sekundy, które należy znaleźć. Czas może być wprowadzany jako ciąg tekstowy w cudzysłowie (na przykład "18:45"), jako liczba dziesiętna (na przykład 0,78125, co reprezentuje godzinę 18:45) lub jako wynik innych formuł lub funkcji (na przykład CZAS.WARTOŚĆ("18:45")).

Spostrzeżenia

Wartości czasu są częścią wartości daty i są reprezentowane przez liczby dziesiętne (na przykład godzina 12:00 jest reprezentowana przez wartość 0,5, ponieważ jest to połowa dnia).

Przykład

Formuła | Opis
=SEKUNDA("4:48:18") | Sekundy czasu (18)
=SEKUNDA("16:48") | Sekundy czasu (0)


CZAS

Zwraca liczbę dziesiętną określającą odpowiedni czas. Liczba dziesiętna zwracana przez funkcję CZAS jest wartością z zakresu od 0 (zero) do 0,99999999 i określa godziny od 0:00:00 do 23:59:59.

Składnia

CZAS(godzina;minuta;sekunda)

Godzina to liczba z zakresu od 0 (zero) do 32 767 reprezentująca godzinę. Każda wartość większa niż 23 zostanie podzielona przez 24, a reszta będzie traktowana jako wartość godziny. Na przykład funkcja CZAS(27;0;0) = CZAS(3;0;0) = 0,125, czyli godzina 3:00.

Minuta to liczba z zakresu od 0 do 32 767 reprezentująca minuty. Każda wartość większa niż 59 zostanie przekonwertowana na godziny i minuty. Na przykład funkcja CZAS(0;750;0) = CZAS(12;30;0) = 0,520833, czyli godzina 12:30.

Sekunda to liczba z zakresu od 0 do 32 767 reprezentująca sekundy. Każda wartość większa niż 59 zostanie przekonwertowana na godziny, minuty i sekundy. Na przykład funkcja CZAS(0;0;2000) = CZAS(0;33;22) = 0,023148, czyli godzina 0:33:20.

Spostrzeżenie

Wartości czasu są częścią wartości daty i są reprezentowane przez liczby dziesiętne (na przykład godzina 12:00 jest reprezentowana przez wartość 0,5, ponieważ jest to połowa dnia).

Przykład

Godzina | Minuta | Sekunda | Formuła | Opis (wynik)
12 | 0 | 0 | =CZAS([Godzina];[Minuta];[Sekunda]) | Godzina wyrażona w formie dziesiętnej (0,5)
16 | 48 | 10 | =CZAS([Godzina];[Minuta];[Sekunda]) | Godzina wyrażona w formie dziesiętnej (0,700115741)


CZAS.WARTOŚĆ

Zwraca liczbę dziesiętną czasu reprezentowanego przez ciąg tekstowy. Liczba dziesiętna to wartość z zakresu od 0 do 0,99999999, reprezentująca czas od 0:00:00 (12:00:00 AM) do 23:59:59 (11:59:59 PM).

Składnia

CZAS.WARTOŚĆ(czas_tekst)

Czas_tekst jest ciągiem tekstowym określającym godzinę w jednym z formatów czasowych arkusza kalkulacyjnego; na przykład jako ciągi tekstowe "6:45 PM” i "18:45” w cudzysłowach oznaczające czas.

Spostrzeżenia

  • Informacja o dacie umieszczona w argumencie „czas_tekst” jest ignorowana.

Przykład

Formuła | Opis (wynik)
=CZAS.WARTOŚĆ("2:24") | Dziesiętna część dnia dla podanego czasu (0,1)
=CZAS.WARTOŚĆ("22-sie-2008 6:35") | Dziesiętna część dnia dla podanego czasu (0.274305556)


DZIŚ

Zwraca liczbę kolejną, która określa bieżącą datę. Liczba kolejna jest kodem określającym godzinę i datę, używanym do obliczania daty i godziny.

Uwaga Funkcji DZISIAJ można używać tylko jako wartości domyślnej; nie można jej używać w kolumnie obliczeniowej.

Składnia

DZISIAJ

Spostrzeżenie

Daty są przechowywane jako liczby kolejne, co pozwala używać ich w obliczeniach. Domyślnie dacie 31 grudnia 1899 r. odpowiada liczba kolejna 1, a dacie 1 stycznia 2008 r. odpowiada liczba kolejna 39 448, ponieważ przypada 39 448 dni po 1 stycznia 1900 r.


DZIEŃ.TYG

Zwraca dzień tygodnia odpowiadający dacie. Dzień jest wyrażony jako liczba całkowita z określonego domyślnie przedziału od 1 (niedziela) do 7 (sobota).

Składnia

DZIEŃ.TYG(liczba_kolejna;zwracany_typ)

Liczba_kolejna to liczba porządkowa reprezentująca datę poszukiwanego dnia.

Zwracany_typ to liczba, która określa typ zwracanej wartości.

Zwracany_typ | Liczba zwracana przez funkcję
1 lub pominięty | Liczby od 1 (niedziela) do 7 (sobota)
2 | Liczby od 1 (poniedziałek) do 7 (niedziela)
3 | Liczby od 0 (poniedziałek) do 6 (niedziela)

Spostrzeżenie

Daty są przechowywane jako liczby kolejne, co pozwala używać ich w obliczeniach. Domyślnie dacie 31 grudnia 1899 r. odpowiada liczba kolejna 1, a dacie 1 stycznia 2008 r. odpowiada liczba kolejna 39 448, ponieważ przypada 39 448 dni po 1 stycznia 1900 r.

Przykład

Formuła | Opis (wynik)
=DZIEŃ.TYG("2008-02-14") | Dzień tygodnia, numerowany od 1 (niedziela) do 7 (niedziela) (5)
=DZIEŃ.TYG("2008-02-14";2) | Dzień tygodnia, numerowany od 1 (poniedziałek) do 7 (niedziela) (4)
=DZIEŃ.TYG("2008-02-14";3) | Dzień tygodnia, numerowany od 0 (poniedziałek) do 6 (niedziela) (3)

Uwaga Dacie 2008-02-14 odpowiada czwartek.


ROK

Zwraca rok odpowiadający dacie.

Składnia

ROK(liczba_kolejna)

Liczba_kolejna to data poszukiwanego roku.

Spostrzeżenia

Daty są przechowywane jako liczby kolejne, co pozwala używać ich w obliczeniach. Domyślnie dacie 31 grudnia 1899 r. odpowiada liczba kolejna 1, a dacie 1 stycznia 2008 r. odpowiada liczba kolejna 39 448, ponieważ przypada 39 448 dni po 1 stycznia 1900 r.

Wartości zwracane przez funkcje ROK, MIESIĄC i DZIEŃ są wartościami gregoriańskimi, bez względu na format wyświetlania wprowadzonej wartości daty. Na przykład, jeśli formatem wyświetlania wprowadzonej daty jest Hidżra, wartości zwracane przez funkcje ROK, MIESIĄC i DZIEŃ będą skojarzone z odpowiednią datą z kalendarza gregoriańskiego.

Przykład

Formuła | Opis (wynik)
=ROK("2008-07-05") | Rok pierwszej daty (2008)
=ROK("5-lip-2010") | Rok drugiej daty (2010)


DDB

Zwraca amortyzację środka trwałego w podanym okresie, obliczoną przy użyciu metody podwójnie malejącego salda lub innej metody określonej przez użytkownika.

Składnia

DDB(koszt;odzysk;czas_życia;okres;współczynnik)

Koszt to początkowy koszt środka trwałego.

Odzysk to wartość środka trwałego po zakończonej amortyzacji (zwany również odzyskaną wartością środka trwałego po całkowitym czasie amortyzacji).

Czas_życia to liczba okresów, w czasie których środek trwały jest amortyzowany (zwany również okresem użytkowania).

Okres to okres, dla którego zostanie obliczona amortyzacja. Argument okres musi być wyrażony w tych samych jednostkach, co argument „czas_życia”.

Współczynnik to szybkość zmniejszania się salda. Jeśli współczynnik ten zostanie pominięty, to zakłada się, że wynosi 2 (metoda podwójnie malejącego salda).

Wszystkie pięć argumentów musi być liczbami dodatnimi.

Spostrzeżenia

  • Metoda podwójnie malejącego salda oblicza amortyzację w sposób przyspieszony. Wartość amortyzacji jest największa w pierwszym okresie i maleje w następnych okresach. Funkcja DDB używa następującej formuły do obliczenia amortyzacji w danym okresie:

    ((koszt – odzysk) – deprecjacja całkowita z poprzednich okresów) * (współczynnik/czas_życia)

  • Jeśli użycie metody podwójnie malejącego salda jest niepożądane, należy zmienić wartość argumentu „współczynnik”.

Przykład

Koszt | Odzysk | Czas_życia | Formuła | Opis (wynik)
2400 | 300 | 10 | =DDB([Koszt];[Odzysk];[Czas_życia]*365;1) | Deprecjacja w pierwszym dniu przy automatycznym założeniu, że współczynnik ma wartość 2 (1,32)
2400 | 300 | 10 | =DDB([Koszt];[Odzysk];[Czas_życia]*12;1;2) | Amortyzacja po pierwszym miesiącu (40,00)
2400 | 300 | 10 | =DDB([Koszt];[Odzysk];[Czas_życia];1;2) | Amortyzacja po pierwszym roku (480,00)
2400 | 300 | 10 | =DDB([Koszt];[Odzysk];[Czas_życia];2;1,5) | Amortyzacja w drugim roku, obliczona przy użyciu współczynnika równego 1,5 zamiast metody podwójnie malejącego salda (306,00)
2400 | 300 | 10 | =DDB([Koszt];[Odzysk];[Czas_życia];10) | Deprecjacja w dziesiątym roku przy automatycznym założeniu, że współczynnik ma wartość 2 (22,12)

Uwaga Wyniki są zaokrąglane do dwóch miejsc dziesiętnych.


FV

Zwraca przyszłą wartość inwestycji przy założeniu stałych płatności okresowych i stałej stopy procentowej.

Składnia

FV(stopa;liczba_okresów;rata;wartość_bieżąca;typ)

Dokładniejszy opis argumentów funkcji FV oraz więcej informacji na temat funkcji annuitetowych znajduje się w opisie funkcji PV.

Stopa to stopa procentowa dla okresu.

Liczba_okresów to całkowita liczba okresów płatności annuitetowej.

Rata to wpłata dokonywana okresowo; nie może być zmieniana w całym okresie płatności annuitetowej. Rata obejmuje zazwyczaj kapitał i odsetki, z wyłączeniem innych opłat i podatków. Jeśli argument „rata” zostanie pominięty, musi zostać podany argument „wartość_bieżąca”.

Wartość_bieżąca to obecna wartość, czyli całkowita suma bieżącej wartości serii przyszłych płatności. W przypadku pominięcia argumentu „wartość_obecna” przyjmuje się jego wartość jako 0 (zero) i konieczne jest określenie argumentu „rata”.

Typ to liczba 0 albo 1, która wskazuje, kiedy płatność jest należna. W przypadku pominięcia tego argumentu domyślnie przyjmuje on wartość 0.

Wartość argumentu „typ” wynosi | Płatność przypada na
0 | koniec okresu
1 | początek okresu

Spostrzeżenia
  • Należy się upewnić, że treść dotycząca używania argumentów „stopa” i „liczba_okresów” jest zrozumiała. Jeśli dokonuje się miesięcznych spłat czteroletniej pożyczki oprocentowanej na 12% rocznie, to argument „stopa” wynosi 12%/12, a argument „liczba_okresów” wynosi 4*12. Jeśli dokonuje się rocznych spłat tej samej pożyczki, to argument „stopa” wynosi 12%, a argument „liczba_okresów” — 4.
  • Przy wszystkich argumentach środki wypłacane, takie jak wypłaty z rachunków oszczędnościowych, są wyrażone liczbami ujemnymi, podczas gdy przychody, takie jak wypłaty z tytułu dywidend, są wyrażone liczbami dodatnimi.

Przykład 1

Stopa | Liczba_okresów | Rata | Wartość_bieżąca | Typ | Formuła | Opis (wynik)
6% | 10 | -200 | -500 | 1 | =FV(Stopa/12; Liczba_okresów; Rata; Wartość_bieżąca; Typ) | Przyszła wartość inwestycji z określonymi argumentami (2581,40)

Uwaga Roczna stopa procentowa jest podzielona przez 12, ponieważ dotyczy ona płatności naliczanych miesięcznie.

Przykład 2

Stopa | Liczba_okresów | Rata | Formuła | Opis (wynik)
12% | 12 | -1000 | =FV([Stopa]/12; [Liczba_okresów]; [Rata]) | Przyszła wartość inwestycji z określonymi argumentami (12 682,50)

Uwaga Roczna stopa procentowa jest podzielona przez 12, ponieważ dotyczy ona płatności naliczanych miesięcznie.


IPMT

Zaokrągla wypłatę odsetek za dany okres inwestycji na podstawie okresowych, stałych płatności i stałej stopy procentowej. Dokładniejszy opis argumentów funkcji IPMT oraz więcej informacji na temat funkcji annuitetowych znajduje się w opisie funkcji PV.

Składnia

IPMT(stopa;okres;liczba_okresów;wartość_bieżąca;wartość_przyszła;typ)

Stopa to stopa procentowa dla okresu.

Okres to okres, za który należy wyznaczyć procent; musi pochodzić z przedziału wartości od 1 do liczba_okresów.

Liczba_okresów to całkowita liczba okresów płatności w czasie trwania annuitetu.

Wart_bieżąca to obecna wartość, czyli całkowita suma bieżącej wartości serii przyszłych płatności.

Wartość_przyszła to przyszła wartość, czyli poziom finansowy, do którego zmierza się po dokonaniu ostatniej płatności. W przypadku pomięcia argumentu „wartość_przyszła” jako jego wartość przyjmuje się 0 (na przykład przyszła wartość pożyczki wynosi 0).

Typ to liczba 0 albo 1, która wskazuje, kiedy płatność jest należna. W przypadku pominięcia tego argumentu domyślnie przyjmuje on wartość 0.

Wartość argumentu „typ” wynosi | Płatność przypada na
0 | koniec okresu
1 | początek okresu

Spostrzeżenia
  • Należy się upewnić, że treść dotycząca używania argumentów „stopa” i „liczba_okresów” jest zrozumiała. Jeśli dokonuje się miesięcznych spłat czteroletniej pożyczki oprocentowanej na 12% rocznie, to argument „stopa” wynosi 12%/12, a argument „liczba_okresów” wynosi 4*12. Jeśli dokonuje się rocznych spłat tej samej pożyczki, to argument „stopa” wynosi 12%, a argument „liczba_okresów” — 4.
  • Przy wszystkich argumentach środki wypłacane, takie jak wypłaty z rachunków oszczędnościowych, są wyrażone liczbami ujemnymi, podczas gdy przychody, takie jak wypłaty z tytułu dywidend, są wyrażone liczbami dodatnimi.

Przykład

Stopa | Okres | Liczba_okresów | Wartość_bieżąca | Formuła | Opis (wynik)
10% | 1 | 3 | 8000 | =IPMT([Stopa]/12; [Okres]*3; [Liczba_okresów]; [Wartość_bieżąca]) | Odsetki należne w pierwszym miesiącu pożyczki z określonymi argumentami (-22,41)
10% | 1 | 3 | 8000 | =IPMT([Stopa]; 3; Liczba_okresów; [Wartość_bieżąca]) | Odsetki należne w ostatnim roku pożyczki z określonymi argumentami, gdzie płatności są dokonywane co roku (-292,45)

Uwaga Aby uzyskać stopę miesięczną, stopa oprocentowania jest dzielona przez 12. Liczba lat okresu spłaty należności jest mnożona przez 12 w celu obliczenia liczby spłat.


ISPMT

Oblicza wysokość odsetek płatnych w określonym okresie inwestycji.

Składnia

ISPMT(stopa;okres;liczba_okresów;wartość_bieżąca)

Stopa to stopa procentowa inwestycji.

Okres to okres, za który należy wyznaczyć procent; musi pochodzić z przedziału wartości od 1 do liczba_okresów.

Liczba_okresów to całkowita liczba okresów płatności inwestycji.

Wartość_bieżąca to obecna wartość inwestycji. W przypadku pożyczki „wartość_bieżąca” jest sumą pożyczki.

Spostrzeżenia

  • Należy się upewnić, że treść dotycząca używania argumentów „stopa” i „liczba_okresów” jest zrozumiała. Jeśli dokonuje się miesięcznych spłat czteroletniej pożyczki oprocentowanej na 12% rocznie, to argument „stopa” wynosi 12%/12, a argument „liczba_okresów” wynosi 4*12. Jeśli dokonuje się rocznych spłat tej samej pożyczki, to argument „stopa” wynosi 12%, a argument „liczba_okresów” — 4.
  • Przy wszystkich argumentach środki wypłacane, takie jak wypłaty z rachunków oszczędnościowych, są wyrażone liczbami ujemnymi, podczas gdy przychody, takie jak wypłaty z tytułu dywidend, są wyrażone liczbami dodatnimi.
  • Aby uzyskać dodatkowe informacje o funkcjach finansowych, należy zapoznać się z opisem funkcji PV.

Przykład

Stopa | Okres | Liczba_okresów | Wartość_bieżąca | Formuła | Opis (wynik)
10% | 1 | 3 | 8 000 000 | =ISPMT([Stopa]/12;[Okres];[Liczba_okresów]*12;[Wartość_bieżąca]) | Odsetki wypłacane za pierwszą miesięczną płatność pożyczki z określonymi argumentami (-64 814,8)
10% | 1 | 3 | 8 000 000 | =ISPMT([Stopa];1;[Liczba_okresów];[Wartość_bieżąca]) | Odsetki wypłacone w pierwszym roku pożyczki z określonymi argumentami (-533 333)

Uwaga Aby uzyskać stopę miesięczną, stopa oprocentowania jest dzielona przez 12. Liczba lat okresu spłaty należności jest mnożona przez 12 w celu obliczenia liczby spłat.


NPER

Zwraca liczbę okresów dla inwestycji polegającej na okresowych, stałych wpłatach przy stałym oprocentowaniu.

Składnia

NPER(stopa;rata;wartość_bieżąca;wartość_przyszła;typ)

Dokładniejszy opis argumentów funkcji NPER oraz więcej informacji o funkcjach annuitetowych znajduje się w opisie funkcji PV.

Stopa to stopa procentowa dla okresu.

Rata to płatność dokonywana okresowo, która nie ulega zmianie w czasie trwania annuitetu. Rata obejmuje zazwyczaj kapitał i odsetki z wyłączeniem innych opłat i podatków.

Wartość_bieżąca to obecna wartość, czyli całkowita suma bieżącej wartości serii przyszłych płatności.

Wartość_przyszła to przyszła wartość, czyli poziom finansowy, do którego zmierza się po dokonaniu ostatniej płatności. W przypadku pomięcia argumentu „wartość_przyszła” jako jego wartość przyjmuje się 0 (na przykład przyszła wartość pożyczki wynosi 0).

Typ to liczba 0 albo 1, która wskazuje, kiedy płatność jest należna.

Wartość argumentu „typ” wynosi | Płatność przypada na
0 lub pominięty | koniec okresu
1 | początek okresu

Przykład
Stopa | Rata | Wartość_bieżąca | Wartość_przyszła | Typ | Formuła | Opis (wynik)
12% | -100 | -1000 | 10 000 | 1 | =NPER([Stopa]/12; [Rata]; [Wartość_bieżąca]; [Wartość_przyszła]; 1) | Okresy inwestycji z określonymi argumentami (60)
12% | -100 | -1000 | 10 000 | 1 | =NPER([Stopa]/12; [Rata]; [Wartość_bieżąca]; [Wartość_przyszła]) | Okresy inwestycji z określonymi argumentami przy spłatach dokonywanych na początku okresu (60)
12% | -100 | -1000 | 10 000 | 1 | =NPER([Stopa]/12; [Rata]; [Wartość_bieżąca]) | Okresy inwestycji z określonymi argumentami przy wartości przyszłej wynoszącej 0 (-9,578)


NPV

Oblicza wartość bieżącą netto inwestycji na podstawie danej stopy dyskontowej oraz serii przyszłych płatności (wartości ujemne) i dochodów (wartości dodatnie).

Składnia

NPV(stopa;wartość1;wartość2;...)

Stopa to stopa dyskontowa stała w danym okresie.

Wartość1; wartość2;... to od 1 do 29 argumentów przedstawiających płatności i dochody.

  • Przyjmuje się, że wartość1, wartość2,... są równomiernie rozmieszczone w czasie i przypadają na koniec każdego okresu.
  • Funkcja NPV używa sekwencji wartość1, wartość2,... do przedstawienia przepływów gotówkowych. Wartości płatności i dochodów należy koniecznie wprowadzać we właściwej kolejności.
  • Uwzględniane są argumenty, które są liczbami, wartościami logicznymi, odwzorowaniami tekstowymi liczb lub są puste. Argumenty, które są wartościami błędów lub tekstem, którego nie można przekształcić w liczby, są ignorowane.

Spostrzeżenia

  • Inwestycja w funkcji NPV rozpoczyna się jeden okres przed datą przepływu gotówkowego wartość1, a kończy się wraz z ostatnim przepływem gotówkowym znajdującym się na liście. Obliczenie wartości funkcji NPV jest wykonywane na podstawie przyszłych przepływów gotówkowych. Jeśli pierwszy przepływ ma miejsce na początku pierwszego okresu, to wartość ta musi być dodana do wyniku NPV, a nie zawarta w wartościach argumentów. Więcej informacji zawierają poniższe przykłady.
  • Jeśli n jest liczbą przepływów gotówkowych na liście wartości, formuła umożliwiająca obliczenie funkcji NPV jest następująca:

  • Funkcja NPV jest podobna do funkcji PV (wartość obecna). Podstawowa różnica między funkcjami PV i NPV polega na tym, że funkcja PV pozwala, by przepływy zaczynały się na końcu lub na początku okresu. W odróżnieniu od zmiennych przepływów gotówkowych NPV, przepływy gotówkowe PV muszą być stałe w okresie inwestycji. Więcej informacji o annuitetach i funkcjach finansowych zamieszczono w opisie funkcji PV.
  • Funkcja NPV jest także związana z funkcją IRR (wewnętrzna stopa zwrotu). Funkcja IRR jest stopą, dla której wartość funkcji NPV jest równa zero: NPV(IRR(...); ...) = 0.

Przykład 1

W poniższym przykładzie:

  • Stopa jest roczną stopą dyskontową.
  • Wartość1 to pierwotny koszt inwestycji za jeden rok od dziś.
  • Wartość2 to zwrot z pierwszego roku.
  • Wartość3 to zwrot z drugiego roku.
  • Wartość4 to zwrot z trzeciego roku.
Stopa | Wartość1 | Wartość2 | Wartość3 | Wartość4 | Formuła | Opis (wynik)
10% | -10 000 | 3000 | 4200 | 6800 | =NPV([Stopa]; [Wartość1]; [Wartość2]; [Wartość3]; [Wartość4]) | Wartość bieżąca netto tej inwestycji (1 188,44)

W powyższym przykładzie jako jedną z wartości wprowadzono początkowy koszt 10 000 zł, ponieważ płatność przypadała na koniec pierwszego okresu.

Przykład 2

W poniższym przykładzie:

  • Stopa jest roczną stopą dyskontową. Może to być stopa inflacji lub stopa odsetek konkurencyjnej inwestycji.
  • Wartość1 to pierwotny koszt inwestycji za jeden rok od dziś.
  • Wartość2 to zwrot z pierwszego roku.
  • Wartość3 to zwrot z drugiego roku.
  • Wartość4 to zwrot z trzeciego roku.
  • Wartość5 to zwrot z czwartego roku.
  • Wartość6 to zwrot z piątego roku.
Stopa | Wartość1 | Wartość2 | Wartość3 | Wartość4 | Wartość5 | Wartość6 | Formuła | Opis (wynik)
8% | 40 000 | 8000 | 9200 | 10 000 | 12 000 | 14 500 | =NPV(Stopa; [Wartość2]; [Wartość3]; [Wartość4]; [Wartość5]; [Wartość6])+[Wartość1] | Wartość bieżąca netto tej inwestycji (1 922,06)
8% | 40 000 | 8000 | 9200 | 10 000 | 12 000 | 14 500 | =NPV(Stopa; [Wartość2]; [Wartość3]; [Wartość4]; [Wartość5]; [Wartość6]; -9000)+[Wartość1] | Wartość bieżąca netto tej inwestycji, ze stratą w szóstym roku wynoszącą 9000 (-3 749,47)

W powyższym przykładzie nie można uznać kosztu początkowego 40 000 zł jako jednej z wartości, ponieważ płatność miała miejsce na początku pierwszego okresu.


PMT

Oblicza kwotę spłaty pożyczki przy założeniu stałych spłat okresowych i stałej stopy procentowej.

Składnia

PMT(stopa;liczba_okresów;wartość_bieżąca;wartość_przyszła;typ)

Dokładniejszy opis argumentów funkcji PMT znajduje się w opisie funkcji PV.

Stopa to stopa procentowa pożyczki.

Liczba_okresów to całkowita liczba spłat w ramach pożyczki.

Wartość_bieżąca to obecna wartość, czyli całkowita kwota będąca wartością serii przyszłych płatności (nazywana także kapitałem).

Wartość_przyszła to przyszła wartość, czyli saldo gotówkowe, które chce się uzyskać po dokonaniu ostatniej płatności. Jeśli argument „wartość_przyszła” zostanie pominięty, to jako jego wartość zostanie przyjęta liczba 0 (co znaczy, że przyszła wartość pożyczki wynosi 0).

Typ to liczba 0 lub 1, która wskazuje, kiedy płatność jest należna.

Wartość argumentu „typ” wynosi | Płatność przypada na
0 lub pominięty | koniec okresu
1 | początek okresu

Spostrzeżenia
  • Płatności zwracane przez funkcję PMT obejmują kapitał i oprocentowanie, lecz nie obejmują podatków ani innych opłat związanych z pożyczką.
  • Należy się upewnić, że treść dotycząca używania argumentów „stopa” i „liczba_okresów” jest zrozumiała. Jeśli dokonuje się miesięcznych spłat czteroletniej pożyczki oprocentowanej na 12% rocznie, to argument „stopa” wynosi 12%/12, a argument „liczba_okresów” wynosi 4*12. Jeśli dokonuje się rocznych spłat tej samej pożyczki, to argument „stopa” wynosi 12%, a argument „liczba_okresów” — 4.

Pokaż Porada

Aby uzyskać całkowitą kwotę zapłaconą w okresie trwania pożyczki, należy pomnożyć wynik funkcji PMT przez wartość „liczba_okresów”.

Przykład 1

W poniższym przykładzie:

  • Stopa jest roczną stopą odsetek.
  • Liczba_okresów jest liczbą miesięcy płatności.
  • Wartość_bieżąca jest kwotą pożyczki.
Stopa | Liczba_okresów | Wartość_bieżąca | Formuła | Opis (wynik)
8% | 10 | 10 000 | =PMT([Stopa]/12; [Liczba_okresów]; [Wartość_bieżąca]) | Miesięczna płatność pożyczki z określonymi argumentami (-1 037,03)
8% | 10 | 10 000 | =PMT([Stopa]/12; [Liczba_okresów]; [Wartość_bieżąca]; 0; 1) | Miesięczna płatność pożyczki z określonymi argumentami, bez płatności należnych na początku okresu (-1 030,16)

Przykład 2

Funkcję PMT można zastosować do obliczenia płatności annuitetowych innych niż pożyczki.

W poniższym przykładzie:

  • Stopa jest roczną stopą odsetek.
  • Liczba_okresów określa lata planowanego oszczędzania.
  • Wartość_bieżąca jest sumą, jaka ma zostać zaoszczędzona w ciągu 18 lat.
Stopa | Liczba_okresów | Wartość_bieżąca | Formuła | Opis (wynik)
6% | 18 | 50 000 | =PMT([Stopa]/12; [Liczba_okresów]*12; 0; [Wartość_bieżąca]) | Kwota przewidywanych oszczędności w każdym miesiącu, aby po 18 latach oszczędzania została zgromadzona kwota 50 000 (-129,08)

Uwaga Aby uzyskać stopę miesięczną, stopa oprocentowania jest dzielona przez 12. Liczba lat okresu spłaty należności jest mnożona przez 12 w celu obliczenia liczby spłat.


PPMT

Zwraca spłaty kapitału w podanym okresie dla inwestycji przy stałych spłatach okresowych i stałej stopie procentowej.

Składnia

PPMT(stopa;okres;liczba_okresów;wartość_bieżąca;wartość_przyszła;typ)

Dokładniejszy opis argumentów funkcji PPMT znajduje się w opisie funkcji PV.

Stopa to stopa procentowa dla okresu.

Okres oznacza okres w skali od 1 do liczba_okresów.

Liczba_okresów to całkowita liczba okresów płatności annuitetowej.

Wartość_bieżąca to obecna wartość, czyli całkowita suma bieżącej wartości serii przyszłych płatności.

Wartość_przyszła to wartość przyszła, czyli saldo gotówkowe, które chce się uzyskać po dokonaniu ostatniej płatności. Jeśli argument „wartość_przyszła” zostanie pominięty, to jako jego wartość zostanie przyjęta liczba 0 (co znaczy, że przyszła wartość pożyczki wynosi 0).

Typ to liczba 0 albo 1, która wskazuje, kiedy płatność jest należna.

Wartość argumentu „typ” wynosi | Płatność przypada na
0 lub pominięty | koniec okresu
1 | początek okresu

Spostrzeżenia

Należy się upewnić, że treść dotycząca używania argumentów „stopa” i „liczba_okresów” jest zrozumiała. Jeśli dokonuje się miesięcznych spłat czteroletniej pożyczki oprocentowanej na 12% rocznie, to argument „stopa” wynosi 12%/12, a argument „liczba_okresów” wynosi 4*12. Jeśli dokonuje się rocznych spłat tej samej pożyczki, to argument „stopa” wynosi 12%, a argument „liczba_okresów” — 4.

Przykład 1

Stopa | Liczba_okresów | Wartość_bieżąca | Formuła | Opis (wynik)
10% | 2 | 2000 | =PPMT([Stopa]/12; 1; [Liczba_okresów]*12; [Wartość_bieżąca]) | Spłata kapitału w pierwszym miesiącu pożyczki (-75,62)

Uwaga Aby uzyskać stopę miesięczną, stopa oprocentowania jest dzielona przez 12. Liczba lat okresu spłaty należności jest mnożona przez 12 w celu obliczenia liczby spłat.

Przykład 2

Stopa | Okres | Wartość_bieżąca | Formuła | Opis (wynik)
8% | 10 | 200 000 | =PPMT([Stopa]; [Okres]; 10; [Wartość_bieżąca]) | Płatność nominalna za ostatni rok pożyczki z określonymi argumentami (-27 598,05)


PV

Zwraca wartość bieżącą inwestycji. Wartość bieżąca jest całkowitą sumą bieżącej wartości serii przyszłych płatności. Na przykład, gdy pożycza się pieniądze, kwota pożyczki jest wartością bieżącą dla pożyczkodawcy.

Składnia

PV(stopa;liczba_okresów;rata;wartość_przyszła;typ)

Stopa to stopa procentowa dla okresu. Na przykład osoba otrzymująca pożyczkę na samochód, oprocentowaną na 10 procent rocznie, spłacająca tę pożyczkę w miesięcznych ratach, będzie płacić miesięczne oprocentowanie w wysokości 10%/12, czyli 0,83%. Dlatego jako stopę oprocentowania należy wprowadzić do formuły wartość 10%/12 lub 0,83% (albo 0,0083).

Liczba_okresów to całkowita liczba okresów płatności w okresie spłaty. Na przykład osoba otrzymująca czteroletnią pożyczkę na samochód, spłacająca tę pożyczkę w miesięcznych ratach, będzie ją spłacać w ciągu 4*12 (czyli 48) okresów. Dlatego jako argument „liczba_okresów” należy wprowadzić do formuły liczbę 48.

Rata to płatność dokonywana w każdym okresie, nie zmieniana przez cały okres pożyczki. Rata obejmuje zazwyczaj kapitał i odsetki z wyłączeniem innych opłat i podatków. Na przykład miesięczna spłata czteroletniej pożyczki na samochód w wysokości 10 000 zł, oprocentowanej na 12 %, wynosi 263,33 zł. Jako argument „rata” należy wprowadzić do formuły wartość -263,33. Jeśli argument „rata” zostanie pominięty, musi zostać podany argument „wartość przyszła”.

Wartość_przyszła to przyszła wartość, czyli poziom finansowy, do którego zmierza się po dokonaniu ostatniej płatności. Jeśli ten argument zostanie pominięty, to jako jego wartość przyjmuje się 0 (na przykład przyszła wartość pożyczki wynosi 0). Na przykład, jeśli chce się zaoszczędzić 50 000 zł w ciągu 18 lat na określony cel, to 50 000 zł jest wartością przyszłą. Przy założeniu pewnej stopy procentowej można obliczyć, ile pieniędzy trzeba odkładać co miesiąc. Jeśli argument „wartość_przyszła” zostanie pominięty, musi zostać podany argument „rata”.

Typ to liczba 0 albo 1, która wskazuje, kiedy płatność jest należna.

Wartość argumentu „typ” wynosi | Płatność przypada na
0 lub pominięty | koniec okresu
1 | początek okresu

Spostrzeżenia
  • Należy się upewnić, że treść dotycząca używania argumentów „stopa” i „liczba_okresów” jest zrozumiała. Jeśli dokonuje się miesięcznych spłat czteroletniej pożyczki oprocentowanej na 12% rocznie, to argument „stopa” wynosi 12%/12, a argument „liczba_okresów” wynosi 4*12. Jeśli dokonuje się rocznych spłat tej samej pożyczki, to argument „stopa” wynosi 12%, a argument „liczba_okresów” — 4.
  • Poniższe funkcje odnoszą się do płatności annuitetowych:
    • FV
    • IPMT
    • PMT
    • PPMT
    • PV
    • RATE
    Płatność annuitetowa to seria stałych płatności gotówkowych dokonywanych w danym okresie. Na przykład kredyt samochodowy lub hipoteka są płatnościami annuitetowymi. Aby uzyskać więcej informacji, zapoznaj się z opisami poszczególnych funkcji płatności annuitetowych.
  • W funkcjach annuitetowych wydatki (koszty) mają wartości ujemne, a przychody — dodatnie. Na przykład 1000 zł jako depozyt w banku będzie reprezentowane przez argument -1000 dla depozytariusza (1000 dla banku).
  • Jeden argument finansowy jest rozpatrywany w zależności od innych. Jeśli stopa jest różna od zera, to:

    Jeśli stopa jest równa zero:

    (pmt * nper) + pv + fv = 0

Przykład

W poniższym przykładzie:

  • Rata to pieniądze wypłacane jako płatności annuitetowe z polisy ubezpieczeniowej na koniec każdego miesiąca.
  • Stopa to procent od wypłaconych pieniędzy.
  • Liczba_okresów określa liczbę lat, przez które pieniądze będą wypłacane.
Rata | Stopa | Liczba_okresów | Formuła | Opis (wynik)
500 | 8% | 20 | =PV([Stopa]/12; 12*[Liczba_okresów]; [Rata]; ; 0) | Wartość bieżąca płatności annuitetowej z określonymi argumentami (-59 777,15).

Wynik jest ujemny, ponieważ reprezentuje pieniądze wpłacane przez indywidualną osobę, czyli wypływ gotówki. Gdyby jako płatności annuitetowej zażądano wpłacenia kwoty 60 000, można by stwierdzić, że nie jest to dobra inwestycja, ponieważ bieżąca wartość annuitetu (59 777,15) jest niższa od żądanej wpłaty.

Uwaga Aby uzyskać stopę miesięczną, stopa oprocentowania jest dzielona przez 12. Liczba lat okresu spłaty należności jest mnożona przez 12 w celu obliczenia liczby spłat.


RATE

Zwraca stopę procentową dla pojedynczego okresu annuitetu. Funkcja RATE jest obliczana przez iterację i może mieć zero lub więcej rozwiązań. Jeśli kolejne wyniki funkcji RATE nie są zbieżne z przybliżeniem 0,0000001, to po 20 iteracjach funkcja RATE zwraca wartość błędu #LICZBA!

Składnia

RATE(liczba_okresów;rata;wartość_bieżąca;wartość_przyszła;typ;oszacowanie)

Pełny opis argumentów liczba_okresów, rata, wartość_bieżąca, wartość_przyszła i typ znajduje się w opisie funkcji PV.

Liczba_okresów to całkowita liczba okresów annuitetu.

Rata to płatność dokonywana w każdym okresie, nie zmieniana przez cały czas trwania annuitetu. Rata obejmuje zazwyczaj kapitał i odsetki z wyłączeniem innych opłat i podatków. Jeśli argument „rata” zostanie pominięty, musi zostać podany argument „wartość_bieżąca”.

Wartość_bieżąca to obecna wartość, czyli całkowita suma bieżącej wartości serii przyszłych płatności.

Wartość_przyszła to przyszła wartość, czyli poziom finansowy, do którego zmierza się po dokonaniu ostatniej płatności. W przypadku pomięcia argumentu „wartość_przyszła” jako jego wartość przyjmuje się 0 (na przykład przyszła wartość pożyczki wynosi 0).

Typ to liczba 0 albo 1, która wskazuje, kiedy płatność jest należna.

Wartość argumentu „typ” wynosi | Płatność przypada na
0 lub pominięty | koniec okresu
1 | początek okresu

Oszacowanie to przypuszczana wysokość oprocentowania.

  • Jeśli argument „oszacowanie” zostanie pominięty, to jako jego wartość przyjmuje się 10%.
  • Jeśli funkcja RATE nie jest zbieżna, należy spróbować innej wartości argumentu „oszacowanie”. Funkcja RATE jest zwykle zbieżna dla wartości argumentu „oszacowanie” zawartego między 0 a 1.

Spostrzeżenia

Należy się upewnić, że treść dotycząca używania argumentów „oszacowanie” i „liczba_okresów” jest zrozumiała. Jeśli dokonuje się miesięcznych spłat czteroletniej pożyczki oprocentowanej na 12% rocznie, to argument „oszacowanie” wynosi 12%/12, a argument „liczba_okresów” wynosi 4*12. Jeśli dokonuje się rocznych spłat tej samej pożyczki, to argument „oszacowanie” wynosi 12%, a argument „liczba_okresów” — 4.

Przykład

Liczba_okresów | Rata | Wartość_bieżąca | Formuła | Opis (wynik)
4 | -200 | 8000 | =STOPA([Liczba_okresów]*12; [Rata]; [Wartość_bieżąca]) | Stopa miesięczna pożyczki z określonymi argumentami (1%)
4 | -200 | 8000 | =STOPA([Liczba_okresów]*12; [Rata]; [Wartość_bieżąca])*12 | Roczna stopa pożyczki z określonymi argumentami (0,09241767 lub 9,24%)

Uwaga Lata pożyczki są mnożone przez 12 w celu uzyskania liczby miesięcy.


SLN

Zwraca wartość amortyzacji liniowej środka trwałego dla jednego okresu.

Składnia

SLN(koszt;odzysk;czas_życia)

Koszt to początkowy koszt środka trwałego.

Odzysk to wartość środka trwałego po zakończonej amortyzacji (zwany również odzyskaną wartością środka trwałego po całkowitym czasie amortyzacji).

Czas_życia to liczba okresów, w czasie których środek trwały jest amortyzowany (czas życia nazywany jest nieraz czasem użytkowania).

Przykład

Koszt | Odzysk | Czas_życia | Formuła | Opis (wynik)
30 000 | 7500 | 10 | =SLN([Koszt]; [Odzysk]; [Czas_życia]) | Odpis amortyzacyjny dla każdego roku (2 250)


SYD

Zwraca amortyzację środka trwałego w podanym okresie metodą sumy cyfr wszystkich lat amortyzacji.

Składnia

SYD(koszt;odzysk;czas_życia;okres)

Koszt to początkowy koszt środka trwałego.

Odzysk to wartość środka trwałego po zakończonej amortyzacji (zwany również odzyskaną wartością środka trwałego po całkowitym czasie amortyzacji).

Czas_życia to liczba okresów, w czasie których środek trwały jest amortyzowany (czas życia nazywany jest nieraz czasem użytkowania).

Okres to określony czas, który musi być podawany w takich samych jednostkach jak argument „czas_życia”.

Spostrzeżenie

  • Funkcja SYD jest obliczana w następujący sposób:

Przykład

Koszt | Odzysk | Czas_życia | Formuła | Opis (wynik)
30 000 | 7500 | 10 | =SYD([Koszt];[Odzysk];[Czas_życia];1) | Roczne odliczenie amortyzacyjne za pierwszy rok (4 090,91)
30 000 | 7500 | 10 | =SYD([Koszt];[Odzysk];[Czas_życia];10) | Roczne odliczenie amortyzacyjne za 10-ty rok (409,09)


CZY

W tej części omówiono dziewięć funkcji, które służą do testowania typu wartości lub odwołania kolumny.

Każda z tych funkcji, które łącznie są zwane funkcjami CZY, sprawdza typ wartości i zwraca wartość PRAWDA lub FAŁSZ w zależności od wyniku. Na przykład funkcja CZY.PUSTA zwraca wartość logiczną PRAWDA, jeśli wartość jest pustym odwołaniem kolumny. W przeciwnym wypadku zwraca wartość FAŁSZ.

Składnia

CZY.PUSTA(wartość)
CZY.BŁ(wartość)
CZY.BŁĄD(wartość)
CZY.LOGICZNA(wartość)
CZY.BRAK(wartość)
CZY.NIE.TEKST(wartość)
CZY.ZERO(wartość)
CZY.LICZBA(wartość)
CZY.TEKST(wartość)

Wartość jest wartością, która ma zostać przetestowana. Wartość może być pusta, błędna, logiczna, tekstowa lub numeryczna albo może być odwołaniem kolumny.

Funkcja | Zwraca wartość PRAWDA, jeśli
CZY.BŁ | Wartość odwołuje się do każdej wartości błędu z wyjątkiem #N/D.
CZY.BŁĄD | Wartość odwołuje się do każdej wartości błędu (#N/D, #ARG!, #ADR!, #DZIEL/0!, #LICZBA!, #NAZWA? lub #ZERO!).
CZY.BRAK | Wartość odwołuje się do wartości błędu #N/D (brak wartości).
CZY.LICZBA | Wartość odwołuje się do liczby.
CZY.LOGICZNA | Wartość odwołuje się do wartości logicznej.
CZY.NIE.TEKST | Wartość odwołuje się do dowolnego elementu, który nie jest tekstem (należy zauważyć, że ta funkcja zwraca wartość PRAWDA, jeśli wartość odwołuje się do pustego odwołania kolumny).
CZY.PUSTA | Wartość odwołuje się do pustego odwołania kolumny.
CZY.TEKST | Wartość odwołuje się do tekstu.
CZY.ZERO | Wartość odwołuje się do wartości #ZERO!

Spostrzeżenia
  • Argumenty wartości funkcji CZY nie są konwertowane. Na przykład w większości innych funkcji, w których jest wymagana liczba, wartość tekstowa „19” jest konwertowana na liczbę 19. Jednak w formule CZY.LICZBA("19") liczba „19” nie jest konwertowana z wartości tekstowej, a funkcja CZY.LICZBA zwraca wartość FAŁSZ.
  • Funkcje CZY są przydatne w formułach służących do testowania wyniku obliczeń. W połączeniu z odpowiednią funkcją CZY stanowią metodę wyszukiwania błędów w formułach (zobacz poniższe przykłady).

Przykład 1

Formuła | Opis (wynik)
=CZY.LOGICZNA(PRAWDA) | Sprawdza, czy PRAWDA jest wartością logiczną. (PRAWDA)
=CZY.LOGICZNA("PRAWDA") | Sprawdza, czy „PRAWDA” jest wartością logiczną. (FAŁSZ)
=CZY.LICZBA(4) | Sprawdza, czy 4 jest liczbą. (PRAWDA)

Przykład 2

Kol1 | Formuła | Opis (wynik)
Złoto | =CZY.PUSTA([Kol1]) | Sprawdza, czy wartość w Kol1 jest pusta. (FAŁSZ)
#ADR! | =CZY.BŁĄD([Kol1]) | Sprawdza, czy wartość w Kol1 jest błędem. (PRAWDA)
#ADR! | =CZY.BRAK([Kol1]) | Sprawdza, czy wartość w Kol1 jest błędem #N/D. (FAŁSZ)
#N/D | =CZY.BRAK([Kol1]) | Sprawdza, czy wartość w Kol1 jest błędem #N/D. (PRAWDA)
#N/D | =CZY.BŁ([Kol1]) | Sprawdza, czy wartość w Kol1 jest błędem. (FAŁSZ)
#ZERO! | =CZY.ZERO([Kol1]) | Sprawdza, czy wartość w kolumnie Kol1 wynosi #ZERO! (Tak)
330,92 | =CZY.LICZBA([Kol1]) | Sprawdza, czy wartość w Kol1 jest liczbą. (PRAWDA)
Region1 | =CZY.TEKST([Kol1]) | Sprawdza, czy wartość w Kol1 jest tekstem. (PRAWDA)


Ja

Zwraca bieżącą nazwę użytkownika.

Składnia

Ja

Spostrzeżenia

  • Funkcji Ja można używać tylko z wartościami domyślnymi. Nie można jej używać w kolumnie obliczeniowej.


ORAZ

Wynikiem funkcji jest wartość logiczna PRAWDA lub Tak, jeśli wszystkie jej argumenty mają wartość PRAWDA, lub wynikiem jest FAŁSZ lub Nie, jeśli choć jeden z jej argumentów ma wartość FAŁSZ.

Składnia

ORAZ(wartość_logiczna1;wartość_logiczna2;...)

Wartość_logiczna1; wartość_logiczna2;... to warunki (od 1 do 30), które można sprawdzić i które mogą przyjmować wartość PRAWDA lub FAŁSZ.

Spostrzeżenia

  • Argumenty muszą prowadzić do uzyskania wartości logicznych, takich jak PRAWDA lub FAŁSZ, lub być odwołaniami do kolumn zawierających wartości logiczne.
  • Jeśli argument będący odwołaniem do kolumny zawiera tekst, funkcja ORAZ zwraca wartość błędu #ARG!, natomiast jeśli jest pusty, zwraca wartość FAŁSZ.
  • Jeśli argumenty nie zawierają wartości logicznych, funkcja ORAZ zwraca wartość błędu #ARG!
  • Jeśli choć jeden argument zawiera wartość #ZERO!, funkcja ORAZ zwraca wartość #ZERO!

Przykład 1

Formuła | Opis (wynik)
=ORAZ(PRAWDA; PRAWDA) | Wszystkie argumenty są PRAWDĄ (PRAWDA)
=ORAZ(PRAWDA; FAŁSZ) | Jeden argument jest FAŁSZEM (FAŁSZ)
=ORAZ(2+2=4; 2+3=5) | Wszystkie argumenty są PRAWDĄ (PRAWDA)
=ORAZ(PRAWDA; #ZERO!) | Pierwszy argument ma wartość PRAWDA i jeden argument zawiera wartość #ZERO! (#ZERO!)

Przykład 2

Kol1 | Kol2 | Formuła | Opis (wynik)
50 | 104 | =ORAZ(1<[Kol1]; [Kol1]<100) | Wyświetla 50, ponieważ liczba ta należy do zakresu od 1 do 100. (PRAWDA)
50 | 104 | =JEŻELI(ORAZ(1<[Kol2]; [Kol2]<100); [Kol2]; "Wartość jest spoza zakresu.") | Wyświetla drugą liczbę, jeśli należy ona do zakresu od 1 do 100. W przeciwnym wypadku wyświetla komunikat. (Wartość jest spoza zakresu.)
50 | 104 | =JEŻELI(ORAZ(1<[Kol1]; [Kol1]<100); [Kol1]; "Wartość jest spoza zakresu.") | Wyświetla pierwszą liczbę, jeśli należy ona do zakresu od 1 do 100. W przeciwnym wypadku wyświetla komunikat. (50)


WYBIERZ

Funkcja używa argumentu „nr_arg”, aby zwrócić wartość z listy argumentów wartości. Funkcja WYBIERZ służy do wybierania jednej z maksymalnie 29 wartości na podstawie numeru argumentu. Jeśli na przykład argumenty od wartość1 do wartość7 to dni tygodnia, funkcja WYBIERZ zwróci jeden z dni, gdy jako argument „nr_arg” zostanie użyta liczba z przedziału między 1 a 7.

Składnia

WYBIERZ(nr_arg;wartość1;wartość2;...)

Nr_arg określa, który argument wartości ma zostać wybrany. Argument nr_arg musi należeć do przedziału od 1 do 29 lub musi być odwołaniem formuły albo kolumny zawierającym liczbę od 1 do 29.

  • Jeśli argument „nr_arg” jest równy 1, funkcja WYBIERZ zwraca wartość1, natomiast jeśli argument „nr_arg” jest równy 2, funkcja WYBIERZ zwraca wartość2 itd.

  • Jeśli argument „nr_arg” jest mniejszy niż 1 lub większy niż numer ostatniej wartości na liście, funkcja WYBIERZ zwraca wartość błędu #ARG!

  • Jeśli argument „nr_arg” jest ułamkiem, zostaje przed użyciem przycięty do najmniejszej liczby całkowitej.

Wartość1, wartość2,... są argumentami wartości z przedziału od 1 do 29, z których funkcja WYBIERZ wybiera wartość lub akcję, która ma być wykonana na podstawie wartości „nr_arg”. Argumenty mogą być liczbami, odwołaniami kolumn, formułami, funkcjami lub tekstem.

Spostrzeżenia

Przykład 1

Kol1 | Kol2 | Kol3 | Kol4 | Formuła | Opis (wynik)
1 | 2 | 3 | Gotowe | =WYBIERZ(2;[Kol1];[Kol2];[Kol3];[Kol4]) | Wartość z drugiego argumentu Kol2 (2)
Gwoździe | Wkręty | Nakrętki | Śruby | =WYBIERZ(4;[Kol1];[Kol2];[Kol3];[Kol4]) | Wartość z czwartego argumentu Kol4 (Śruby)

Przykład 2

Kol1 | Kol2 | Kol3 | Kol4 | Formuła | Opis (wynik)
23 | 45 | 12 | 10 | =SUMA([Kol1]; WYBIERZ(2;[Kol2];[Kol3];[Kol4])) | Suma dwóch argumentów: Kol1 i wyniku działania funkcji Wybierz (35)


FAŁSZ

Zwraca wartość logiczną FAŁSZ.

Składnia

FAŁSZ( )

Spostrzeżenia

Można także wpisać słowo FAŁSZ bezpośrednio w formule. Zostanie ono zinterpretowane jako wartość logiczna FAŁSZ.


JEŻELI

Zwraca jedną wartość, jeśli podany argument zostanie oceniony jako PRAWDA, albo inną wartość, jeśli argument zostanie oceniony jako FAŁSZ.

Funkcji JEŻELI należy używać do przeprowadzania testów warunkowych na wartościach i formułach.

Składnia

JEŻELI(test_logiczny;wartość_jeżeli_prawda;wartość_jeżeli_fałsz)

Test_logiczny jest dowolną wartością lub wyrażeniem, które można ocenić jako PRAWDA lub FAŁSZ. Na przykład [Kwartał1]=100 jest wyrażeniem logicznym; jeżeli wartość w jednym wierszu kolumny, [Kwartał1], jest równa 100, wyrażenie jest oceniane jako PRAWDA. W przeciwnym wypadku wyrażenie jest oceniane jako FAŁSZ. Ten argument może używać dowolnego operatora obliczeń porównawczych.

Wartość_jeżeli_prawda to wartość, która jest zwracana wtedy, gdy argument „test_logiczny” ma wartość PRAWDA. Na przykład, jeśli ten argument jest ciągiem tekstowym „W ramach budżetu”, a argument „test_logiczny” ma wartość PRAWDA, użycie funkcji JEŻELI spowoduje wyświetlenie tekstu „W ramach budżetu”. Jeśli argument „test_logiczny” ma wartość PRAWDA i argument „wartość_jeżeli_prawda” jest pusty, argument ten zwraca 0 (zero). Aby wyświetlić wyraz PRAWDA, należy użyć dla tego argumentu wartości logicznej PRAWDA. Argument „wartość_jeżeli_prawda” może być inną formułą.

Wartość_jeżeli_fałsz to wartość, która jest zwracana wtedy, gdy argument „test_logiczny” ma wartość FAŁSZ. Na przykład, jeśli argument ten jest ciągiem tekstowym „Budżet przekroczony” i argument „test_logiczny” zostanie oszacowany jako FAŁSZ, użycie funkcji JEŻELI spowoduje wyświetlenie tekstu „Budżet przekroczony”. Jeśli argument „test_logiczny” ma wartość FAŁSZ i argument „wartość_jeżeli_fałsz” jest pominięty (tj. po argumencie „wartość_jeżeli_prawda” nie ma średnika), zwracana jest wartość logiczna FAŁSZ. Jeśli argument „test_logiczny” ma wartość FAŁSZ i argument „wartość_jeżeli_fałsz” jest pusty (tj. po argumencie „wartość_jeżeli_prawda” znajduje się średnik, a za średnikiem — nawias zamykający), zwracana jest wartość 0 (zero). Argument „wartość_jeżeli_fałsz” może być inną formułą.

Spostrzeżenia

  • Jako argumenty „wartość_jeżeli_prawda” i „wartość_jeżeli_fałsz” może zostać zagnieżdżonych maksymalnie siedem funkcji JEŻELI w celu utworzenia dokładniejszych testów. Zapoznaj się z ostatnim z poniższych przykładów.
  • Kiedy argumenty „wartość_jeżeli_prawda” i „wartość_jeżeli_fałsz” zostaną obliczone, funkcja JEŻELI zwróci wartość zwróconą przez te wyrażenia.
  • Jeżeli którykolwiek z argumentów funkcji JEŻELI jest tablicą, podczas wykonywania wyrażenia JEŻELI jest obliczany każdy element tej tablicy.

Przykład 1

Kol1 | Kol2 | Kol3 | Wydatki | Formuła | Opis (wynik)
 |  |  | 50 | =JEŻELI([Wydatki]<=100;"W budżecie";"Budżet przekroczony") | Jeżeli liczba jest mniejsza niż lub równa 100, formuła powoduje wyświetlenie komunikatu „W ramach budżetu”. W przeciwnym wypadku użycie tej funkcji powoduje wyświetlenie komunikatu „Budżet przekroczony”. (W ramach budżetu)
23 | 45 | 89 | 50 | =JEŻELI([Wydatki]=100;SUMA([Kol1];[Kol2];[Kol3]);"") | Jeżeli liczba wynosi 100, są dodawane trzy wartości. W przeciwnym wypadku jest zwracany pusty tekst (""). ()

Przykład 2

WydatkiRealne | WydatkiOczekiwane | Formuła | Opis (wynik)
1500 | 900 | =JEŻELI([WydatkiRealne]>[WydatkiOczekiwane];"Budżet przekroczony";"OK") | Sprawdza, czy pierwszy wiersz ma wartość budżetu przekroczonego. (Budżet przekroczony)
500 | 900 | =JEŻELI([WydatkiRealne]>[WydatkiOczekiwane];"Budżet przekroczony";"OK") | Sprawdza, czy drugi wiersz ma wartość budżetu przekroczonego. (OK)

Przykład 3

Wynik | Formuła | Opis (wynik)
45 | =JEŻELI([Wynik]>89;"A";JEŻELI([Wynik]>79;"B"; JEŻELI([Wynik]>69;"C";JEŻELI([Wynik]>59;"D";"F")))) | Przypisuje literę do pierwszego wyniku. (F)
90 | =JEŻELI([Wynik]>89;"A";JEŻELI([Wynik]>79;"B"; JEŻELI([Wynik]>69;"C";JEŻELI([Wynik]>59;"D";"F")))) | Przypisuje literę do drugiego wyniku. (A)
78 | =JEŻELI([Wynik]>89;"A";JEŻELI([Wynik]>79;"B"; JEŻELI([Wynik]>69;"C";JEŻELI([Wynik]>59;"D";"F")))) | Przypisuje literę do trzeciego wyniku. (C)

W poprzednim przykładzie drugie wyrażenie JEŻELI jest także argumentem „wartość_jeżeli_fałsz” pierwszego wyrażenia JEŻELI. Podobnie trzecie wyrażenie JEŻELI jest argumentem „wartość_jeżeli_fałsz” drugiego wyrażenia JEŻELI. Na przykład, jeżeli pierwszy argument „test_logiczny” ([Wynik]>89) jest PRAWDĄ, zwracana jest litera „A”. Jeżeli pierwszy argument „test_logiczny” jest FAŁSZEM, obliczane jest drugie wyrażenie JEŻELI itd.

Oceny w postaci liter są przypisywane liczbom według poniższego klucza (przy założeniu, że są to tylko liczby całkowite).

Jeśli „Wynik” wynosi | Zwracane jest
Więcej niż 89 | A
Od 80 do 89 | B
Od 70 do 79 | C
Od 60 do 69 | D
Mniej niż 60 | F


NIE

Odwraca wartość swojego argumentu. Funkcję NIE należy stosować w sytuacjach, gdy dana wartość nie ma być równa jakiejś szczególnej wartości.

Składnia

NIE(logiczna)

Logiczna to wartość lub wyrażenie, które może przyjmować wartości PRAWDA lub FAŁSZ.

Spostrzeżenia

Jeśli argument „logiczna” ma wartość FAŁSZ, funkcja NIE zwraca wartość PRAWDA; jeśli argument „logiczna” ma wartość PRAWDA, funkcja NIE zwraca wartość FAŁSZ.

Przykład

Formuła | Opis (wynik)
=NIE(FAŁSZ) | Odwraca FAŁSZ (PRAWDA)
=NIE(1+1=2) | Odwraca równanie, którego wynikiem jest PRAWDA (FAŁSZ)


LUB

Zwraca wartość logiczną PRAWDA, jeśli choć jeden argument ma wartość logiczną PRAWDA. Jeśli wszystkie argumenty mają wartość logiczną FAŁSZ, funkcja zwraca wartość logiczną FAŁSZ.

Składnia

LUB(wartość_logiczna1;wartość_logiczna2;...)

Wartość_logiczna1; wartość_logiczna2;... to od 1 do 30 warunków, które można sprawdzić i które mogą przyjmować wartość PRAWDA lub FAŁSZ.

Spostrzeżenia

  • Argumenty muszą prowadzić do uzyskania wartości logicznych, takich jak PRAWDA bądź FAŁSZ, albo być tablicami bądź odwołaniami zawierającymi wartości logiczne.
  • Jeśli argument odwołania kolumny zawiera tekst lub jest pusty, wartości te są ignorowane.
  • Jeśli określony zakres nie zawiera wartości logicznych, funkcja LUB zwraca wartość błędu #ARG!
  • Jeśli choć jeden argument zawiera wartość #ZERO!, funkcja LUB zwraca wartość #ZERO!

Przykład

Formuła | Opis (wynik)
=LUB(PRAWDA) | Jedyny argument ma wartość PRAWDA. (PRAWDA)
=LUB(1+1=1;2+2=5) | Wszystkie argumenty mają wartość FAŁSZ. (FAŁSZ)
=LUB(PRAWDA;FAŁSZ;PRAWDA) | Przynajmniej jeden argument ma wartość PRAWDA. (PRAWDA)
=LUB(#ZERO!;#ZERO!) | Obydwa argumenty zawierają wartość #ZERO! (#ZERO!)
=LUB(1+1=1;#ZERO!) | Pierwszy argument ma wartość FAŁSZ, a drugim argumentem jest wartość #ZERO! (#ZERO!)


PRAWDA

Zwraca wartość logiczną PRAWDA.

Składnia

PRAWDA( )

Spostrzeżenie

Wartość PRAWDA można wprowadzać bezpośrednio, bez konieczności używania tej funkcji. Funkcja PRAWDA służy głównie zapewnieniu zgodności z innymi programami.


MODUŁ.LICZBY

Zwraca wartość bezwzględną liczby. Wartością bezwzględną liczby jest liczba bez znaku.

Składnia

MODUŁ.LICZBY(liczba)

Liczba jest liczbą rzeczywistą, której wartość bezwzględną chcesz uzyskać.

Przykłady

Kol1 | Formuła | Opis (wynik)
-4 | =MODUŁ.LICZBY([Kol1]) | Wartość bezwzględna liczby -4 (4)


ACOS

Zwraca arcus cosinus lub odwrotny cosinus liczby. Arcus cosinus jest wartością kąta, którego cosinus to liczba. Zwracany kąt w radianach należy do przedziału od 0 (zero) do pi.

Składnia

ACOS(liczba)

Liczba jest cosinusem poszukiwanego kąta i powinna należeć do przedziału od -1 do 1.

Spostrzeżenia

Aby dokonać konwersji wyniku z radianów na stopnie, należy go pomnożyć przez 180/PI() albo zastosować funkcję STOPNIE.

Przykład

Formuła | Opis (wynik)
=ACOS(-0,5) | Arcus cosinus liczby -0,5 wyrażony w radianach, 2*pi/3 (2,094395)
=ACOS(-0,5)*180/PI() | Arcus cosinus liczby -0,5 wyrażony w stopniach (120)
=STOPNIE(ACOS(-0,5)) | Arcus cosinus liczby -0,5 wyrażony w stopniach (120)


ACOSH

Zwraca odwrócony cosinus hiperboliczny liczby. Liczba musi być większa niż lub równa 1. Odwrócony cosinus hiperboliczny jest wartością, której cosinus hiperboliczny jest liczbą, dlatego ACOSH(COSH(liczba)) równa się liczba.

Składnia

ACOSH(liczba)

Liczba jest dowolną liczbą rzeczywistą większą niż lub równą 1.

Przykład

Formuła | Opis (wynik)
=ACOSH(1) | Arcus cosinus hiperboliczny liczby 1 (0)
=ACOSH(10) | Arcus cosinus hiperboliczny liczby 10 (2,993223)


ASIN

Zwraca arcus sinus lub odwrotny sinus liczby. Arcus sinus jest wartością kąta, którego sinus to liczba. Zwracany kąt w radianach należy do przedziału od -pi/2 do pi/2.

Składnia

ASIN(liczba)

Liczba jest sinusem poszukiwanego kąta i powinna należeć do przedziału od -1 do 1.

Spostrzeżenia

Aby wyrazić arcus sinus w stopniach, należy pomnożyć wynik przez 180/PI( ) albo użyć funkcji STOPNIE.

Formuła | Opis (wynik)
=ASIN(-0,5) | Arcus sinus liczby -0,5 wyrażony w radianach, -pi/6 (-0,5236)
=ASIN(-0,5)*180/PI() | Arcus sinus liczby -0,5 wyrażony w stopniach (-30)
=STOPNIE(ASIN(-0,5)) | Arcus sinus liczby -0,5 wyrażony w stopniach (-30)


ASINH

Zwraca arcus sinus hiperboliczny liczby. Arcus sinus hiperboliczny jest wartością, której sinus hiperboliczny to liczba, dlatego ASINH(SINH(liczba)) równa się liczba.

Składnia

ASINH(liczba)

Liczba to dowolna liczba rzeczywista.

Przykład

Formuła | Opis (wynik)
=ASINH(-2,5) | Arcus sinus hiperboliczny liczby -2,5 (-1,64723)
=ASINH(10) | Arcus sinus hiperboliczny liczby 10 (2,998223)


ATAN

Zwraca arcus tangens liczby, funkcję odwrotną do funkcji tangens. Arcus tangens to kąt, którego tangens jest liczbą. Zwracany kąt jest wyrażony w radianach w zakresie od -pi/2 do pi/2.

Składnia

ATAN(liczba)

Liczba to tangens kąta, który należy wyznaczyć.

Spostrzeżenia

Aby wyrazić arcus tangens w stopniach, należy pomnożyć wynik przez 180/PI( ) albo użyć funkcji STOPNIE.

Przykład

Formuła | Opis (wynik)
=ATAN(1) | Arcus tangens liczby 1 wyrażony w radianach, pi/4 (0,785398)
=ATAN(1)*180/PI() | Arcus tangens liczby 1 wyrażony w stopniach (45)
=STOPNIE(ATAN(1)) | Arcus tangens liczby 1 wyrażony w stopniach (45)


ATAN2

Zwraca arcus tangens lub odwrotny tangens określonych współrzędnych x i y. Arcus tangens jest wartością kąta pomiędzy osią x a linią prostą poprowadzoną przez początek układu współrzędnych i punkt o współrzędnych (x_liczba,y_liczba). Kąt w radianach zawiera się w przedziale od -pi do pi, z wyłączeniem wartości -pi.

Składnia

ATAN2(x_liczba;y_liczba)

X_liczba to współrzędna x punktu.

Y_liczba to współrzędna y punktu.

Spostrzeżenia

  • Wynik dodatni odpowiada kątowi liczonemu od osi x w kierunku przeciwnym do ruchu wskazówek zegara, a wynik ujemny odpowiada kierunkowi zgodnemu z ruchem wskazówek zegara.
  • ATAN2(a;b) jest równe ATAN(b/a), z wyjątkiem przypadku, gdy a jest równe 0 dla funkcji ATAN2.
  • Jeśli obydwie wartości x_liczba i y_liczba są równe 0, wartością funkcji ATAN2 będzie wartość błędu #DZIEL/0!
  • Aby wyrazić arcus tangens w stopniach, należy pomnożyć wynik przez 180/PI( ) albo użyć funkcji STOPNIE.

Przykład

Formuła | Opis (wynik)
=ATAN2(1; 1) | Arcus tangens punktu o współrzędnych (1,1) wyrażony w radianach, pi/4 (0,785398)
=ATAN2(-1; -1) | Arcus tangens punktu o współrzędnych (-1,-1) wyrażony w radianach, -3*pi/4 (-2,35619)
=ATAN2(-1; -1)*180/PI() | Arcus tangens punktu o współrzędnych (1,1) wyrażony w stopniach (-135)
=STOPNIE(ATAN2(-1; -1)) | Arcus tangens punktu o współrzędnych (1,1) wyrażony w stopniach (-135)


ATANH

Zwraca odwrócony tangens hiperboliczny liczby. Liczba musi należeć do zakresu od -1 do 1 (oprócz wartości -1 i 1). Odwrócony tangens hiperboliczny jest wartością, której tangens hiperboliczny jest liczbą, stąd ATANH(TANH(liczba)) równa się liczba.

Składnia

ATANH(liczba)

Liczba to dowolna liczba rzeczywista z przedziału od 1 do -1.

Przykład

Formuła | Opis (wynik)
=ATANH(0,76159416) | Arcus tangens hiperboliczny liczby 0,76159416 (1, w przybliżeniu)
=ATANH(-0,1) | Arcus tangens hiperboliczny liczby -0,1 (-0,10034)


ZAOKR.W.GÓRĘ

Zwraca wartość liczby, zaokrąglając ją w górę, dalej od zera, do najbliższej wielokrotności cyfry znaczącej. Jeśli na przykład chce się uniknąć używania ułamków bilonu w cenach, a produkt jest wyceniony na 4,42 zł, należy użyć formuły =ZAOKR.W.GÓRĘ(4,42;0,05), aby zaokrąglić cenę do najbliższej drobnej monety.

Składnia

ZAOKR.W.GÓRĘ(liczba;cyfra_znacząca)

Liczba jest wartością, która ma zostać zaokrąglona.

Cyfra_znacząca jest wielokrotnością, do której ma nastąpić zaokrąglenie.

Spostrzeżenia

  • Jeśli którykolwiek z argumentów nie jest liczbą, funkcja ZAOKR.W.GÓRĘ zwraca wartość błędu #ARG!
  • Bez względu na znak liczby wartość jest zaokrąglana w kierunku dalszym od zera. Jeśli liczba jest dokładną wielokrotnością cyfry znaczącej, zaokrąglenie nie nastąpi.
  • Jeśli liczba i cyfra znacząca mają różne znaki, funkcja ZAOKR.W.GÓRĘ zwraca wartość błędu #LICZBA!

Przykład

Formuła | Opis (wynik)
=ZAOKR.W.GÓRĘ(2,5; 1) | Zaokrągla 2,5 do najbliższej wielokrotności 1. (3)
=ZAOKR.W.GÓRĘ(-2,5; -2) | Zaokrągla -2,5 do najbliższej wielokrotności -2. (-4)
=ZAOKR.W.GÓRĘ(-2.5; 2) | Zwraca błąd, ponieważ argumenty -2,5 i 2 mają odmienne znaki. (#LICZBA!)
=ZAOKR.W.GÓRĘ(1,5; 0,1) | Zaokrągla 1,5 w górę do najbliższej wielokrotności 0,1. (1,5)
=ZAOKR.W.GÓRĘ(0,234; 0,01) | Zaokrągla 0,234 w górę do najbliższej wielokrotności 0,01. (0,24)


COS

Zwraca cosinus danego kąta.

Składnia

COS(liczba)

Liczba to kąt w radianach, dla którego należy obliczyć cosinus.

Spostrzeżenia

Jeśli kąt jest wyrażony w stopniach, należy go pomnożyć przez PI()/180 lub przeliczyć na radiany za pomocą funkcji RADIANY.

Przykład

Formuła | Opis (wynik)
=COS(1,047) | Cosinus 1,047 radianów (0,500171)
=COS(60*PI()/180) | Cosinus 60 stopni (0,5)
=COS(RADIANY(60)) | Cosinus 60 stopni (0,5)


COSH

Zwraca cosinus hiperboliczny liczby.

Składnia

COSH(liczba)

Liczba to dowolna liczba rzeczywista, której cosinus hiperboliczny ma zostać obliczony.

Spostrzeżenia

Formuła cosinusa hiperbolicznego jest następująca:

Przykład

Formuła | Opis (wynik)
=COSH(4) | Cosinus hiperboliczny liczby 4 (27,30823)
=COSH(EXP(1)) | Cosinus hiperboliczny podstawy logarytmu naturalnego (7,610125)


STOPNIE

Konwertuje radiany na stopnie.

Składnia

STOPNIE(kąt)

Kąt to przeznaczony do konwersji kąt określony w radianach.

Przykład

Formuła | Opis (wynik)
=STOPNIE(PI()) | Liczba stopni dla pi radianów (180)


ZAOKR.DO.PARZ

Zwraca wartość liczby zaokrąglonej do najbliższej parzystej liczby całkowitej. Funkcji tej można używać do przetwarzania elementów występujących parami. Na przykład opakowanie pozwala na umieszczenie jednego lub dwóch rodzajów przedmiotów. Opakowanie jest wypełnione, gdy liczba przedmiotów, zaokrąglona do najbliższej liczby parzystej, zgadza się z jego pojemnością.

Składnia

ZAOKR.DO.PARZ(liczba)

Liczba to wartość do zaokrąglenia.

Spostrzeżenia

  • Jeśli argument „liczba” nie jest liczbą, funkcja ZAOKR.DO.PARZ zwraca wartość błędu #ARG!
  • Niezależnie od znaku liczby wartość jest zaokrąglana w kierunku dalszym od zera. Jeśli liczba jest parzystą liczbą całkowitą, zaokrąglanie nie następuje.

Przykład

Formuła | Opis (wynik)
=ZAOKR.DO.PARZ(1,5) | Zaokrągla 1,5 w górę do najbliższej parzystej liczby całkowitej. (2)
=ZAOKR.DO.PARZ(3) | Zaokrągla 3 w górę do najbliższej parzystej liczby całkowitej. (4)
=ZAOKR.DO.PARZ(2) | Zaokrągla 2 w górę do najbliższej parzystej liczby całkowitej. (2)
=ZAOKR.DO.PARZ(-1) | Zaokrągla -1 w górę do najbliższej parzystej liczby całkowitej. (-2)


EXP

Zwraca wartość liczby e podniesioną do potęgi „liczba”. Stała e jest równa 2,71828182845904, podstawie logarytmu naturalnego.

Składnia

EXP(liczba)

Liczba to wykładnik potęgi o podstawie e.

Spostrzeżenia

  • W celu obliczenia potęg przy innych podstawach należy użyć operatora potęgowego (^).
  • EXP jest funkcją odwrotną do funkcji LN, logarytmu naturalnego liczby.

Przykład

Formuła | Opis (wynik)
=EXP(1) | Przybliżona wartość liczby e (2,718282)
=EXP(2) | Podstawa logarytmu naturalnego e podniesiona do potęgi 2 (7,389056)


SILNIA

Zwraca wartość silni liczby. Silnia liczby jest równa wyrażeniu 1*2*3*...* liczba.

Składnia

SILNIA(liczba)

Liczba jest liczbą nieujemną, dla której ma zostać obliczona silnia. Jeśli argument „liczba” nie jest liczbą całkowitą, jego wartość jest obcinana do liczby całkowitej.

Przykład

Formuła | Opis (wynik)
=SILNIA(5) | Silnia liczby 5 lub 1*2*3*4*5 (120)
=SILNIA(1,9) | Silnia liczby całkowitej z liczby 1,9 (1)
=SILNIA(0) | Silnia liczby 0 (1)
=SILNIA(-1) | Liczby ujemne powodują zwrócenie wartości błędu (#LICZBA!)
=SILNIA(1) | Silnia liczby 1 (1)


ZAOKR.W.DÓŁ

Zaokrągla liczbę w dół, w kierunku zera, do najbliższej wielokrotności istotności.

Składnia

ZAOKR.W.DÓŁ(liczba;istotność)

Liczba to wartość liczbowa, która ma zostać zaokrąglona.

Istotność to wielokrotność, do której ma zostać przeprowadzone zaokrąglanie.

Spostrzeżenia

  • Jeśli którykolwiek z argumentów nie jest liczbą, funkcja ZAOKR.W.DÓŁ zwraca wartość błędu #ARG!
  • Jeśli wartości argumentów „liczba” i „istotność” mają różne znaki, funkcja ZAOKR.W.DÓŁ zwraca wartość błędu #LICZBA!
  • Niezależnie od znaku argumentu „liczba”, wartość jest zaokrąglana w kierunku dalszym od zera. Jeśli argument „liczba” jest dokładną wielokrotnością argumentu „istotność”, zaokrąglenie nie nastąpi.

Przykład

Formuła | Opis (wynik)
=ZAOKR.W.DÓŁ(2,5;1) | Zaokrągla 2,5 w dół do najbliższej wielokrotności 1. (2)
=ZAOKR.W.DÓŁ(-2,5;-2) | Zaokrągla -2,5 w dół do najbliższej wielokrotności -2. (-2)
=ZAOKR.W.DÓŁ(-2,5;2) | Zwraca błąd, ponieważ argumenty -2,5 i 2 mają odmienne znaki. (#LICZBA!)
=ZAOKR.W.DÓŁ(1,5;0,1) | Zaokrągla 1,5 w dół do najbliższej wielokrotności 0,1. (1,5)
=ZAOKR.W.DÓŁ(0,234;0,01) | Zaokrągla 0,234 w dół do najbliższej wielokrotności 0,01. (0,23)


ZAOKR.DO.CAŁK

Zaokrągla liczbę w dół do najbliższej liczby całkowitej.

Składnia

ZAOKR.DO.CAŁK(liczba)

Liczba to liczba rzeczywista, którą należy zaokrąglić w dół do liczby całkowitej.

Przykład 1

Formuła | Opis (wynik)
=ZAOKR.DO.CAŁK(8,9) | Zaokrągla 8,9 w dół. (8)
=ZAOKR.DO.CAŁK(-8,9) | Zaokrągla -8,9 w dół. (-9)

Przykład 2

Kol1 | Formuła | Opis (wynik)
19,5 | =[Kol1]–ZAOKR.DO.CAŁK([Kol1]) | Zwraca część dziesiętną dodatniej liczby rzeczywistej w kolumnie Kol1. (0,5)


LN

Zwraca wartość logarytmu naturalnego danej liczby. Podstawą logarytmów naturalnych jest stała e (2,71828182845904).

Składnia

LN(liczba)

Liczba to liczba rzeczywista dodatnia, której logarytm naturalny należy obliczyć.

Spostrzeżenia

LN jest funkcją odwrotną do funkcji EXP.

Przykład

Formuła | Opis (wynik)
=LN(86) | Logarytm naturalny 86 (4,454347)
=LN(2,7182818) | Logarytm naturalny stałej e (1)
=LN(EXP(3)) | Logarytm naturalny e do potęgi trzeciej (3)


LOG

Zwraca logarytm liczby przy zadanej podstawie.

Składnia

LOG(liczba;podstawa)

Liczba to dodatnia liczba rzeczywista, której logarytm należy obliczyć.

Podstawa to postawa logarytmu. Jeśli argument podstawa jest pominięty, domyślnie przyjmuje się 10.

Przykład

Formuła | Opis (wynik)
=LOG(10) | Logarytm liczby 10 (1)
=LOG(8; 2) | Logarytm liczby 8 przy podstawie 2 (3)
=LOG(86; 2,7182818) | Logarytm liczby 86 przy podstawie e (4,454347)


LOG10

Zwraca logarytm zadanej liczby przy podstawie 10.

Składnia

LOG10(liczba)

Liczba to dodatnia liczba rzeczywista, której logarytm przy podstawie 10 należy wyznaczyć.

Przykład

Formuła | Opis (wynik)
=LOG10(86) | Logarytm dziesiętny z liczby 86 (1,934498451)
=LOG10(10) | Logarytm dziesiętny z liczby 10 (1)
=LOG10(1E5) | Logarytm dziesiętny z liczby 1E5 (5)
=LOG10(10^5) | Logarytm dziesiętny z liczby 10^5 (5)


MOD

Zwraca wartość reszty po podzieleniu liczby przez dzielnik. Wynik ma taki sam znak jak dzielnik.

Składnia

MOD(liczba;dzielnik)

Liczba to liczba, dla której należy wyznaczyć resztę.

Dzielnik to liczba, przez którą należy podzielić liczbę.

Spostrzeżenia

  • Jeśli dzielnik jest równy 0, funkcja MOD zwraca wartość błędu #DZIEL/0!

  • Funkcja MOD może być wyrażona za pomocą funkcji ZAOKR.DO.CAŁK:

    MOD(n, d) = n - d*INT(n/d)

Przykład

Formuła | Opis (wynik)
=MOD(3; 2) | Reszta z dzielenia 3/2. (1)
=MOD(-3; 2) | Reszta z dzielenia -3/2. Znak jest taki sam, jak znak dzielnika. (1)
=MOD(3; -2) | Reszta z dzielenia 3/-2. Znak jest taki sam, jak znak dzielnika. (-1)
=MOD(-3; -2) | Reszta z dzielenia -3/-2. Znak jest taki sam, jak znak dzielnika. (-1)


ZAOKR.DO.NPARZ

Zwraca wartość liczby zaokrągloną w górę do najbliższej nieparzystej liczby całkowitej.

Składnia

ZAOKR.DO.NPARZ(liczba)

Liczba to wartość do zaokrąglenia.

Spostrzeżenia

  • Jeśli „liczba” jest argumentem nieliczbowym, funkcja ZAOKR.DO.NPARZ zwraca wartość błędu #ARG!
  • Niezależnie od znaku argumentu „liczba” wartość jest zaokrąglana w kierunku dalszym od zera. Jeśli argument „liczba” jest nieparzystą liczbą całkowitą, zaokrąglanie nie następuje.

Przykład

Formuła | Opis (wynik)
=ZAOKR.DO.NPARZ(1,5) | Zaokrągla liczbę 1,5 w górę do najbliższej liczby całkowitej nieparzystej. (3)
=ZAOKR.DO.NPARZ(3) | Zaokrągla liczbę 3 w górę do najbliższej liczby całkowitej nieparzystej. (3)
=ZAOKR.DO.NPARZ(2) | Zaokrągla liczbę 2 w górę do najbliższej liczby całkowitej nieparzystej. (3)
=ZAOKR.DO.NPARZ(-1) | Zaokrągla liczbę -1 w górę do najbliższej liczby całkowitej nieparzystej. (-1)
=ZAOKR.DO.NPARZ(-2) | Zaokrągla liczbę -2 w górę do najbliższej liczby całkowitej nieparzystej. (-3)


PI

Zwraca liczbę 3,14159265358979, stałą matematyczną pi, z dokładnością do 15 cyfr.

Składnia

PI( )

Przykład

Formuła | Opis (wynik)
=PI() | Pi (3,14159265358979)
=PI()/2 | Pi/2 (1,570796327)
=PI()*(3^2) | Powierzchnia koła o promieniu (28,27433388)


POTĘGA

Zwraca wartość liczby podniesionej do potęgi.

Składnia

POTĘGA(liczba;potęga)

Liczba to podstawa potęgi. Może być dowolną liczbą rzeczywistą.

Potęga to wykładnik potęgi, do której jest podnoszona podstawa.

Spostrzeżenia

Aby wskazać, do której potęgi ma być podniesiona podstawa, zamiast funkcji POTĘGA można używać operatora „^”, na przykład 5^2.

Przykład

Formuła | Opis (wynik)
=POTĘGA(5;2) | Kwadrat liczby (25)
=POTĘGA(98,6;3,2) | Liczba 98,6 podniesiona do potęgi 3,2 (2 401 077)
=POTĘGA(4,5/4) | Liczba 4 podniesiona do potęgi 5/4 (5,656854)


ILOCZYN

Mnoży wszystkie liczby będące argumentami i zwraca wynik mnożenia.

Składnia

ILOCZYN(liczba1;liczba2;...)

Liczba1; liczba2;... to liczby z zakresu od 1 do 30, które mają zostać pomnożone.

Spostrzeżenia

  • Uwzględniane są argumenty, które są liczbami, wartościami logicznymi lub odwzorowaniami tekstowymi liczb. Argumenty, które są wartościami błędów lub tekstem, którego nie można przekształcić w liczby, powodują błędy.
  • Jeśli argument jest odwołaniem kolumny, uwzględniane są tylko liczby. Argumenty puste, wartości logiczne, tekst lub wartości błędów są ignorowane.

Przykład

Kol1 | Kol2 | Kol3 | Formuła | Opis (wynik)
5 | 15 | 30 | =ILOCZYN([Kol1]; [Kol2]; [Kol3]) | Mnoży liczby. (2 250)
5 | 15 | 30 | =ILOCZYN([Kol1]; [Kol2]; [Kol3];2) | Mnoży liczby i 2. (4 500)


RADIANY

Konwertuje stopnie na radiany.

Składnia

RADIANY(kąt)

Kąt to kąt podany w stopniach, który należy skonwertować.

Przykład

Formuła | Opis (wynik)
=RADIANY(270) | Kąt 270 stopni, wyrażony w radianach (4,712389 lub 3?/2 radianów)


RZYMSKIE

Konwertuje cyfry arabskie na rzymskie (jako tekst).

Składnia

RZYMSKIE(liczba;forma)

Liczba jest cyfrą arabską, która ma zostać przekonwertowana.

Forma to liczba określająca wybrany rodzaj cyfr rzymskich. Styl numeracji rzymskiej zmienia się od klasycznej do bardziej uproszczonej. Zwartość formy rośnie wraz ze wzrostem wartości argumentu. Zobacz przykład występujący po przykładzie

ROMAN(499,0)
w dalszej części artykułu.

Forma | Typ
0 lub pominięty | Klasyczny.
1 | Bardziej zwarty. Patrz przykład poniżej.
2 | Bardziej zwarty. Patrz przykład poniżej.
3 | Bardziej zwarty. Patrz przykład poniżej.
4 | Uproszczony.
PRAWDA | Klasyczny.
FAŁSZ | Uproszczony.

Spostrzeżenia

  • Jeśli argument „liczba” jest ujemny, to funkcja zwróci wartość błędu #ARG!
  • Jeśli argument „liczba” jest większy od 3999, to funkcja zwróci wartość błędu #ARG!

Przykład

Formuła | Opis (wynik)
=RZYMSKIE(499;0) | Liczba 499 zapisana w klasycznym stylu rzymskim (CDXCIX)
=RZYMSKIE(499,1) | Liczba 499 zapisana w bardziej zwartym stylu rzymskim (LDVLIV)
=RZYMSKIE(499;2) | Liczba 499 zapisana w bardziej zwartym stylu rzymskim (XDIX)
=RZYMSKIE(499;3) | Liczba 499 zapisana w bardziej zwartym stylu rzymskim (VDIV)
=RZYMSKIE(499;4) | Liczba 499 zapisana w bardziej zwartym stylu rzymskim (ID)
=RZYMSKIE(2013;0) | Liczba 2013 zapisana w klasycznym stylu rzymskim (MMXIII)


ZAOKR

Część treści tego tematu może nie mieć zastosowania w przypadku niektórych języków.

Zaokrągla liczbę do określonej liczby cyfr.

Składnia

ZAOKR(liczba;liczba_znaków)

Liczba jest wartością, która ma zostać zaokrąglona.

Liczba_cyfr określa liczbę cyfr, do której liczba ma zostać zaokrąglona.

Spostrzeżenia

  • Jeśli wartość „liczba_znaków” jest większa od zera, liczba jest zaokrąglana do określonego miejsca po przecinku.
  • Jeśli wartość „liczba_znaków” wynosi zero, liczba jest zaokrąglana do najbliższej liczby całkowitej.
  • Jeśli wartość „liczba_znaków” jest mniejsza od zera, liczba jest zaokrąglana do liczby z lewej strony przecinka dziesiętnego.

Przykład

Formuła | Opis (wynik)
=ZAOKR(2,15; 1) | Zaokrągla liczbę 2,15 do jednego miejsca po przecinku. (2,2)
=ZAOKR(2,149; 1) | Zaokrągla liczbę 2,149 do jednego miejsca po przecinku. (2,1)
=ZAOKR(-1,475; 2) | Zaokrągla liczbę -1,475 do dwóch miejsc po przecinku. (-1,48)
=ZAOKR(21,5; -1) | Zaokrągla liczbę 21,5 do jednego miejsca z lewej strony przecinka dziesiętnego. (20)


ZAOKR.DÓŁ

Zaokrągla liczbę w dół w kierunku zera.

Składnia

ZAOKR.DÓŁ(liczba;liczba_cyfr)

Liczba to dowolna liczba rzeczywista, która ma zostać zaokrąglona w dół.

Liczba_cyfr jest liczbą znaków, do której liczba ma zostać zaokrąglona.

Spostrzeżenia

  • Funkcja ZAOKR.DÓŁ zachowuje się jak funkcja ZAOKR, z taką różnicą, że zawsze zaokrągla liczbę w dół.
  • Jeśli argument „liczba_cyfr” jest większy od zera, to liczba jest zaokrąglana w dół do podanej liczby miejsc dziesiętnych.
  • Jeśli argument „liczba_cyfr” wynosi zero, to liczba jest zaokrąglana w dół do najbliższej liczby całkowitej.
  • Jeśli argument „liczba_cyfr” jest mniejszy od zera, to liczba jest zaokrąglana w dół do wartości z lewej strony przecinka dziesiętnego.

Przykład

Formuła | Opis (wynik)
=ZAOKR.DÓŁ(3,2; 0) | Zaokrągla liczbę 3,2 w dół do zerowej liczby miejsc dziesiętnych. (3)
=ZAOKR.DÓŁ(76,9;0) | Zaokrągla liczbę 76,9 w dół do zerowej liczby miejsc dziesiętnych. (76)
=ZAOKR.DÓŁ(3,14159; 3) | Zaokrągla liczbę 3,14159 w dół do trzech miejsc dziesiętnych. (3,141)
=ZAOKR.DÓŁ(-3,14159; 1) | Zaokrągla liczbę -3,14159 w dół do jednego miejsca dziesiętnego. (-3,1)
=ZAOKR.DÓŁ(31415,92654; -2) | Zaokrągla liczbę 31 415,92654 w dół do dwóch miejsc dziesiętnych po lewej stronie przecinka. (31 400)


ZAOKR.GÓRA

Zaokrągla liczbę w górę, dalej od zera.

Składnia

ZAOKR.GÓRA(liczba;liczba_cyfr)

Liczba to dowolna liczba rzeczywista, która ma być zaokrąglona w górę.

Liczba_cyfr jest liczbą znaków, do której liczba ma zostać zaokrąglona.

Spostrzeżenia

  • Funkcja ZAOKR.GÓRA zachowuje się jak funkcja ZAOKR, z taką różnicą, że zawsze zaokrągla liczbę w górę.

  • Jeśli argument „liczba_cyfr” jest większy od zera, to liczba jest zaokrąglana w górę do podanej liczby miejsc dziesiętnych.

  • Jeśli argument „liczba_cyfr” wynosi zero, to liczba jest zaokrąglana w górę do najbliższej liczby całkowitej.

  • Jeśli argument „liczba_cyfr” jest mniejszy od zera, to liczba jest zaokrąglana w górę do wartości z lewej strony przecinka dziesiętnego.

Przykład

Formuła | Opis (wynik)
=ZAOKR.GÓRA(3,2;0) | Zaokrągla liczbę 3,2 w górę do zerowej liczby miejsc dziesiętnych. (4)
=ZAOKR.GÓRA(76,9;0) | Zaokrągla liczbę 76.9 w górę do zerowej liczby miejsc dziesiętnych. (77)
=ZAOKR.GÓRA(3,14159;3) | Zaokrągla liczbę 3,14159 w górę do trzech miejsc dziesiętnych. (3,142)
=ZAOKR.GÓRA(-3,14159;1) | Zaokrągla liczbę -3,14159 w górę do jednego miejsca dziesiętnego. (-3,2)
=ZAOKR.GÓRA(31415,92654; -2) | Zaokrągla liczbę 31 415,92654 w górę do dwóch miejsc dziesiętnych po lewej stronie przecinka. (31 500)


ZNAK.LICZBY

Określa znak liczby. Funkcja zwraca wartość 1, jeśli liczba jest dodatnia, wartość 0, jeśli liczba wynosi zero, oraz wartość -1, jeśli liczba jest ujemna.

Składnia

ZNAK.LICZBY(liczba)

Liczba to dowolna liczba rzeczywista.

Przykład

Formuła | Opis (wynik)
=ZNAK.LICZBY(10) | Znak liczby dodatniej (1)
=ZNAK.LICZBY(4-4) | Wartość zero (0)
=ZNAK.LICZBY(-0,00001) | Znak liczby ujemnej (-1)


SIN

Zwraca sinus podanego kąta.

Składnia

SIN(liczba)

Liczba to kąt w radianach, dla którego należy obliczyć sinus.

Spostrzeżenia

Jeśli argument jest podany w stopniach, należy go pomnożyć przez PI()/180 lub użyć funkcji RADIANY, aby przekonwertować stopnie na radiany.

Przykład

Formuła | Opis (wynik)
=SIN(PI()) | Sinus radianów pi (0, w przybliżeniu)
=SIN(PI()/2) | Sinus radianów pi/2 (1)
=SIN(30*PI()/180) | Sinus kąta 30 stopni (0,5)
=SIN(RADIANY(30)) | Sinus kąta 30 stopni (0,5)


SINH

Zwraca sinus hiperboliczny liczby.

Składnia

SINH(liczba)

Liczba to dowolna liczba rzeczywista.

Spostrzeżenie

Formuła obliczająca sinus hiperboliczny jest następująca:

Przykład 1

Formuła | Opis (wynik)
=SINH(1) | Sinus hiperboliczny liczby 1 (1,175201194)
=SINH(-1) | Sinus hiperboliczny liczby -1 (-1,175201194)

Przykład 2

Funkcji obliczającej sinus hiperboliczny można używać do aproksymowania skumulowanego rozkładu prawdopodobieństwa. Załóżmy, że wartości z testu laboratoryjnego zawierają się w przedziale od 0 do 10 sekund. Analiza empiryczna zarejestrowanej historii eksperymentów pokazuje, że prawdopodobieństwo uzyskania wyniku x, który będzie mniejszy niż t sekund, jest aproksymowane przez następujące równanie:

P(x<t) = 2,868 * SINH(0,0342 * t), gdzie 0<t<10

Aby obliczyć prawdopodobieństwo uzyskania wyniku mniejszego niż 1,03 sekundy, należy za t podstawić wartość 1,03.

Formuła | Opis (wynik)
=2,868*SINH(0,0342*1,03) | Prawdopodobieństwo uzyskania wyniku mniejszego niż 1,03 sekundy (0,101049063)

Można oczekiwać, że wynik ten wystąpi około 101 razy w każdym tysiącu doświadczeń.


PIERWIASTEK

Zwraca dodatni pierwiastek kwadratowy liczby.

Składnia

PIERWIASTEK(liczba)

Liczba to liczba, dla której należy obliczyć pierwiastek kwadratowy.

Spostrzeżenie

Jeśli argument „liczba” ma wartość ujemną, funkcja PIERWIASTEK zwraca wartość błędu #LICZBA!

Przykład

Formuła | Opis (wynik)
=PIERWIASTEK(16) | Pierwiastek kwadratowy liczby 16. (4)
=PIERWIASTEK(-16) | Pierwiastek kwadratowy z 16. W związku z tym, że liczba jest ujemna, zostanie zwrócony błąd. (#LICZBA!)
=PIERWIASTEK(MODUŁ.LICZBY(-16)) | Pierwiastek kwadratowy z wartości bezwzględnej liczby. (4)


SUMA

Dodaje wszystkie liczby do określonych argumentów.

Składnia

SUMA(liczba1;liczba2;...)

Liczba1; liczba2;... to od 1 do 30 argumentów, dla których należy obliczyć wartość całkowitą, czyli sumę.

Spostrzeżenia

  • Funkcja zlicza liczby, wartości logiczne i odwzorowania tekstowe liczb, które zostały wpisane bezpośrednio na listę argumentów. Zobacz pierwszy i drugi z poniższych przykładów.
  • Argumenty będące wartościami błędów lub tekstem, którego nie można przekształcić w liczby, powodują błędy.

Przykład

Kol1 | Kol2 | Kol3 | Kol4 | Kol5 | Formuła | Opis (wynik)
-5 | 15 | 30 |  | PRAWDA | =SUMA(3;2) | Dodaje liczby 3 i 2. (5)
-5 | 15 | 30 |  | PRAWDA | =SUMA("5";15;PRAWDA) | Dodaje liczby 5, 15 i 1, ponieważ wartości tekstowe są przekształcane w liczby, a wartość logiczna PRAWDA jest przekształcana w liczbę 1. (21)
-5 | 15 | 30 |  | PRAWDA | =SUMA(Kol1]; [Kol2]; [Kol3]) | Dodaje pierwsze trzy liczby w kolumnach. (40)
-5 | 15 | 30 |  | PRAWDA | =SUMA(Kol1]; [Kol2]; [Kol3]; 15) | Dodaje pierwsze trzy liczby w kolumnach i liczbę 15. (55)
-5 | 15 | 30 |  | PRAWDA | =SUMA([Kol4]; [Kol5]; 2) | Dodaje wartości w dwóch ostatnich kolumnach i liczbę 2. (2)


SUMA.KWADRATÓW

Zwraca sumę kwadratów argumentów.

Składnia

SUMA.KWADRATÓW(liczba1;liczba2;...)

Liczba1; liczba2;... to od 1 do 30 argumentów, których sumę kwadratów należy obliczyć.

Przykład

Formuła | Opis (wynik)
=SUMA.KWADRATÓW(3; 4) | Suma kwadratów liczb 3 i 4 (25)


TAN

Zwraca tangens podanego kąta.

Składnia

TAN(liczba)

Liczba to kąt wyrażony w radianach, dla którego należy obliczyć tangens.

Spostrzeżenie

Jeśli argument jest podany w stopniach, należy go pomnożyć przez PI()/180 lub użyć funkcji RADIANY, aby przekonwertować stopnie na radiany.

Przykład

Formuła | Opis (wynik)
=TAN(0,785) | Tangens 0,785 radianów (0,99920)
=TAN(45*PI()/180) | Tangens kąta 45 stopni (1)
=TAN(RADIANY(45)) | Tangens kąta 45 stopni (1)


TANH

Zwraca tangens hiperboliczny liczby.

Składnia

TANH(liczba)

Liczba to dowolna liczba rzeczywista.

Spostrzeżenie

Formuła obliczająca tangens hiperboliczny przedstawia się następująco:

Przykład

Formuła | Opis (wynik)
=TANH(-2) | Tangens hiperboliczny liczby -2 (-0,96403)
=TANH(0) | Tangens hiperboliczny liczby 0 (0)
=TANH(0,5) | Tangens hiperboliczny liczby 0,5 (0,462117)


LICZBA.CAŁK

Obcina liczbę do części całkowitej, usuwając z niej jej część ułamkową.

Składnia

LICZBA.CAŁK(liczba;liczba_cyfr)

Liczba to liczba, którą należy obciąć.

Liczba_cyfr to liczba określająca dokładność obcinania. Argument „liczba_cyfr” przyjmuje domyślnie wartość 0 (zero).

Spostrzeżenie

Funkcje LICZBA.CAŁK i ZAOKR.DO.CAŁK działają podobnie — obie zwracają liczby całkowite. Funkcja LICZBA.CAŁK usuwa ułamkową część liczby. Funkcja ZAOKR.DO.CAŁK zaokrągla liczbę w dół do najbliższej liczby całkowitej na podstawie wartości ułamkowej części liczby. Funkcje LICZBA.CAŁK i ZAOKR.DO.CAŁK działają inaczej tylko wtedy, gdy są używane liczby ujemne: funkcja

TRUNC(-4.3)
zwraca wartość -4, ale funkcja
INT(-4.3)
zwraca wartość -5, ponieważ -5 jest liczbą mniejszą.

Przykład

Formuła | Opis (wynik)
=LICZBA.CAŁK(8,9) | Część całkowita liczby 8,9 (8)
=LICZBA.CAŁK(-8,9) | Część całkowita liczby -8,9 (-8)
=LICZBA.CAŁK(PI()) | Część całkowita liczby pi (3)


ODCH.ŚREDNIE

Zwraca wartość średnią odchyleń bezwzględnych punktów danych od ich wartości średniej. Funkcja ODCH.ŚREDNIE jest miarą zmienności zbioru danych.

Składnia

ODCH.ŚREDNIE(liczba1;liczba2;...)

Liczba1; liczba2;... to od 1 do 30 argumentów, dla których należy wyznaczyć średnią odchyleń bezwzględnych.

Spostrzeżenia

  • Argumenty muszą być liczbami lub odwołaniami kolumn zawierającymi liczby.
  • Jeśli argument odwołania kolumny zawiera tekst, wartości logiczne lub jest pusty, wartości te są ignorowane lub zwracana jest wartość błędu #ARG!; uwzględniana jest jednak wartość zero.
  • Równanie na średnie odchylenie jest następujące:

Na funkcję ODCH.ŚREDNIE ma wpływ przyjęty system jednostek danych wejściowych.

Przykład

Kol1 | Kol2 | Kol3 | Kol4 | Kol5 | Kol6 | Kol7 | Formuła | Opis (wynik)
4 | 5 | 6 | 7 | 5 | 4 | 3 | =ODCH.ŚREDNIE([Kol1];[Kol2];[Kol3];[Kol4];[Kol5];[Kol6];[Kol7]) | Średnia odchyleń bezwzględnych liczb od ich średniej (1,020408)


ŚREDNIA

Zwraca średnią (arytmetyczną) argumentów.

Składnia

ŚREDNIA(liczba1;liczba2;...)

Liczba1; liczba2;... to argumenty numeryczne (od 1 do 30), dla których ma zostać obliczona średnia.

Spostrzeżenia

  • Argumenty muszą być liczbami lub odwołaniami zawierającymi liczby.
  • Jeśli tablica lub argument odwołania kolumny zawiera tekst, wartości logiczne lub jest pusty, wartości te są ignorowane lub jest zwracana wartość błędu #ARG!; argumenty o wartości zero są jednak uwzględniane.

Przykład

Kol1 | Kol2 | Kol3 | Kol4 | Kol5 | Formuła | Opis (wynik)
10 | 7 | 9 | 27 | 2 | =ŚREDNIA([Kol1]; [Kol2]; [Kol3]; [Kol4]; [Kol5]) | Średnia liczb z kolumn (11)
10 | 7 | 9 | 27 | 2 | =ŚREDNIA([Kol1]; [Kol2]; [Kol3]; [Kol4]; [Kol5]; 5) | Średnia liczb z kolumn i 5 (10)


ŚREDNIA.A

Oblicza średnią (arytmetyczną) wartości znajdujących się na liście argumentów. W przeciwieństwie do funkcji ŚREDNIA tekst i wartości logiczne, takie jak PRAWDA i FAŁSZ, są uwzględniane w obliczeniach.

Składnia

ŚREDNIA.A(wartość1;wartość2;...)

Wartość1; wartość2;... są argumentami (od 1 do 30), dla których ma zostać obliczona średnia.

Spostrzeżenia

  • Argumenty zawierające tekst są interpretowane jako 0 (zero). Pusty tekst ("") jest interpretowany jako 0 (zero). Jeśli w obliczeniach średniej nie mogą zostać uwzględnione wartości tekstowe, należy użyć funkcji ŚREDNIA.
  • Wartość liczbowa argumentów zawierających wartość logiczną PRAWDA wynosi 1; wartość liczbowa argumentów zawierających wartość logiczną FAŁSZ wynosi 0 (zero).

Przykład

Kol1 | Kol2 | Kol3 | Kol4 | Kol5 | Kol6 | Formuła | Opis (wynik)
10 | 7 | 9 | 2 | 0 |  | =ŚREDNIA.A([Kol1];[Kol2];[Kol3];[Kol4];[Kol5]) | Średnia liczb (5,6)
10 | 10 | 9 | 2 | 1 |  | =ŚREDNIA.A([Kol1];[Kol2];[Kol3];[Kol4];[Kol6]) | Średnia liczb i pusty argument (7,75)


ROZKŁAD.BETA

Zwraca skumulowany rozkład prawdopodobieństwa beta. Skumulowany rozkład prawdopodobieństwa beta jest często używany w analizie zmian zawartości procentowych w próbkach, np. części dnia, które ludzie spędzają przed telewizorem.

Składnia

ROZKŁAD.BETA(x;alfa;beta;A;B)

X to wartość między A a B, dla której określa się funkcję.

Alfa to parametr rozkładu.

Beta to parametr rozkładu.

A to opcjonalne dolne ograniczenie interwału wartości x.

B to opcjonalne górne ograniczenie interwału wartości x.

Spostrzeżenia

  • Jeśli którykolwiek z argumentów nie jest liczbą, to funkcja ROZKŁAD.BETA zwraca wartość błędu #ARG!
  • Jeśli alfa ? 0 lub beta ? 0, to funkcja ROZKŁAD.BETA zwraca wartość błędu #LICZBA!
  • Jeśli x < A, x > B lub A = B, to funkcja ROZKŁAD.BETA zwraca wartość błędu #LICZBA!
  • Jeśli wartości argumentów A i B zostały pominięte, to w funkcji ROZKŁAD.BETA jest stosowany standardowy skumulowany rozkład beta, tzn. A = 0 i B = 1.

Przykład

X | Alfa | Beta | A | B | Formuła | Opis (wynik)
2 | 8 | 10 | 1 | 3 | =ROZKŁAD.BETA([X];[Alfa];[Beta];[A];[B]) | Funkcja sumy gęstości prawdopodobieństwa beta dla podanych parametrów (0,685470581)


ROZKŁAD.BETA.ODW

Zwraca odwrotność skumulowanego rozkładu prawdopodobieństwa beta, tzn. jeśli prawdopodobieństwo = ROZKŁAD.BETA(x;...), to ROZKŁAD.BETA.ODW(prawdopodobieństwo;...) = x. Skumulowany rozkład beta może być używany przy planowaniu projektów w modelowaniu możliwych czasów zakończenia, jeśli jest dany planowany czas zakończenia i zmienność.

Składnia

ROZKŁAD.BETA.ODW(prawdopodobieństwo;alfa;beta;A;B)

Prawdopodobieństwo to prawdopodobieństwo skojarzone z rozkładem beta.

Alfa to parametr rozkładu.

Beta to parametr rozkładu.

A to opcjonalne dolne ograniczenie interwału wartości x.

B to opcjonalne górne ograniczenie interwału wartości x.

Spostrzeżenia

  • Jeśli którykolwiek z argumentów nie jest liczbą, to funkcja ROZKŁAD.BETA.ODW zwraca wartość błędu #ARG!
  • Jeśli alfa ? 0 lub beta ? 0, to funkcja ROZKŁAD.BETA.ODW zwraca wartość błędu #LICZBA!
  • Jeśli prawdopodobieństwo ? 0 lub prawdopodobieństwo > 1, to funkcja ROZKŁAD.BETA.ODW zwraca wartość błędu #LICZBA!
  • Jeśli wartości argumentów A i B zostały pominięte, to w funkcji ROZKŁAD.BETA.ODW jest stosowany standardowy skumulowany rozkład beta, tzn. A = 0 i B = 1.

Funkcja ROZKŁAD.BETA.ODW wykorzystuje technikę iteracyjną obliczania funkcji. Jeśli dana jest wartość prawdopodobieństwa, funkcja ROZKŁAD.BETA.ODW wykonuje iteracje, dopóki wynik nie charakteryzuje się dokładnością do ±3x10-7. Jeśli po 100 iteracjach nie nastąpi zbieżność funkcji ROZKŁAD.BETA.ODW, funkcja zwróci wartość błędu #N/D.

Przykład

Prawdopodobieństwo | Alfa | Beta | A | B | Formuła | Opis (wynik)
0,685470581 | 8 | 10 | 1 | 3 | =ROZKŁAD.BETA.ODW([Prawdopodobieństwo];[Alfa];[Beta];[A];[B]) | Odwrotność funkcji sumy gęstości prawdopodobieństwa beta dla podanych parametrów (2)


ROZKŁAD.DWUM

Zwraca wartość pojedynczego składnika dwumianowego rozkładu prawdopodobieństwa. Funkcję ROZKŁAD.DWUM należy stosować do rozwiązywania problemów, w których występuje stała liczba testów lub prób, wynik każdej próby może być tylko sukcesem lub porażką, próby są niezależne, a prawdopodobieństwo sukcesu jest stałe w trakcie eksperymentu. Na przykład funkcja ROZKŁAD.DWUM może obliczyć prawdopodobieństwo, że z trojga następnych nowonarodzonych dzieci dwoje będzie płci męskiej.

Składnia

ROZKŁAD.DWUM(liczba_s;liczba_prób;prawdopodobieństwo_s;skumulowany)

Liczba_s to liczba sukcesów w próbach.

Próby to liczba niezależnych prób.

Prawdopodobieństwo_s to prawdopodobieństwo sukcesu w każdej próbie.

Skumulowany jest wartością logiczną określającą formę funkcji. Jeśli suma jest PRAWDĄ, to funkcja ROZKŁAD.DWUM zwraca skumulowany rozkład, dla którego istnieje prawdopodobieństwo, że istnieje co najwyżej „liczba_s” sukcesów; jeśli jest FAŁSZEM, zwraca masę prawdopodobieństwa, dla której istnieje prawdopodobieństwo, że istnieje dokładnie „liczba_s” sukcesów.

Spostrzeżenia

  • Argumenty „liczba_s” i „próby” są obcinane do liczb całkowitych.
  • Jeśli dowolny z argumentów: „liczba_s”, „próby” lub „prawdopodobieństwo_s” nie jest liczbą, to funkcja ROZKŁAD.DWUM zwraca wartość błędu #ARG!
  • Jeśli „liczba_s” < 0 lub „liczba_s” > „próby”, to funkcja ROZKŁAD.DWUM zwraca wartość błędu #LICZBA!
  • Jeśli „prawdopodobieństwo_s” < 0 lub „prawdopodobieństwo_s“ > 1, to funkcja ROZKŁAD.DWUM zwraca wartość błędu #LICZBA!
  • Funkcja gęstości prawdopodobieństwa dwumianowego przedstawia się następująco:

    gdzie:

    jest funkcją KOMBINACJE(n;x).

    Uwaga Funkcja KOMBINACJE została tu użyta w celu przedstawienia formuły matematycznej używanej przez funkcję ROZKŁAD.DWUM. Nie jest to funkcja, z której można korzystać w liście.

    Skumulowany rozkład dwumianowy przedstawia się następująco:

Przykład

liczba_s | próby | prawdopodobieństwo_s | Formuła | Opis (wynik)
6 | 10 | 0,5 | =ROZKŁAD.DWUM([liczba_s];[próby];[prawdopodobieństwo_s];FAŁSZ) | Prawdopodobieństwo dokładnie 6 sukcesów w 10 próbach (0,205078)


ROZKŁAD.CHI

Zwraca jednostronne prawdopodobieństwo rozkładu chi-kwadrat. Rozkład ?2 jest skojarzony z próbą ?2. Próba ?2 służy do porównania wartości obserwowanej i oczekiwanej. Na przykład w eksperymencie genetycznym może się pojawić hipoteza, że następne pokolenie roślin będzie się charakteryzować określonym zestawem kolorów. Dzięki porównaniu wyniku obserwowanego z oczekiwanym można zdecydować, czy pierwotna hipoteza była słuszna.

Składnia

ROZKŁAD.CHI(x;stopnie_swobody)

X to wartość, dla której ma zostać obliczony rozkład.

Stopnie_swobody to liczba stopni swobody.

Spostrzeżenia

  • Jeśli którykolwiek z argumentów nie jest liczbą, funkcja ROZKŁAD.CHI zwraca wartość błędu #ARG!
  • Jeśli argument x jest ujemny, funkcja ROZKŁAD.CHI zwraca wartość błędu #LICZBA!
  • Jeśli argument „stopnie_swobody” nie jest liczbą całkowitą, jest obcinany do liczby całkowitej.
  • Jeśli wartość „stopnie_swobody” < 1 lub jeśli „stopnie_swobody” ? 10^10, funkcja ROZKŁAD.CHI zwraca wartość błędu #LICZBA!
  • Wartość ROZKŁAD.CHI oblicza się jako ROZKŁAD.CHI = P(X>x), gdzie X jest zmienną losową ?2.

Przykład

X | Stopnie_swobody | Formuła | Opis (wynik)
18,307 | 10 | =ROZKŁAD.CHI([X];[Stopnie_swobody]) | Jednostronne prawdopodobieństwo rozkładu chi-kwadrat dla określonych argumentów (0,050001)


ROZKŁAD.CHI.ODW

Zwraca odwrotność jednostronnego prawdopodobieństwa rozkładu chi-kwadrat. Jeśli prawdopodobieństwo = ROZKŁAD.CHI(x;...), to ROZKŁAD.CHI.ODW([prawdopodobieństwo;...) = x. Ta funkcja służy do porównywania wyników obserwowanych z oczekiwanymi w celu potwierdzenia pierwotnej hipotezy.

Składnia

ROZKŁAD.CHI.ODW(prawdopodobieństwo;stopnie_swobody)

Prawdopodobieństwo to prawdopodobieństwo skojarzone z rozkładem chi-kwadrat.

Stopnie_swobody to liczba stopni swobody.

Spostrzeżenia

  • Jeśli którykolwiek z argumentów nie jest liczbą, funkcja ROZKŁAD.CHI.ODW zwraca wartość błędu #ARG!
  • Jeśli „prawdopodobieństwo” < 0 albo „prawdopodobieństwo” > 1, funkcja ROZKŁAD.CHI.ODW zwraca wartość błędu #LICZBA!
  • Jeśli argument „stopnie_swobody” nie jest liczbą całkowitą, jest obcinany do liczby całkowitej.
  • Jeśli wartość „stopnie_swobody” < 1 lub jeśli „stopnie_swobody” ? 10^10, funkcja ROZKŁAD.CHI.ODW zwraca wartość błędu #LICZBA!

Funkcja ROZKŁAD.CHI.ODW wykorzystuje technikę iteracyjną obliczania funkcji. Jeśli dana jest wartość prawdopodobieństwa, funkcja ROZKŁAD.CHI.ODW wykonuje iteracje, dopóki wynik nie charakteryzuje się dokładnością do ± 3x10^-7. Jeśli po 100 iteracjach nie nastąpi zbieżność funkcji ROZKŁAD.CHI.ODW, funkcja zwróci wartość błędu #N/D.

Przykład

Prawdopodobieństwo | Stopnie_swobody | Formuła | Opis (wynik)
0,05 | 10 | =ROZKŁAD.CHI.ODW([Prawdopodobieństwo];[Stopnie_swobody]) | Odwrotność jednostronnego prawdopodobieństwa rozkładu chi-kwadrat (18,30703)


UFNOŚĆ

Zwraca przedział ufności dla średniej populacji z rozkładem zwykłym. Przedział ufności jest zakresem po obu stronach średniej danej próbki. Na przykład w przypadku zamówienia produktu pocztą można określić, z określoną pewnością (ufnością), kiedy najwcześniej lub najpóźniej będzie go można otrzymać.

Składnia

UFNOŚĆ(alfa;odchylenie_std;wielkość)

Alfa to poziom istotności używany do obliczania poziomu ufności. Poziom ufności jest równy 100*(1 – alfa)% lub innymi słowy, alfa równe 0,05 wskazuje 95-procentowy poziom ufności.

Odchylenie_std to odchylenie standardowe populacji zakresu danych, przy czym zakłada się, że jest ono znane.

Wielkość oznacza wielkość próby.

Spostrzeżenia

  • Jeśli którykolwiek z argumentów nie jest liczbą, funkcja UFNOŚĆ zwraca wartość błędu #ARG!
  • Jeśli alfa ? 0 lub alfa ? 1, funkcja UFNOŚĆ zwraca wartość błędu #LICZBA!
  • Jeśli odchylenie_std ? 0, funkcja UFNOŚĆ zwraca wartość błędu #LICZBA!
  • Jeśli argument „wielkość” nie jest liczbą całkowitą, jego wartość jest obcinana do liczby całkowitej.
  • Jeśli argument „wielkość” < 1, funkcja UFNOŚĆ zwraca wartość błędu #LICZBA!
  • Jeśli przyjmie się alfa równe 0,05, to trzeba obliczyć obszar pod standardową krzywą normalną, który jest równy (1 – alfa) lub 95%. Wartość ta jest równa ± 1,96. Przedział ufności jest zatem równy:

Przykład

Przypuśćmy, że w próbie 50 pracowników dojeżdżających do pracy zaobserwowano, że średnia długość dojazdu do pracy jest równa 30 minut przy standardowym odchyleniu populacji równym 2,5. Możemy być na 95 procent pewni, że średnia populacji należy do przedziału:

Alfa | OdchStd | Wielkość | Formuła | Opis (wynik)
0,05 | 0,5 | 50 | =UFNOŚĆ([Alfa];[OdchStd];[Wielkość]) | Przedział ufności dla średniej danej populacji. Innymi słowy, średnia długość dojazdu do pracy wynosi 30 ± 0,692951 minut lub od 29,3 do 30,7 minut. (0,692951)


ILE.LICZB

Oblicza liczbę argumentów zawierających liczby.

Składnia

ILE.LICZB(wartość1;wartość2;...)

Wartość1; wartość2;... są argumentami (od 1 do 30), które mogą zawierać różne typy danych lub odnosić się do tych danych; zliczane są jednak tylko liczby.

Spostrzeżenia

  • Uwzględniane są argumenty, które są liczbami, datami lub odwzorowaniami tekstowymi liczb. Argumenty, które są wartościami błędów lub tekstem, którego nie można przekształcić w liczby, są ignorowane.
  • Jeśli trzeba obliczyć wartości logiczne, tekst lub wartości błędów, należy użyć funkcji ILE.NIEPUSTYCH.

Przykład

Kol1 | Kol2 | Kol3 | Kol4 | Kol5 | Kol6 | Kol7 | Formuła | Opis (wynik)
Sprzedaż | 2008-12-08 |  | 19 | 22,24 | PRAWDA | #DZIEL/0! | =ILE.LICZB([Kol1];[Kol2];[Kol3];[Kol4];[Kol5];[Kol6];[Kol7]) | Oblicza liczbę argumentów zawierających liczby z listy (3).
 |  |  | 19 | 22,24 | PRAWDA | #DZIEL/0! | =ILE.LICZB([Kol4];[Kol5];[Kol6];[Kol7]) | Oblicza liczbę argumentów zawierających liczby z ostatnich 4 wierszy listy (2).
Sprzedaż | 2008-02-08 |  | 19 | 22,24 | PRAWDA | #DZIEL/0! | =ILE.LICZB([Kol1];[Kol2];[Kol3];[Kol4];[Kol5];[Kol6];[Kol7];2) | Oblicza liczbę argumentów zawierających liczby z listy oraz wartość 2 (4).


ILE.NIEPUSTYCH

Oblicza liczbę argumentów, które nie są puste.

Składnia

ILE.NIEPUSTYCH(wartość1;wartość2;...)

Wartość1; wartość2;... są argumentami (od 1 do 30) odpowiadającymi wartościom, które mają zostać obliczone. W tym przypadku wartość jest dowolnym typem informacji, w tym pustym tekstem (""), ale z wyłączeniem pustych argumentów. Jeśli nie trzeba obliczać wartości logicznych, tekstu ani wartości błędów, należy użyć funkcji ILE.LICZB.

Przykład

Kol1 | Kol2 | Kol3 | Kol4 | Kol5 | Kol6 | Kol7 | Formuła | Opis (wynik)
Sprzedaż | 2008-12-08 |  | 19 | 22,24 | PRAWDA | #DZIEL/0! | =ILE.NIEPUSTYCH([Kol1];[Kol2];[Kol3];[Kol4];[Kol5];[Kol6];[Kol7]) | Oblicza liczbę niepustych argumentów z listy. (6)
Sprzedaż | 2008-12-08 |  | 19 | 22,24 | PRAWDA | #DZIEL/0! | =ILE.NIEPUSTYCH([Kol4];[Kol5];[Kol6];[Kol7])) | Oblicza liczbę niepustych argumentów z ostatnich 4 wierszy listy. (4)
Sprzedaż | 2008-12-08 |  | 19 | 22,24 | PRAWDA | #DZIEL/0! | =ILE.NIEPUSTYCH([Kol1];[Kol2];[Kol3];[Kol4];[Kol5];[Kol6];[Kol7];2) | Oblicza liczbę niepustych argumentów z listy oraz wartość 2. (7)
Sprzedaż | 2008-12-08 |  | 19 | 22,24 | PRAWDA | #DZIEL/0! | =ILE.NIEPUSTYCH([Kol1];[Kol2];[Kol3];[Kol4];[Kol5];[Kol6];[Kol7]; "Dwa") | Oblicza liczbę niepustych argumentów z listy i wartość „Dwa”. (7)


PRÓG.ROZKŁAD.DWUM

Zwraca najmniejszą wartość, dla której skumulowany rozkład dwumianowy jest równy wartości kryterium lub od niej większy. Tej funkcji należy używać w aplikacjach badających niezawodność. Na przykład funkcji PRÓG.ROZKŁAD.DWUM można użyć do wyznaczenia największej liczby wadliwych części, jakie mogą opuścić linię montażową, nie powodując odrzucenia całej serii produktów.

Składnia

PRÓG.ROZKŁAD.DWUM(liczba_prób;prawdopodobieństwo_s;alfa)

Liczba_prób to liczba prób Bernoulliego.

Prawdopodobieństwo_s to prawdopodobieństwo sukcesu każdej próby.

Alfa to wartość kryterium.

Spostrzeżenia

  • Jeśli którykolwiek z argumentów nie jest liczbą, funkcja PRÓG.ROZKŁAD.DWUM zwraca wartość błędu #ARG!
  • Jeśli argument „liczba_prób” nie jest liczbą całkowitą, jego wartość jest obcinana do liczby całkowitej.
  • Jeśli argument „liczba_prób” < 0, funkcja PRÓG.ROZKŁAD.DWUM zwraca wartość błędu #LICZBA!
  • Jeśli argument „prawdopodobieństwo_s” < 0 lub argument „prawdopodobieństwo_s” > 1, funkcja PRÓG.ROZKŁAD.DWUM zwraca wartość błędu #LICZBA!
  • Jeśli argument „alfa” < 0 lub argument „alfa” > 1, funkcja PRÓG.ROZKŁAD.DWUM zwraca wartość błędu #LICZBA!

Przykład

Liczba_prób | Prawdopodobieństwo_s | Alfa | Formuła | Opis (wynik)
6 | 0,5 | 0,75 | =PRÓG.ROZKŁAD.DWUM([Liczba_prób];[Prawdopodobieństwo_s];[Alfa]) | Najmniejsza wartość, dla której skumulowany rozkład dwumianowy jest równy wartości kryterium lub od niej większy (4)


ODCH.KWADRATOWE

Zwraca wartość sumy kwadratów odchyleń punktów danych od ich średniej z próby.

Składnia

ODCH.KWADRATOWE(liczba1;liczba2;...)

Liczba1;liczba2;... to od 1 do 30 argumentów, dla których jest obliczana suma kwadratów odchyleń.

Spostrzeżenia

  • Argumenty muszą być liczbami lub odwołaniami kolumn zawierającymi liczby.
  • Jeśli argument zawiera tekst, wartości logiczne lub jest pusty, wartości te są ignorowane. Argumenty o wartości zero są jednak uwzględniane.
  • Równanie sumy kwadratów odchyleń jest następujące:

Przykład

Kol1 | Kol2 | Kol3 | Kol4 | Kol5 | Kol6 | Kol7 | Formuła | Opis (wynik)
4 | 5 | 8 | 7 | 11 | 4 | 3 | =ODCH.KWADRATOWE([Kol1];[Kol2];[Kol3];[Kol4];[Kol5];[Kol6];[Kol7]) | Suma kwadratów odchyleń danych od ich średniej arytmetycznej (48)


ROZKŁAD.EXP

Zwraca skumulowaną funkcję (dystrybuantę) rozkładu wykładniczego. Funkcja ROZKŁAD.EXP umożliwia modelowanie upływu czasu między zdarzeniami, np. czasu oczekiwania na wypłatę gotówki z bankomatu. Funkcji ROZKŁAD.EXP można na przykład użyć do wyznaczenia prawdopodobieństwa, że zajmie to najwyżej jedną minutę.

Składnia

ROZKŁAD.EXP(x;lambda;skumulowany)

X to wartość funkcji.

Lambda to wartość parametryczna.

Skumulowany to wartość logiczna, wskazująca na formę funkcji wykładniczej, jakiej należy użyć. Jeśli argument skumulowany ma wartość PRAWDA, funkcja ROZKŁAD.EXP zwraca wartość funkcji rozkładu skumulowanego; jeśli ma wartość FAŁSZ, funkcja zwraca wartość funkcji rozkładu prawdopodobieństwa.

Spostrzeżenia

  • Jeśli argumenty x lub lambda nie są liczbami, funkcja ROZKŁAD.EXP zwraca wartość błędu #ARG!
  • Jeśli argument x < 0, funkcja ROZKŁAD.EXP zwraca wartość błędu #LICZBA!
  • Jeśli argument lambda ? 0, funkcja ROZKŁAD.EXP zwraca wartość błędu #LICZBA!
  • Równanie funkcji rozkładu prawdopodobieństwa jest następujące:

  • Równanie funkcji rozkładu skumulowanego jest następujące:

Przykład 1

Formuła | Opis (wynik)
=ROZKŁAD.EXP(0,2;10;FAŁSZ) | Funkcja wykładniczego rozkładu prawdopodobieństwa (1,353353)

Przykład 2

X | Lambda | Formuła | Opis (wynik)
0,2 | 10 | =ROZKŁAD.EXP([X];[Lambda];PRAWDA) | Funkcja wykładniczego rozkładu skumulowanego (0,864665)


ROZKŁAD.F

Zwraca rozkład prawdopodobieństwa F. Za pomocą tej funkcji można określić, czy dwa zestawy danych mają różne stopnie zróżnicowania. Na przykład można sprawdzić wyniki testu dla dziewcząt i chłopców rozpoczynających naukę w liceum i określić, czy zróżnicowanie wśród dziewcząt jest inne niż zróżnicowanie wśród chłopców.

Składnia

ROZKŁAD.F(x;stopnie_swobody1;stopnie_swobody2)

X to wartość, dla której ta funkcja ma zostać obliczona.

Stopnie_swobody1 to licznik stopni swobody.

Stopnie_swobody2 to mianownik stopni swobody.

Spostrzeżenia

  • Jeśli którykolwiek z argumentów nie jest liczbą, funkcja ROZKŁAD.F zwraca wartość błędu #ARG!
  • Jeśli argument x ma wartość ujemną, funkcja ROZKŁAD.F zwraca wartość błędu #LICZBA!
  • Jeśli argument „stopnie_swobody1” lub „stopnie_swobody2” nie jest liczbą całkowitą, jego wartość zostanie obcięta do liczby całkowitej.
  • Jeśli argument „stopnie_swobody1” < 1 lub argument „stopnie_swobody1” ? 10^10, funkcja ROZKŁAD.F zwraca wartość błędu #LICZBA!
  • Jeśli argument „stopnie_swobody2” < 1 lub argument „stopnie_swobody2” ? 10^10, funkcja ROZKŁAD.F zwraca wartość błędu #LICZBA!
  • Funkcja ROZKŁAD.F jest obliczana jako ROZKŁAD.F = P( F<x ), gdzie F jest zmienną losową z rozkładem F.

Przykład

X | Stopnie1 | Stopnie2 | Formuła | Opis (wynik)
15,20675 | 6 | 4 | =ROZKŁAD.F([X];[Stopnie1];[Stopnie2]) | Rozkład prawdopodobieństwa F dla określonych argumentów (0,01)


ROZKŁAD.F.ODW

Zwraca wartość funkcji odwrotnej rozkładu F prawdopodobieństwa. Jeśli p = ROZKŁAD.F(x;...), to ROZKŁAD.F.ODW(p;...) = x.

Rozkładu F można używać w teście F porównującym stopień zróżnicowania dwóch zestawów danych. Na przykład można analizować rozkład przychodów w USA i Kanadzie w celu określenia, czy w obu krajach jest zbliżony poziom zróżnicowania.

Składnia

ROZKŁAD.F.ODW(prawdopodobieństwo;stopnie_swobody1;stopnie_swobody2)

Prawdopodobieństwo to prawdopodobieństwo skojarzone ze skumulowanym rozkładem F.

Stopnie_swobody1 to licznik stopni swobody.

Stopnie_swobody2 to mianownik stopni swobody.

Spostrzeżenia

  • Jeśli którykolwiek z argumentów nie jest liczbą, funkcja ROZKŁAD.F.ODW zwraca wartość błędu #ARG!
  • Jeśli argument „prawdopodobieństwo” < 0 lub argument „prawdopodobieństwo” > 1, funkcja ROZKŁAD.F.ODW zwraca wartość błędu #LICZBA!
  • Jeśli argument „stopnie_swobody1” lub argument „stopnie_swobody2” nie jest liczbą całkowitą, jego wartość zostanie obcięta do liczby całkowitej.
  • Jeśli argument „stopnie_swobody1” < 1 lub argument „stopnie_swobody1” ? 10^10, funkcja ROZKŁAD.F.ODW zwraca wartość błędu #LICZBA!
  • Jeśli argument „stopnie_swobody2” < 1 lub argument „stopnie_swobody2” ? 10^10, funkcja ROZKŁAD.F zwraca wartość błędu #LICZBA!

Funkcji ROZKŁAD.F.ODW można używać do otrzymywania wartości krytycznych rozkładu F. Na przykład wynikiem obliczeń ANOVA są często dane dla statystyki F, prawdopodobieństwa F i wartości krytycznej F przy poziomie istotności 0,05. Aby otrzymać wartość krytyczną F, należy użyć poziomu istotności jako argumentu prawdopodobieństwa dla funkcji ROZKŁAD.F.ODW.

Funkcja ROZKŁAD.F.ODW wykorzystuje technikę iteracyjną obliczania funkcji. Jeśli dana jest wartość prawdopodobieństwa, funkcja ROZKŁAD.F.ODW wykonuje iteracje, dopóki wynik nie charakteryzuje się dokładnością do ± 3x10^-7. Jeśli po 100 iteracjach nie nastąpi zbieżność funkcji ROZKŁAD.F.ODW, funkcja zwróci wartość błędu #N/D.

Przykład

Prawdopodobieństwo | Stopnie1 | Stopnie2 | Formuła | Opis (wynik)
0,01 | 6 | 4 | =ROZKŁAD.F.ODW([Prawdopodobieństwo];[Stopnie1];[Stopnie2]) | Odwrotność rozkładu prawdopodobieństwa F dla określonych argumentów (15,20675)


ROZKŁAD.FISHER

Zwraca transformację Fishera dla wartości x. Dzięki tej transformacji uzyskuje się funkcję, która ma w przybliżeniu rozkład normalny, a nie skośny. Za pomocą tej funkcji można testować hipotezy dotyczące współczynnika korelacji.

Składnia

ROZKŁAD.FISHER(x)

X to wartość liczbowa, dla której ma zostać dokonana transformacja.

Spostrzeżenia

  • Jeśli argument x nie jest liczbą, funkcja ROZKŁAD.FISHER zwraca wartość błędu #ARG!
  • Jeśli argument x ? -1 lub argument x ? 1, funkcja ROZKŁAD.FISHER zwraca wartość błędu #LICZBA!

  • Równanie transformacji Fishera ma postać:

Przykład

Formuła | Opis (wynik)
=ROZKŁAD.FISHER(0,75) | Transformacja Fishera w punkcie 0,75 (0,972955)


ROZKŁAD.FISHER.ODW

Zwraca wartość funkcji odwrotnej transformacji Fishera. Transformacja ta jest przydatna podczas analizy korelacji między zakresami lub tablicami danych. Jeśli y = ROZKŁAD.FISHER(x), to ROZKŁAD.FISHER.ODW(y) = x.

Składnia

ROZKŁAD.FISHER.ODW(y)

Y to wartość, dla której ma zostać wyznaczona funkcja odwrotna transformacji.

Spostrzeżenia

  • Jeśli argument y nie jest liczbą, to funkcja ROZKŁAD.FISHER.ODW zwraca wartość błędu #ARG!

  • Równanie funkcji odwrotnej transformacji Fishera ma postać:

Przykład

Formuła | Opis (wynik)
=ROZKŁAD.FISHER.ODW(0,972955) | Funkcja odwrotna transformacji Fishera w punkcie 0,972955 (0,75)


ROZKŁAD.GAMMA

Zwraca rozkład gamma. Funkcja ta umożliwia badanie zmiennych, które mogą mieć rozkład skośny. Rozkład gamma jest powszechnie stosowany w analizie kolejek.

Składnia

ROZKŁAD.GAMMA(x;alfa;beta;skumulowany)

X to wartość, dla której ma zostać obliczony rozkład.

Alfa to parametr rozkładu.

Beta to parametr rozkładu. Jeśli wartość argumentu beta = 1, funkcja ROZKŁAD.GAMMA zwraca standardowy rozkład gamma.

Skumulowany jest wartością logiczną, która określa formę funkcji. Jeśli wartość skumulowana jest prawdziwa (PRAWDA), funkcja ROZKŁAD.GAMMA zwraca skumulowaną funkcję rozkładu; jeśli jest fałszywa (FAŁSZ), zwraca funkcję gęstości prawdopodobieństwa.

Spostrzeżenia

  • Jeśli argument x, alfa lub beta nie jest liczbą, funkcja ROZKŁAD.GAMMA zwraca wartość błędu #ARG!
  • Jeśli argument x < 0, funkcja ROZKŁAD.GAMMA zwraca wartość błędu #LICZBA!
  • Jeśli argument alfa ? 0 lub jeśli argument beta ? 0, funkcja ROZKŁAD.GAMMA zwraca wartość błędu #LICZBA!
  • Równanie rozkładu gamma jest następujące:

    Standardowy rozkład gamma jest następujący:

  • Jeśli argument alfa = 1, funkcja ROZKŁAD.GAMMA zwraca rozkład wykładniczy z:

  • Dla dodatniej liczby całkowitej n, kiedy argument alfa = n/2, argument beta = 2, a argument skumulowany ma wartość PRAWDA, funkcja ROZKŁAD.GAMMA zwraca (1 — ROZKŁAD.CHI(x)) z n stopniami swobody.
  • Jeśli argument alfa jest dodatnią liczbą całkowitą, funkcja ROZKŁAD.GAMMA nazywana jest również rozkładem Erlanga.

Przykład

X | Alfa | Beta | Formuła | Opis (wynik)
10 | 9 | 2 | =ROZKŁAD.GAMMA([X];[Alfa];[Beta];FAŁSZ) | Rozkład prawdopodobieństwa gamma argumentów (0,032639)
10 | 9 | 2 | =ROZKŁAD.GAMMA([X];[Alfa];[Beta];PRAWDA) | Skumulowany rozkład gamma argumentów (0,068094)


ROZKŁAD.GAMMA.ODW

Zwraca funkcję odwrotną skumulowanego rozkładu gamma. Jeśli p = ROZKŁAD.GAMMA.ODW(x;...), to ROZKŁAD.GAMMA.ODW(p;...) = x.

Funkcja ta jest przydatna w badaniu zmiennej, której rozkład może być skośny.

Składnia

ROZKŁAD.GAMMA.ODW(prawdopodobieństwo;alfa;beta)

Prawdopodobieństwo to prawdopodobieństwo skojarzone z rozkładem gamma.

Alfa to parametr rozkładu.

Beta to parametr rozkładu. Jeśli wartość argumentu beta = 1, funkcja ROZKŁAD.GAMMA.ODW zwraca standardowy rozkład gamma.

Spostrzeżenia

  • Jeśli którykolwiek z argumentów nie jest liczbą, funkcja ROZKŁAD.GAMMA.ODW zwraca wartość błędu #ARG!
  • Jeśli wartość argumentu prawdopodobieństwa < 0 lub wartość argumentu prawdopodobieństwa > 1, funkcja ROZKŁAD.GAMMA.ODW zwraca wartość błędu #LICZBA!
  • Jeśli wartość argumentu alfa ? 0 lub jeśli wartość argumentu beta ? 0, funkcja ROZKŁAD.GAMMA.ODW zwraca wartość błędu #LICZBA!

Funkcja ROZKŁAD.GAMMA.ODW wykorzystuje technikę iteracyjną obliczania funkcji. Jeśli dana jest wartość prawdopodobieństwa, funkcja ROZKŁAD.GAMMA.ODW wykonuje iteracje, dopóki wynik nie charakteryzuje się dokładnością do ±3x10^-7. Jeśli po 100 iteracjach nie nastąpi zbieżność funkcji ROZKŁAD.GAMMA.ODW, funkcja zwróci wartość błędu #N/D.

Przykład

Prawdopodobieństwo | Alfa | Beta | Formuła | Opis (wynik)
0,068094 | 9 | 2 | =ROZKŁAD.GAMMA.ODW([Prawdopodobieństwo];[Alfa];[Beta]) | Odwrotność skumulowanego rozkładu gamma dla argumentów (10)


ROZKŁAD.LIN.GAMMA

Zwraca logarytm naturalny funkcji gamma, ?(x).

Składnia

ROZKŁAD.LIN.GAMMA(x)

X to wartość, dla której ma zostać obliczona funkcja ROZKŁAD.LIN.GAMMA.

Spostrzeżenia

  • Jeśli argument x nie jest liczbą, funkcja ROZKŁAD.LIN.GAMMA zwraca wartość błędu #ARG!
  • Jeśli wartość argumentu x ? 0, funkcja ROZKŁAD.LIN.GAMMA zwraca wartość błędu #LICZBA!
  • Liczba e podniesiona do potęgi ROZKŁAD.LIN.GAMMA(i), gdzie i jest liczbą całkowitą, daje taki sam wynik jak (i – 1)!
  • Funkcja ROZKŁAD.LIN.GAMMA jest obliczana w następujący sposób:

    gdzie:

Przykład

Formuła | Opis (wynik)
=ROZKŁAD.LIN.GAMMA(4) | Logarytm naturalny funkcji gamma w punkcie 4 (1,791759)


ŚREDNIA.GEOMETRYCZNA

Zwraca średnią geometryczną danych dodatnich. Za pomocą funkcji ŚREDNIA.GEOMETRYCZNA można obliczyć na przykład szybkość wzrostu, gdy dany jest procent składany z różnymi stawkami.

Składnia

ŚREDNIA.GEOMETRYCZNA(liczba1;liczba2;...)

Liczba1;liczba2;... to od 1 do 30 argumentów, dla których należy obliczyć wartość średnią.

Spostrzeżenia

  • Argumenty muszą być liczbami lub odwołaniami kolumn zawierającymi liczby.
  • Jeśli argument (odwołanie kolumny) zawiera tekst, wartości logiczne lub jest pusty, wartości te są ignorowane. Argumenty o wartości zero są jednak uwzględniane.
  • Jeśli dowolny punkt danych ? 0, funkcja ŚREDNIA.GEOMETRYCZNA zwraca wartość błędu #LICZBA!
  • Równanie dla średniej geometrycznej jest następujące:

Przykład

Kol1 | Kol2 | Kol3 | Kol4 | Kol5 | Kol6 | Kol7 | Formuła | Opis (wynik)
4 | 5 | 8 | 7 | 11 | 4 | 3 | =ŚREDNIA.GEOMETRYCZNA([Kol1];[Kol2];[Kol3];[Kol4];[Kol5];[Kol6];[Kol7]) | Średnia geometryczna danych (5,476987)


ŚREDNIA.HARMONICZNA

Zwraca średnią harmoniczną zbioru danych. Średnia harmoniczna jest odwrotnością średniej arytmetycznej odwrotności.

Składnia

ŚREDNIA.HARMONICZNA(liczba1;liczba2;...)

Liczba1;liczba2;... to od 1 do 30 argumentów, dla których należy obliczyć wartość średnią.

Spostrzeżenia

  • Argumenty muszą być liczbami lub odwołaniami kolumn zawierającymi liczby.
  • Jeśli argument (odwołanie kolumny) zawiera tekst, wartości logiczne lub jest pusty, wartości te są ignorowane. Argumenty o wartości zero są jednak uwzględniane.
  • Jeśli którykolwiek z punktów danych ? 0, funkcja ŚREDNIA.HARMONICZNA zwraca wartość błędu #LICZBA!
  • Średnia harmoniczna jest zawsze mniejsza niż średnia geometryczna, która jest zawsze mniejsza niż średnia arytmetyczna.
  • Równanie dla średniej harmonicznej przedstawia się następująco:

Przykład

Kol1 | Kol2 | Kol3 | Kol4 | Kol5 | Kol6 | Kol7 | Formuła | Opis (wynik)
4 | 5 | 8 | 7 | 11 | 4 | 3 | =ŚREDNIA.HARMONICZNA([Kol1];[Kol2];[Kol3];[Kol4];[Kol5];[Kol6];[Kol7]) | Średnia harmoniczna danych (5,028376)


ROZKŁAD.HIPERGEOM

Zwraca rozkład hipergeometryczny. Funkcja ROZKŁAD.HIPERGEOM zwraca prawdopodobieństwo sukcesów danej liczby próbek przy podanym rozmiarze próbki oraz podanych sukcesach populacji i rozmiarze populacji. Funkcję ROZKŁAD.HIPERGEOM należy stosować do rozwiązywania zagadnień dotyczących skończonej populacji, gdzie każda obserwacja jest sukcesem albo porażką i gdzie każdy podzbiór o podanej wielkości wybierany jest z jednakowym prawdopodobieństwem.

Składnia

ROZKŁAD.HIPERGEOM(s_próbki;wielk_próbki;s_populacji;wielk_populacji)

S_próbki to liczba sukcesów w próbce.

Wielk_próbki to rozmiar próbki.

S_populacji to liczba sukcesów w populacji.

Wielk_populacji to rozmiar populacji.

Spostrzeżenia

  • Wszystkie argumenty są zaokrąglane do liczb całkowitych.
  • Jeśli którykolwiek z argumentów nie jest liczbą, funkcja ROZKŁAD.HIPERGEOM zwraca wartość błędu #ARG!
  • Jeśli wartość „s_próbki” < 0 lub jeśli wartość „s_próbki” jest większa niż mniejsza z wartości: „wielk_próbki” lub „s_populacji”, funkcja ROZKŁAD.HIPERGEOM zwraca wartość błędu #LICZBA!
  • Jeśli wartość s_próbki” jest mniejsza niż większa z wartości: 0 lub (wielk_próbki – wielk_populacji + s_populacji), funkcja ROZKŁAD.HIPERGEOM zwraca wartość błędu #LICZBA!
  • Jeśli wartość „wielk_próbki” < 0 lub jeśli „wielk_próbki” > „wielk_populacji”, funkcja ROZKŁAD.HIPERGEOM zwraca wartość błędu #LICZBA!
  • Jeśli wartość „s_populacji” < 0 lub jeśli „s_populacji” > „wielk_populacji”, funkcja ROZKŁAD.HIPERGEOM zwraca wartość błędu #LICZBA!
  • Jeśli wartość „wielk_populacji” < 0, funkcja ROZKŁAD.HIPERGEOM zwraca wartość błędu #LICZBA!
  • Równanie dla rozkładu hipergeometrycznego przedstawia się następująco:

    gdzie:

    x = s_próbki

    n = wielk_próbki

    M = s_populacji

    L = wielk_populacji

    Funkcję ROZKŁAD.HIPERGEOM stosuje się przy próbkowaniu bez zastępowania ze skończonej populacji.

Przykład

Urządzenie do pobierania próbek czekoladek zawiera 20 sztuk. Osiem czekoladek to czekoladki karmelowe, a pozostałe dwanaście czekoladek to czekoladki orzechowe. Jeśli osoba wybierze 4 przypadkowe czekoladki, następująca funkcja zwraca prawdopodobieństwo, że dokładnie 1 czekoladka będzie czekoladką karmelową.

S_próbki | Wielk_próbki | S_populacji | Wielk_populacji | Formuła | Opis (wynik)
1 | 4 | 8 | 20 | =ROZKŁAD.HIPERGEOM([S_próbki],[Wielk_próbki],[S_populacji],[Wielk_populacji]) | Rozkład hipergeometryczny dla próbki i populacji (0,363261)


KURTOZA

Zwraca kurtozę zbioru danych. Kurtoza charakteryzuje względną szczytowość lub płaskość rozkładu w porównaniu z rozkładem normalnym. Dodatnia kurtoza oznacza rozkład o stosunkowo dużej szczytowości. Ujemna kurtoza oznacza rozkład stosunkowo płaski.

Składnia

KURTOZA(liczba1;liczba2;...)

Liczba1;liczba2;... to od 1 do 30 argumentów, dla których jest obliczana kurtoza.

Spostrzeżenia

  • Argumenty muszą być liczbami lub odwołaniami kolumn zawierającymi liczby.
  • Jeśli argument (odwołanie kolumny) zawiera tekst, wartości logiczne lub jest pusty, wartości te są ignorowane. Argumenty o wartości zero są jednak uwzględniane.
  • Jeśli jest mniej niż cztery punkty danych lub jeśli standardowe odchylenie próbki jest równe zero, funkcja KURTOZA zwraca wartość błędu #DZIEL/0!
  • Kurtoza jest definiowana w następujący sposób:

    gdzie:

    s jest przykładowym odchyleniem standardowym.

Przykład

Kol1 | Kol2 | Kol3 | Kol4 | Kol5 | Kol6 | Kol7 | Kol8 | Kol9 | Kol10 | Formuła | Opis (wynik)
3 | 4 | 5 | 2 | 3 | 4 | 5 | 6 | 4 | 7 | =KURTOZA([Kol1];[Kol2];[Kol3];[Kol4];[Kol5];[Kol6];[Kol7];[Kol8];[Kol9];[Kol10]) | Kurtoza zbioru danych (-0,1518)


ROZKŁAD.LOG.ODW

Zwraca wartość funkcji odwrotnej skumulowanego rozkładu logarytmiczno-normalnego x, gdzie ln(x) ma rozkład normalny z parametrami „średnia” i „odchylenie_std”. Jeśli p = ROZKŁAD.LOG(x;...), to ROZKŁAD.LOG.ODW(p;...) = x.

Rozkład logarytmiczno-normalny jest używany przy analizie danych przekształconych logarytmicznie.

Składnia

ROZKŁAD.LOG.ODW(prawdopodobieństwo;średnia;odchylenie_std)

Prawdopodobieństwo to prawdopodobieństwo skojarzone z rozkładem logarytmiczno-normalnym.

Średnia to wartość średnia ln(x).

Odchylenie_std to standardowe odchylenie ln(x).

Spostrzeżenia

  • Jeśli którykolwiek z argumentów nie jest liczbą, funkcja ROZKŁAD.LOG.ODW zwraca wartość błędu #ARG!
  • Jeśli wartość „prawdopodobieństwo” < 0 lub wartość „prawdopodobieństwo” > 1, funkcja ROZKŁAD.LOG.ODW zwraca wartość błędu #LICZBA!
  • Jeśli wartość „odchylenie_std” <= 0, funkcja ROZKŁAD.LOG.ODW zwraca wartość błędu #LICZBA!

  • Funkcja odwrotna do funkcji rozkładu logarytmiczno-normalnego jest równa:

Przykład

Prawdopodobieństwo | Średnia | OdchStd | Formuła | Opis (wynik)
0,039084 | 3,5 | 1,2 | =ROZKŁAD.LOG.ODW([Prawdopodobieństwo]; [Średnia]; [OdchStd]) | Odwrotność skumulowanego rozkładu logarytmiczno-normalnego dla określonych argumentów (4,000028)


ROZKŁAD.LOG

Zwraca skumulowany rozkład logarytmiczno-normalny x, gdzie ln(x) ma rozkład normalny o parametrach „średnia” i „odchylenie_std”. Funkcja ta jest używana do przeprowadzania analizy danych przekształconych logarytmicznie.

Składnia

ROZKŁAD.LOG(x;średnia;odchylenie_std)

X to wartość, dla której ta funkcja ma zostać obliczona.

Średnia to wartość średnia ln(x).

Odchylenie_std to standardowe odchylenie ln(x).

Spostrzeżenia

  • Jeśli którykolwiek z argumentów nie jest liczbą, funkcja ROZKŁAD.LOG zwraca wartość błędu #ARG!
  • Jeśli x ? 0 lub jeśli odchylenie_std ? 0, funkcja ROZKŁAD.LOG zwraca wartość błędu #LICZBA!
  • Równanie skumulowanego rozkładu logarytmiczno-normalnego jest następujące:

Przykład

X | Średnia | OdchStd | Formuła | Opis (wynik)
4 | 3,5 | 1,2 | =ROZKŁAD.LOG([X];[Średnia];[OdchStd]) | Skumulowany rozkład logarytmiczno-normalny dla wartości 4 z określonymi argumentami (0,039084)


MAX

Zwraca największą wartość w zbiorze wartości.

Składnia

MAX(liczba1;liczba2;...)

Liczba1;liczba2;... to od 1 do 30 liczb, dla których należy znaleźć największą wartość.

Spostrzeżenia

  • Można określić argumenty, które są liczbami, wartościami logicznymi lub odwzorowaniami tekstowymi liczb albo są puste. Argumenty, które są wartościami błędów lub tekstem, którego nie można przekształcić w liczby, powodują błędy.
  • Jeśli nie można zignorować wartości logicznych i tekstu, należy użyć funkcji MAX.A.
  • Jeśli argumenty nie zawierają liczb, funkcja MAX zwraca 0 (zero).

Przykład

Kol1 | Kol2 | Kol3 | Kol4 | Kol5 | Formuła | Opis (wynik)
10 | 7 | 9 | 27 | 2 | =MAX([Kol1];[Kol2];[Kol3];[Kol4];[Kol5]) | Największa z liczb (27)
10 | 7 | 9 | 27 | 2 | =MAX(Kol1];[Kol2];[Kol3];[Kol4];[Kol5];30) | Największa z liczb i 30 (30)


MAX.A

Zwraca największą wartość z listy argumentów. Porównywane są: tekst, wartości logiczne, takie jak PRAWDA i FAŁSZ, oraz liczby.

Funkcja MAX.A działa podobnie jak funkcja MIN.A. Aby uzyskać więcej informacji, zobacz przykłady dla funkcji MIN.A.

Składnia

MAX.A(wartość1;wartość2;...)

Wartość1;wartość2;... to 1 do 30 wartości, dla których należy znaleźć największą wartość.

Spostrzeżenia

  • Można określić argumenty, które są liczbami, wartościami logicznymi lub odwzorowaniami tekstowymi liczb albo są puste. Argumenty, które są wartościami błędów, powodują błędy. Jeśli w obliczeniach nie można uwzględniać tekstu ani wartości logicznych, należy użyć funkcji MAX.
  • Wartość liczbowa argumentów zawierających wartość logiczną PRAWDA wynosi 1; wartość liczbowa argumentów zawierających tekst lub wartość logiczną FAŁSZ wynosi 0 (zero).
  • Jeśli argumenty nie zawierają żadnych wartości, funkcja MAX.A zwraca wartość 0 (zero).

Przykład

Kol1 | Kol2 | Kol3 | Kol4 | Kol5 | Formuła | Opis (wynik)
0 | 0,2 | 0,5 | 0,4 | PRAWDA | =MAX.A([Kol1];[Kol2];[Kol3];[Kol4];[Kol5]) | Największa z liczb. Wartość PRAWDA odpowiada wartości 1. (1)


MEDIANA

Zwraca medianę określonych liczb. Mediana jest liczbą w środku zbioru liczb; tj. połowa liczb ma wartości większe niż mediana, a połowa ma wartości mniejsze.

Składnia

MEDIANA(liczba1;liczba2;...)

Liczba1; liczba2;... to 1 do 30 liczb, dla których należy wyznaczyć medianę.

Spostrzeżenia

  • Argumenty powinny być liczbami lub odwołaniami kolumn zawierającymi liczby.
  • Jeśli argument (odwołanie kolumny) zawiera tekst, wartości logiczne lub jest pusty, wartości te są ignorowane. Argumenty o wartości zero są jednak uwzględniane.

  • Jeśli w zbiorze znajduje się parzysta liczba liczb, funkcja MEDIANA oblicza średnią dwóch liczb w środku. Zapoznaj się z drugą formułą poniżej.

Przykład

Kol1 | Kol2 | Kol3 | Kol4 | Kol5 | Kol6 | Formuła | Opis (wynik)
1 | 2 | 3 | 4 | 5 | 6 | =MEDIANA([Kol1];[Kol2];[Kol3];[Kol4];[Kol5]) | Mediana pierwszych 5 liczb z listy (3)
1 | 2 | 3 | 4 | 5 | 6 | =MEDIANA([Kol1];[Kol2];[Kol3];[Kol4];[Kol5];[Kol6]) | Mediana wszystkich liczb lub średnia liczb 3 i 4 (3,5)


MIN

Zwraca najmniejszą liczbę w zbiorze wartości.

Składnia

MIN(liczba1;liczba2;...)

Liczba1; liczba2;... to 1 do 30 liczb, dla których należy znaleźć minimalną wartość.

Spostrzeżenia

  • Można określić argumenty, które są liczbami, wartościami logicznymi lub odwzorowaniami tekstowymi liczb albo są puste. Argumenty, które są wartościami błędów lub tekstem, którego nie można przekształcić w liczby, powodują błędy.
  • Jeśli argument jest odwołaniem kolumny, używane są tylko liczby. Jeśli wartości logiczne i tekst nie powinny być ignorowane, należy użyć funkcji MIN.A.
  • Jeśli argumenty nie zawierają liczb, funkcja MIN zwraca 0.

Przykład

Kol1 | Kol2 | Kol3 | Kol4 | Kol5 | Formuła | Opis (wynik)
10 | 7 | 9 | 27 | 2 | =MIN([Kol1];[Kol2];[Kol3];[Kol4];[Kol5]) | Najmniejsza z liczb (2)
10 | 7 | 9 | 27 | 2 | =MIN([Kol1];[Kol2];[Kol3];[Kol4];[Kol5],0) | Najmniejsza z liczb i 0 (0)


MIN.A

Zwraca najmniejszą wartość z listy argumentów. Porównywane są: tekst, wartości logiczne, takie jak PRAWDA i FAŁSZ, oraz liczby.

Składnia

MIN.A(wartość1;wartość2;...)

Wartość1, wartość2,... to 1 do 30 wartości, dla których należy znaleźć najmniejszą wartość.

Spostrzeżenia

  • Można określić argumenty, które są liczbami, wartościami logicznymi lub tekstowymi odwzorowaniami liczb albo są puste. Argumenty, które są wartościami błędów, powodują błędy. Jeśli w obliczeniach nie można uwzględniać tekstu ani wartości logicznych, należy użyć funkcji MIN.
  • Wartość liczbowa argumentów zawierających wartość logiczną PRAWDA wynosi 1; wartość liczbowa argumentów zawierających tekst lub wartość logiczną FAŁSZ wynosi 0 (zero).
  • Jeśli argumenty nie zawierają żadnych wartości, funkcja MIN.A zwraca wartość 0 (zero).

Przykład

Kol1 | Kol2 | Kol3 | Kol4 | Kol5 | Formuła | Opis (wynik)
FAŁSZ | 0,2 | 0,5 | 0,4 | 0,8 | =MIN.A([Kol1];[Kol2];[Kol3];[Kol4];[Kol5]) | Najmniejsza z liczb. Wartość FAŁSZ odpowiada wartości 0. (0)


WYST.NAJCZĘŚCIEJ

Zwraca najczęściej występującą lub powtarzającą się wartość na liście argumentów. Podobnie jak funkcja MEDIANA, funkcja WYST.NAJCZĘŚCIEJ służy do obliczania położenia.

Składnia

WYST.NAJCZĘŚCIEJ(liczba1;liczba2;...)

Liczba1; liczba2;... to argumenty (od 1 do 30), dla których ma zostać obliczona wartość modalna.

Spostrzeżenia

  • Argumenty powinny być liczbami lub odwołaniami kolumn zawierającymi liczby.
  • Jeśli argument (odwołanie kolumny) zawiera tekst, wartości logiczne lub jest pusty, wartości te są ignorowane. Argumenty o wartości zero są jednak uwzględniane.
  • Jeśli zbiór danych nie zawiera zduplikowanych punktów danych, funkcja WYST.NAJCZĘŚCIEJ zwraca wartość błędu #N/D!

W zestawie wartości wartość modalna jest wartością, która występuje najczęściej; mediana jest wartością środkową; średnia jest wartością uśrednioną. Nie istnieje sposób pomiaru tendencji centralnej, który umożliwiałby uzyskanie pełnego obrazu danych. Załóżmy, że dane są zgrupowane w trzech obszarach, połowa wokół jednej wartości dolnej i połowa wokół dwóch dużych wartości. Zarówno funkcja ŚREDNIA, jak i funkcja MEDIANA mogą zwracać wartość w stosunkowo pustym środku, a funkcja WYST.NAJCZĘŚCIEJ może zwracać niską wartość dominanty.

Przykład

Kol1 | Kol2 | Kol3 | Kol4 | Kol5 | Kol6 | Formuła | Opis (wynik)
5,6 | 4 | 4 | 3 | 2 | 4 | =WYST.NAJCZĘŚCIEJ([Kol1]; [Kol2]; [Kol3]; [Kol4]; [Kol5]; [Kol6]) | Wartość modalna lub najczęściej występująca liczba (4)


ROZKŁAD.DWUM.PRZEC

Zwraca ujemny rozkład dwumianowy. Funkcja ROZKŁAD.DWUM.PRZEC zwraca w wyniku prawdopodobieństwo, że przy stałym prawdopodobieństwie sukcesu równym „prawdopodobieństwo_s” przed sukcesem o numerze określonym w argumencie „liczba_s” wystąpi „liczba_p” niepowodzeń. Funkcja ta działa podobnie jak funkcja zwracająca rozkład dwumianowy, z tym wyjątkiem, że liczba sukcesów jest stała, a liczba prób jest zmienna. Podobnie jak w przypadku rozkładu dwumianowego przyjmuje się, że próby są niezależne.

Załóżmy na przykład, że trzeba znaleźć 10 osób z doskonałym refleksem, a prawdopodobieństwo, że kandydat ma taką umiejętność, jest równe 0,3. Funkcja ROZKŁAD.DWUM.PRZEC oblicza prawdopodobieństwo, że trzeba będzie przeprowadzić rozmowy z pewną liczbą kandydatów bez takiej umiejętności, zanim znajdzie się 10 kandydatów mających taką umiejętność.

Składnia

ROZKŁAD.DWUM.PRZEC(liczba_p;liczba_s;prawdopodobieństwo_s)

Liczba_p to liczba porażek.

Liczba_s to progowa liczba sukcesów.

Prawdopodobieństwo_s to prawdopodobieństwo sukcesu.

Spostrzeżenia

  • Wartości argumentów „liczba_p” i „liczba_s” powinny być >= 0.
  • Wartości argumentów „liczba_p” i „liczba_s” są obcinane do liczb całkowitych.
  • Jeśli którykolwiek z argumentów nie jest liczbą, funkcja ROZKŁAD.DWUM.PRZEC zwraca wartość błędu #ARG!
  • Jeśli wartość „prawdopodobieństwo_s” < 0 lub jeśli wartość „prawdopodobieństwo_s” > 1, funkcja ROZKŁAD.DWUM.PRZEC zwraca wartość błędu #LICZBA!
  • Równanie ujemnego rozkładu dwumianowego przedstawia się następująco:

    gdzie:

    x to liczba_p, r to liczba_s, a p to prawdopodobieństwo_s.

Przykład

Liczba_p | Liczba_s | Prawdopodobieństwo_s | Formuła | Opis (wynik)
10 | 5 | 0,25 | =ROZKŁAD.DWUM.PRZEC([Liczba_p]; [Liczba_s]; [Prawdopodobieństwo_s]) | Ujemny rozkład dwumianowy dla określonych argumentów (0,055049)


ROZKŁAD.NORMALNY

Zwraca rozkład normalny dla określonej średniej i odchylenia standardowego. Ta funkcja ma bardzo szeroki zakres zastosowań w statystyce, łącznie z badaniem hipotez.

Składnia

ROZKŁAD.NORMALNY(x;średnia;odchylenie_std;skumulowany)

X to wartość, dla której należy obliczyć wartość rozkładu.

Średnia to średnia arytmetyczna rozkładu.

Odchylenie_std to standardowe odchylenie rozkładu.

Skumulowany to wartość logiczna, która określa format funkcji. Jeśli argument skumulowany ma wartość PRAWDA, wówczas funkcja ROZKŁAD.NORMALNY zwraca skumulowaną funkcję rozkładu; a jeśli ma wartość FAŁSZ, jest zwracana funkcja gęstości prawdopodobieństwa.

Spostrzeżenia

  • Jeśli argument „średnia” lub „odchylenie_std” nie jest liczbą, funkcja ROZKŁAD.NORMALNY zwraca wartość błędu #ARG!
  • Jeśli wartość „odchylenie_std” ? 0, funkcja ROZKŁAD.NORMALNY zwraca wartość błędu #LICZBA!
  • Jeśli „średnia” = 0, „odchylenie_std” = 1 i „skumulowany” = PRAWDA, funkcja ROZKŁAD.NORMALNY zwraca standardowy rozkład normalny (ROZKŁAD.NORMALNY.S).
  • Równanie normalnej funkcji gęstości („skumulowany” = FAŁSZ) przedstawia się następująco:

  • Gdy wartość „skumulowany” = PRAWDA, formuła jest całką od minus nieskończoności do x danej formuły.

Przykład

X | Średnia | OdchStd | Formuła | Opis (wynik)
42 | 40 | 1,5 | =ROZKŁAD.NORMALNY([X];[Średnia];[OdchStd];PRAWDA) | Skumulowany rozkład dla określonych argumentów (0,908789)
42 | 40 | 1,5 | =ROZKŁAD.NORMALNY([X];[Średnia];[OdchStd];FAŁSZ) | Funkcja masy prawdopodobieństwa dla określonych argumentów (0,10934005)


ROZKŁAD.NORMALNY.ODW

Zwraca odwrotność skumulowanego rozkładu normalnego dla podanej średniej i odchylenia standardowego.

Składnia

ROZKŁAD.NORMALNY.ODW(prawdopodobieństwo;średnia;odchylenie_std)

Prawdopodobieństwo to prawdopodobieństwo odpowiadające rozkładowi normalnemu.

Średnia to średnia arytmetyczna rozkładu.

Odchylenie_std to standardowe odchylenie rozkładu.

Spostrzeżenia

  • Jeśli którykolwiek z argumentów nie jest liczbą, funkcja ROZKŁAD.NORMALNY.ODW zwraca wartość błędu #ARG!
  • Jeśli wartość „prawdopodobieństwo” < 0 lub jeśli wartość „prawdopodobieństwo” > 1, funkcja ROZKŁAD.NORMALNY.ODW zwraca wartość błędu #LICZBA!
  • Jeśli wartość „odchylenie_std” ? 0, funkcja ROZKŁAD.NORMALNY.ODW zwraca wartość błędu #LICZBA!

  • Jeśli „średnia” = 0 i „odchylenie_std” = 1, funkcja ROZKŁAD.NORMALNY.ODW stosuje standardowy rozkład normalny (zobacz ROZKŁAD.NORMALNY.S.ODW).

Funkcja ROZKŁAD.NORMALNY.ODW wykorzystuje technikę iteracyjną obliczania funkcji. Jeśli dana jest wartość prawdopodobieństwa, funkcja ROZKŁAD.NORMALNY.ODW wykonuje iteracje, dopóki wynik nie charakteryzuje się dokładnością do ± 3x10^-7. Jeśli po 100 iteracjach nie nastąpi zbieżność funkcji ROZKŁAD.NORMALNY.ODW, funkcja zwróci wartość błędu #N/D.

Przykład

Prawdopodobieństwo | Średnia | OdchStd | Formuła | Opis (wynik)
0,908789 | 40 | 1,5 | =ROZKŁAD.NORMALNY.ODW([Prawdopodobieństwo];[Średnia];[OdchStd]) | Odwrotność normalnego skumulowanego rozkładu dla określonych argumentów (42)


ROZKŁAD.NORMALNY.S

Zwraca funkcję skumulowanego rozkładu normalnego. Rozkład ten ma średnią równą zero i odchylenie standardowe równe jeden. Funkcję tę należy stosować zamiast tabeli obszarów standardowych krzywych normalnych.

Składnia

ROZKŁAD.NORMALNY.S(z)

Z to wartość, dla której należy obliczyć wartość funkcji.

Spostrzeżenia

  • Jeśli „z” jest argumentem nieliczbowym, funkcja ROZKŁAD.NORMALNY.S zwraca wartość błędu #ARG!
  • Równaniem standardowej funkcji gęstości rozkładu normalnego jest:

Przykład

Formuła | Opis (wynik)
=ROZKŁAD.NORMALNY.S(1,333333) | Funkcja skumulowanego rozkładu normalnego dla argumentu 1,333333 (0,908789)


ROZKŁAD.NORMALNY.S.ODW

Zwraca funkcję odwrotną skumulowanego, standardowego rozkładu normalnego. Rozkład ten ma średnią równą zero i odchylenie standardowe równe jeden.

Składnia

ROZKŁAD.NORMALNY.S.ODW(prawdopodobieństwo)

Prawdopodobieństwo to prawdopodobieństwo odpowiadające rozkładowi normalnemu.

Spostrzeżenia

  • Jeśli „prawdopodobieństwo” jest argumentem nieliczbowym, funkcja ROZKŁAD.NORMALNY.S.ODW zwraca wartość błędu #ARG!
  • Jeśli wartość „prawdopodobieństwo” < 0 lub jeśli wartość „prawdopodobieństwo” > 1, funkcja ROZKŁAD.NORMALNY.S.ODW zwraca wartość błędu #LICZBA!

Funkcja ROZKŁAD.NORMALNY.S.ODW wykorzystuje technikę iteracyjną obliczania funkcji. Jeśli dana jest wartość prawdopodobieństwa, funkcja ROZKŁAD.NORMALNY.S.ODW wykonuje iteracje, dopóki wynik nie charakteryzuje się dokładnością do ± 3x10^-7. Jeśli po 100 iteracjach nie nastąpi zbieżność funkcji ROZKŁAD.NORMALNY.S.ODW, funkcja zwróci wartość błędu #N/D.

Przykład

Formuła | Opis (wynik)
=ROZKŁAD.NORMALNY.S.ODW(0,908789) | Funkcja odwrotna skumulowanego, standardowego rozkładu normalnego przy prawdopodobieństwie równym 0,908789 (1,3333)


ROZKŁAD.POISSON

Zwraca skumulowaną funkcję (dystrybuantę) rozkładu Poissona. Typowym zastosowaniem rozkładu Poissona jest prognozowanie liczby zdarzeń w danym czasie, takiej jak liczba samochodów przejeżdżających przez plac w czasie jednej minuty.

Składnia

ROZKŁAD.POISSON (x;średnia;skumulowany)

X to liczba zdarzeń.

Średnia to oczekiwana wartość liczbowa.

Skumulowany to wartość logiczna, która określa formę zwracanego rozkładu prawdopodobieństwa. Jeśli argument skumulowany ma wartość PRAWDA, funkcja ROZKŁAD.POISSON zwraca skumulowane prawdopodobieństwo Poissona, że liczba przypadkowych zdarzeń będzie pomiędzy zero a x włącznie. Jeśli ma wartość FAŁSZ, wówczas funkcja ta zwraca funkcję masy prawdopodobieństwa Poissona, że liczba zdarzeń będzie dokładnie równa x.

Spostrzeżenia

  • Jeśli argument x nie jest liczbą całkowitą, jest obcinany do liczby całkowitej.
  • Jeśli argumenty x lub „średnia” nie są wartościami liczbowymi, funkcja ROZKŁAD.POISSON zwraca wartość błędu #ARG!
  • Jeśli x ? 0, funkcja POISSON zwraca wartość błędu #LICZBA!
  • Jeśli „średnia” ? 0, funkcja POISSON zwraca wartość błędu #LICZBA!
  • Funkcja ROZKŁAD.POISSON jest obliczana w następujący sposób:

    Dla wartości „skumulowany” = FAŁSZ:

    Dla wartości „skumulowany” = PRAWDA:

Przykład

X | Średnia | Formuła | Opis (wynik)
2 | 5 | =ROZKŁAD.POISSON([X];[Średnia];PRAWDA) | Skumulowane prawdopodobieństwo Poissona z określonymi argumentami (0,124652)
2 | 5 | =ROZKŁAD.POISSON([X];[Średnia];FAŁSZ) | Funkcja masy prawdopodobieństwa Poissona z określonymi argumentami (0,084224)


SKOŚNOŚĆ

Zwraca skośność rozkładu. Skośność charakteryzuje stopień asymetrii rozkładu wokół jego średniej. Skośność dodatnia określa rozkład z asymetrią rozciągającą się w kierunku wartości dodatnich. Skośność ujemna określa rozkład z asymetrią rozciągającą się w kierunku wartości ujemnych.

Składnia

SKOŚNOŚĆ(liczba1;liczba2;...)

Liczba1;liczba2... to od 1 do 30 argumentów, dla których należy obliczyć skośność.

Spostrzeżenia

  • Argumenty muszą być liczbami lub odwołaniami kolumn zawierającymi liczby.
  • Jeśli argument (odwołanie kolumny) zawiera tekst, wartości logiczne lub jest pusty, wartości te są ignorowane. Argumenty o wartości zero są jednak uwzględniane.
  • Jeśli liczba punktów danych jest mniejsza niż trzy lub jeśli przykładowe odchylenie standardowe jest równe zero, funkcja SKOŚNOŚĆ zwraca wartość błędu #DZIEL/0!
  • Równanie obliczające skośność przedstawia się następująco:

Przykład

D1 | D2 | D3 | D4 | D5 | D6 | D7 | D8 | D9 | D10 | Formuła | Opis (wynik)
3 | 4 | 5 | 2 | 3 | 4 | 5 | 6 | 4 | 7 | =SKOŚNOŚĆ([D1]; [D2]; [D3]; [D4]; [D5]; [D6]; [D7]; [D8]; [D9]; [D10]) | Skośność rozkładu zestawu danych (0,359543)


NORMALIZUJ

Zwraca wartość znormalizowaną z rozkładu opisanego przez argumenty „średnia” i „odchylenie_std”.

Składnia

NORMALIZUJ(x;średnia;odchylenie_std)

X to wartość, którą należy znormalizować.

Średnia to średnia arytmetyczna rozkładu.

Odchylenie_std to standardowe odchylenie rozkładu.

Spostrzeżenia

  • Jeśli odchylenie_std ? 0, funkcja NORMALIZUJ zwraca wartość błędu #LICZBA!
  • Równanie obliczające wartość znormalizowaną przedstawia się następująco:

Przykład

X | Średnia | OdchStd | Formuła | Opis (wynik)
42 | 40 | 1,5 | =NORMALIZUJ([X];[Średnia];[OdchStd]) | Wartość znormalizowana 42 dla określonych argumentów (1,333333)


ODCH.STANDARDOWE

Szacuje odchylenie standardowe próbki. Odchylenie standardowe jest miarą tego, jak dalece wartości odbiegają od wartości przeciętnej (średniej).

Składnia

ODCH.STANDARDOWE(liczba1;liczba2;...)

Liczba1; liczba2;... to od 1 do 30 argumentów liczbowych, które odpowiadają próbce populacji.

Spostrzeżenia

  • Wartości logiczne, takie jak PRAWDA i FAŁSZ, oraz tekst są ignorowane. Jeśli wartości logiczne i tekst nie mogą być ignorowane, należy użyć funkcji ODCH.STANDARDOWE.A.
  • Działanie funkcji ODCH.STANDARDOWE jest oparte na założeniu, że argumenty tej funkcji są próbką populacji. Jeśli dane reprezentują całą populację, należy obliczyć standardowe odchylenie za pomocą funkcji ODCH.STANDARD.POPUL.
  • Odchylenie standardowe oblicza się za pomocą metody „nieobciążonej” lub „n–1”.
  • Funkcja ODCH.STANDARDOWE korzysta z następującej formuły:

Przykład

Przyjmijmy, że 10 narzędzi wykonanych na tej samej maszynie w jednym cyklu produkcyjnym zostało zebranych jako przypadkowa próbka, na której przeprowadzono pomiar wytrzymałości na złamanie.

Wyt1 | Wyt2 | Wyt3 | Wyt4 | Wyt5 | Wyt6 | Wyt7 | Wyt8 | Wyt9 | Wyt10 | Formuła | Opis (wynik)
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1299 | =ODCH.STANDARDOWE([Wyt1]; [Wyt2]; [Wyt3]; [Wyt4]; [Wyt5]; [Wyt6]; [Wyt7]; [Wyt8]; [Wyt9]; [Wyt10]) | Odchylenie standardowe wytrzymałości na złamanie (27,46391572)


ODCH.STANDARDOWE.A

Szacuje odchylenie standardowe próbki. Odchylenie standardowe pozwala określić, jak dalece wartości odbiegają od wartości przeciętnej (średniej). Tekst i wartości logiczne, takie jak PRAWDA i FAŁSZ, są uwzględniane w obliczeniach.

Składnia

ODCH.STANDARDOWE.A(wartość1;wartość2;...)

Wartość1;wartość2;... to od 1 do 30 wartości odpowiadających próbce populacji.

Spostrzeżenia

  • Działanie funkcji ODCH.STANDARDOWE.A jest oparte na założeniu, że jej argumenty są próbką populacji. Jeśli dane reprezentują całą populację, należy obliczyć odchylenie standardowe za pomocą funkcji ODCH.STANDARD.POPUL.A.
  • Argumenty zawierające wartość PRAWDA są interpretowane jako 1; argumenty zawierające tekst lub wartość FAŁSZ są interpretowane jako 0 (zero). Jeśli w obliczeniach nie można uwzględniać tekstu ani wartości logicznych, należy użyć funkcji arkusza kalkulacyjnego ODCH.STANDARDOWE.
  • Odchylenie standardowe oblicza się za pomocą metody „nieobciążonej” lub „n–1”.
  • Funkcja ODCH.STANDARDOWE.A korzysta z następującej formuły:

Przykład

Przyjmijmy, że 10 narzędzi wykonanych na tej samej maszynie w jednym cyklu produkcyjnym zostało zebranych jako przypadkowa próbka, na której przeprowadzono pomiar wytrzymałości na złamanie.

Wyt1 | Wyt2 | Wyt3 | Wyt4 | Wyt5 | Wyt6 | Wyt7 | Wyt8 | Wyt9 | Wyt10 | Formuła | Opis (wynik)
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1299 | =ODCH.STANDARDOWE.A([Wyt1]; [Wyt2]; [Wyt3]; [Wyt4]; [Wyt5]; [Wyt6]; [Wyt7]; [Wyt8]; [Wyt9]; [Wyt10]) | Odchylenie standardowe wytrzymałości na złamanie dla wszystkich narzędzi (27,46391572)


ODCH.STANDARD.POPUL

Oblicza odchylenie standardowe dla całej populacji podanej w postaci argumentów. Odchylenie standardowe jest miarą tego, jak dalece wartości odbiegają od wartości przeciętej (średniej).

Składnia

ODCH.STANDARD.POPUL(liczba1;liczba2;...)

Liczba1;liczba2;... to od 1 to 30 argumentów liczbowych, które odpowiadają populacji.

Spostrzeżenia

  • Wartości logiczne, takie jak PRAWDA i FAŁSZ, oraz tekst są ignorowane. Jeśli wartości logiczne i tekst nie mogą być ignorowane, należy użyć funkcji arkusza kalkulacyjnego ODCH.STANDARD.POPUL.A.
  • Działanie funkcji ODCH.STANDARD.POPUL jest oparte na założeniu, że jej argumenty są całą populacją. Jeśli dane reprezentują próbkę populacji, należy obliczyć odchylenie standardowe za pomocą funkcji ODCH.STANDARDOWE.
  • Dla dużych próbek funkcje ODCH.STANDARDOWE i ODCH.STANDARD.POPUL zwracają w przybliżeniu jednakowe wartości.
  • Odchylenie standardowe oblicza się przy użyciu metody „obciążonej” lub metody „n–1”.
  • Funkcja ODCH.STANDARD.POPUL korzysta z następującej formuły:

Przykład

Wyt1 | Wyt2 | Wyt3 | Wyt4 | Wyt5 | Wyt6 | Wyt7 | Wyt8 | Wyt9 | Wyt10 | Formuła | Opis (wynik)
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1299 | =ODCH.STANDARD.POPUL([Wyt1]; [Wyt2]; [Wyt3]; [Wyt4]; [Wyt5]; [Wyt6]; [Wyt7]; [Wyt8]; [Wyt9]; [Wyt10]) | Odchylenie standardowe wytrzymałości na złamanie przy założeniu, że wyprodukowano tylko 10 narzędzi (26,05455814)


ODCH.STANDARD.POPUL.A

Oblicza odchylenie standardowe dla całej populacji podanej jako argumenty, w tym tekst i wartości logiczne. Odchylenie standardowe jest miarą tego, jak dalece wartości odbiegają od wartości przeciętnej (średniej).

Składnia

ODCH.STANDARD.POPUL.A(wartość1;wartość2;...)

Wartość1;wartość2;... to od 1 do 30 wartości odpowiadających populacji.

Spostrzeżenia

  • Działanie funkcji ODCH.STANDARD.POPUL.A jest oparte na założeniu, że jej argumenty są całą populacją. Jeśli dane reprezentują próbkę populacji, należy obliczyć odchylenie standardowe za pomocą funkcji ODCH.STANDARDOWE.A.
  • Argumenty zawierające wartość PRAWDA są interpretowane jako 1; argumenty zawierające tekst lub wartość FAŁSZ są interpretowane jako 0 (zero). Jeśli w obliczeniach nie można uwzględniać tekstu ani wartości logicznych, należy użyć funkcji arkusza kalkulacyjnego ODCH.STANDARD.POPUL.
  • Dla dużych próbek funkcje ODCH.STANDARDOWE.A i ODCH.STANDARD.POPUL.A dają w przybliżeniu jednakowe wartości.
  • Odchylenie standardowe oblicza się przy użyciu metody „obciążonej” lub metody „n–1”.
  • Funkcja ODCH.STANDARD.POPUL.A korzysta z następującej formuły:

Przykład

Wyt1 | Wyt2 | Wyt3 | Wyt4 | Wyt5 | Wyt6 | Wyt7 | Wyt8 | Wyt9 | Wyt10 | Formuła | Opis (wynik)
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1299 | =ODCH.STANDARD.POPUL.A([Wyt1]; [Wyt2]; [Wyt3]; [Wyt4]; [Wyt5]; [Wyt6]; [Wyt7]; [Wyt8]; [Wyt9]; [Wyt10]) | Odchylenie standardowe wytrzymałości na złamanie przy założeniu, że wyprodukowano tylko 10 narzędzi (26,05455814)


ROZKŁAD.T

Zwraca punkty procentowe (prawdopodobieństwo) dla rozkładu t-Studenta, gdzie wartość numeryczna (x) jest obliczoną wartością t, dla której należy obliczyć punkty procentowe. Rozkład t jest stosowany przy testowaniu hipotez dla małych próbek zbiorów danych. Funkcję tę należy stosować zamiast tabeli wartości krytycznych dla rozkładu t.

Składnia

ROZKŁAD.T(x;stopnie_swobody;ślady)

X to wartość numeryczna, przy której należy oszacować rozkład.

Stopnie_swobody to liczba całkowita oznaczająca liczbę stopni swobody.

Ślady argument określający, ilustronny rozkład ma zostać zwrócony. Jeśli argument „ślady” = 1, funkcja ROZKŁAD.T zwraca rozkład jednostronny. Jeśli argument „ślady” = 2, funkcja ROZKŁAD.T zwraca rozkład dwustronny.

Spostrzeżenia

  • Jeśli którykolwiek z argumentów nie jest liczbą, funkcja ROZKŁAD.T zwraca wartość błędu #ARG!
  • Jeśli argument „stopnie_swobody” < 1, funkcja ROZKŁAD.T zwraca wartość błędu #LICZBA!
  • Argumenty „stopnie_swobody” i „ślady” są obcinane do liczb całkowitych.
  • Jeśli argument „ślady” ma wartość inną niż 1 lub 2, funkcja ROZKŁAD.T zwraca wartość błędu #LICZBA!
  • Funkcja ROZKŁAD.T jest obliczana na podstawie wzoru ROZKŁAD.T = p( x<MODUŁ.LICZBY(X)), gdzie X jest zmienną losową następującą po rozkładzie t.

Przykład

X | Stopnie | Formuła | Opis (wynik)
1,96 | 60 | =ROZKŁAD.T([X];[Stopnie];2) | Rozkład dwustronny (0,054644927 lub 5,46 procent)
1,96 | 60 | =ROZKŁAD.T([X];[Stopnie];1) | Rozkład jednostronny (0,027322463, czyli 2,73 procent)


ROZKŁAD.T.ODW

Zwraca wartość t rozkładu t-Studenta jako funkcję prawdopodobieństwa i liczby stopni swobody.

Składnia

ROZKŁAD.T.ODW(prawdopodobieństwo;stopnie_swobody)

Prawdopodobieństwo to prawdopodobieństwo skojarzone z rozkładem dwustronnym t-Studenta.

Stopnie_swobody jest liczbą stopni swobody charakteryzującą rozkład.

Spostrzeżenia

  • Jeśli którykolwiek z argumentów nie jest liczbą, funkcja ROZKŁAD.T.ODW zwraca wartość błędu #ARG!
  • Jeśli argument „prawdopodobieństwo” < 0 lub jeśli argument „prawdopodobieństwo” > 1, funkcja ROZKŁAD.T.ODW zwraca wartość błędu #LICZBA!
  • Jeśli argument „stopnie_swobody” nie jest liczbą całkowitą, jest obcinany do liczby całkowitej.
  • Jeśli argument „stopnie_swobody” < 1, funkcja ROZKŁAD.T.ODW zwraca wartość błędu #LICZBA!
  • Funkcja ROZKŁAD.T.ODW jest obliczana na podstawie wzoru ROZKŁAD.T.ODW = p( t<X ), gdzie X jest zmienną losową następującą po rozkładzie t.
  • Jednostronna wartość t może zostać obliczona przez zamianę prawdopodobieństwa na 2*prawdopodobieństwo. Dla prawdopodobieństwa równego 0,05 i argumentu „stopnie_swobody” równego 10 wartość dwustronna obliczana jest jako ROZKŁAD.T.ODW(0,05;10) i funkcja zwraca wartość 2,28139. Wartość jednostronna dla takiego samego prawdopodobieństwa i dla takich samych stopni swobody może zostać obliczona przez funkcję ROZKŁAD.T.ODW(2*0,05;10), która zwróci wartość 1,812462.

    Uwaga W niektórych tablicach prawdopodobieństwo jest wyrażane jako (1-p).

Funkcja ROZKŁAD.T.ODW wykorzystuje technikę iteracyjną obliczania funkcji. Jeśli dana jest wartość prawdopodobieństwa, funkcja ROZKŁAD.T.ODW wykonuje iteracje, dopóki wynik nie charakteryzuje się dokładnością do ± 3x10^-7. Jeśli po 100 iteracjach nie nastąpi zbieżność funkcji ROZKŁAD.T.ODW, funkcja zwróci wartość błędu #N/D.

Przykład

Prawdopodobieństwo | Stopnie | Formuła | Opis (wynik)
0,054645 | 60 | =ROZKŁAD.T.ODW([Prawdopodobieństwo];[Stopnie]) | Wartość t rozkładu t-Studenta dla określonych argumentów (1,959997462)


WARIANCJA

Szacuje wariancję na podstawie próbki.

Składnia

WARIANCJA(liczba1;liczba2;...)

Liczba1; liczba2;... to od 1 do 30 argumentów liczbowych, które odpowiadają próbce populacji.

Spostrzeżenia

  • Działanie funkcji WARIANCJA jest oparte na założeniu, że argumenty funkcji są próbkami populacji. Jeśli dane reprezentują całą populację, należy obliczyć wariancję za pomocą funkcji WARIANCJA.POPUL.
  • Wartości logiczne, takie jak PRAWDA i FAŁSZ, oraz tekst są ignorowane. Jeśli wartości logiczne i tekst nie mogą być ignorowane, należy użyć funkcji WARIANCJA.A.
  • Funkcja WARIANCJA korzysta z następującej formuły:

Przykład

Przyjmijmy, że 10 narzędzi wykonanych na tej samej maszynie w jednym cyklu produkcyjnym zostało zebranych jako przypadkowa próbka, na której przeprowadzono pomiar wytrzymałości na złamanie.

Wyt1 | Wyt2 | Wyt3 | Wyt4 | Wyt5 | Wyt6 | Wyt7 | Wyt8 | Wyt9 | Wyt10 | Formuła | Opis (wynik)
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1299 | =WARIANCJA([Wyt1]; [Wyt2]; [Wyt3]; [Wyt4]; [Wyt5]; [Wyt6]; [Wyt7]; [Wyt8]; [Wyt9]; [Wyt10]) | Wariancja wytrzymałości narzędzi na złamanie (754,2666667)


WARIANCJA.A

Szacuje wariancję na podstawie próbki. W obliczeniach oprócz liczb są uwzględniane wartości logiczne, takie jak PRAWDA i FAŁSZ, oraz tekst.

Składnia

WARIANCJA.A(wartość1;wartość2;...)

Wartość1;wartość2;... to od 1 do 30 argumentów wartości, które odpowiadają próbce populacji.

Spostrzeżenia

  • Działanie funkcji WARIANCJA.A jest oparte na założeniu, że jej argumenty są próbką populacji. Jeśli dane reprezentują całą populację, należy obliczyć wariancję za pomocą funkcji WARIANCJA.POPUL.A.
  • Argumenty zawierające wartość PRAWDA są interpretowane jako 1; argumenty zawierające tekst lub wartość FAŁSZ są interpretowane jako 0 (zero). Jeśli w obliczeniach nie można uwzględniać tekstu ani wartości logicznych, należy użyć funkcji WARIANCJA.
  • Funkcja WARIANCJA.A korzysta z następującej formuły:

Przykład

Przyjmijmy, że 10 narzędzi wykonanych na tej samej maszynie w jednym cyklu produkcyjnym zostało zebranych jako przypadkowa próbka, na której przeprowadzono pomiar wytrzymałości na złamanie.

Wyt1 | Wyt2 | Wyt3 | Wyt4 | Wyt5 | Wyt6 | Wyt7 | Wyt8 | Wyt9 | Wyt10 | Formuła | Opis (wynik)
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1299 | =WARIANCJA.A([Wyt1]; [Wyt2]; [Wyt3]; [Wyt4]; [Wyt5]; [Wyt6]; [Wyt7]; [Wyt8]; [Wyt9]; [Wyt10]) | Szacuje wariancję wytrzymałości na złamanie (754,2666667)


WARIANCJA.POPUL

Oblicza wariancję na podstawie całej populacji.

Składnia

WARIANCJA.POPUL(liczba1;liczba2;...)

Liczba1;liczba2;... to od 1 to 30 argumentów liczbowych, które odpowiadają populacji.

  • Wartości logiczne, takie jak PRAWDA i FAŁSZ, oraz tekst są ignorowane. Jeśli wartości logiczne i tekst nie mogą być ignorowane, należy użyć funkcji WARIANCJA.A.

Spostrzeżenia

  • Działanie funkcji WARIANCJA.POPUL jest oparte na założeniu, że argumenty funkcji są całą populacją. Jeśli dane reprezentują próbkę populacji, należy obliczyć wariancję za pomocą funkcji WARIANCJA.
  • Równanie funkcji WARIANCJA.POPUL przedstawia się następująco:

Przykład

Przyjmijmy, że 10 narzędzi wykonanych na tej samej maszynie w jednym cyklu produkcyjnym zostało zebranych jako przypadkowa próbka, na której przeprowadzono pomiar wytrzymałości na złamanie.

Wyt1 | Wyt2 | Wyt3 | Wyt4 | Wyt5 | Wyt6 | Wyt7 | Wyt8 | Wyt9 | Wyt10 | Formuła | Opis (wynik)
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1299 | =WARIANCJA.POPUL([Wyt1]; [Wyt2]; [Wyt3]; [Wyt4]; [Wyt5]; [Wyt6]; [Wyt7]; [Wyt8]; [Wyt9]; [Wyt10]) | Wariancja wytrzymałości na złamanie dla wszystkich narzędzi przy założeniu, że wyprodukowano tylko 10 narzędzi (678,84)


WARIANCJA.POPUL.A

Oblicza wariancję na podstawie całej populacji. W obliczeniach oprócz liczb są uwzględniane wartości logiczne, takie jak PRAWDA i FAŁSZ, oraz tekst.

Składnia

WARIANCJA.POPUL.A(wartość1;wartość2;...)

Wartość1;wartość2;... to od 1 do 30 argumentów wartości, które odpowiadają populacji.

Spostrzeżenia

  • Działanie funkcji WARIANCJA.POPUL.A jest oparte na założeniu, że argumenty funkcji są całą populacją. Jeśli dane reprezentują próbkę populacji, należy obliczyć wariancję za pomocą funkcji WARIANCJA.A.
  • Argumenty zawierające wartość PRAWDA są interpretowane jako 1; argumenty zawierające tekst lub wartość FAŁSZ, są interpretowane jako 0 (zero). Jeśli w obliczeniach nie można uwzględniać tekstu ani wartości logicznych, należy użyć funkcji WARIANCJA.POPUL.
  • Równanie funkcji WARIANCJA.POPUL.A przedstawia się następująco:

Przykład

Przyjmijmy, że 10 narzędzi wykonanych na tej samej maszynie w jednym cyklu produkcyjnym zostało zebranych jako przypadkowa próbka, na której przeprowadzono pomiar wytrzymałości na złamanie.

Wyt1 | Wyt2 | Wyt3 | Wyt4 | Wyt5 | Wyt6 | Wyt7 | Wyt8 | Wyt9 | Wyt10 | Formuła | Opis (wynik)
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1299 | =WARIANCJA.POPUL.A([Wyt1]; [Wyt2]; [Wyt3]; [Wyt4]; [Wyt5]; [Wyt6]; [Wyt7]; [Wyt8]; [Wyt9]; [Wyt10]) | Wariancja wytrzymałości na złamanie dla wszystkich narzędzi przy założeniu, że wyprodukowano tylko 10 narzędzi (678,84)


ROZKŁAD.WEIBULL

Zwraca skumulowaną funkcję (dystrybuantę) rozkładu Weibulla. Rozkład ten znajduje zastosowanie w analizie niezawodności, na przykład przy obliczaniu średniego czasu międzyawaryjnego urządzeń.

Składnia

ROZKŁAD.WEIBULL(x;alfa;beta;skumulowany)

X to wartość, dla której należy obliczyć tę funkcję.

Alfa to parametr rozkładu.

Beta to parametr rozkładu.

Skumulowany wyznacza formę funkcji.

Spostrzeżenia

  • Jeśli argument x, alfa lub beta nie jest liczbą, funkcja ROZKŁAD.WEIBULL zwraca wartość błędu #ARG!
  • Jeśli x < 0, funkcja ROZKŁAD.WEIBULL zwraca wartość błędu #LICZBA!
  • Jeśli alfa ? 0 lub beta ? 0, funkcja ROZKŁAD.WEIBULL zwraca wartość błędu #LICZBA!
  • Równanie funkcji skumulowanego rozkładu Weibulla jest następujące:

  • Równanie funkcji gęstości prawdopodobieństwa Weibulla jest następujące:

  • Jeśli alfa = 1, funkcja ROZKŁAD.WEIBULL zwraca rozkład wykładniczy z:

Przykład

X | Alfa | Beta | Formuła | Opis (wynik)
105 | 20 | 100 | =ROZKŁAD.WEIBULL([X];[Alfa];[Beta];PRAWDA) | Skumulowany rozkład Weibulla dla określonych argumentów (0,929581)
105 | 20 | 100 | =ROZKŁAD.WEIBULL([X];[Alfa];[Beta];FAŁSZ) | Funkcja gęstości rozkładu Weibulla dla określonych argumentów (0,035589)


ASC

W językach korzystających z dwubajtowego zestawu znaków (DBCS) zmienia znaki o pełnej szerokości (dwubajtowe) na znaki o połówkowej szerokości (jednobajtowe).

Składnia

ASC(tekst)

Tekst to tekst lub odwołanie do kolumny, w którym znajduje się tekst, który ma zostać zmieniony. Jeśli tekst nie zawiera liter o pełnej szerokości, nie jest zmieniany.

Przykłady

=ASC("EXCEL")
równa się "EXCEL"

=ASC("
Excel Excel Excel Excel
")
równa się " Excel Excel Excel Excel "


ZNAK

Zwraca znak określony za pomocą liczby. Funkcja ZNAK służy do przeprowadzania translacji liczb strony kodowej, które można uzyskać wśród znaków z plików na innych typach komputerów.

Składnia

ZNAK(liczba)

„Liczba” jest liczbą z zakresu od 1 do 255 określającą odpowiedni znak. Znak pochodzi z zestawu znaków używanego przez komputer.

Przykład

Formuła | Opis (wynik)
=ZNAK(65) | Wyświetla 65. znak w zestawie. (A)
=ZNAK(33) | Wyświetla 33. znak w zestawie. (!)


OCZYŚĆ

Usuwa z tekstu wszystkie znaki niedrukowalne. Funkcji OCZYŚĆ należy używać do tekstów importowanych z innych aplikacji, zawierających znaki, których być może nie da się wydrukować w danym systemie operacyjnym. Funkcję OCZYŚĆ można na przykład zastosować do usunięcia niektórych kodów komputerowych niskiego poziomu, których nie można wydrukować, a które często kończą i rozpoczynają pliki danych.

Składnia

OCZYŚĆ(tekst)

Tekst jest dowolną informacją, z której mają zostać usunięte znaki niedrukowalne.

Przykład

Kol1 | Formuła | Opis (wynik)
ZNAK(7)&"tekst"&ZNAK(7) | =OCZYŚĆ([Kol1]) | Usuwa z ciągu niedrukowalny znak ZNAK(7). (tekst)


KOD

Zwraca kod numeryczny pierwszego znaku w ciągu tekstowym. Zwracany jest kod stosowny do zestawu znaków używanego na komputerze.

Składnia

KOD(tekst)

„Tekst” jest tekstem, dla którego jest potrzebny kod pierwszego znaku w ciągu.

Przykład

Formuła | Opis (wynik)
=KOD("A") | Wyświetla kod numeryczny znaku A (65)
=KOD("!") | Wyświetla kod numeryczny znaku ! (33)


ZŁĄCZ.TEKSTY

Łączy kilka ciągów tekstowych w jeden.

Składnia

ZŁĄCZ.TEKSTY (tekst1;tekst2;...)

Tekst1; tekst2,... są elementami tekstu (od 1 do 30), które mają zostać połączone w jeden element tekstu. Elementami tekstu mogą być ciągi tekstowe, liczby lub odwołania kolumn.

Spostrzeżenia

Elementy tekstu można także łączyć za pomocą operatora „&” zamiast funkcji ZŁĄCZ.TEKSTY.

Przykład

Kol1 | Kol2 | Kol3 | Formuła | Opis
pstrąg potokowy | w strumieniach | 32 | =ZŁĄCZ.TEKSTY("Populacja gatunku";[Kol1];" ";[Kol2];" wynosi ";[Kol3];"/km") | Łączy zdanie z danych (Populacja gatunku pstrąg potokowy w strumieniach wynosi 32/km).


KWOTA

Konwertuje liczbę na tekst przy użyciu formatu waluty z zaokrągleniem do określonego miejsca po przecinku. Używany jest następujący format: # ##0,00 zł.

Składnia

KWOTA(liczba;miejsca_dziesiętne)

„Liczba” jest liczbą, odwołaniem kolumny zawierającym liczbę lub formułą umożliwiającą obliczenie liczby.

„Miejsca_dziesiętne” to liczba cyfr z prawej strony przecinka. Jeśli wartość argumentu „miejsca_dziesiętne” jest ujemna, liczba jest zaokrąglana do wartości po lewej stronie przecinka. Jeśli argument „miejsca_dziesiętne” nie zostanie zdefiniowany, w celu określenia liczby miejsc dziesiętnych będą używane ustawienia lokalne systemu.

Spostrzeżenia

Funkcja Kwota wykorzystuje ustawienia waluty komputera użytkownika. Jeśli zawsze mają być wyświetlane dolary amerykańskie (USD), należy użyć funkcji DOLAR.AMER.

Przykład

Kol1 | Formuła | Opis (wynik)
1234,567 | =KWOTA([Kol1]; 2) | Wyświetla pierwszą liczbę w formacie walutowym z dwiema (2) cyframi po prawej stronie przecinka dziesiętnego (1 234,57 zł).
1234,567 | =KWOTA([Kol1]; -2) | Wyświetla pierwszą liczbę w formacie walutowym z dwiema (2) cyframi po lewej stronie przecinka dziesiętnego (1 200 zł).
-1234,567 | =KWOTA([Kol1]; -2) | Wyświetla drugą liczbę w formacie walutowym z dwiema (2) cyframi po lewej stronie przecinka dziesiętnego (-1 200 zł).
-0,123 | =KWOTA([Kol1]; 4) | Wyświetla trzecią liczbę w formacie walutowym z czterema (4) cyframi po prawej stronie przecinka dziesiętnego (-0,1230 zł).
99,888 | =KWOTA([Kol1]) | Wyświetla czwartą liczbę w formacie walutowym z dwiema (2) cyframi po lewej stronie przecinka dziesiętnego (99,89 zł).


PORÓWNAJ

Porównuje dwa ciągi tekstowe i zwraca wartość PRAWDA, jeśli są one identyczne; w przeciwnym wypadku zwraca wartość FAŁSZ. Podczas korzystania z funkcji PORÓWNAJ należy zwracać uwagę na wielkość liter. Przy użyciu funkcji PORÓWNAJ można testować tekst wprowadzany do dokumentu.

Składnia

PORÓWNAJ(tekst1;tekst2)

Tekst1 to pierwszy tekst.

Tekst2 to drugi tekst.

Przykład

Kol1 | Kol2 | Formuła | Opis (wynik)
wyraz | wyraz | =PORÓWNAJ([Kol1];[Kol2]) | Sprawdza, czy ciągi są zgodne. (PRAWDA)
Wyraz | wyraz | =PORÓWNAJ([Kol1];[Kol2] | Sprawdza, czy ciągi są zgodne. (FAŁSZ)
wy raz | wyraz | =PORÓWNAJ([Kol1];[Kol2]) | Sprawdza, czy ciągi są zgodne. (FAŁSZ)


ZNAJDŹ

Wyszukuje jeden ciąg tekstowy (tekst_szukany) w innym ciągu tekstowym (w_tekście) i zwraca numer pozycji początkowej tekstu szukanego, począwszy od pierwszego znaku przeszukiwanego ciągu tekstowego (w_tekście). Do wyszukiwania ciągów w innych ciągach można także użyć funkcji SZUKAJ.TEKST, ale w przeciwieństwie do funkcji SZUKAJ.TEKST, w funkcji ZNAJDŹ jest uwzględniana wielkość liter i nie można używać symboli wieloznacznych.

Składnia

ZNAJDŹ(tekst_szukany;w_tekście;liczba_początkowa)

Tekst_szukany jest tekstem, który ma zostać znaleziony.

W_tekście jest tekstem zawierającym szukany tekst.

Liczba_początkowa określa znak, od którego ma się rozpocząć wyszukiwanie. Pierwszym znakiem w przeszukiwanym ciągu tekstowym (w_tekście) jest znak numer 1. Jeśli parametr „liczba_początkowa” zostanie pominięty, zakłada się, że jego wartość wynosi 1.

Pokaż Porada

Dzięki parametrowi „liczba początkowa” można pomijać określoną liczbę znaków. Załóżmy, na przykład, że pracujesz z ciągiem tekstowym „AYF0093.OdzieżMłodzieżowa”. Aby znaleźć numer pierwszej litery „O” w części opisowej ciągu tekstowego, ustaw dla parametru „liczba_początkowa” wartość 8, aby nie była przeszukiwana część tekstu z numerem seryjnym. Funkcja ZNAJDŹ rozpoczyna wyszukiwanie od znaku 8, znajduje wartość „tekst_szukany” (następny znak) i zwraca numer 9. Funkcja ZNAJDŹ zawsze znajduje liczbę znaków od początku przeszukiwanego ciągu tekstowego (w_tekście), licząc znaki pominięte, jeśli argument „liczba_początkowa” jest większy od 1.

Spostrzeżenia

  • Jeśli argument „tekst_szukany” ma wartość "" (pusty), funkcja ZNAJDŹ wyszukuje pierwszy znak w przeszukiwanym ciągu (tj. znak o numerze „liczba_początkowa” lub 1).
  • Argument „tekst_szukany” nie może zawierać symboli wieloznacznych.
  • Jeśli wartość „tekst_szukany” nie występuje w przeszukiwanym ciągu (w_tekście), funkcja ZNAJDŹ zwraca wartość błędu #ARG!
  • Jeśli argument „liczba_początkowa” nie jest większy od zera, funkcja ZNAJDŹ zwraca wartość błędu #ARG!
  • Jeśli argument „liczba_początkowa” jest większy niż długość przeszukiwanego ciągu tekstowego (w_tekście), funkcja ZNAJDŹ zwraca wartość błędu #ARG!

Przykład 1

Formuła | Opis (wynik)
=ZNAJDŹ("M";"Marek Malemski") | Pozycja pierwszego „M" w ciągu (1)
=ZNAJDŹ("m";"Marek Malemski") | Pozycja pierwszego „m” w ciągu (11)
=ZNAJDŹ("M";"Marek Malemski";3) | Pozycja pierwszego „M” w ciągu, począwszy od trzeciego znaku (7)

Przykład 2

Kol1 | Formuła | Opis (wynik)
Izolatory ceramiczne #124-TD45-87 | =FRAGMENT.TEKSTU([Kol1];1;ZNAJDŹ(" #";[Kol1];1)-1) | Wyodrębnia tekst od pozycji 1 do pozycji „#” ciągu. (Izolatory ceramiczne)
Cewki miedziane #12-671-6772 | =FRAGMENT.TEKSTU([Kol1];1;ZNAJDŹ(" #";[Kol1];1)-1) | Wyodrębnia tekst od pozycji 1 do pozycji „#” ciągu. (Cewki miedziane)
Rezystory zmienne #116010 | =FRAGMENT.TEKSTU([Kol1];1;ZNAJDŹ(" #";[Kol1];1)-1) | Wyodrębnia tekst od pozycji 1 do pozycji „#” ciągu. (Rezystory zmienne)


ZAOKR.DO.TEKST

Zaokrągla liczbę do podanej liczby miejsc dziesiętnych, formatuje liczbę do postaci dziesiętnej z użyciem przecinka i spacji oraz zwraca wynik w postaci tekstowej.

Składnia

ZAOKR.DO.TEKST(liczba;miejsca_dziesiętne;bez_separatora)

Liczba to liczba, która ma zostać zaokrąglona i przekonwertowana na tekst.

Miejsca_dziesiętne to liczba cyfr po prawej stronie przecinka dziesiętnego.

Bez_separatora to wartość logiczna, która, jeśli ma wartość PRAWDA, zapobiega umieszczaniu przez funkcję ZAOKR.DO.TEKST spacji w zwróconym tekście.

Spostrzeżenia

  • Jeśli wartość argumentu „miejsca_dziesiętne” jest ujemna, liczba jest zaokrąglana do wartości po lewej stronie przecinka dziesiętnego.
  • Jeśli argument „miejsca_dziesiętne” nie zostanie zdefiniowany, w celu określenia liczby miejsc dziesiętnych będą używane ustawienia lokalne systemu.
  • Jeśli argument „bez_separatora” ma wartość FAŁSZ lub nie jest określony, zwrócony tekst zawiera normalne separatory (spacje).

Przykład

Formuła | Opis (wynik)
=ZAOKR.DO.TEKST(1 234;567; 1) | Zaokrągla do pierwszej cyfry po prawej stronie przecinka dziesiętnego (1 234,6)
=ZAOKR.DO.TEKST(1 234,567; -1) | Zaokrągla do pierwszej cyfry po lewej stronie przecinka dziesiętnego (1 230)
=ZAOKR.DO.TEKST(-1 234,567;-1;PRAWDA) | Zaokrągla do drugiej cyfry po lewej stronie przecinka dziesiętnego, bez spacji (-1 230)
=ZAOKR.DO.TEKST(44,332) | Zaokrągla trzecią liczbę do dwóch cyfr po lewej stronie przecinka dziesiętnego (44,33)


LEWY

Funkcja LEWY zwraca co najmniej jeden pierwszy znak w ciągu tekstowym na podstawie określonej liczby znaków.

Składnia

LEWY(tekst;liczba_znaków)

Tekst jest ciągiem tekstowym zawierającym znaki, które mają zostać wyodrębnione.

Liczba_znaków określa liczbę znaków, które mają zostać wyodrębnione za pomocą funkcji LEWY.

  • Argument „liczba_znaków” musi być większy niż lub równy zero.

  • Jeśli wartość argumentu „liczba_znaków” jest większa niż długość tekstu, funkcja LEWY zwraca cały tekst.

  • Jeśli argument liczba_znaków zostanie pominięty, przyjmuje się, że jego wartość wynosi 1.

Przykład

Kol1 | Formuła | Opis (wynik)
Cena sprzedaży | =LEWY([Kol1];4) | Pierwsze cztery znaki ciągu (Cena)
Szwecja | =LEWY([Kol1]) | Pierwszy znak ciągu (S)


DŁ

Funkcja DŁ zwraca liczbę znaków ciągu tekstowego.

Składnia

DŁ(tekst)

Tekst to tekst, którego długość ma zostać znaleziona. Spacje są liczone jako znaki.

Przykład

Kol1 | Formuła | Opis (wynik)
Olsztyn, w-m | =DŁ([Kol1]) | Długość ciągu (11)
 | =DŁ([Kol1]) | Długość ciągu (0)
A Jeden | =DŁ([Kol1]) | Długość ciągu z 5 spacjami (10)


LITERY.MAŁE

Konwertuje wszystkie wielkie litery w ciągu tekstowym na małe.

Składnia

LITERY.MAŁE(tekst)

Tekst to tekst, który należy przekonwertować na małe litery. Funkcja LITERY.MAŁE nie zmienia w tekście tych znaków, które nie są literami.

Przykład

Kol1 | Formuła | Opis (wynik)
M. L. Nowak | =LITERY.MAŁE([Kol1]) | Małe litery w ciągu (m. l. nowak)
Lokal 2B | =LITERY.MAŁE([Kol1]) | Małe litery w ciągu (lokal 2b)


FRAGMENT.TEKSTU

Funkcja FRAGMENT.TEKSTU zwraca konkretną liczbę znaków z ciągu tekstowego, począwszy od określonego miejsca, na podstawie określonej liczby znaków.

Składnia

FRAGMENT.TEKSTU(tekst;liczba_początkowa;liczba_znaków)

Tekst jest ciągiem tekstowym zawierającym znaki, które mają zostać wyodrębnione.

Liczba_początkowa jest pozycją pierwszego znaku tekstu, który ma zostać wyodrębniony. Wartość „liczba_początkowa” pierwszego znaku tekstu wynosi 1 itd.

Liczba_znaków określa liczbę znaków tekstu, które mają zostać zwrócone przez funkcję FRAGMENT.TEKSTU.

Spostrzeżenia

  • Jeśli wartość „liczba_początkowa” jest większa niż długość tekstu, funkcja FRAGMENT.TEKSTU zwraca "" (pusty tekst).
  • Jeśli wartość „liczba_początkowa” jest mniejsza niż długość tekstu, ale suma wartości „liczba_początkowa” i „liczba_znaków” przekracza długość tekstu, funkcja FRAGMENT.TEKSTU zwraca znaki do końca tekstu.
  • Jeśli wartość „liczba_początkowa” jest mniejsza niż 1, funkcja FRAGMENT.TEKSTU zwraca wartość błędu #ARG!

  • Jeśli wartość „liczba_znaków” jest ujemna, funkcja FRAGMENT.TEKSTU zwraca wartość błędu #ARG!

Przykład

Formuła | Opis (wynik)
=FRAGMENT.TEKSTU("Przepływ płynu";1;8) | Osiem znaków z pierwszego ciągu, począwszy od pierwszego znaku (Przepływ)
=FRAGMENT.TEKSTU("Przepływ płynu";10;20) | Dwadzieścia znaków ciągu, począwszy od dziesiątego (płynu)
=FRAGMENT.TEKSTU("Przepływ płynu";20;5) | Zwrócenie pustego tekstu, ponieważ punkt początkowy jest większy niż długość ciągu ()


ZERO

Zwraca wartość #ZERO! i służy do wskazywania pustych wartości w kolumnie obliczeniowej.

Za pomocą funkcji ZERO można uniknąć problemu niezamierzonego uwzględnienia pustych wartości w obliczeniach. Gdy formuła odwołuje się do komórki zawierającej wartość #ZERO!, zwraca wartość #ZERO!

Składnia

ZERO()

Spostrzeżenie

Składnia funkcji ZERO nie zawiera żadnych argumentów. Do nazwy funkcji należy dołączyć puste nawiasy okrągłe. W przeciwnym przypadku program Microsoft SharePoint Foundation 2010 nie rozpozna nazwy jako funkcji.


NZ

Sprawdza, czy wartość wynosi #ZERO! Jeśli argument ma wartość PRAWDA, funkcja zwraca wartość alternatywną. W przeciwnym razie zwraca daną wartość.

Składnia

NZ(wartość; wartość_alternatywna)

Argument | Opis
wartość | Może być odwołaniem kolumny. Jeśli argument wartość jest równy #ZERO!, funkcja zwraca argument wartość_alternatywna. W przeciwnym razie zwraca argument wartość.
wartość_alternatywna | Mogą to być liczby, tekst lub odwołania kolumn. Argument wartość_alternatywna jest zwracany, jeśli argument wartość wynosi #ZERO!

Przykład

Kol1 | Kol2 | Formuła | Opis (wynik)
#ZERO! | 200 | =NZ([Kol1];[Kol2]) | Sprawdza, czy wartość w kolumnie Kol1 jest błędem typu #ZERO! i zwraca wartość alternatywną. (200)
400 | 450 | =NZ([Kol1];[Kol2]) | Sprawdza, czy wartość w kolumnie Kol1 jest błędem typu #ZERO! i zwraca wartość alternatywną. (400)


Z.WIELKIEJ.LITERY

Zamienia pierwszą literę ciągu tekstowego i wszystkie litery po znaku, który nie jest literą, na wielkie litery. Zamienia wszystkie pozostałe litery w ciągu tekstowym na małe litery.

Składnia

Z.WIELKIEJ.LITERY(tekst)

Tekst znajduje się w cudzysłowach; jest to formuła, która zwraca tekst lub odwołanie kolumny zawierające tekst, w którym niektóre małe litery mają zostać zamienione na wielkie.

Przykład

Formuła | Opis (wynik)
=Z.WIELKIEJ.LITERY("to jest TYTUŁ") | Właściwa wielkość liter w ciągu (To Jest Tytuł)
=Z.WIELKIEJ.LITERY("warty 2 centy") | Właściwa wielkość liter w ciągu (Warty 2 Centy)
=Z.WIELKIEJ.LITERY("BudŻet76") | Właściwa wielkość liter w ciągu (Budżet76)


ZASTĄP

Funkcja ZASTĄP zastępuje część ciągu tekstowego innym ciągiem tekstowym z uwzględnieniem określonej liczby znaków.

Składnia

ZASTĄP(stary_tekst;liczba_początkowa;liczba_znaków;nowy_tekst)

Stary_tekst jest tekstem, w którym mają zostać zmienione znaki.

Liczba_początkowa jest pozycją znaku w starym tekście, która ma zostać zastąpiona nowym tekstem.

Liczba_znaków jest liczbą znaków w starym tekście, która ma zostać zastąpiona nowym tekstem.

Nowy_tekst jest tekstem, który zastąpi znaki w starym tekście.

Przykład

Formuła | Opis (wynik)
=ZASTĄP("abcdefghijk";6;5;"*") | Zastępuje pięć znaków, rozpoczynając od szóstego znaku. (abcde*k)
=ZASTĄP("2009";3;2;"10") | Zastępuje ostatnie dwie cyfry liczby 2009 liczbą 10. (2010)
=ZASTĄP("123456";1;3;"@") | Zastępuje pierwsze trzy znaki znakiem @. (@456)


POWT

Powtarza tekst określoną liczbę razy. Za pomocą funkcji POWT można dodać określoną liczbę wystąpień ciągu tekstowego.

Składnia

POWT(tekst;ile_razy)

Tekst to tekst, który ma być powtarzany.

Ile_razy to liczba dodatnia określająca liczbę powtórzeń tekstu.

Spostrzeżenia

  • Jeśli argument „ile_razy” ma wartość 0 (zero), funkcja POWT zwraca "" (pusty tekst).

  • Jeśli argument „ile_razy” nie jest liczbą całkowitą, jest do takiej liczby obcinany.

  • Wynik funkcji POWT nie może być dłuższy niż 2000 znaków. W przeciwnym wypadku funkcja zwróci wartość błędu #ARG!

Przykład

Formuła | Opis (wynik)
=POWT("*-";3) | Wyświetla ciąg 3 razy. (*-*-*-)
=POWT("-";10) | Wyświetla łącznik 10 razy. (----------)


PRAWY

Funkcja PRAWY zwraca ostatnie znaki w ciągu tekstowym na podstawie określonej liczby znaków.

Składnia

PRAWY(tekst;liczba_znaków)

Tekst jest ciągiem tekstowym zawierającym znaki, które mają zostać wyodrębnione.

Liczba_znaków określa liczbę znaków, które mają zostać wyodrębnione za pomocą funkcji PRAWY.

Spostrzeżenia

  • Argument „liczba_znaków” musi być większy niż lub równy zero.
  • Jeśli wartość argumentu „liczba_znaków” jest większa niż długość tekstu, funkcja PRAWY zwraca cały tekst.
  • Jeśli argument „liczba_znaków” zostanie pominięty, przyjmuje się, że jego wartość wynosi 1.

Przykład

Formuła | Opis (wynik)
=PRAWY("Cena sprzedaży";9) | Ostatnie 9 znaków ciągu (sprzedaży)
=PRAWY("Liczba akcji") | Ostatni znak ciągu (i)


SZUKAJ.TEKST

Funkcja SZUKAJ.TEKST zwraca numer pozycji, w której po raz pierwszy znaleziono dany znak lub ciąg tekstowy, począwszy od wartości „liczba_początkowa”. Za pomocą funkcji SZUKAJ.TEKST można określić pozycję znaku lub ciągu tekstowego w innym ciągu tekstowym, tak aby można było zmieniać tekst za pomocą funkcji FRAGMENT.TEKSTU lub ZASTĄP.

Składnia

SZUKAJ.TEKST(tekst_szukany;w_tekście;liczba_początkowa)

Tekst_szukany jest tekstem, który ma zostać znaleziony. W tekście szukanym można używać symboli wieloznacznych — znaku zapytania (?) i gwiazdki (*). Znak zapytania zastępuje dowolne znaki pojedyncze; gwiazdka zastępuje dowolną sekwencję znaków. Aby znaleźć znak zapytania lub gwiazdkę, należy wpisać tyldę (~) przed odpowiednim znakiem.

W_tekście jest tekstem, w którym będzie poszukiwana wartość „tekst_szukany”.

Liczba_początkowa jest numerem znaku w przeszukiwanym ciągu tekstowym (w_tekście), od którego ma się rozpocząć wyszukiwanie.

Pokaż Porada

Dzięki parametrowi „liczba_początkowa” można pomijać określoną liczbę znaków. Załóżmy, na przykład, że pracujesz z ciągiem tekstowym „AYF0093.OdzieżMłodzieżowa”. Aby znaleźć numer pierwszej litery „O” w części opisowej ciągu tekstowego, ustaw dla parametru „liczba początkowa” wartość 8, aby nie była przeszukiwana część tekstu z numerem seryjnym. Funkcja SZUKAJ.TEKST rozpoczyna wyszukiwanie od znaku 8, znajduje wartość „tekst_szukany” (następny znak) i zwraca numer 9. Funkcja SZUKAJ.TEKST zawsze znajduje liczbę znaków od początku przeszukiwanego ciągu tekstowego (w_tekście), licząc znaki pominięte, jeśli argument „liczba_początkowa” jest większy od 1.

Spostrzeżenia

  • Funkcja SZUKAJ.TEKST nie rozróżnia wielkich i małych liter podczas przeszukiwania tekstu.
  • Funkcja SZUKAJ.TEKST jest podobna do funkcji ZNAJDŹ, z tą różnicą, że funkcja ZNAJDŹ uwzględnia wielkość liter.
  • Jeśli wartość „tekst_szukany” nie zostanie znaleziona, jest zwracana wartość błędu #ARG!
  • Jeśli wartość „liczba_początkowa” zostanie pominięta, zakłada się, że wynosi 1.
  • Jeśli wartość „liczba_początkowa” nie jest większa od zera (0) lub jest większa niż długość przeszukiwanego tekstu (w_tekście), jest zwracana wartość błędu #ARG!

Przykład

Kol1 | Kol2 | Kol3 | Formuła | Opis (wynik)
Zestawienia | Marża zysku | marża | =SZUKAJ.TEKST("e";[Kol1];6) | Pozycja pierwszego „e” w ciągu, począwszy od szóstego znaku (8)
Zestawienia | Marża zysku | marża | =SZUKAJ.TEKST([Kol2];[Kol3]) | Pozycja słowa „marża” w wyrażeniu „Marża zysku” (1)
Zestawienia | Marża zysku | marża | =ZASTĄP([Kol3];SZUKAJ.TEKST([Kol3];[Kol2]);1;"Kwota") | Zastąpienie słowa „Marża” słowem „Kwota” (Kwota zysku)


T

Zwraca tekst, do którego odwołuje się wartość.

Składnia

T(wartość)

Wartość to wartość, którą należy przetestować.

Spostrzeżenia

  • Jeśli argument „wartość” jest tekstem lub odwołuje się do tekstu, funkcja T zwraca wartość. Jeśli argument „wartość” nie odwołuje się do tekstu, funkcja T zwraca "" (pusty tekst).

  • Zazwyczaj nie trzeba używać funkcji T w formule, ponieważ wartości są na ogół konwertowane na bieżąco.

Przykład

Formuła | Opis (wynik)
=T("Opady") | W związku z tym, że wartość jest tekstem, zwracany jest tekst. (Opady)
=T(19) | W związku z tym, że wartość jest liczbą, zwracany jest pusty tekst. ()
=T(PRAWDA) | W związku z tym, że wartość jest wartością logiczną, zwracany jest pusty tekst. ()


TEKST

Konwertuje wartość na tekst w określonym formacie liczbowym.

Składnia

TEKST(wartość;format_tekstowy)

Wartość jest wartością numeryczną, formułą przeliczającą na wartość numeryczną lub odwołaniem kolumny zawierającym wartość numeryczną.

Format_tekstowy jest formatem liczbowym w formacie tekstowym.

Spostrzeżenia

  • Funkcja TEKST konwertuje wartość na tekst sformatowany, a wynik nie jest obliczany jako liczba.

Przykład

Sprzedawca | Sprzedaż | Formuła | Opis (wynik)
Bochenek | 2800 | =[Sprzedawca]&" sprzedał(a) towar o wartości "&TEKST([Sprzedaż];"0,00 PLN;(0,00 PLN)")&"." | Łączy całość w zdanie (Bochenek sprzedał(a) towar o wartości 2 800,00 PLN.)
Dubicki | 0,4 | =[Sprzedawca]&" uzyskał(a) wynik "&TEKST([Sprzedaż];"0,00%")&" łącznej sprzedaży." | Łączy całość w zdanie (Dubicki uzyskała(a) 40,00% łącznej sprzedaży.)


USUŃ.ZBĘDNE.ODSTĘPY

Usuwa wszystkie spacje z tekstu, z wyjątkiem pojedynczych spacji występujących między wyrazami. Funkcję USUŃ.ZBĘDNE.ODSTĘPY należy stosować w przypadku tekstu uzyskanego z innej aplikacji, w którym mogą występować nieregularne spacje.

Składnia

USUŃ.ZBĘDNE.ODSTĘPY(tekst)

Tekst to tekst, z którego mają zostać usunięte spacje.

Przykład

Formuła | Opis (wynik)
=USUŃ.ZBĘDNE.ODSTĘPY(" Zarobki w pierwszym kwartale ") | Usuwa pierwszą spację i końcowe spacje z tekstu w formule. (Zarobki w pierwszym kwartale)


USUŃ.KOŃCE

Usuwa spacje wiodące i końcowe, takie jak światło i spacje nierozdzielające, przed tekstem i po tekście. Z funkcji USUŃ.KOŃCE należy korzystać w przypadku ciągów tekstowych pochodzących z innej aplikacji, które mogą zawierać dodatkowe odstępy tego typu.

Uwaga Funkcja USUŃ.KOŃCE zachowuje odstępy w obrębie ciągu tekstowego. Aby zmienić odstępy w obrębie ciągu tekstowego, należy użyć funkcji USUŃ.ZBĘDNE.ODSTĘPY. Dodatkowe informacje można znaleźć w temacie Pomocy dotyczącym funkcji USUŃ.ZBĘDNE.ODSTĘPY.

Składnia

USUŃ.KOŃCE(tekst)

Tekst Ciąg, z którego mają zostać usunięte spacje.

Przykład

Formuła | Opis (wynik)
=USUŃ.KOŃCE(“ Rekordowa sprzedaż ”) | Usuwa spacje wiodące i końcowe z tekstu w formule (Rekordowa sprzedaż).


LITERY.WIELKIE

Konwertuje małe litery na wielkie litery.

Składnia

LITERY.WIELKIE(tekst)

Tekst jest tekstem, którego znaki mają zostać przekonwertowane na wielkie litery. Tekst może być odwołaniem kolumny lub ciągiem tekstowym.

Przykład

Formuła | Opis (wynik)
=LITERY.WIELKIE("suma") | Ciąg zapisany wielkimi literami (SUMA)
=LITERY.WIELKIE("Wydajność") | Ciąg zapisany wielkimi literami (WYDAJNOŚĆ)


DOLAR.AMER

Konwertuje liczbę na tekst przy użyciu formatu waluty z zaokrągleniem do określonego miejsca po przecinku. Używany jest następujący format: # ##0,00 zł.

Składnia

DOLAR.AMER(liczba;miejsca dziesiętne)

„Liczba” może być liczbą, odwołaniem kolumny zawierającym liczbę lub formułą umożliwiającą obliczenie liczby.

„Miejsca_dziesiętne” to liczba cyfr z prawej strony przecinka. Jeśli wartość argumentu „miejsca_dziesiętne” jest ujemna, liczba jest zaokrąglana do wartości po lewej stronie przecinka. Jeśli argument „miejsca_dziesiętne” nie zostanie zdefiniowany, w celu określenia liczby miejsc dziesiętnych będą używane ustawienia lokalne systemu.

Spostrzeżenie

Funkcja DOLAR.AMER zawsze wyświetla walutę USA. Aby wyświetlić sumę w walucie ustawionej w konfiguracji komputera, należy użyć funkcji KWOTA.

Przykład

Kol1 | Formuła | Opis (wynik)
1234,567 | =DOLAR.AMER([Kol1]; 2) | Wyświetla pierwszą liczbę w formacie walutowym z dwiema (2) cyframi po prawej stronie przecinka dziesiętnego (1 234,57 zł).
1234,567 | =DOLAR.AMER([Kol1]; -2) | Wyświetla pierwszą liczbę w formacie walutowym z dwiema (2) cyframi po lewej stronie przecinka dziesiętnego (1 200 zł).
-1234,567 | =DOLAR.AMER([Kol1]; -2) | Wyświetla drugą liczbę w formacie walutowym z dwiema (2) cyframi po lewej stronie przecinka dziesiętnego (-1 200 zł).
-0,123 | =DOLAR.AMER([Kol1]; 4) | Wyświetla trzecią liczbę w formacie walutowym z czterema (4) cyframi po prawej stronie przecinka dziesiętnego (-0,1230 zł).
99,888 | =DOLAR.AMER([Kol1]) | Wyświetla czwartą liczbę w formacie walutowym z dwiema (2) cyframi po lewej stronie przecinka dziesiętnego (99,89 zł).


WARTOŚĆ

Konwertuje ciąg tekstowy reprezentujący liczbę na liczbę.

Składnia

WARTOŚĆ(tekst)

Tekst jest tekstem w cudzysłowach lub odwołaniem kolumny zawierającym tekst, który ma zostać przekonwertowany.

Spostrzeżenia

  • Tekst może być w dowolnym stałym formacie liczby, daty lub czasu. Jeśli nie jest w jednym z tych formatów, funkcja WARTOŚĆ zwraca wartość błędu #ARG!

Przykład

Formuła | Opis (wynik)
=WARTOŚĆ("1000 zł") | Liczba równoważna podanemu ciągowi (1000)
=WARTOŚĆ("16:48:00")–WARTOŚĆ("12:00:00") | Liczba kolejna równoważna podanej wartości 4 godzin i 48 minut, tj. wynikowi działania "16:48:00"–"12:00:00" (0,2 lub 4:48)


Zwiększanie wydajności składnika Access Web Datasheet — informacje

Wydajność widoku arkusza danych zależy od wielu czynników, takich jak rozmiar listy, wydajność i konfiguracja serwera oraz warunki panujące w sieci. W tym temacie znajduje się klika wskazówek, dzięki którym wydajność tę można zwiększyć.

Wykonanie poniższych operacji może być długotrwałe, dlatego należy wykonać jak najmniej z nich:

  • Odświeżenie widoku zawierającego dużą ilość danych.
  • Przeniesienie lub skopiowanie dużych zestawów danych.
  • Wypełnienie wielu komórek przez przeciągnięcie uchwytu wypełniania.
  • Zmienienie formuły w kolumnie obliczeniowej.
  • Załączenie dużych dokumentów.
  • Wyeksportowanie z programu Microsoft Excel 2010 i utworzenie łączy do tego programu.
  • Usunięcie wielu błędów.

Aby zwiększyć wydajność widoku, należy wykonać następujące czynności:

  • Usuń zbędne kolumny z widoku. Na stronie Edytowanie widoku arkusza danych usuń znaczniki z pól wyboru Wyświetl przy kolumnach, które nie muszą być wyświetlane w widoku. Nie usuwaj natomiast kolumn oznaczonych jako Wymagane. Jeśli w widoku nie będzie wszystkich wymaganych kolumn, dodawanie danych nie będzie możliwe.
  • Zastosuj co najmniej jeden filtr, aby usunąć zbędne wiersze. Możesz na przykład przeprowadzić edycję definicji widoku Kierownicy, aby uwzględnić filtr ukrywający wiersze pracowników, którzy nie są kierownikami.

    Oprócz zapisanych filtrów można stosować filtry podczas sesji, aby jeszcze bardziej ograniczyć ilość danych w widoku. Na przykład, jeśli obecnie aktualizujesz wiersze kierowników w Warszawie, ukryj wiersze kierowników z innych miast.

  • Skonfiguruj serwer programu SharePoint, aby zwiększyć wydajność. Aby uzyskać więcej informacji dotyczących zwiększania wydajności serwera, zobacz Pomoc programu Microsoft SharePoint Foundation 2010. Aby wyświetlić Pomoc programu Microsoft SharePoint Foundation 2010, kliknij przycisk Pomoc ( Ikona Pomocy).


Jest wyświetlany komunikat „Struktura listy została zmieniona”

Gdy dwóch użytkowników jednocześnie wprowadza zmiany w strukturze listy, zostaną uwzględnione zmiany wprowadzone przez użytkownika, który wprowadzi zmianę jako pierwszy, natomiast drugi użytkownik otrzyma powiadomienie o zmianie w strukturze listy.

W poniższej tabeli zebrano scenariusze, w których użytkownik jest informowany o zmianie w strukturze listy.

Użytkownik A | Użytkownik B
Usuwa kolumnę | Aktualizuje dane w tej samej kolumnie
Zmienia typ danych kolumny | Dodaje lub aktualizuje dane, powodując niezgodność typów
Dodaje lub usuwa kolumnę, zmienia jej nazwę, typ jej danych lub inne właściwości | Edytuje kolumnę obliczeniową
Wprowadza zmiany na poziomie listy, np. zmienia nazwę, opis lub ustawienia zabezpieczeń listy, zmienia kolejność kolumn, włącza lub wyłącza załączniki lub dodaje listę do paska Szybkie uruchamianie | Edytuje kolumnę obliczeniową
Edytuje kolumnę obliczeniową | Dodaje lub usuwa kolumnę, zmienia jej nazwę, typ jej danych lub inne właściwości Uwaga Użytkownik B musi przejść do strony Dodaj kolumnę lub Zmień kolumnę, zanim użytkownik A rozpocznie edytowanie kolumny obliczeniowej
Edytuje kolumnę obliczeniową | Wprowadza zmiany na poziomie listy, np. zmienia nazwę, opis lub ustawienia zabezpieczeń listy, zmienia kolejność kolumn, włącza lub wyłącza załączniki lub dodaje listę do paska Szybkie uruchamianie Uwaga Użytkownik B musi przejść do strony Ustawienia listy, zanim użytkownik A rozpocznie edytowanie kolumny obliczeniowej.

Konflikt strukturalny można rozwiązać, odświeżając listę. Po odświeżeniu listy zmiany zostaną odrzucone, a w widoku pojawi się najnowsza wersja listy. Po odświeżeniu listy należy po prostu ponownie wprowadzić zmiany.


Jest wyświetlany komunikat „Przerwanie przesyłania zmian”

Próbujesz zatrzymać proces przesyłania zmian do serwera przed odświeżeniem, wyjściem z listy lub wprowadzeniem zmian w kolumnie obliczeniowej. Możesz wykonać jedną z następujących czynności:

  • Kliknij przycisk Tak, aby przerwać przesyłanie zmian z listy do serwera. Zmiany, które nie zostały jeszcze zapisane na serwerze, zostaną utracone. Nie będzie także można rozwiązać konfliktów ani poprawić błędów spowodowanych zmianami, które zostały już przesłane do serwera.
  • Kliknij przycisk Nie, aby kontynuować przesyłanie zmian. Rozwiązywanie konfliktów i poprawianie błędów oraz ponowne przesyłanie zmian do serwera będzie możliwe.


Jest wyświetlany komunikat „Prześlij oczekujące zmiany”

Przed kontynuowaniem wykonania polecenia odświeżenia, wyjścia z listy lub edytowania kolumny obliczeniowej jest wykonywana próba przesłania zmian z listy do serwera. Można wykonać jedną z następujących czynności:

  • Zaczekaj, aż wszystkie zmiany zostaną przesłane do serwera. Dzięki temu będzie można rozwiązać konflikty i poprawić błędy, a następnie ponownie przesłać zmiany do serwera, jeśli to konieczne.
  • Odrzuć zmiany, klikając przycisk Anuluj. Gdy zostanie kliknięty przycisk Anuluj, pojawi się monit o potwierdzenie, że wysyłanie zmian do serwera ma zostać przerwane. Kliknięcie przycisku Tak spowoduje utratę zmian, które nie zostały jeszcze zapisane na serwerze. Nie będzie można także rozwiązywać konfliktów i poprawiać błędów spowodowanych zmianami, które zostały już przesłane do serwera.


Jest wyświetlany komunikat „Masz oczekujące zmiany lub nierozwiązane konflikty i błędy”

Podjęto próbę odświeżenia listy, przejścia poza listę lub wprowadzenia zmian w kolumnie obliczeniowej. Niektóre z wprowadzonych zmian nie zostały jeszcze przesłane do serwera.

Można wykonać jedną z następujących czynności:

  • Kliknij przycisk Tak, aby zaczekać na przesłanie zmian do serwera. Jeśli w wyniku przesłania zmian do serwera powstaną konflikty lub błędy, będzie można je usunąć i ponownie podjąć próbę przesłania zmian do serwera.
  • Kliknij przycisk Nie, aby natychmiast dokończyć ostatnią akcję. Zostaną utracone wszystkie lub niektóre zmiany, które nie zostały jeszcze przesłane do serwera. Nie będzie można również usunąć konfliktów ani błędów spowodowanych przez zmiany już przesłane do serwera.


Na pasku stanu jest wyświetlane łącze „Oczekujące zmiany”

W przypadku edytowania zawartości listy nie trzeba czekać z wprowadzeniem kolejnej zmiany, aż poprzednia zmiana zostanie przesłana do serwera. Zmiany wprowadzane w danych są przesyłane do serwera na bieżąco w tle. Jeśli jest edytowanych kilka komórek naraz, np. wypełnianych jest kilka wierszy kolumny przez przeciąganie uchwytu wypełniania, wysłanie wszystkich zmian z listy do serwera może potrwać kilka sekund. W takich sytuacjach na pasku stanu jest wyświetlane łącze Oczekujące zmiany.

Wyświetlenie tego łącza nie znaczy, że trzeba wstrzymać się z dodawaniem lub edytowaniem danych aż do momentu przesłania wszystkich dotychczasowych zmian. Jednak przy próbie przeprowadzenia edycji formuły w kolumnie obliczeniowej, odświeżenia albo zamknięcia widoku zostanie wyświetlony komunikat z prośbą o zaczekanie do momentu zakończenia przesyłania danych do serwera.


Na pasku stanu jest wyświetlany komunikat „Tylko do odczytu” lub „Ten widok jest przeznaczony tylko do odczytu”

Zaznaczona komórka, kolumna, zaznaczony wiersz lub cały widok jest tylko do odczytu. Nie można edytować komórek, kolumn ani wierszy oznaczonych jako tylko do odczytu. Jeśli cały widok jest przeznaczony tylko do odczytu, nie można edytować żadnej jego części.

Części widoku (lub cały widok) mogą być oznaczone jako tylko do odczytu z co najmniej jednego z następujących powodów:

  • Niektóre kolumny, takie jak Utworzony przez i Zmodyfikowany, są zawsze tylko do odczytu. Wartości w tych kolumnach są wprowadzane automatycznie.
  • Zmiany wprowadzone w zaznaczonym wierszu lub zaznaczonej kolumnie zostały przesłane do serwera. Jeśli nie wystąpił konflikt ani błąd, wiersz lub kolumnę będzie można edytować po zapisaniu zmian.
  • W zaznaczonym wierszu lub zaznaczonej kolumnie jest nieusunięty konflikt lub błąd. Przed rozpoczęciem edycji zaznaczonego wiersza lub zaznaczonej kolumny należy usunąć konflikt lub błąd.
  • Lista jest tak skonfigurowana, aby zatwierdzanie zawartości było wymagane, i jest wyświetlana w widoku Wszystkie elementy.
  • W widoku Przesłane elementy listy, która wymaga zatwierdzenia zawartości, kolumny Stan zatwierdzenia i Komentarz są kolumnami tylko do odczytu. Może je edytować tylko użytkownik z uprawnieniem Osoba zatwierdzająca.
  • Załączniki na liście wymagającej zatwierdzenia zawartości są tylko do odczytu. Nie można ich wyświetlać ani edytować w żadnym widoku.
  • Dokument w bieżącym wierszu został wyewidencjonowany przez użytkownika. Nie można edytować kolumn w wierszu, dopóki użytkownik nie zaewidencjonuje dokumentu.
  • Nie masz uprawnień do edytowania kolumny lub wiersza. Skontaktuj się z autorem listy, aby uzyskać więcej informacji.


Na pasku stanu jest wyświetlany komunikat „Pobieranie danych”

Dane są pobierane do listy w partiach wierszy. Następuje próba pobrania następnej partii. Może to chwilę potrwać, jeśli serwer jest zajęty.

Jeśli serwer napotka problem podczas pobierania danych, zostanie wyświetlony komunikat. W takim przypadku należy zamknąć listę i spróbować ponownie później.


Obsługa międzynarodowa — informacje

Szczegółowe informacje dotyczące obsługi międzynarodowej list znajdują się w Pomocy programu Microsoft SharePoint Foundation 2010.

Aby wyświetlić Pomoc programu Microsoft SharePoint Foundation 2010, kliknij przycisk Pomoc ( Ikona Pomocy).


Ponowne konwertowanie ciągu znaków

Uwaga To polecenie jest dostępne tylko wtedy, gdy w systemie operacyjnym lub ustawieniach języka pakietu Microsoft Office jest włączony edytor Input Method Editor języka japońskiego, chińskiego uproszczonego lub chińskiego tradycyjnego.

Można ponownie konwertować ciąg znaków, który został już wprowadzony i przekonwertowany.

  1. Umieść punkt wstawiania na początku lub w środku ciągu znaków, które mają zostać ponownie przekonwertowane.
  2. Kliknij prawym przyciskiem myszy komórkę, a następnie w menu skrótów kliknij polecenie Konwertuj ponownie.
  3. Kliknij odpowiedni znak, a następnie dwa razy naciśnij klawisz ENTER.