Automating security configuration tasks

By calling the Secedit.exe command-line tool from a batch file or automatic task scheduler, you can use it to automatically create and apply templates, and analyze system security. You can also run it dynamically from the command line.

Secedit.exe is useful when you have multiple computers on which security must be analyzed or configured, and you need to perform these tasks during off-hours.

  • For procedural information about using the Secedit.exe command-line tool to perform security tasks, see Secedit commands.
  • For information about defining Security Templates, see Security Templates.
  • For more information about security configuration and analysis, see Security Configuration and Analysis.

Note

  • The secedit /refreshpolicy command has been replaced with the gpupdate command. For information about how to refresh security settings, see Gpupdate.


Compile Date

 Compile Date: 2001-07-09