Computer Configuration

Location: Computer Configuration\

Description:
Contains settings that may only be used to configure Computers.

    ADM File: wuau.adm


Configure Automatic Updates

Requirements: Windows Server 2003, XP SP1, 2000 SP3

Location: Computer Configuration\Windows Components\Windows Update\

Description:
Specifies whether this computer will receive security updates and other important downloads through the Windows automatic updating service.

This setting lets you specify if automatic updates are enabled on this computer. If the service is enabled, you must select one of the four options in the Group Policy Setting:

2 = Notify before downloading any updates and notify again before installing them.

When Windows finds updates that apply to this computer, an icon appears in the status area with a message that updates are ready to be downloaded. Clicking the icon or message provides the option to select the specific updates to download. Windows then downloads the selected updates in the background. When the download is complete, the icon appears in the status area again, with notification that the updates are ready to be installed. Clicking the icon or message provides the option to select which updates to install.

3 = (Default setting) Download the updates automatically and notify when they are ready to be installed

Windows finds updates that apply to your computer and downloads these updates in the background (the user is not notified or interrupted during this process). When the download is complete, the icon appears in the status area, with notification that the updates are ready to be installed. Clicking the icon or message provides the option to select which updates to install.

4 = Automatically download updates and install them on the schedule specified below

Specify the schedule using the options in the Group Policy Setting. If no schedule is specified, the default schedule for all installations will be everyday at 3:00 AM. If any of the updates require a restart to complete the installation, Windows will restart the computer automatically. (If a user is logged on to the computer when Windows is ready to restart, the user will be notified and given the option to delay the restart.)

5 = Allow local administrators to select the configuration mode that Automatic Updates should notify and install updates

With this option, the local administrators will be allowed to use the Automatic Updates control panel to select a configuration option of their choice. For example they can choose their own scheduled installation time. Local administrators will not be allowed to disable Automatic Updates' configuration.

To use this setting, click Enabled, and then select one of the options (2, 3, 4 or 5). If you select 4, you can set a recurring schedule (if no schedule is specified, all installations will occur everyday at 3:00 AM).

If the status is set to Enabled, Windows recognizes when this computer is online and uses its Internet connection to search the Windows Update Web site for updates that apply to this computer.

If the status is set to Disabled, any updates that are available on the Windows Update Web site must be downloaded and installed manually by going to http://windowsupdate.microsoft.com.

If the status is set to Not Configured, use of Automatic Updates is not specified at the Group Policy level. However, an administrator can still configure Automatic Updates through Control Panel.

ADM File: wuau.adm


Specify intranet Microsoft update service location

Requirements: Windows Server 2003, XP SP1, 2000 SP3

Location: Computer Configuration\Windows Components\Windows Update\

Description:
Specifies an intranet server to host updates from the Microsoft Update Web sites. You can then use this update service to automatically update computers on your network.

This setting lets you specify a server on your network to function as an internal update service. The Automatic Updates client will search this service for updates that apply to the computers on your network.

To use this setting, you must set two servername values: the server from which the Automatic Updates client detects and downloads updates, and the server to which updated workstations upload statistics. You can set both values to be the same server.

If the status is set to Enabled, the Automatic Updates client connects to the specified intranet Microsoft update service, instead of Windows Update, to search for and download updates. Enabling this setting means that end users in your organization don't have to go through a firewall to get updates, and it gives you the opportunity to test updates before deploying them.

If the status is set to Disabled or Not Configured, and if Automatic Updates is not disabled by policy or user preference, the Automatic Updates client connects directly to the Windows Update site on the Internet.

Note

  • If the "Configure Automatic Updates" policy is disabled, then this policy has no effect.

ADM File: wuau.adm


Enable client-side targeting

Requirements: Windows Server 2003, XP SP1, 2000 SP3

Location: Computer Configuration\Windows Components\Windows Update\

Description:
Specifies the target group name that should be used to receive updates from an intranet Microsoft update service.

If the status is set to Enabled, the specified target group information is sent to the intranet Microsoft update service which uses it to determine which updates should be deployed to this computer.

If the status is set to Disabled or Not Configured, no target group information will be sent to the intranet Microsoft update service.

Note

  • This policy applies only when the intranet Microsoft update service this computer is directed to is configured to support client-side targeting. If the "Specify intranet Microsoft update service location" policy is disabled or not configured, this policy has no effect.

ADM File: wuau.adm


Reschedule Automatic Updates scheduled installations

Requirements: Windows Server 2003, XP SP1, 2000 SP3

Location: Computer Configuration\Windows Components\Windows Update\

Description:
Specifies the amount of time for Automatic Updates to wait, following system startup, before proceeding with a scheduled installation that was missed previously.

If the status is set to Enabled, a scheduled installation that did not take place earlier will occur the specified number of minutes after the computer is next started.

If the status is set to Disabled, a missed scheduled installation will occur with the next scheduled installation.

If the status is set to Not Configured, a missed scheduled installation will occur one minute after the computer is next started.

Note

  • This policy applies only when Automatic Updates is configured to perform scheduled installations of updates. If the "Configure Automatic Updates" policy is disabled, this policy has no effect.

ADM File: wuau.adm


No auto-restart for scheduled Automatic Updates installations

Requirements: Windows Server 2003, XP SP1, 2000 SP3

Location: Computer Configuration\Windows Components\Windows Update\

Description:
Specifies that to complete a scheduled installation, Automatic Updates will wait for the computer to be restarted by any user who is logged on, instead of causing the computer to restart automatically.

If the status is set to Enabled, Automatic Updates will not restart a computer automatically during a scheduled installation if a user is logged in to the computer. Instead, Automatic Updates will notify the user to restart the computer.

Be aware that the computer needs to be restarted for the updates to take effect.

If the status is set to Disabled or Not Configured, Automatic Updates will notify the user that the computer will automatically restart in 5 minutes to complete the installation.

Note

  • This policy applies only when Automatic Updates is configured to perform scheduled installations of updates. If the "Configure Automatic Updates" policy is disabled, this policy has no effect.

ADM File: wuau.adm


Automatic Updates detection frequency

Requirements: Windows Server 2003, XP SP1, 2000 SP3

Location: Computer Configuration\Windows Components\Windows Update\

Description:
Specifies the hours that Windows will use to determine how long to wait before checking for available updates. The exact wait time is determined by using the hours specified here minus zero to twenty percent of the hours specified. For example, if this policy is used to specify a 20 hour detection frequency, then all clients to which this policy is applied will check for updates anywhere between 16 and 20 hours.

If the status is set to Enabled, Windows will check for available updates at the specified interval.

If the status is set to Disabled or Not Configured, Windows will check for available updates at the default interval of 22 hours.

Note

  • The "Specify intranet Microsoft update service location" setting must be enabled for this policy to have effect.

Note

  • If the "Configure Automatic Updates" policy is disabled, this policy has no effect.

ADM File: wuau.adm


Allow Automatic Updates immediate installation

Requirements: Windows Server 2003, XP SP1, 2000 SP3

Location: Computer Configuration\Windows Components\Windows Update\

Description:
Specifies whether Automatic Updates should automatically install certain updates that neither interrupt Windows services nor restart Windows.

If the status is set to Enabled, Automatic Updates will immediately install these updates once they are downloaded and ready to install.

If the status is set to Disabled, such updates will not be installed immediately.

Note

  • If the "Configure Automatic Updates" policy is disabled, this policy has no effect.

ADM File: wuau.adm


Delay Restart for scheduled installations

Requirements: Windows Server 2003, XP SP1, 2000 SP3

Location: Computer Configuration\Windows Components\Windows Update\

Description:
Specifies the amount of time for Automatic Updates to wait before proceeding with a scheduled restart.

If the status is set to Enabled, a scheduled restart will occur the specified number of minutes after the installation is finished.

If the status is set to Disabled or Not Configured, the default wait time is 5 minutes.

Note

  • This policy applies only when Automatic Updates is configured to perform scheduled installations of updates. If the "Configure Automatic Updates" policy is disabled, this policy has no effect.

ADM File: wuau.adm


Re-prompt for restart with scheduled installations

Requirements: Windows Server 2003, XP SP1, 2000 SP3

Location: Computer Configuration\Windows Components\Windows Update\

Description:
Specifies the amount of time for Automatic Updates to wait before prompting again with a scheduled restart.

If the status is set to Enabled, a scheduled restart will occur the specified number of minutes after the previous prompt for restart was postponed.

If the status is set to Disabled or Not Configured, the default interval is 10 minutes.

Note

  • This policy applies only when Automatic Updates is configured to perform scheduled installations of updates. If the "Configure Automatic Updates" policy is disabled, this policy has no effect.

ADM File: wuau.adm


Administrative Templates Help

 Group Policy Admin Templates

Group Policy settings for Automatic Updates

ADM File: wuau.adm

Welcome to the administrative template help for Group Policy. Also see the main Group Policy help.

  • Computer Configuration